Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Sortie de Fedora Linux 35 Beta

#1 31/07/2021 10:38:42

fgland
Rédacteur Wiki
Rédacteur Wiki
Lieu : Lituanie
Inscription : 09/08/2004
Messages : 3 463

[Résolu] problème wine et dnf

Bonjour,

après mise à jour,
dnf me renvoi l'erreur

# dnf upgrade
Traceback (most recent call last):
  File "/usr/bin/dnf", line 57, in <module>
    from dnf.cli import main
  File "/usr/lib/python3.9/site-packages/dnf/__init__.py", line 30, in <module>
    import dnf.base
  File "/usr/lib/python3.9/site-packages/dnf/base.py", line 29, in <module>
    import libdnf.transaction
  File "/usr/lib64/python3.9/site-packages/libdnf/__init__.py", line 12, in <module>
    from . import conf
  File "/usr/lib64/python3.9/site-packages/libdnf/conf.py", line 13, in <module>
    from . import _conf
ImportError: /lib64/libmodulemd.so.2: file too short

# file /lib64/libmodulemd.so.2
/lib64/libmodulemd.so.2: symbolic link to libmodulemd.so.2.13.0

# file /lib64/libmodulemd.so.2.13.0 
/lib64/libmodulemd.so.2.13.0: empty

J'ai téléchargé le paquet et l'installation à résolu ce problème

rpm -iv --force libmodulemd-2.13.0-1.fc33.x86_64.rpm 

wine

$ winecfg
002c:err:module:load_ntdll_functions LdrSystemDllInitBlock not found

la mise à jour ne résout pas

Erreur : Erreur de la transaction de test :
  le fichier /usr/share/doc/wine-core/ANNOUNCE de l'installation de wine-core-6.13-1.fc33.i686 entre en conflit avec le fichier du paquet wine-core-6.12-1.fc33.x86_64
  le fichier /usr/share/doc/wine-core/AUTHORS de l'installation de wine-core-6.13-1.fc33.i686 entre en conflit avec le fichier du paquet wine-core-6.12-1.fc33.x86_64
  le fichier /usr/share/doc/wine-core/VERSION de l'installation de wine-core-6.13-1.fc33.i686 entre en conflit avec le fichier du paquet wine-core-6.12-1.fc33.x86_64

je tente un dnf downgrade wine
il me semble avoir vu des fils avec des problème sur la dernière version de wine mais je ne retrouve pas
marche avec la version précédente.
Je ne rencontre pas ce problème sous F34

Dernière modification par fgland (31/07/2021 13:30:18)


F35, Kde/plasma (X11), AMD FX-6300, NVIDIA GM107 [GeForce GTX 750 Ti], 8Go de mémoire

Hors ligne

Pied de page des forums