Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 35 est disponible sous le nouveau nom de Fedora Linux 35

#1 02/03/2021 09:32:19

didierg
Bricoleur du dimanche
Modérateur
Inscription : 11/07/2005
Messages : 5 609

[Résolu] skype - skypeforlinux-8.68.0.100-1.x86_64

Bonjour,

La mise à jour vers skypeforlinux-8.68.0.100-1.x86_64 a un problème de dépendance:

 Problème: cannot install the best update candidate for package skypeforlinux-8.68.0.100-1.x86_64
  - nothing provides libatomic1 needed by skypeforlinux-8.69.0.77-1.x86_64

Voir: https://answers.microsoft.com/en-us/sky … 6e0cdc4105

La solution suivante permet d'installer cette mise à jour qui fonctionne:

$ sudo dnf download skypeforlinux
$ sudo rpm -U --nodeps skypeforlinux_8.69.0.77-1.x86_64.rpm

Hors ligne

#2 02/03/2021 10:44:28

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 536
Site Web

Re : [Résolu] skype - skypeforlinux-8.68.0.100-1.x86_64

A mon avis il faudra quand même installer aussi la libatomic/libatomic-static, si c'est pas déjà fait, qui est dispo en version 10.2.1-3 (en x86_64 ou i686 après je pense que c'est le premier vu que le paquet de skype est en x86_64).

Reste a savoir ce qu'il a besoin et si il ne faut pas simplement faire un lien symbolique vers la libatomic.so.1.


AMD R7 5800x, MSI Pro Carbon X470, 32Go DDR4 3200@3400Mhz Gskill TridentZ CL14,5700XT MSI WaterCooling OC, SSD : 1xPNY LXR8 1To + 1x970EVO 500Go + 2x500Go 860EVO, 3x1To 860EVO, HDD WD 2To + 4To Black, 3To Red, BeQuiet Purepower 1000W plat, BSGT Dark 900
AMD R7 2700x + 16Go DDR4 2933Mhz, 1xPNY LXR8 1To, 2x1To 860QVO, BMT MasterBox Q300L
AMD R5 2600, Asus A320, 24Go DDR4 2133Mhz, 1x250GO SSD, 3x 2To RAID5 WDBlue, BCubes Chieftec + AMD A6 9500, 8Go, SSD 250Go

Hors ligne

#3 02/03/2021 12:03:32

fgland
Rédacteur Wiki
Rédacteur Wiki
Lieu : Lituanie
Inscription : 09/08/2004
Messages : 3 478

Re : [Résolu] skype - skypeforlinux-8.68.0.100-1.x86_64

il n'est jamais bon de passer un --nodeps pour installer un paquet...
Gérard


F35, Kde/plasma (X11), AMD FX-6300, NVIDIA GM107 [GeForce GTX 750 Ti], 8Go de mémoire

Hors ligne

#4 02/03/2021 12:34:24

didierg
Bricoleur du dimanche
Modérateur
Inscription : 11/07/2005
Messages : 5 609

Re : [Résolu] skype - skypeforlinux-8.68.0.100-1.x86_64

VINDICATORs a écrit :

A mon avis il faudra quand même installer aussi la libatomic/libatomic-static, si c'est pas déjà fait, qui est dispo en version 10.2.1-3 (en x86_64 ou i686 après je pense que c'est le premier vu que le paquet de skype est en x86_64).

libatomic-10.2.1-10.fc33.aarch64.rpm et  libatomic-static-10.2.1-10.fc33.aarch64.rpm sont installés avec gcc https://koji.fedoraproject.org/koji/bui … ID=1671502

Selon ma compréhension, le problème est juste au niveau du fichier spec qui requires libatomic1 et non libatomic

# rpmrebuild autogenerated specfile

%define defaultbuildroot /
AutoProv: no
%undefine __find_provides
AutoReq: no
%undefine __find_requires
# Do not try autogenerate prereq/conflicts/obsoletes and check files
%undefine __check_files
%undefine __find_prereq
%undefine __find_conflicts
%undefine __find_obsoletes
# Be sure buildpolicy set to do nothing
%define __spec_install_post %{nil}
# Something that need for rpm-4.1
%define _missing_doc_files_terminate_build 0
#dummy
#dummy
#BUILDHOST:    neu-vn-stretch-338
#BUILDTIME:    Fri Feb 12 22:46:58 2021
#SOURCERPM:    skypeforlinux-8.69.0.77-1.src.rpm

#RPMVERSION:   4.12.0.2



#OS:           linux
#SIZE:           297394161
#ARCHIVESIZE:           297409452
#ARCH:         x86_64
BuildArch:     x86_64
Name:          skypeforlinux
Version:       8.69.0.77
Release:       1
License:       Skype End User License Agreement
Group:         Applications/Internet
Summary:       Skype keeps the world talking, for free.

URL:           https://www.skype.com/
Vendor:        Skype Software Sarl






Provides:      application()
Provides:      application(skypeforlinux-share.desktop)
Provides:      application(skypeforlinux.desktop)
Provides:      libEGL.so()(64bit)
Provides:      libGLESv2.so()(64bit)
Provides:      libffmpeg.so
Provides:      libffmpeg.so()(64bit)
Provides:      libvk_swiftshader.so()(64bit)
Provides:      libvulkan.so()(64bit)
Provides:      mimehandler(application/octet-stream)
Provides:      mimehandler(x-scheme-handler/callto)
Provides:      mimehandler(x-scheme-handler/skype)
Provides:      mimehandler(x-scheme-handler/tel)
Provides:      skypeforlinux = 8.69.0.77-1
Provides:      skypeforlinux(x86-64) = 8.69.0.77-1
Requires(post): /bin/sh
Requires:      /bin/sh
Requires:      gnome-keyring
Requires:      ld-linux-x86-64.so.2()(64bit)
Requires:      ld-linux-x86-64.so.2(GLIBC_2.2.5)(64bit)
Requires:      ld-linux-x86-64.so.2(GLIBC_2.3)(64bit)
Requires:      libX11-xcb.so.1()(64bit)
Requires:      libX11.so.6()(64bit)
Requires:      libXcomposite.so.1()(64bit)
Requires:      libXdamage.so.1()(64bit)
Requires:      libXext.so.6()(64bit)
Requires:      libXfixes.so.3()(64bit)
Requires:      libXrandr.so.2()(64bit)
Requires:      libasound.so.2()(64bit)
Requires:      libasound.so.2(ALSA_0.9)(64bit)
Requires:      libasound.so.2(ALSA_0.9.0rc4)(64bit)
Requires:      libatk-1.0.so.0()(64bit)
Requires:      libatk-bridge-2.0.so.0()(64bit)
Requires:      libatomic1
---/---

Hors ligne

#5 02/03/2021 12:37:44

raigoin
Membre
Inscription : 17/02/2021
Messages : 218

Re : [Résolu] skype - skypeforlinux-8.68.0.100-1.x86_64

Pas fan de Skype, mais il existe un Flatpak qui devrait résoudre tout problème de dépendance : https://flathub.org/apps/details/com.skype.Client

Dernière modification par raigoin (02/03/2021 12:38:42)


Debian && Fedora Silverblue: utilisateur libre, sans compétence particulière.

Hors ligne

#6 02/03/2021 16:49:19

Horigo
Membre
Inscription : 18/11/2007
Messages : 196

Re : [Résolu] skype - skypeforlinux-8.68.0.100-1.x86_64

Je l'ai installé avec snap skype c'est plus simple je trouve

Dernière modification par Horigo (02/03/2021 16:49:38)


qs4u1y-2.png

Hors ligne

Pied de page des forums