Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fin de maintenance pour Fedora 32

#1 30/01/2021 18:36:30

jenrem
Membre
Lieu : cote atlantique sud Ouest
Inscription : 07/12/2018
Messages : 280

[Résolu] Pas de connexion au démarrage

Bonjour à toutes et tous
Décidément cette F33 me donne quelques soucis , j'étais habitué   que tout se passe sans anicroche , hé bien il faut un début à tout . C'est peut être aussi dû au changement de disque ?
Après la monté en version F32 => F33 par " system update " je me retrouve sans connexion au démarrage , je suis obligé d'activer la connexion " à la main "
J'ai fait quelques manips que je mets en dessous

Recherche de la connexion

anna@localhost ~]$ lspci | grep -i ethernet
04:09.0 Ethernet controller: D-Link System Inc DGE-528T Gigabit Ethernet Adapter (rev 10)

Ensuite j'ai " activé "NetworkManager

[anna@localhost ~]$ sudo systemctl enable NetworkManager
[sudo] Mot de passe de anna : 
Unit /etc/systemd/system/NetworkManager-wait-online.service is masked, ignoring.

Où je retrouve une vieille connaissance
J'ai cherché l'adresse de la connexion

[anna@localhost ~]$  ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp4s9: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether bc:0f:9a:9a:2f:4f brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.27/24 brd 192.168.1.255 scope global dynamic noprefixroute enp4s9
       valid_lft 86305sec preferred_lft 86305sec
    inet6 2a01:cb19:5ee:1300:9787:55cd:99f9:2719/64 scope global dynamic noprefixroute 
       valid_lft 1787sec preferred_lft 587sec
    inet6 fe80::8839:bd19:3f49:d42c/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

ensuite son "état"

[anna@localhost ~]$ sudo systemctl status NetworkManager
● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
     Active: active (running) since Sat 2021-01-30 16:57:22 CET; 8min ago
       Docs: man:NetworkManager(8)
   Main PID: 770 (NetworkManager)
      Tasks: 3 (limit: 3528)
     Memory: 8.6M
        CPU: 1.379s
     CGroup: /system.slice/NetworkManager.service
             └─770 /usr/sbin/NetworkManager --no-daemon

janv. 30 17:03:30 localhost.localdomain NetworkManager[770]: <info>  [1612022610.0846] policy: set-hostname: current hostname was changed outside NetworkManager: 'localhost.localdomain'
janv. 30 17:03:30 localhost.localdomain NetworkManager[770]: <info>  [1612022610.0891] policy: set-hostname: current hostname was changed outside NetworkManager: 'localhost.localdomain'
janv. 30 17:03:56 localhost.localdomain NetworkManager[770]: <info>  [1612022636.6472] policy: set-hostname: current hostname was changed outside NetworkManager: 'localhost.localdomain'
janv. 30 17:03:56 localhost.localdomain NetworkManager[770]: <info>  [1612022636.6540] policy: set-hostname: current hostname was changed outside NetworkManager: 'localhost.localdomain'
janv. 30 17:04:28 localhost.localdomain NetworkManager[770]: <info>  [1612022668.6219] policy: set-hostname: current hostname was changed outside NetworkManager: 'localhost.localdomain'
janv. 30 17:04:28 localhost.localdomain NetworkManager[770]: <info>  [1612022668.6245] policy: set-hostname: current hostname was changed outside NetworkManager: 'localhost.localdomain'
janv. 30 17:05:06 localhost.localdomain NetworkManager[770]: <info>  [1612022706.9225] policy: set-hostname: current hostname was changed outside NetworkManager: 'localhost.localdomain'
janv. 30 17:05:06 localhost.localdomain NetworkManager[770]: <info>  [1612022706.9252] policy: set-hostname: current hostname was changed outside NetworkManager: 'localhost.localdomain'
janv. 30 17:05:38 localhost.localdomain NetworkManager[770]: <info>  [1612022738.2746] policy: set-hostname: current hostname was changed outside NetworkManager: 'localhost.localdomain'
janv. 30 17:05:38 localhost.localdomain NetworkManager[770]: <info>  [1612022738.2772] policy: set-hostname: current hostname was changed outside NetworkManager: 'localhost.localdomain'

Je l'ai redémarré

[anna@localhost ~]$ sudo systemctl restart NetworkManager

ensuite

[anna@localhost ~]$ sudo systemctl status NetworkManager
● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
     Active: active (running) since Sat 2021-01-30 17:09:50 CET; 28s ago
       Docs: man:NetworkManager(8)
   Main PID: 1988 (NetworkManager)
      Tasks: 3 (limit: 3528)
     Memory: 3.8M
        CPU: 289ms
     CGroup: /system.slice/NetworkManager.service
             └─1988 /usr/sbin/NetworkManager --no-daemon

janv. 30 17:09:50 localhost.localdomain NetworkManager[1988]: <info>  [1612022990.5023] manager: NetworkManager state is now CONNECTED_SITE
janv. 30 17:09:50 localhost.localdomain NetworkManager[1988]: <info>  [1612022990.5026] policy: set 'Nouvelle connexion : 802-3-ethernet' (enp4s9) as default for IPv4 routing and DNS
janv. 30 17:09:50 localhost.localdomain NetworkManager[1988]: <info>  [1612022990.5029] policy: set 'Nouvelle connexion : 802-3-ethernet' (enp4s9) as default for IPv6 routing and DNS
janv. 30 17:09:50 localhost.localdomain NetworkManager[1988]: <info>  [1612022990.5038] device (enp4s9): Activation: successful, device activated.
janv. 30 17:09:50 localhost.localdomain NetworkManager[1988]: <info>  [1612022990.5092] manager: startup complete
janv. 30 17:09:50 localhost.localdomain NetworkManager[1988]: <info>  [1612022990.7639] manager: NetworkManager state is now CONNECTED_GLOBAL
janv. 30 17:09:50 localhost.localdomain NetworkManager[1988]: <info>  [1612022990.9558] dhcp6 (enp4s9): activation: beginning transaction (timeout in 45 seconds)
janv. 30 17:09:50 localhost.localdomain NetworkManager[1988]: <info>  [1612022990.9603] dhcp6 (enp4s9): option dhcp6_domain_search  => 'home'
janv. 30 17:09:50 localhost.localdomain NetworkManager[1988]: <info>  [1612022990.9604] dhcp6 (enp4s9): option dhcp6_name_servers   => 'fe80::46a6:1eff:fe4d:cf3b'
janv. 30 17:09:50 localhost.localdomain NetworkManager[1988]: <info>  [1612022990.9604] dhcp6 (enp4s9): state changed unknown -> bound

Le résultat a changé en comparaison de la première fois
Et pour finir , c'est là que ça doit coincer un peu

root@localhost ~]# ifup enp4s9
Erreur : connexion inconnue : « /etc/sysconfig/network-scripts/ifcfg-enp4s9 ».

Je ne suis pas allé voir dans le fichier "/etc/sysconfig/network-scripts/ifcfg-enp4s9" je ne suis pas sûr qu'en l'état de mes connaissances cela m'amène une réponse
Je suis allé voir dans " systemd " , et là , NetworkManager est   " active "---------" running"

Ma question est , comment réactiver la connexion au démarrage
Merci
Bonne fin de journée
PS , j'avais déjà fait tout ça ce matin , j'ai dû oublier de valider , parce que lorsque je suis venu voir si j'avais une réponse , je n'ai pas trouvé ma question pint

EDIT : je viens d'aller voir dans ce dossier , et la connexion " enp4s9 " ne figure pas sous ce nom , c'est "nouvelle connexion ethernet "

Dernière modification par jenrem (30/01/2021 18:46:57)


Fedora 34KDE , ordi DELL , intel  i5-3470S

Hors ligne

#2 30/01/2021 19:05:16

fgland
Rédacteur Wiki
Rédacteur Wiki
Lieu : Lituanie
Inscription : 09/08/2004
Messages : 3 356

Re : [Résolu] Pas de connexion au démarrage

Pourrais-tu supprimer le fil créé en F32 car cela va être difficile à suivre et comme il s'agit de F33

sous kde, il y a un utilitaire graphique pour gérer les connexions réseaux, il est normalement dans la 'boite de miniature' à coté de l'heure.
un clic dessus permet déjà de voir si la connexion est active ou non et on peut l'activer.
tout en haut de ce panneau, un icone permet de gérer les connexions.
En sélectionnant enp4s9, dans la configuration générale, vérifier que se connecter... et tous les utilisateurs... sont bien cochés.
Vérifier aussi dans l'onglet 'Câblé' ce qu'il y a dans Restreindre au... car le nom de la carte réseau à pu changer (on ne sais jamais...).
Tous les retours que tu nous donnes avant

Pour essayer d'être le plus complet possible

indique une connexion active. Elle ne marchait pas ?
Gérard


F33, Kde/plasma (X11), AMD FX-6300, NVIDIA GM107 [GeForce GTX 750 Ti], 8Go de mémoire

Hors ligne

#3 30/01/2021 21:12:45

jenrem
Membre
Lieu : cote atlantique sud Ouest
Inscription : 07/12/2018
Messages : 280

Re : [Résolu] Pas de connexion au démarrage

Bonsoir Fgland
Je cherchais partout dans F33 où j'avais bien pu mettre ma question , comme je ne la trouvais pas , j'étais persuadé que j'avais oublié de valider , d'où cette deuxieme " diffusion " . Je vais allé changer ça
Ok pour la boite de dialogue en bas à droite de l'écran , c'est avec elle que j'active la connexion , mais avant de passer à la F33 , la connexion s'activait toute seule au démarrage , je suppose que je l'avais configurée come ça , le problème , c'est que bien qu'ayant remis les codes de la box , ça ne démarre pas tout seul . Je ne considere pas ça comme une gêne énorme , mais tout le monde ne pense pas comme moi , c'est pour ça que j'essaie de résoudre le problème
Après son activation manuelle , il n'y a plus de problème .
C'est juste que je souhaiterais que cela se fasse automatiquement cool
Bonne soirée


Fedora 34KDE , ordi DELL , intel  i5-3470S

Hors ligne

#4 31/01/2021 07:10:08

fgland
Rédacteur Wiki
Rédacteur Wiki
Lieu : Lituanie
Inscription : 09/08/2004
Messages : 3 356

Re : [Résolu] Pas de connexion au démarrage

tu n'as pas répondu à ma question ? car pour moi la connexion est active dès le début  selon tes retours.
systemctl enable NetworkManager n'active pas la connexion c'est systemctl start NetworkManager qui le fait mais le retour de ip addr montre une connexion active.

vérifier que se connecter... et tous les utilisateurs... sont bien cochés.

Gérard


F33, Kde/plasma (X11), AMD FX-6300, NVIDIA GM107 [GeForce GTX 750 Ti], 8Go de mémoire

Hors ligne

#5 31/01/2021 12:48:29

jenrem
Membre
Lieu : cote atlantique sud Ouest
Inscription : 07/12/2018
Messages : 280

Re : [Résolu] Pas de connexion au démarrage

Bjour Fgland
J'ai pris un peu de retard
Comme le montre  "Ip addr" , j'ai 2 connexion  enp4s9 qui est la bonne adresse de connexion , mais qui se nomme dans " /etc/sysconfig/network-scripts/ifcfg-enp4s9" nouvelle connexion
L'autre " lo "  se nomme " eth0" et c'est elle qui essaie de se connecter en premier , et qui ne le peux pas , mais je pense que sur la F32 c'était ( la seule ) adresse de connexion active  et que la F33  (où il y a quelques évolutions ) c'est créer une nouvelle adresse de connexion sans supprimer " eth0" et qu'il y a conflit entre les deux
Voici un extrait du fichier   " eth0"

IPV6_ADDR_GEN_MODE=stable-privacy
NAME=eth0
UUID=d132d186-219c-3ba3-aa5f-9996b46823cd
ONBOOT=yes
IEEE_8021X_EAP_METHODS=PWD
IEEE_8021X_IDENTITY=anna
ETHTOOL_OPTS="autoneg on"
IPV6_PRIVACY=no

ainsi que cette ligne

AUTOCONNECT_PRIORITY=99

Si je supprime " anna "  de la ligne "IEEE_8021X_IDENTITY=anna  " ,ou je passe "AUTOCONNECT_PRIORITY=99 " en priorité  " 100 " ou " 0 " ,  est ce que cela  permettra à " enp4s9" de se connecter en premier
Alors que dans " nouvelle connexion ( enp4s9) "  il n'y a pas  " priorité " , il n'y a que " USERS=anna"

ip addr montre une connexion active.

Je vais  " m'engager" un peu   
Oui , elle est active , mais " ifup" ne la reconnais pas , cela a t-il une incidence sur la connexion
Bonne journée

Edit : @Nouvo09 , si les 2 sont actifs , ce n'est pas moi qui l'ai " choisi " , je suppose que cela s'est fait à l'installation de F33 , ou alors tu as trouvé dans les codes que j'ai mis , un passage où j'active l'un ou l'autre
Je vais aller supprimer le fil de la  section  F32

Dernière modification par jenrem (31/01/2021 12:54:12)


Fedora 34KDE , ordi DELL , intel  i5-3470S

Hors ligne

#6 31/01/2021 15:22:07

fgland
Rédacteur Wiki
Rédacteur Wiki
Lieu : Lituanie
Inscription : 09/08/2004
Messages : 3 356

Re : [Résolu] Pas de connexion au démarrage

la connexion lo est la connexion locale, elle ne sert pas au réseau donc on l'ignore.
Sauf erreur de ma part, ifup et ifdown relève de nertwork, mais comme NetworkManager est lancé, il ne faut pas l'utiliser.
Je ne vois pas l'utilité de la limiter à un utilisateur.
Dans l'utilitaire graphique de configuration de kde, supprime la connexion eth0 et configurer l'onglet Configuration générale comme sur l'image
https://upload.disroot.org/r/BELpUY9W#P … 29ts9rRdM=
Gérard


F33, Kde/plasma (X11), AMD FX-6300, NVIDIA GM107 [GeForce GTX 750 Ti], 8Go de mémoire

Hors ligne

#7 31/01/2021 17:45:21

jenrem
Membre
Lieu : cote atlantique sud Ouest
Inscription : 07/12/2018
Messages : 280

Re : [Résolu] Pas de connexion au démarrage

Re Fgland
Voila , c'est réglé . C'était assez simple , mais je  souhaitais l'avis de connaisseurs avant de supprimer quelque chose , j'ai quelques fois des initiatives désastreuses sur mon ordi , mais c'est le mien et je ne m'en prends qu'à moi même , et j'ai en stock la clef usb avec la dernière version , donc " au cas où , ya plus ka "
Pour la configuration , je l'avais faite , mais " eth0 " prenait toujours le pas sur la " nouvelle connexion "
Quant à la différence entre " network " et  networkmanager " , j'avoue que je n'y avais pas fait attention ,d'autant moins que cela c'est fait au changement de version

  je vais passer en résolu 

Merci  Gerard  ( je me permet  , si tu acceptes )pour ton aide et ton temps passé
JR


Fedora 34KDE , ordi DELL , intel  i5-3470S

Hors ligne

#8 31/01/2021 18:24:37

fgland
Rédacteur Wiki
Rédacteur Wiki
Lieu : Lituanie
Inscription : 09/08/2004
Messages : 3 356

Re : [Résolu] Pas de connexion au démarrage

en gros NetworkManager est un utilitaire de connexion réseau qui utilise les scripts de network. Il est actif depuis F10. Il permet à l'utilisateur de gérer les connexions.
network n'est configurable que par root.
Donc sur un pc bureautique, on utilisera NetworkManager, sur un serveur sans interface graphique ce sera network.

eth0 était un reste d'une ancienne configuration réseau, depuis je ne sais quelle version, la carte réseau à un nom plus spécifique lié à la carte.

Gérard


F33, Kde/plasma (X11), AMD FX-6300, NVIDIA GM107 [GeForce GTX 750 Ti], 8Go de mémoire

Hors ligne

#9 31/01/2021 21:03:45

jenrem
Membre
Lieu : cote atlantique sud Ouest
Inscription : 07/12/2018
Messages : 280

Re : [Résolu] Pas de connexion au démarrage

Bonsoir Fgland
Pour " eth0 " , je pense que c'est " l'ancienne " connexion de F32 , puisque lors de la F32 ,je n'avais qu'une connexion
J'ai l'impression que la F33 a été " refondue " sur beaucoup d'applis qui ne reconnaissent peut être pas les anciennes configurations ( pure suppositions de ma part )
Pour la différence entre Network et networkManager , Nouvo09 disait que j'avais les 2 d'activés , et que c'était incompatible , est ce que le fait de de ne pouvoir démarrer qu'en  terminal n'aurait pas activé " network "
Tout cela n'est bien sûr que suppositions
Bonne soirée


Fedora 34KDE , ordi DELL , intel  i5-3470S

Hors ligne

Pied de page des forums