Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 34 Beta est disponible

#1 08/01/2021 10:19:23

j2p
Membre
Inscription : 06/07/2012
Messages : 68

sortie hdmi 2.0 non reconnue sous fedora 32 ou 33

bonne année à tous

mon vieux dell xps 17 a rendu l' âme au bout 10 ans de bons et loyaux services
je l'utilisais en double écran avec un vieux 17 pouces samsung lié via une prise hdmi

je me suis offert il y a plusieurs mois un portable  Dell G3 15 accompagné d'un écran dell 24 pouces lequel possède une double entrée hdmi et VGA
la carte video est une nvidia geforce 1600

après la manip pour virer le raid0 du bios j'ai installé la fedora 32 ( upgradée en 33) en double démarrage

mes jeux sont sous windows
le reste de mes activités sous linux

mon souci est que fedora ne gère pas correctement la liaison hdmi et que pour travailler en double écran j'ai du passer par une liaison VGA sans le son

alors que tout fonctionne  sous w10 le son et l'image sont exécutés par le 24 pouces via le Port HDMI 2.0 |

une idée ?


dell G3 15  Intel® Core™ i7-10750H CPU @ 2.60GHz × 12  16 G mem 1 To
Carte graphique NVIDIA® GeForce® GTX 1650 Ti avec 4 Go de mémoire GDDR6

Hors ligne

#2 08/01/2021 10:32:48

j2p
Membre
Inscription : 06/07/2012
Messages : 68

Re : sortie hdmi 2.0 non reconnue sous fedora 32 ou 33

addendum

je précise que la liaison par hdmi classique est gérée aussi

mais  j'ai du rajouter un accessoire via un port usb pour vga et hdmi


dell G3 15  Intel® Core™ i7-10750H CPU @ 2.60GHz × 12  16 G mem 1 To
Carte graphique NVIDIA® GeForce® GTX 1650 Ti avec 4 Go de mémoire GDDR6

Hors ligne

#3 08/01/2021 10:41:23

Vorahk
Membre
Lieu : Près de Chartres
Inscription : 16/01/2019
Messages : 160

Re : sortie hdmi 2.0 non reconnue sous fedora 32 ou 33

Même problème depuis que j'ai remplacé mon antique Thinkpad E520 par un Asus TUF FX505DV, à double GPU (iGPU Vega intégré au Ryzen 7 3750H et dGPU nVidia GeForce RTX2060). Avec nouveau, la carte nVidia n'est pas reconnue correctement, avec akmod-nvidia (de RPM Fusion) la carte est bien reconnue, mais pas moyen d'avoir l'affichage sur HDMI, juste un écran noir (il y a bien un signal vidéo quand même, quand c'est pas le cas, mon home cinéma affiche son logo, et là c'est pas le cas), mais le son passe bien.

Ça vient probablement des pilotes de la carte nVidia, ou d'un paramétrage du multi-GPU (qui soit dit en passant, était nettement plus simple sur mon Thinkpad avec son iGPU Intel (CPU: i5-2410m) et son dGPU AMD Radeon 6630m).


Mon PC était vendu avec W10, mais je ne l'ai jamais lancé (pour pouvoir me le faire rembourser, 60 balles de récupérés ! ), donc je ne sais pas ce qu'il en est (ça devrait certainement marcher, puisque c'est la config d'usine).
Du coup j'ai fait quelques tests (pour info, j'avais installé F32 KDE, j'ai upgradé vers F33 ensuite):
- Avec Wayland (en utilisant un autre user que le mien, créer pour l'occasion): ça marche pas (il faudrait que je re-teste, il y a eu des updates depuis).
- En Live avec F33 Workstation (donc bureau Gnome sur Wayland): ça marche pas.
- En Live avec Ubuntu et Kubuntu (je ne sais plus quelle version mais soit la dernière, soit l'avant dernière je pense): ça marche pas.

Je vais tester avec Manjaro KDE quand j'aurais le temps.


Edit:
Je viens de tester avec Manjaro KDE (ISO téléchargé hier midi), il y a deux options de boot:
- "Drivers open source": là j'ai l'affichage, mais j'ai des artéfacts sur l'écran en HDMI.
- "Drivers proprios": pareil que sur Fedora, écran noir et pas moyen d'y déplacer quoi que ce soit (pas vu par KDE)

Dernière modification par Vorahk (08/01/2021 11:28:04)


PC Fixe: AMD Ryzen 5 3600X | AsRock B550 Phantom Gaming 4 | Kingston HyperX Predator DDR4 2x 8Go @ 2666MHz | Sapphire Radeon RX580 Nitro+ 4Go GDDR5 | PNY CS3030 500Go NVMe
PC portables: Asus TUF-505DV (AL062T) | Lenovo Thinkpad E520 (11433MG) | Asus eeePC 1005PE
Serveur (ex-fixe): Intel i5-2550K | Gigabyte GA-Z68X-UD3H-B3 | Corsair Vengeance DDR3 2x 4Go @ 1600MHz | Sapphire Radeon R5 230 2Go GDDR3 | Hitachi 7K750 500Go @ 7200rpm

Hors ligne

Pied de page des forums