Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 34 Beta est disponible

#1 02/01/2021 08:09:42

primelooker
Membre
Inscription : 02/01/2021
Messages : 5

[Résolu] Update non fonctionnelle sur ma fedora 33

Bonjour la communauté et bonne année 2021

Depuis que je suis passsé à la fedora 33, au debut mes mises à jour fonctionnaient très bien jusqu' à la version du noyau 5.9.8.

Apres la version 5.9.8, apres chaque mise à jour, la nouvelle version de noyau installé ne demarre pas. Je suis chaque fois obligé de demarrer la version du kernel 5.9.8 avant de pouvoir utiliser mon pc.

Le problème persiste déjà depuis environ un mois et ma recente mise à jour a installer la version 5.9.16 qui n'est toujours pas fonctionnelle.

J'ai eu à lire ce qui est indiqué ici mais le problème n'est toujours pas resolu.

Je suis sur une HP Probook en dual boot avec Window 10

Merci

Dernière modification par primelooker (02/01/2021 08:11:04)

Hors ligne

#2 02/01/2021 09:51:29

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 6 365
Site Web

Re : [Résolu] Update non fonctionnelle sur ma fedora 33

Aurais-tu la référence exacte de ton PC ?

Que retourne

$ lspci

Après avoir démarré sur un kernel qui ne fonctionne pas, puis depuis un qui fonctionne, que retourne pour commencer

$ sudo journalctl -b -1 -p err

F34_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F33_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F33_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#3 02/01/2021 09:56:31

primelooker
Membre
Inscription : 02/01/2021
Messages : 5

Re : [Résolu] Update non fonctionnelle sur ma fedora 33

$ lspci 
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:16.3 Serial controller: Intel Corporation Sunrise Point-LP Active Management Technology - SOL (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #2 (rev f1)
00:1c.3 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #4 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection I219-LM (rev 21)
01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)
02:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)
$ sudo journalctl -b -1 -p err
-- Logs begin at Sun 2020-11-08 22:36:24 WAT, end at Sat 2021-01-02 08:55:12 WAT. --
Jan 01 23:21:36 localhost.localdomain systemd-modules-load[219]: Failed to find module 'platform-integrity'
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: Needed [Buffer/String/Package], found [Integer] 0000000026514d50 (20200717/exresop-557)
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20200717/dswexec-431)
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WVPO due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WMPV due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: Needed [Buffer/String/Package], found [Integer] 0000000067e10d1e (20200717/exresop-557)
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20200717/dswexec-431)
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WVPO due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WMPV due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: Needed [Buffer/String/Package], found [Integer] 0000000082dbf2dd (20200717/exresop-557)
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20200717/dswexec-431)
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WVPO due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WMPV due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: Needed [Buffer/String/Package], found [Integer] 00000000be40d3b5 (20200717/exresop-557)
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20200717/dswexec-431)
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WVPO due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 01 22:22:07 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WMPV due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 01 22:22:07 localhost.localdomain kernel: mei_wdt 0000:00:16.0-05b79a6f-4628-4d7f-899d-a91514cb32ab: Could not reg notif event ret=-22
Jan 01 22:22:07 localhost.localdomain kernel: snd_hda_codec_conexant hdaudioC0D0: vmaster hook already present before cdev!
Jan 01 22:22:07 localhost.localdomain kernel: Bluetooth: hci0: Reading supported features failed (-16)
Jan 01 22:21:53 localhost.localdomain systemd-udevd[614]: could not read from '/sys/module/pcc_cpufreq/initstate': No such device
Jan 01 22:22:15 localhost.localdomain bluetoothd[774]: Failed to set mode: Blocked through rfkill (0x12)
Jan 01 22:22:59 localhost.localdomain bluetoothd[774]: Failed to set mode: Blocked through rfkill (0x12)
Jan 01 22:23:01 localhost.localdomain pulseaudio[1620]: module-rescue-stream is obsolete and should no longer be loaded. Please remove it from your configuration.

Au demarrage, lorsque je choisi une version du kernel qui ne fonctionne pas, le demarrage bloque sur un ecran noir. Je suis obliger de forcer l'extinction.

Dernière modification par primelooker (02/01/2021 09:59:45)

Hors ligne

#4 02/01/2021 10:21:59

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 6 365
Site Web

Re : [Résolu] Update non fonctionnelle sur ma fedora 33

Ce sont bien les logs après l'échec d'un démarrage ?

Que retourne dans ce cas

$ sudo journalctl -b -p err

Depuis le menu du Grub et avec un kernel qui ne démarre pas, peux-tu éditer la ligne du kernel en appuyant sur la touche [e], puis retirer les options rhgb et quiet pour que ça cause un peu plus lors du démarrage. Ensuite appuyer sur la touche [F10] pour lancer le démarrage.

Si tu es à nouveau bloqué, est-ce que tu as accès à un TTY par la combinaison de touches [Ctrl] + [Alt] + [F3] ?


F34_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F33_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F33_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#5 02/01/2021 10:57:18

primelooker
Membre
Inscription : 02/01/2021
Messages : 5

Re : [Résolu] Update non fonctionnelle sur ma fedora 33

$ sudo journalctl -b -p err

-- Logs begin at Sun 2020-11-08 22:36:24 WAT, end at Sat 2021-01-02 09:50:58 WAT. --
Jan 02 10:45:51 localhost.localdomain systemd-modules-load[219]: Failed to find module 'platform-integrity'
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: Needed [Buffer/String/Package], found [Integer] 000000006026e253 (20200717/exresop-557)
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20200717/dswexec-431)
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WVPO due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WMPV due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: Needed [Buffer/String/Package], found [Integer] 00000000708cb21a (20200717/exresop-557)
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20200717/dswexec-431)
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WVPO due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WMPV due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: Needed [Buffer/String/Package], found [Integer] 000000002811822a (20200717/exresop-557)
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20200717/dswexec-431)
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WVPO due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WMPV due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: Needed [Buffer/String/Package], found [Integer] 000000002d7f01e1 (20200717/exresop-557)
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20200717/dswexec-431)
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WVPO due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 02 09:46:09 localhost.localdomain kernel: ACPI Error: Aborting method \_SB.WMIV.WMPV due to previous error (AE_AML_OPERAND_TYPE) (20200717/psparse-529)
Jan 02 09:46:09 localhost.localdomain kernel: mei_wdt 0000:00:16.0-05b79a6f-4628-4d7f-899d-a91514cb32ab: Could not reg notif event ret=-22
Jan 02 09:46:11 localhost.localdomain kernel: snd_hda_codec_conexant hdaudioC0D0: vmaster hook already present before cdev!
Jan 02 09:46:12 localhost.localdomain kernel: Bluetooth: hci0: Reading supported features failed (-16)
Jan 02 09:46:20 localhost.localdomain avahi-daemon[790]: chroot.c: open() failed: No such file or directory
Jan 02 09:46:22 localhost.localdomain bluetoothd[774]: Failed to set mode: Blocked through rfkill (0x12)
Jan 02 09:47:05 localhost.localdomain bluetoothd[774]: Failed to set mode: Blocked through rfkill (0x12)
Jan 02 09:47:05 localhost.localdomain pulseaudio[1625]: module-rescue-stream is obsolete and should no longer be loaded. Please remove it from your configuration.
Jan 02 09:47:17 localhost.localdomain gdm-password][1921]: gkr-pam: unable to locate daemon control file
Jan 02 09:48:11 localhost.localdomain gnome-software[2404]: libostree HTTP error from remote flathub for <https://dl.flathub.org/repo/summary.sig>: Couldn't resolve hos>
Jan 02 09:48:11 localhost.localdomain gnome-software[2404]: libostree HTTP error from remote flathub for <https://dl.flathub.org/repo/summary.sig>: Couldn't resolve hos>
Jan 02 09:48:11 localhost.localdomain gnome-software[2404]: libostree HTTP error from remote flathub for <https://dl.flathub.org/repo/summary.sig>: Couldn't resolve hos>
Jan 02 09:48:11 localhost.localdomain gnome-software[2404]: libostree HTTP error from remote flathub for <https://dl.flathub.org/repo/summary.sig>: Couldn't resolve hos>
Jan 02 09:48:11 localhost.localdomain gnome-software[2404]: libostree HTTP error from remote flathub for <https://dl.flathub.org/repo/summary.sig>: Couldn't resolve hos>
Jan 02 09:48:11 localhost.localdomain gnome-software[2404]: libostree HTTP error from remote flathub for <https://dl.flathub.org/repo/summary.sig>: Couldn't resolve hos>
Jan 02 09:48:11 localhost.localdomain gnome-software[2404]: libostree HTTP error from remote flathub for <https://dl.flathub.org/repo/summary.sig>: Couldn't resolve hos>
Jan 02 09:48:11 localhost.localdomain gnome-software[2404]: libostree HTTP error from remote flathub for <https://dl.flathub.org/repo/summary.sig>: Couldn't resolve hos>
Jan 02 09:48:11 localhost.localdomain gnome-software[2404]: libostree HTTP error from remote flathub for <https://dl.flathub.org/repo/summary.sig>: Couldn't resolve hos>
Jan 02 09:48:11 localhost.localdomain gnome-software[2404]: libostree HTTP error from remote flathub for <https://dl.flathub.org/repo/summary.sig>: Couldn't resolve hos>
Jan 02 09:48:11 localhost.localdomain gnome-software[2404]: libostree HTTP error from remote flathub for <https://dl.flathub.org/repo/summary.sig>: Couldn't resolve hos>
Jan 02 09:49:18 localhost.localdomain pulseaudio[3359]: module-rescue-stream is obsolete and should no longer be loaded. Please remove it from your configuration.
lines 4-38/38 (END)

Quand je retire les options rhgb et quiet et que j'appui sur F10, j'ai ce resultat:

EFI stub: UEFI Secure Boot is enabled
_

oui, J'ai un accès à un TTY par la combinaison de touches [Ctrl] + [Alt] + [F3] lorsque je demarre sur mon kernel fonctionnelle

Dernière modification par primelooker (02/01/2021 10:58:13)

Hors ligne

#6 02/01/2021 11:23:01

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 6 365
Site Web

Re : [Résolu] Update non fonctionnelle sur ma fedora 33

Alors c'était avec un kernel non fonctionnel la combinaison de touches pour l'accès à un TTY.

Ensuite le message EFI arrive tout de suite ou alors il y a autre chose avant ?

As-tu essayé de désactiver le Secure Boot dans ton bios ? Il est possible que tu utilises un module non-signé.


F34_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F33_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F33_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#7 02/01/2021 12:25:47

primelooker
Membre
Inscription : 02/01/2021
Messages : 5

Re : [Résolu] Update non fonctionnelle sur ma fedora 33

C'est sur le kernel fonctionnelle que la combinaison de touche ctrl+alt+F3 a marché.

Pour le message UEFI, c'est lorsque je retire les options que vous avez indiqué et appuyer sur F10 que le message apparait directement et bloque sur l'ecran noir.

A defaut de desactiver le boot secure qui est un system de protection de la machine, pourquoi lorsque je fais la mise à jour depuis un kernel fonctionnel, il telecharger donc des modules non signé ? Y a t-il des fichiers à modifier pour que lors d'une mise à jour, seul des modules signées soient telecharger ?

Merci

Hors ligne

#8 02/01/2021 12:57:02

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 6 365
Site Web

Re : [Résolu] Update non fonctionnelle sur ma fedora 33

C'est juste une supputation concernant les modules. Les options retirées permettent de voir le démarrage en détail, tu peux le faire avec le kernel qui fonctionne comme ça tu verras un démarrage complet.

Il faudrait essayer de désactiver le Secure Boot pour voir si ça vient de là ou pas.

Ensuite est-ce que le bios UEFI est à jour avec sa dernière version car ça peut aussi venir de lui ?

Non il n'y a pas de procédure pour ce que tu souhaites, du moins pas dans cette configuration de paquets.

Je mettrai quand même une grosse option sur la mise à jour du bios UEFI. Il y a dû y avoir une mise à jour du microcode Intel à coup sûr.


F34_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F33_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F33_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#9 03/01/2021 04:47:25

primelooker
Membre
Inscription : 02/01/2021
Messages : 5

Re : [Résolu] Update non fonctionnelle sur ma fedora 33

Bonjour !
J'ai eu à désactiver le démarrage sécurisé dans mon BIOS et j'obtient une belle erreur au demarrage.

Selected boot image did not authenticate
Please press enter to attempt boot to next device

Lorsque j'appui sur Entree, il me charge directement Window 10 qui est mon second système.

Si je n'arrive pas a resoudre le problème, je pourrai toujours rester sur mon kernel 5.9.8 et attendre la sortie de la Fedora 34 dans les 4 prochains mois smile smile

Dernière modification par primelooker (03/01/2021 04:48:20)

Hors ligne

#10 03/01/2021 13:52:32

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 5 479

Re : [Résolu] Update non fonctionnelle sur ma fedora 33

J'ai eu des problèmes de démarrage apparus avec les kernel 5.9.x sur un portable ASUS qui ont été résolus par une mise à jour du BIOS:

https://forums.fedora-fr.org/viewtopic.php?id=72065

https://bugzilla.redhat.com/show_bug.cgi?id=1903332



primelooker a écrit :

Si je n'arrive pas a resoudre le problème, je pourrai toujours rester sur mon kernel 5.9.8 et attendre la sortie de la Fedora 34 dans les 4 prochains mois smile smile

Le kernel 5.10.x est disponible pour fedora 33 sur koji: https://forums.fedora-fr.org/viewtopic.php?id=72107

Ca vaudrait la peine de l'essayer.

Hors ligne

Pied de page des forums