Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 37 Beta est disponible

#1 23/05/2020 19:26:35

flipflip
Membre
Inscription : 25/10/2004
Messages : 208
Site Web

[Résolu] Mise à jour Fedora 30 > 32

Bonjour à tous,

Je me lance dans la mise à jour de ma version 30 vers la 32. Après un petit ménage des paquets trop vieux (j'en ai trouvé de la version initiale installé, la 24...) je lance

dnf system-upgrade download --releasever=32

dnf me répond très mal

Avant de continuer, assurez-vous que votre système est complètement à jour en lançant « dnf --refresh upgrade ». Voulez-vous continuer ? [y/N]: y

Atom Editor                                                                                                                                                                     171  B/s | 833  B     00:04    
Fedora Modular 32 - x86_64                                                                                                                                                       12 kB/s |  24 kB     00:02    
Fedora Modular 32 - x86_64 - Updates                                                                                                                                            7.6 kB/s |  23 kB     00:03    
Fedora 32 - x86_64 - Updates                                                                                                                                                     17 kB/s |  21 kB     00:01    
Fedora 32 - x86_64                                                                                                                                                               20 kB/s |  24 kB     00:01    
RPM Fusion for Fedora 32 - Free - Updates                                                                                                                                        13 kB/s | 9.0 kB     00:00    
RPM Fusion for Fedora 32 - Free                                                                                                                                                  18 kB/s | 9.9 kB     00:00    
RPM Fusion for Fedora 32 - Nonfree - Updates                                                                                                                                    9.8 kB/s | 9.8 kB     00:00    
RPM Fusion for Fedora 32 - Nonfree                                                                                                                                               19 kB/s |  10 kB     00:00    
TeamViewer - x86_64                                                                                                                                                             5.5 kB/s | 2.5 kB     00:00    
Erreur : 
 Problème 1: package python2-PyDrive-1.3.1-7.fc30.noarch requires python2-oauth2client >= 4.0.0, but none of the providers can be installed
  - package python2-PyDrive-1.3.1-7.fc30.noarch requires python2.7dist(oauth2client) >= 4.0.0, but none of the providers can be installed
  - python2-oauth2client-4.1.3-2.fc30.noarch does not belong to a distupgrade repository
  - problem with installed package python2-PyDrive-1.3.1-7.fc30.noarch
 Problème 2: package python2-dropbox-9.4.0-1.fc30.noarch requires python2-requests, but none of the providers can be installed
  - package python2-dropbox-9.4.0-1.fc30.noarch requires python2.7dist(requests) >= 2.16.2, but none of the providers can be installed
  - python2-requests-2.22.0-2.fc30.noarch does not belong to a distupgrade repository
  - problem with installed package python2-dropbox-9.4.0-1.fc30.noarch
 Problème 3: package python2-google-api-client-1:1.6.7-6.fc30.noarch requires python2-uritemplate >= 3.0.0, but none of the providers can be installed
  - package python2-google-api-client-1:1.6.7-6.fc30.noarch requires python2.7dist(uritemplate) >= 3.0.0, but none of the providers can be installed
  - package python2-google-api-client-1:1.6.7-6.fc30.noarch requires python2.7dist(uritemplate) < 4dev, but none of the providers can be installed
  - python2-uritemplate-3.0.0-5.fc30.noarch does not belong to a distupgrade repository
  - problem with installed package python2-google-api-client-1:1.6.7-6.fc30.noarch
 Problème 4: package python2-gpg-1.13.1-7.fc30.x86_64 requires gpgme(x86-64) = 1.13.1-7.fc30, but none of the providers can be installed
  - gpgme-1.13.1-7.fc30.x86_64 does not belong to a distupgrade repository
  - problem with installed package python2-gpg-1.13.1-7.fc30.x86_64
 Problème 5: package python2-kickstart-3.20-2.fc30.noarch requires python2-ordered-set, but none of the providers can be installed
  - python2-ordered-set-2.0.2-8.fc30.noarch does not belong to a distupgrade repository
  - problem with installed package python2-kickstart-3.20-2.fc30.noarch
 Problème 6: package python2-langtable-0.0.43-3.fc30.noarch requires langtable = 0.0.43-3.fc30, but none of the providers can be installed
  - langtable-0.0.43-3.fc30.noarch does not belong to a distupgrade repository
  - problem with installed package python2-langtable-0.0.43-3.fc30.noarch
 Problème 7: package python2-pwquality-1.4.0-12.fc30.x86_64 requires libpwquality(x86-64) = 1.4.0-12.fc30, but none of the providers can be installed
  - libpwquality-1.4.0-12.fc30.x86_64 does not belong to a distupgrade repository
  - problem with installed package python2-pwquality-1.4.0-12.fc30.x86_64
 Problème 8: package yum-utils-1.1.31-519.fc30.noarch requires python2-kitchen, but none of the providers can be installed
  - python2-kitchen-1.2.5-5.fc29.noarch does not belong to a distupgrade repository
  - problem with installed package yum-utils-1.1.31-519.fc30.noarch
 Problème 9: package python2-langtable-0.0.43-3.fc30.noarch requires langtable-data = 0.0.43-3.fc30, but none of the providers can be installed
  - package yum-langpacks-0.4.5-10.fc30.noarch requires python2-langtable, but none of the providers can be installed
  - langtable-data-0.0.43-3.fc30.noarch does not belong to a distupgrade repository
  - problem with installed package yum-langpacks-0.4.5-10.fc30.noarch
(essayez d’ajouter « --skip-broken » pour ignorer les paquets non installables)

Je regarde rapidement pour virer python2-PyDrive et la liste de dépendance me fait peur (deja et duplicity...), du coups j'hésite à les supprimer pour faire la mise à jour.
Comme je suis fou j'ajoute --allowerasing, ça passe comme papa dans maman, je lance le reboot. Le processus de mise à jour commence et à peine une seconde plus tard nouveau reboot et j'arrive sur la fedora 30 :(

Malheureusement je ne sais pas où trouver les log de la tentative de mise à jour.

Avez-vous déjà rencontrer ce problème ?

Merci d'avance.


J'ai un string dans l'array

Hors ligne

#2 23/05/2020 21:11:51

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 7 491
Site Web

Re : [Résolu] Mise à jour Fedora 30 > 32

Si tu dis retrouver des versions de paquets en fc24, je te conseille de repartir sur une installation propre de F32.
Ça t'évitera des déconvenues avec d'anciens fichiers de configurations et le ménage sera fait.


F36_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F36_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F36_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#3 23/05/2020 22:05:39

Refuznik
Membre
Inscription : 31/01/2007
Messages : 8 089

Re : [Résolu] Mise à jour Fedora 30 > 32

Ou alors de faire deja un upgrade de F30 à F31 et voir où ça coince.

Hors ligne

#4 25/05/2020 08:26:20

flipflip
Membre
Inscription : 25/10/2004
Messages : 208
Site Web

Re : [Résolu] Mise à jour Fedora 30 > 32

Bonjour à tous,

Si tu dis retrouver des versions de paquets en fc24, je te conseille de repartir sur une installation propre de F32.

L'idée de me taper de nouveau toute la config me fatigue déjà et jusqu'à présent je n'ai jamais eu de problème avec les fichiers de config sachant que j'utilise ce pc uniquement pour de la bureautique/travail (admin et un peu de dev mais tout est à distance sur serveur).


Ou alors de faire deja un upgrade de F30 à F31 et voir où ça coince.

J'ai tenté mais même message.

Du coups je me suis décidé à supprimer les paquets python2 qui posent problèmes. Maintenant je n'ai plus besoin de --allowerasing mais j'ai toujours le même problème lors du reboot. Il commence le processus et reboot au bout d'une seconde. Dans les logs de dnf j'ai :

2020-05-24T16:39:08Z DEBUG DNF version: 4.2.18
2020-05-24T16:39:08Z DDEBUG Command: dnf system-upgrade reboot 
2020-05-24T16:39:08Z DDEBUG Installroot: /
2020-05-24T16:39:08Z DDEBUG Releasever: 30
2020-05-24T16:39:08Z DEBUG cachedir: /var/cache/dnf
2020-05-24T16:39:08Z DDEBUG Base command: system-upgrade
2020-05-24T16:39:08Z DDEBUG Extra commands: ['system-upgrade', 'reboot']
2020-05-24T16:39:08Z DEBUG Valeur de configuration inconnue : failovermethod=priority dans /etc/yum.repos.d/teamviewer.repo; Configuration : OptionBinding ayant pour id « failovermethod » n’existe pas
2020-05-24T16:39:08Z DDEBUG Cleaning up.
2020-05-24T16:41:03Z INFO --- logging initialized ---
2020-05-24T16:41:03Z DDEBUG timer: config: 44 ms
2020-05-24T16:41:03Z DEBUG Plugins chargés : builddep, changelog, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, needs-restarting, playground, repoclosure, repodiff, repograph, repomanage, reposync, system-upgrade
2020-05-24T16:41:03Z DEBUG DNF version: 4.2.18
2020-05-24T16:41:03Z DDEBUG Command: dnf system-upgrade upgrade 
2020-05-24T16:41:03Z DDEBUG Installroot: /
2020-05-24T16:41:03Z DDEBUG Releasever: 30
2020-05-24T16:41:03Z DEBUG cachedir: /var/cache/dnf
2020-05-24T16:41:03Z DDEBUG Base command: system-upgrade
2020-05-24T16:41:03Z DDEBUG Extra commands: ['system-upgrade', 'upgrade']
2020-05-24T16:41:03Z DEBUG Valeur de configuration inconnue : failovermethod=priority dans /etc/yum.repos.d/teamviewer.repo; Configuration : OptionBinding ayant pour id « failovermethod » n’existe pas
2020-05-24T16:41:08Z DEBUG dépôt : utilisation du cache pour : Atom
2020-05-24T16:41:08Z DEBUG Atom : utilisation des métadonnées depuis le mer. 20 mai 2020 05:48:49 CEST.
2020-05-24T16:41:08Z DEBUG dépôt : utilisation du cache pour : fedora-modular
2020-05-24T16:41:08Z DEBUG fedora-modular : utilisation des métadonnées depuis le mer. 22 avril 2020 23:03:13 CEST.
2020-05-24T16:41:08Z DEBUG dépôt : utilisation du cache pour : updates-modular
2020-05-24T16:41:08Z DEBUG updates-modular : utilisation des métadonnées depuis le ven. 22 mai 2020 06:35:18 CEST.
2020-05-24T16:41:08Z DEBUG dépôt : utilisation du cache pour : updates
2020-05-24T16:41:08Z DEBUG updates : utilisation des métadonnées depuis le dim. 24 mai 2020 03:33:43 CEST.
2020-05-24T16:41:09Z DEBUG dépôt : utilisation du cache pour : fedora
2020-05-24T16:41:09Z DEBUG fedora : utilisation des métadonnées depuis le jeu. 23 avril 2020 00:22:36 CEST.
2020-05-24T16:41:09Z DEBUG dépôt : utilisation du cache pour : rpmfusion-free-updates
2020-05-24T16:41:09Z DEBUG rpmfusion-free-updates : utilisation des métadonnées depuis le dim. 24 mai 2020 13:21:20 CEST.
2020-05-24T16:41:09Z DEBUG dépôt : utilisation du cache pour : rpmfusion-free
2020-05-24T16:41:09Z DEBUG rpmfusion-free : utilisation des métadonnées depuis le ven. 24 avril 2020 19:27:23 CEST.
2020-05-24T16:41:09Z DEBUG dépôt : utilisation du cache pour : rpmfusion-nonfree-updates
2020-05-24T16:41:09Z DEBUG rpmfusion-nonfree-updates : utilisation des métadonnées depuis le dim. 24 mai 2020 13:41:29 CEST.
2020-05-24T16:41:09Z DEBUG dépôt : utilisation du cache pour : rpmfusion-nonfree
2020-05-24T16:41:09Z DEBUG rpmfusion-nonfree : utilisation des métadonnées depuis le ven. 24 avril 2020 19:52:12 CEST.
2020-05-24T16:41:09Z DEBUG dépôt : utilisation du cache pour : teamviewer
2020-05-24T16:41:09Z DEBUG teamviewer : utilisation des métadonnées depuis le mer. 20 mai 2020 09:50:20 CEST.
2020-05-24T16:41:09Z INFO Dernière vérification de l’expiration des métadonnées effectuée il y a 0:03:21 le dim. 24 mai 2020 18:37:48 CEST.
2020-05-24T16:41:09Z DDEBUG timer: sack setup: 6068 ms
2020-05-24T16:41:09Z DEBUG Completion plugin: Generating completion cache...
2020-05-24T16:41:14Z DEBUG --> Début de la résolution des dépendances
2020-05-24T16:41:14Z DEBUG --> Finding unneeded leftover dependencies
2020-05-24T16:41:15Z DEBUG --> Résolution des dépendances terminée
2020-05-24T16:41:15Z DDEBUG timer: depsolve: 1081 ms
2020-05-24T16:41:15Z SUBDEBUG 
Traceback (most recent call last):
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 122, in cli_run
    ret = resolving(cli, base)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 158, in resolving
    base.resolve(cli.demands.allow_erasing)
  File "/usr/lib/python3.7/site-packages/dnf/base.py", line 777, in resolve
    raise exc
dnf.exceptions.DepsolveError: 
 Problème: both package rpmfusion-free-obsolete-packages-32-3.fc32.noarch and fedora-obsolete-packages-32-44.noarch obsolete gstreamer-plugins-ugly < 0.10.19-34
  - conflicting requests
2020-05-24T16:41:15Z CRITICAL Erreur : 
 Problème: both package rpmfusion-free-obsolete-packages-32-3.fc32.noarch and fedora-obsolete-packages-32-44.noarch obsolete gstreamer-plugins-ugly < 0.10.19-34
  - conflicting requests
2020-05-24T16:41:15Z INFO (essayez d’ajouter « --skip-broken » pour ignorer les paquets non installables)
2020-05-24T16:41:15Z DDEBUG Cleaning up.

Avant ça j'ai supprimé deux autres paquets en rapport avec gstreamer. A priori c'est un problème connu https://bugzilla.redhat.com/show_bug.cgi?id=1822597 . Je n'ai pas encore eu le temps de lire correctement le rapport de bug.

Dernière modification par flipflip (25/05/2020 08:27:52)


J'ai un string dans l'array

Hors ligne

#5 25/05/2020 09:34:31

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 8 472
Site Web

Re : [Résolu] Mise à jour Fedora 30 > 32

et le paquet gstreamer-plugins-ugly qui semble déranger, tu l'as ? si oui t'as tenté de le désinstaller ?


Linux, ya moins bien, mais c'est plus chèr!!!
Fedora 32 WorkStation sur HP 850 G5
Fedora 32 SilverBlue sur Lenovo Thinkpad Yoga 12

Hors ligne

#6 26/05/2020 08:42:35

flipflip
Membre
Inscription : 25/10/2004
Messages : 208
Site Web

Re : [Résolu] Mise à jour Fedora 30 > 32

J'ai réussi à faire la mise à jour.

J'ai viré les paquets gstreamer-plugin* et le processus a pu aller jusqu'au bout.

Merci.


J'ai un string dans l'array

Hors ligne

Pied de page des forums