Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 34 Beta est disponible

#1 06/05/2020 17:01:58

antiours
Membre
Inscription : 04/05/2014
Messages : 2

VNC via partage de bureau gnome - Connexion refusée par l'ordinateur

Bonjour,

J'ai activé le partage de bureau depuis mon PC hôte en FC31.
Lorsque je lance le vncviewer officiel depuis un client windows je reçois le message d'erreur "Connexion refusée par l'ordinateur"

:~$ sudo firewall-cmd --list-services
vnc-server
:~$ sudo firewall-cmd --list-ports
5900/tcp

J'ai installé et tenté de lancer vncserver sur :0 pour voir un peu son retour et il me dit qu'un serveur VNC est déjà en écoute sur :0
Lorsque je le lance sur :1 alors je peux me connecter à un bureau distant, mais celui qui m'intéresse c'est :0 pour accéder à l'affichage de l'utilisateur courant et via gnome pour éviter d'installer des trucs supplémentaire redondants (pas via d'autres serveurs VNC).

:~$ vncserver :0

Warning: salon-pc:0 is taken because of /tmp/.X11-unix/X0
Remove this file if there is no X server salon-pc:0
A VNC server is already running as :0

Ma question est donc de savoir comment faire fonctionner le gnome VNC en fedora 31 ?
Pour information un telnet depuis windows sur le port 5900 ne fonctionne pas. J'ai l'impression que le service n'est pas lancé, malgré le fait que j'ai cocher la case dans le panneau de configuration des partages. Comment la lancer en ligne de commande ?

Dernière modification par antiours (06/05/2020 17:05:28)

Hors ligne

#2 06/05/2020 22:07:13

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 6 370
Site Web

Re : VNC via partage de bureau gnome - Connexion refusée par l'ordinateur

Le client Windows est dans ton réseau ou pas ?

Sur ta F31 le port est en écoute ou pas ?


F34_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F33_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F33_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#3 07/05/2020 17:58:26

antiours
Membre
Inscription : 04/05/2014
Messages : 2

Re : VNC via partage de bureau gnome - Connexion refusée par l'ordinateur

Oui aux deux questions.

J'ai l'impression que le serveur VNC de gnome FC31 est vino. Est-ce le bien cas ?
J'ai pu faire quelques progrès hier sur la base de cette supposition car lorsque je lance vino à la main j'ai bien un réponse coté client et j'arrive à lancer la connexion.
Par contre j'ai un message d'erreur qui me dit que le cryptage coté serveur n'est pas compatible avec le client.
Lorsque je désactive le cryptage coté serveur via la ligne de commande il me jette sur le mot de passe.
Lorsque je désactive ensuite authentification via le mot de passe alors j'ai bien une connexion mais un écran noir coté client et aucun message d'erreur dans la sortie standard du serveur que j'ai lancé depuis une invite de commande de celui-ci.




Quelques fonctions utiles pour les lecteurs :
Il est possible de lancer vino depuis la machine serveur (pas via ssh) avec la commande

:~$ sudo /usr/libexec/vino-server

source
Il est possible de modifier les paramètres du serveur vino avec les commandes depuis la machine (pas via ssh). Par exemple :

:~$ sudo gsettings set org.gnome.Vino require-encryption false

commandes disponibles :
alternative-port            lock-screen-on-disconnect   require-encryption
authentication-methods      mailto                      use-alternative-port
disable-background          network-interface           use-upnp
disable-xdamage             notify-on-connect           view-only
icon-visibility             prompt-enabled              vnc-password

Dernière modification par antiours (07/05/2020 18:06:25)

Hors ligne

Pied de page des forums