Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 34 Beta est disponible

#1 01/04/2020 11:37:07

soldatcassis
Membre
Inscription : 26/01/2012
Messages : 113

[Résolu] Joomla

Bonjour,
J'essaie d'installer Joomla en local sur mon poste fedora 31 , à la maison.
J'ai installé LAMP comme indiqué dans le poste ici , avec tous les tests requis et les services apache, mariadb "enable".
J'ai créé un dossier Joomla dans /var/www/html/
J'ai créé un utilisateur "tototest" qui a une base de donnée "totobase" avec un mot de passe
J'ai ouvert mon navigateur et j'ai entré l'adresse localhost/Joomla

La page d'installation de joomla s'est affichée

Je remplis la première page
Je passe à la 2e
Vient la 3e avec le serveur ftp que je n'installe pas, comme indiqué
vient la 4e avec le résumé.
1585737249.png
1585737249.png

Je lance l'installation

J'obtiens un écran qui montre le début de l'installation, avec une barre de progression au tiers remplie et 4 petits bonhommes de couleur qui font une ronde et après 30 secondes environ, je retombe sur la page de résumé

Il y a donc un bug quelque part, mais où?

Si quelqu'un a déjà installé joomla sur fedora en local, ce serait sympa..
Déjà merci


fedora31 Lenovo v510 15IKB Intel® Core™ i5 - 7200U CPU  @ 2.5 GHz
Dualboot sur 2 disques durs

Hors ligne

#2 01/04/2020 16:19:35

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 8 472
Site Web

Re : [Résolu] Joomla

Bonjour,

La règle de base, le premier réflexe: que disent les logs ? Apache et SELinux en priorité.
S'il n'y a rien de ce côté, faudra voir l'aide du côté du projet Joomla, il y a plus de chance que tu reçoives des réponses.


Linux, ya moins bien, mais c'est plus chèr!!!
Fedora 32 WorkStation sur HP 850 G5
Fedora 32 SilverBlue sur Lenovo Thinkpad Yoga 12

Hors ligne

#3 01/04/2020 17:04:31

soldatcassis
Membre
Inscription : 26/01/2012
Messages : 113

Re : [Résolu] Joomla

Bonjour,
merci pour la réponse rapide.
dans /var/log/httpd/, j'ai un fichier error_log dont une copie partielle est ci-dessous

[Wed Apr 01 08:20:00.022869 2020] [core:notice] [pid 997:tid 140719745241408] S>
[Wed Apr 01 08:20:00.261237 2020] [suexec:notice] [pid 997:tid 140719745241408]>
[Wed Apr 01 08:20:00.312336 2020] [lbmethod_heartbeat:notice] [pid 997:tid 1407>
[Wed Apr 01 08:20:00.312933 2020] [http2:warn] [pid 997:tid 140719745241408] AH>
[Wed Apr 01 08:20:00.317691 2020] [mpm_event:notice] [pid 997:tid 1407197452414>
[Wed Apr 01 08:20:00.317732 2020] [core:notice] [pid 997:tid 140719745241408] A>
[Wed Apr 01 08:20:00.540081 2020] [:warn] [pid 1337:tid 140719745241408] ./mod_>
[Wed Apr 01 09:27:33.945366 2020] [proxy_fcgi:error] [pid 1340:tid 140718915884>
[Wed Apr 01 09:29:48.171860 2020] [proxy_fcgi:error] [pid 7419:tid 140718748194>
[Wed Apr 01 09:43:56.566570 2020] [proxy_fcgi:error] [pid 1340:tid 140719058560>
[Wed Apr 01 09:45:52.905154 2020] [proxy_fcgi:error] [pid 7419:tid 140718588798>
[Wed Apr 01 09:48:16.099683 2020] [mpm_event:notice] [pid 997:tid 1407197452414>
[Wed Apr 01 09:48:18.689623 2020] [core:notice] [pid 8052:tid 139973004636480] >
[Wed Apr 01 09:48:18.702212 2020] [suexec:notice] [pid 8052:tid 139973004636480>
[Wed Apr 01 09:48:18.719073 2020] [lbmethod_heartbeat:notice] [pid 8052:tid 139>
[Wed Apr 01 09:48:18.719700 2020] [http2:warn] [pid 8052:tid 139973004636480] A>
[Wed Apr 01 09:48:18.722795 2020] [mpm_event:notice] [pid 8052:tid 139973004636>
[Wed Apr 01 09:48:18.722831 2020] [core:notice] [pid 8052:tid 139973004636480] >
[Wed Apr 01 09:48:18.776965 2020] [:warn] [pid 8056:tid 139973004636480] ./mod_>
[Wed Apr 01 09:53:16.938695 2020] [proxy_fcgi:error] [pid 8059:tid 139972641519>
[Wed Apr 01 09:58:49.879886 2020] [mpm_event:notice] [pid 8052:tid 139973004636>
[Wed Apr 01 09:58:51.094418 2020] [core:notice] [pid 8549:tid 140359587062080] >
[Wed Apr 01 09:58:51.096312 2020] [suexec:notice] [pid 8549:tid 140359587062080>
[Wed Apr 01 09:58:51.117185 2020] [lbmethod_heartbeat:notice] [pid 8549:tid 140>
[Wed Apr 01 09:58:51.118367 2020] [http2:warn] [pid 8549:tid 140359587062080] A>
[Wed Apr 01 09:58:51.121400 2020] [mpm_event:notice] [pid 8549:tid 140359587062>
[Wed Apr 01 09:58:51.121436 2020] [core:notice] [pid 8549:tid 140359587062080] >
[Wed Apr 01 10:00:38.101268 2020] [proxy_fcgi:error] [pid 8556:tid 140358960789>
[Wed Apr 01 10:00:42.274755 2020] [proxy_fcgi:error] [pid 8554:tid 140359207159>
[Wed Apr 01 10:03:38.475362 2020] [proxy_fcgi:error] [pid 8784:tid 140358860142>

Pour SELinux, je ne sais pas où chercher ...

Sinon, j'espère que vous allez tous bien.
A +


fedora31 Lenovo v510 15IKB Intel® Core™ i5 - 7200U CPU  @ 2.5 GHz
Dualboot sur 2 disques durs

Hors ligne

#4 02/04/2020 11:30:25

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 8 472
Site Web

Re : [Résolu] Joomla

Sans la fin des lignes c'est inutilisable. Pourtant on voit des erreurs. Peut-être une piste.

Pour vérifier si c'est SELinux qui en protégeant ton pc bloque joomla tu peux désactiver ce dernier temporairement et voir si ça passe mieux :

sudo setenforce 0

et 1 pour le réactiver (ou un reboot)


Linux, ya moins bien, mais c'est plus chèr!!!
Fedora 32 WorkStation sur HP 850 G5
Fedora 32 SilverBlue sur Lenovo Thinkpad Yoga 12

Hors ligne

#5 07/04/2020 15:25:38

soldatcassis
Membre
Inscription : 26/01/2012
Messages : 113

Re : [Résolu] Joomla

Bonjour,
Excusez le délai pour la réponse, mais j'ai essayé plusieurs pistes sans succès. De guerre lasse, je me suis résolu à installer un autre CMS: wordpress (wp). Quand la documentation manque quelque part, il faut chercher ailleurs.
Je résume:

1) J'ai installé mariadb en suivant ce poste mariadb
J'ai également créé une base de données (important pour la signaler à wp), un utilisateur de cette base (idem) ainsi que son mot de passe.
J'ai activé mariadb avec la commande

#systemctl start mariadb

2) J'ai procédé de même pour installer apache en suivant ce poste https://doc.fedora-fr.org/wiki/Installa … d%27Apache
J'ai activé le service en entrant la commande

#systemctl start httpd.service

3) Et rebelote avec php en suivant ce poste https://doc.fedora-fr.org/wiki/Installa … ion_de_PHP
en écrivant le fichier ini.php de contrôle avec l'éditeur nano
Et tout ça a bien fonctionné.
4) Et pour finir, je me suis aidé de ce poste Install WordPress 5 with... en modifiant un peu le téléchargement de wp.
Je suis allé sur le site de wp en français, j'ai téléchargé le fichier .zip sur mon ordi et ensuite je l'ai décompressé là où c'était demandé.
J'ai lancé l'installation, j'ai complété les champs demandés et voilà mon site en localhost.

Le problème en localhost est qu'on n'a pas accès directement au site de wordpress (c'est normal). Donc pour les plugins, il faut les télécharger d'abord sur son ordi, avant de les installer. Mais ça fonctionne.
Voilà, je mets le sujet comme résolu, même si la démarche n'est pas très élégante.
Si je trouve une fois une méthode pour installer joomla, je la présenterai
Encore merci


fedora31 Lenovo v510 15IKB Intel® Core™ i5 - 7200U CPU  @ 2.5 GHz
Dualboot sur 2 disques durs

Hors ligne

Pied de page des forums