Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : La nouvelle version de Fedora dite 33 est sortie

#1 29/11/2019 14:44:54

Mabed
Membre
Inscription : 10/04/2019
Messages : 9

[Résolu] STEAM ne se lance pas

Bonjour,
Je viens de passer a la nouvelle version de fedora (31) je viens de finir ma config (driver nvidia via rpmfusion, logiciel, clef ssh)

je viens d'installer STEAM et il ne se lance pas, à savoir mon ordinateur portable qui est sous fedora31 arrive bien a lancer steam.
Voici les erreurs :

$ sudo dnf install steam
$ steam
Running Steam on fedora 31 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
/home/mathieu/.local/share/Steam/ubuntu12_32/steam
Installing breakpad exception handler for appid(steam)/version(1574216296)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Installing breakpad exception handler for appid(steam)/version(1574216296)
Installing breakpad exception handler for appid(steam)/version(1574216296)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Steam: An X Error occurred
X Error of failed request:  GLXBadContext
Major opcode of failed request:  151
Serial number of failed request:  61
xerror_handler: X failed, continuing
Steam: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)
Major opcode of failed request:  151
Value in failed request:  0x0
Serial number of failed request:  60
xerror_handler: X failed, continuing
Steam: An X Error occurred
X Error of failed request:  BadMatch (invalid parameter attributes)
Major opcode of failed request:  151
Serial number of failed request:  62
xerror_handler: X failed, continuing
assert_20191129132428_1.dmp[11753]: Uploading dump (out-of-process)
/tmp/dumps/assert_20191129132428_1.dmp
/home/mathieu/.local/share/Steam/steam.sh : ligne 722 : 11731 Erreur de segmentation  (core dumped)$STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"
assert_20191129132428_1.dmp[11753]: Finished uploading minidump (out-of-process): success = yes
assert_20191129132428_1.dmp[11753]: response: CrashID=bp-b48153e3-1974-462c-9b76-daa7f2191129
assert_20191129132428_1.dmp[11753]: file ''/tmp/dumps/assert_20191129132428_1.dmp'', upload yes: ''CrashID=bp-b48153e3-1974-462c-9b76-daa7f2191129''
$ uname -a
Linux game-station 5.3.12-300.fc31.x86_64 #1 SMP Thu Nov 21 22:52:07 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
$ nvidia-smi 
Fri Nov 29 13:34:23 2019       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 440.36       Driver Version: 440.36       CUDA Version: 10.2     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 1080    Off  | 00000000:01:00.0  On |                  N/A |
| 11%   50C    P0    48W / 200W |    581MiB /  8116MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      2568      G   /usr/libexec/Xorg                            297MiB |
|    0      9460      G   /usr/bin/kwin_x11                            167MiB |
|    0      9544      G   /usr/bin/krunner                               1MiB |
|    0      9549      G   /usr/bin/plasmashell                          99MiB |
|    0      9916      G   /usr/bin/akonadi_archivemail_agent             2MiB |
|    0      9928      G   /usr/bin/akonadi_mailfilter_agent              2MiB |
|    0      9944      G   /usr/bin/akonadi_sendlater_agent               2MiB |
|    0      9946      G   /usr/bin/akonadi_unifiedmailbox_agent          2MiB |
+-----------------------------------------------------------------------------+

glxgear est ok.

Je reste a votre disposition pour vous fournir les sorties de commande qui vous s’intéresse.

Cordialement,

Mathieu

Dernière modification par Mabed (29/11/2019 16:36:23)


Laptop : Lenovo Y520 / SSD 240Go / 16 Go de ram 2400mhz / GTX 1060 6 Go / 15" Fedora 32 + KDE PLASMA

Desktop : i7 4790k 4.6ghz / SSD 240Go / 16go ram 2400mhz / GTX 1080 8go / Samsung 27" 2560x1440 144 hz & AOC 24" 1920x1080 Fedora 31 + KDE

Hors ligne

#2 29/11/2019 15:47:28

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 8 472
Site Web

Re : [Résolu] STEAM ne se lance pas

Bonjour,

Tout d'abord, une information importante, comment a été installé Steam ?


Linux, ya moins bien, mais c'est plus chèr!!!
Fedora 32 WorkStation sur HP 850 G5
Fedora 32 SilverBlue sur Lenovo Thinkpad Yoga 12

Hors ligne

#3 29/11/2019 16:34:54

Mabed
Membre
Inscription : 10/04/2019
Messages : 9

Re : [Résolu] STEAM ne se lance pas

Bonjour,
Merci de ton aide.

Steam à été installer via les repo 'dnf install steam"

--------------------------------------------------------------------------

Je viens de trouver ma solution:
après installation de ce paquet Steam se lance :

dnf install xorg-x11-drv-nvidia-libs.i686

Laptop : Lenovo Y520 / SSD 240Go / 16 Go de ram 2400mhz / GTX 1060 6 Go / 15" Fedora 32 + KDE PLASMA

Desktop : i7 4790k 4.6ghz / SSD 240Go / 16go ram 2400mhz / GTX 1080 8go / Samsung 27" 2560x1440 144 hz & AOC 24" 1920x1080 Fedora 31 + KDE

Hors ligne

#4 29/11/2019 16:52:07

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 8 472
Site Web

Re : [Résolu] STEAM ne se lance pas

Merci d'avoir partagé la solution. Bonne continuation.


Linux, ya moins bien, mais c'est plus chèr!!!
Fedora 32 WorkStation sur HP 850 G5
Fedora 32 SilverBlue sur Lenovo Thinkpad Yoga 12

Hors ligne

#5 29/11/2019 18:39:35

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 5 933
Site Web

Re : [Résolu] STEAM ne se lance pas

Tu utilises le pilote nvidia provenant d'où et installé comment ?


F32_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F32_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F32_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#6 01/12/2019 17:08:41

winmandrake
Rédacteur Wiki
Rédacteur Wiki
Inscription : 08/07/2008
Messages : 1 234

Re : [Résolu] STEAM ne se lance pas

Je vais répondre à sa place en le citant:

Mabed a écrit :

Bonjour,
Je viens de passer a la nouvelle version de fedora (31) je viens de finir ma config (driver nvidia via rpmfusion, logiciel, clef ssh)
[....]
Cordialement,

Mathieu

smile

Mais il est dommage que dnf n'est pas installé xorg-x11-drv-nvidia-libs.i686 en même temps que les drivers nvidia.

Dernière modification par winmandrake (01/12/2019 17:09:00)


Mon pc : AMD R5-2400G sur Asus Prime B450M-A, 16 Go ram, Nvidia 1050Ti (4Go), SSD Samsung 850 EVO (250 Go) + black caviar de 1To.

Hors ligne

#7 01/12/2019 17:14:17

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 5 933
Site Web

Re : [Résolu] STEAM ne se lance pas

Pinaise, je l'ai loupé à la lecture tellement c'était noyé. Merci winmandrake !

J'ai ajouté ce détail dans l'article https://doc.fedora-fr.org/wiki/Steam.


F32_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F32_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F32_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#8 02/12/2019 16:48:06

come
Rédacteur Wiki
Rédacteur Wiki
Inscription : 03/01/2012
Messages : 10

Re : [Résolu] STEAM ne se lance pas

Nicosss a écrit :

Pinaise, je l'ai loupé à la lecture tellement c'était noyé. Merci winmandrake !

J'ai ajouté ce détail dans l'article https://doc.fedora-fr.org/wiki/Steam.

Peut-être qu'il faudrait préciser xorg-x11-drv-nvidia-libs.i686 puisque ce sont des encore des fichiers 32 bits qui sont nécessaires pour steam.

Hors ligne

#9 02/12/2019 17:00:30

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 5 933
Site Web

Re : [Résolu] STEAM ne se lance pas

come a écrit :
Nicosss a écrit :

Pinaise, je l'ai loupé à la lecture tellement c'était noyé. Merci winmandrake !

J'ai ajouté ce détail dans l'article https://doc.fedora-fr.org/wiki/Steam.

Peut-être qu'il faudrait préciser xorg-x11-drv-nvidia-libs.i686 puisque ce sont des encore des fichiers 32 bits qui sont nécessaires pour steam.

Bien vu, effectivement j'ai oublié de le mettre. J'ai corrigé.

Merci pour le retour !


F32_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F32_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F32_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

Pied de page des forums