Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fin de maintenance pour Fedora 32

#26 22/10/2019 04:47:25

NovFedo
Membre
Lieu : Villeurbanne
Inscription : 03/11/2010
Messages : 175

Re : [Résolu] akmod nvidia-340xx et kernel 5.3.x

Merci didierg pour ton aide et tes recherches j'ai pu installer le patch et reconstruire le kmod ça à fait drôle j'ai été déconnecté et j'ai put me loguer
normalement et l'affichage est revenu correctement j'ai redémarré pour voir si tout se passait bien et la pas de soucis le démarrage à fonctionné
je suis maintenant sur le 5.3.6-200 avec un affichage normal.
Merci à toi pour ta patience et ton aide

Dernière modification par NovFedo (22/10/2019 11:24:11)


msi i7 nvidia840M  8Go de ram  fedora 34 KDE      Asus P8Z77-V LK  Intel Core i7 3770 16Go  Fedora 34 KDE

Hors ligne

#27 22/10/2019 07:20:34

Vorahk
Membre
Lieu : Près de Chartres
Inscription : 16/01/2019
Messages : 162

Re : [Résolu] akmod nvidia-340xx et kernel 5.3.x

Je confirme, j'ai mis à jour mon vieux Qosmio (équipé d'une 9800m GTS, donc akmod-nvidia-340) hier soir, le akmod ne compile pas en 5.3.6.


PC Fixe: AMD Ryzen 5 3600X | AsRock B550 Phantom Gaming 4 | Kingston HyperX Predator DDR4 2x 8Go @ 2666MHz | Sapphire Radeon RX580 Nitro+ 4Go GDDR5 | PNY CS3030 500Go NVMe
PC portables: Asus TUF-505DV (AL062T) | Lenovo Thinkpad E520 (11433MG) | Asus eeePC 1005PE
Serveur (ex-fixe): Intel i5-2550K | Gigabyte GA-Z68X-UD3H-B3 | Corsair Vengeance DDR3 2x 4Go @ 1600MHz | Sapphire Radeon R5 230 2Go GDDR3 | Hitachi 7K750 500Go @ 7200rpm

Hors ligne

#28 22/10/2019 10:02:43

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 5 544

Re : [Résolu] akmod nvidia-340xx et kernel 5.3.x

NovFedo a écrit :

Merci didierg pour ton aide et tes recherches j'ai pu installer le patch et reconstruire le kmod ça à fait drôle j'ai été déconnecté et j'ai put me loguer normalement et l'affichage est revenu correctement j'ai redémarré pour voir si tout se passait bien et la pas de soucis je démarrage à fonctionné
je suis maintenant sur le 5.3.6-200 avec un affichage normal.

Super.

Peux remplacer le sujet de ton premier message par quelque chose du genre

akmod nvidia-340xx et kernel 5.3.x

et passer la discussion en résolu.

Voir: https://forums.fedora-fr.org/viewtopic. … 61#p602561

Hors ligne

#29 22/10/2019 11:15:10

NovFedo
Membre
Lieu : Villeurbanne
Inscription : 03/11/2010
Messages : 175

Re : [Résolu] akmod nvidia-340xx et kernel 5.3.x

didierg a écrit :
NovFedo a écrit :

Merci didierg pour ton aide et tes recherches j'ai pu installer le patch et reconstruire le kmod ça à fait drôle j'ai été déconnecté et j'ai put me loguer normalement et l'affichage est revenu correctement j'ai redémarré pour voir si tout se passait bien et la pas de soucis je démarrage à fonctionné
je suis maintenant sur le 5.3.6-200 avec un affichage normal.

Super.

Peux remplacer le sujet de ton premier message par quelque chose du genre

akmod nvidia-340xx et kernel 5.3.x

et passer la discussion en résolu.

Voir: https://forums.fedora-fr.org/viewtopic. … 61#p602561

Non je ne peut pas je ne suis pas l'auteur de la discution elle à été initiée par Anarclick et
j'ai pris le train en route je ne vois pas d'options pour moi pour modifier le titre ou passer en résolu


msi i7 nvidia840M  8Go de ram  fedora 34 KDE      Asus P8Z77-V LK  Intel Core i7 3770 16Go  Fedora 34 KDE

Hors ligne

#30 26/10/2019 17:31:28

greg0ire
La bonne fée Dora
Inscription : 27/01/2007
Messages : 616
Site Web

Re : [Résolu] akmod nvidia-340xx et kernel 5.3.x

Euh… quand je lis le thread que tu as linké didierg, j'ai un peu peur :P
Si j'ai bien tout compris va falloir utiliser nouveau. Je viens de tenter ça, mais je ne sais pas pourquoi, nouveau ne se charge pas naturellement alors que je l'ai retiré des modules blacklistés et que j'ai fait un `dracut --force`.

Si je fais un `modprobe nouveau`, le module semble se charger correctement, mais si je tente ensuite un `startx`, ça me dit "No screens found"… super…

NovFedo, tu as fait comment pour appliquer le patch exactement?

Dernière modification par greg0ire (26/10/2019 17:31:48)


profile for greg0ire on Stack Exchange, a network of free, community-driven Q&A sites

Hors ligne

#31 26/10/2019 19:45:17

NovFedo
Membre
Lieu : Villeurbanne
Inscription : 03/11/2010
Messages : 175

Re : [Résolu] akmod nvidia-340xx et kernel 5.3.x

tu te met dans le dossier ou tu l'as téléchargé

# rpm -U filename.rpm

mais sur la mise à jour de ce jour il y avait un akmod  peut être qu'il est fonctionnel

Dernière modification par NovFedo (26/10/2019 19:47:23)


msi i7 nvidia840M  8Go de ram  fedora 34 KDE      Asus P8Z77-V LK  Intel Core i7 3770 16Go  Fedora 34 KDE

Hors ligne

#32 27/10/2019 00:38:58

greg0ire
La bonne fée Dora
Inscription : 27/01/2007
Messages : 616
Site Web

Re : [Résolu] akmod nvidia-340xx et kernel 5.3.x

Je devais déjà avoir fait la mise à jour car dnf ne me montre rien… du coup ça doit pas être fonctionnel. En tout cas merci pour l'instruction, j'avais essayé avec dnf localinstall, sans succès, là ça fonctionne!


profile for greg0ire on Stack Exchange, a network of free, community-driven Q&A sites

Hors ligne

#33 27/10/2019 10:51:17

Fifi
Membre
Lieu : Belgique
Inscription : 22/05/2006
Messages : 5 257

Re : [Résolu] akmod nvidia-340xx et kernel 5.3.x

Bonjour à tous.
Une petite remarque pour d'autres qui auraient le même problème : avant d'installer le paquet akmod-nvidia-340xx patché ( qui fonctionne aussi chez moi car j'avais le même problème avec les kernel 5.3 ), il faut supprimer l'autre paquet akmod-nvidia-340xx mis à jour par dnf upgrade sinon erreur.


Fedora 31-x86_64 - KDE 5 - Plasma 5.17 - Gigabyte B450 Aorus Elite - AMD Ryzen 7 2700 - Nvidia GTX 1650 Super Windforce ( avec le driver proprio Nvidia ) - 16 Go RAM Corsair - 1 disque dur WD de 2 To en Sata3 et un SSD Crucial de 256 Go ( disque de boot )
Multiboot Fedora - Centos 7.0  -  Windows 10 Pro - Systemrescuecd
brave-browser-1.2.43-1.fc31.x86_64  -  thunderbird-68.4.1-1.fc31.x86_64

Hors ligne

#34 28/10/2019 21:27:07

arnaud056
Membre
Lieu : Allemagne
Inscription : 03/03/2015
Messages : 61
Site Web

Re : [Résolu] akmod nvidia-340xx et kernel 5.3.x

merci bien de partager ces infos! wink

Quelqu'un saurait-il ce qui est prévu pour F31 en ce qui concerne nvidia-340?

@+

Hors ligne

#35 06/01/2020 18:00:19

Fifi
Membre
Lieu : Belgique
Inscription : 22/05/2006
Messages : 5 257

Re : [Résolu] akmod nvidia-340xx et kernel 5.3.x

Bonjour à tous,
C'était résolu pour les kernels 5.3.x, mais le problème se repose pour le kernel 5.4.4-100 de la mise à jour de ce matin ...
Espérons qu'il y ait un patch également.

Edit : Mise à jour de l'akmod-nvidia-340xx : ça fonctionne maintenant avec le kernel 5.4.7-100 sous Fedora 30, donc sous Fedora 31 ça doit aller aussi.

Dernière modification par Fifi (10/01/2020 22:41:47)


Fedora 31-x86_64 - KDE 5 - Plasma 5.17 - Gigabyte B450 Aorus Elite - AMD Ryzen 7 2700 - Nvidia GTX 1650 Super Windforce ( avec le driver proprio Nvidia ) - 16 Go RAM Corsair - 1 disque dur WD de 2 To en Sata3 et un SSD Crucial de 256 Go ( disque de boot )
Multiboot Fedora - Centos 7.0  -  Windows 10 Pro - Systemrescuecd
brave-browser-1.2.43-1.fc31.x86_64  -  thunderbird-68.4.1-1.fc31.x86_64

Hors ligne

Pied de page des forums