Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Arrêt de maintenance pour Fedora 28

#1 20/02/2019 17:01:49

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 874

[Résolu] Numlock (encore !)

Bonjour,

Suite à un problème matériel j'ai dû réinstallé Fedora 29 from scratch (heureusement le disque sur lequel se trouve mon /home n'a pas été affecté).

Avec mon ancien système qui était une Fedora 26 upgradée en 27 puis en 28 pour finir en 29 j'avais le clavier numérique activé dès le démarrage dès lors que je l'avais activé dans le BIOS AMI de ma carte mère Asus P8Z77-V LE.

Je n'arrive pas à réédité cet "exploit" sur ma nouvelle installation.

Any help ?

#2 20/02/2019 17:12:37

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 4 854
Site Web

Re : [Résolu] Numlock (encore !)

Tu as regardé https://doc.fedora-fr.org/wiki/Numlockx … %A9marrage ?

Sinon même matos du coup, mis à part peut-être un disque ?


F30_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F30_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F30_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#3 20/02/2019 17:23:07

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 874

Re : [Résolu] Numlock (encore !)

En fait c'est mon alimentation (Corsair) qui a dégagé, elle faisait sauter le disjoncteur mural et l'ordi ne démarrait plus.

Dans la bataille j'ai perdu des partitions sur mon SSD de boot mais mon HDD avec mon /home n'a pas été touché.

J'ai donc juste réinstallé Fedora 29 sur mon SSD à partir de l'ISO.

Pour ce qui est de la doc sur Numlockx, ça ne fonctionne pas alors que je suis sur une session xorg.

#4 20/02/2019 17:56:31

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 4 854
Site Web

Re : [Résolu] Numlock (encore !)

Et la commande en elle même fonctionne bien ?


F30_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F30_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F30_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#5 20/02/2019 19:05:02

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 21 751

Re : [Résolu] Numlock (encore !)

didierg a écrit :

Pour ce qui est de la doc sur Numlockx, ça ne fonctionne pas alors que je suis sur une session xorg.

Tu peux dire exactement ce que tu as fait ?


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#6 20/02/2019 19:37:17

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 874

Re : [Résolu] Numlock (encore !)

Nicosss a écrit :

Et la commande en elle même fonctionne bien ?

$ gsettings get org.gnome.settings-daemon.peripherals.keyboard numlock-state
'off'
$ /usr/bin/numlockx on
$ gsettings get org.gnome.settings-daemon.peripherals.keyboard numlock-state
'on'
$ /usr/bin/numlockx off
$ gsettings get org.gnome.settings-daemon.peripherals.keyboard numlock-state
'off'
nouvo09 a écrit :

Tu peux dire exactement ce que tu as fait ?

$ tail /etc/gdm/Init/Default
    fi
  fi
fi

# Active le pavé numérique au démarrage
if [ -x /usr/bin/numlockx ]; then
        /usr/bin/numlockx on
fi

exit 0

#7 20/02/2019 21:08:37

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 21 751

Re : [Résolu] Numlock (encore !)

Ben oui mais ta commande est placée tout à la fin, après tous les "fi" et tu ne te demandes pas ce qu'il se passe si les conditions préalables sont remplies. Sans doute  ta commande ne peut jamais être  exécutée. Pour ten être sur, rajoute un truc genre echo "'toto" >> /tmp/testnum.

tu verras si cette cimmande rend quelque chose.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#8 21/02/2019 03:21:15

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 874

Re : [Résolu] Numlock (encore !)

Le genre de chose qui m'agace....

Ma carte mère est une Asus P8Z77-V LE et dans le BIOS UEFI de celle-ci, j'ai activé le pavé numérique au démarrage.

J'ai réinstallé un dual boot Fedora 29 et Windows 10:

- Windows 10 démarre avec le pavé numérique activé
- Fedora 29 démarre avec le pavé numérique inactivé et je n'arrive pas à trouver comment l'activer systématiquement

#9 21/02/2019 09:13:16

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 21 751

Re : [Résolu] Numlock (encore !)

Tous les systèmes unix/linux désactivent systématiquement le pavé numérique au démarrage. C'est sans doute agaçant mais c'est volontaire et tripoter le bios n'y changera rien.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#10 21/02/2019 17:09:21

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 874

Re : [Résolu] Numlock (encore !)

Ayant côtoyé pendant quelques années SunOS puis Solaris, je sais que les Unix démarre avec le pavé numérique désactivé ce qui n'est pas vraiment gênant sur un serveur.

Ce qui est agaçant sur Fedora utilisé en work station, c'est de ne pas pouvoir activer aisément ce pavé au démarrage si on le souhaite.

#11 21/02/2019 17:22:53

hechmi50
Membre
Inscription : 21/08/2007
Messages : 1 956

Re : [Résolu] Numlock (encore !)

Essaye avec dconf-edotor, voici ce que j'ai.
1550762211-capture-d-ecran-du-2019-02-21-15-24-50.png


fedorauser.png

Hors ligne

#12 21/02/2019 18:11:42

beber_mal
Membre
Inscription : 17/04/2008
Messages : 58

Re : [Résolu] Numlock (encore !)

installe le paquet numlockx

Hors ligne

#13 22/02/2019 09:11:10

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 21 751

Re : [Résolu] Numlock (encore !)

didierg a écrit :

Ayant côtoyé pendant quelques années SunOS puis Solaris, je sais que les Unix démarre avec le pavé numérique désactivé ce qui n'est pas vraiment gênant sur un serveur.

Ce qui est agaçant sur Fedora utilisé en work station, c'est de ne pas pouvoir activer aisément ce pavé au démarrage si on le souhaite.

place ta commande au début du fichier /etc/gdm/Init/Default   pur voir


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#14 22/02/2019 12:32:03

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 874

Re : [Résolu] Numlock (encore !)

nouvo09 a écrit :

place ta commande au début du fichier /etc/gdm/Init/Default   pur voir

Même résultat avec:

#!/usr/bin/sh
# Stolen from the debian kdm setup, aren't I sneaky
# Plus a lot of fun stuff added
#  -George

PATH="/usr/bin:$PATH"
OLD_IFS=$IFS

# Active le pavé numérique au démarrage
if [ -x /usr/bin/numlockx ]; then
        /usr/bin/numlockx on
fi

gdmwhich () {

#15 22/02/2019 12:57:38

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 21 751

Re : [Résolu] Numlock (encore !)

Alors c'est que ce script n'est pas exécuté. (je parle de fichier Default)


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#16 22/02/2019 13:05:57

beber_mal
Membre
Inscription : 17/04/2008
Messages : 58

Re : [Résolu] Numlock (encore !)

Tu as essayé

dnf install numlockx

?

Ce paquet est fait pour justement activer le numlock au démarrage.

Hors ligne

#17 22/02/2019 13:36:43

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 874

Re : [Résolu] Numlock (encore !)

beber_mal a écrit :

installe le paquet numlockx

- le paquet numlockx est bien installé
- le script numlockx.sh est bien dans /etc/X11/xinit/xinitrc.d

$ cat /etc/X11/xinit/xinitrc.d/numlockx.sh
#!/bin/sh
/usr/bin/numlockx

#18 22/02/2019 15:07:15

beber_mal
Membre
Inscription : 17/04/2008
Messages : 58

Re : [Résolu] Numlock (encore !)

Ce n'est pas un problème avec wayland par hasard?

sur cette page, ils disent que la clé org.gnome.settings-daemon.peripherals.keyboard remember-numlock-state doit être fixée à true et la clé org.gnome.settings-daemon.peripherals.keyboard numlock-state doit être sur 'on'. C'est bien ce que tu as?

Hors ligne

#19 22/02/2019 19:58:43

cezame
Membre
Lieu : Arlon près du triangle BFL
Inscription : 24/10/2016
Messages : 239

Re : [Résolu] Numlock (encore !)

Au risque de me faire mitrailler, mais de mon côté j'ai édité /etc/lightdm/lightdm.conf et j'y ai ajouté à la fin:

[SeatDefaults]
greeter-setup-script=/usr/bin/numlockx on

un reboot et cela marche. A noter je suis sous cinnamon.

Hors ligne

#20 22/02/2019 20:06:18

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 4 854
Site Web

Re : [Résolu] Numlock (encore !)

cezame a écrit :

Au risque de me faire mitrailler, mais de mon côté j'ai édité /etc/lightdm/lightdm.conf et j'y ai ajouté à la fin:

[SeatDefaults]
greeter-setup-script=/usr/bin/numlockx on

un reboot et cela marche. A noter je suis sous cinnamon.

Ce n'est pas le même gestionnaire de session. Voir la documentation que j'ai citée au début du post.


F30_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F30_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F30_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#21 22/02/2019 21:14:32

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 21 751

Re : [Résolu] Numlock (encore !)

cezame a écrit :

Au risque de me faire mitrailler, mais de mon côté j'ai édité /etc/lightdm/lightdm.conf et j'y ai ajouté à la fin:

[SeatDefaults]
greeter-setup-script=/usr/bin/numlockx on

un reboot et cela marche. A noter je suis sous cinnamon.

1) d abord on te dit qu'il s'agit de gdm, donc en quoi ton post est-il pertinent ?

2) tu n'es pas sous windows, tu n'as pas à rebooter. Un systemctl restart lightdm suffit.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#22 22/02/2019 21:44:18

cezame
Membre
Lieu : Arlon près du triangle BFL
Inscription : 24/10/2016
Messages : 239

Re : [Résolu] Numlock (encore !)

militaire%20(8).gif

Hors ligne

#23 23/02/2019 15:12:15

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 874

Re : [Résolu] Numlock (encore !)

nouvo09 a écrit :

Alors c'est que ce script n'est pas exécuté. (je parle de fichier Default)

J'ai effectivement lu quelque part, je ne me souviens plus où car il y a une multitude de posts sur toutes les distributions à ce sujet, que  /etc/gdm/Init/Default n'était plus exécuté.

#24 23/02/2019 16:28:09

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 4 854
Site Web

Re : [Résolu] Numlock (encore !)

Je percute que maintenant, tu dis utiliser Gnome sous X mais as-tu modifié pour GDM car ce dernier est désormais sous Wayland par défaut.

Regarde ton fichier /etc/gdm/custom.conf , à coup sûr tu as

#WaylandEnable=false

F30_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F30_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F30_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#25 23/02/2019 18:24:56

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 874

Re : [Résolu] Numlock (encore !)

Je suis effectivement sous Wayland au niveau GDM et sous xorg au niveau gnome-shell

J'ai fait un essai en passant en xorg au niveau GDM et en ajoutant numlockx à la fin de /etc/gdm/Init/Default mais sans plus de succès.

La question que je me pose est est-ce que quelqu'un a déjà réussi à activer le clavier numérique sur une fresh install workstation ?

Pied de page des forums