Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Venez tester Fedora 30 Beta !

#1 27/12/2018 16:21:22

Girafe Albinos
Membre
Inscription : 27/12/2018
Messages : 3

[F29] Asus E200H - Pas de son (sortie factice)

Bonjour,

j'ai récemment installé Fedora 29 sur mon Asus E200H. Tout est ok mis à part le son et le micro.

Je suis débutante sur Linux mais mon entourage s'y connaît un peu, on a cherché sans trouver de solution, si ce n'est des scripts github datés impliquant des modifications de kernel.

On a déjà supprimé .pulse et /.config/pulse.

alsamixer propose les cartes sons suivant : Intel HDMI/DP LPE Audio et bytcht-nocodec. Ces choix ne semblent pas changer grand chose.

$ lspci
00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register (rev 36)
00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers (rev 36)
00:0b.0 Signal processing controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller (rev 36)
00:14.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller (rev 36)
00:1a.0 Encryption controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine (rev 36)
00:1c.0 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #1 (rev 36)
00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU (rev 36)
01:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
 
 $pulseaudio --check -v
I: [pulseaudio] main.c: Daemon running as PID 1473 
$ pulseaudio -vv
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: RealtimeKit worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 12.2-rebootstrapped
D: [pulseaudio] main.c: Compilation host: x86_64-redhat-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -W -Wextra -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -fno-common -fdiagnostics-show-option -fdiagnostics-color=auto
D: [pulseaudio] main.c: Running on host: Linux x86_64 4.19.10-300.fc29.x86_64 #1 SMP Mon Dec 17 15:34:44 UTC 2018
D: [pulseaudio] main.c: Found 4 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
I: [pulseaudio] main.c: Machine ID is 936fcf1d71c846839e8d302593f1611f.
I: [pulseaudio] main.c: Session ID is 2.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/girafealbinos/.config/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib64/pulse-12.2/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: Échec de pa_pid_file_create().
$ pactl info
Chaîne du serveur : unix:/run/user/1000/pulse/native
Version du protocole de bibliothèque : 32
Version du protocole du serveur : 32
Local : oui
Index client : 18
Tile Size: 65472
Nom d'utilisateur : girafealbinos
Nom d'hôte : pc19.home
Nom du serveur : pulseaudio
Version du serveur : 12.2-rebootstrapped
Spécification d'échantillon par défaut : s16le 2ch 44100Hz
Plan de canaux par défaut : front-left,front-right
Destination par défaut : auto_null
Source par défaut : auto_null.monitor
Cookie : 82aa:3331
 $ pactl list cards
Carte #0
	Nom : alsa_card.pci-0000_00_02.0-platform-hdmi-lpe-audio
	Pilote : module-alsa-card.c
	Module propriétaire : 23
	Propriétés :
		alsa.card = "0"
		alsa.card_name = "Intel HDMI/DP LPE Audio"
		alsa.long_card_name = "Intel HDMI/DP LPE Audio"
		alsa.driver_name = "snd_hdmi_lpe_audio"
		device.bus_path = "pci-0000:00:02.0-platform-hdmi-lpe-audio"
		sysfs.path = "/devices/pci0000:00/0000:00:02.0/hdmi-lpe-audio/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "22b0"
		device.product.name = "Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers"
		device.string = "0"
		device.description = "Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	Profils :
		output:hdmi-stereo: Sortie Digital Stereo (HDMI) (sinks: 1, sources: 0, priority: 5900, available: non)
		output:hdmi-surround: Sortie Digital Surround 5.1 (HDMI) (sinks: 1, sources: 0, priority: 800, available: non)
		output:hdmi-surround71: Sortie Digital Surround 7.1 (HDMI) (sinks: 1, sources: 0, priority: 800, available: non)
		output:hdmi-stereo-extra1: Sortie Digital Stereo (HDMI 2) (sinks: 1, sources: 0, priority: 5700, available: non)
		output:hdmi-surround-extra1: Sortie Digital Surround 5.1 (HDMI 2) (sinks: 1, sources: 0, priority: 600, available: non)
		output:hdmi-surround71-extra1: Sortie Digital Surround 7.1 (HDMI 2) (sinks: 1, sources: 0, priority: 600, available: non)
		output:hdmi-stereo-extra2: Sortie Digital Stereo (HDMI 3) (sinks: 1, sources: 0, priority: 5700, available: non)
		output:hdmi-surround-extra2: Sortie Digital Surround 5.1 (HDMI 3) (sinks: 1, sources: 0, priority: 600, available: non)
		output:hdmi-surround71-extra2: Sortie Digital Surround 7.1 (HDMI 3) (sinks: 1, sources: 0, priority: 600, available: non)
		off: Éteint (sinks: 0, sources: 0, priority: 0, available: oui)
	Profil actif : off
	Ports :
		hdmi-output-0: HDMI / DisplayPort (priority: 5900, latency offset: 0 usec, not available)
			Propriétés :
				device.icon_name = "video-display"
			Partie du(des) profil(s) : output:hdmi-stereo, output:hdmi-surround, output:hdmi-surround71
		hdmi-output-1: HDMI / DisplayPort 2 (priority: 5800, latency offset: 0 usec, not available)
			Propriétés :
				device.icon_name = "video-display"
			Partie du(des) profil(s) : output:hdmi-stereo-extra1, output:hdmi-surround-extra1, output:hdmi-surround71-extra1
		hdmi-output-2: HDMI / DisplayPort 3 (priority: 5700, latency offset: 0 usec, not available)
			Propriétés :
				device.icon_name = "video-display"
			Partie du(des) profil(s) : output:hdmi-stereo-extra2, output:hdmi-surround-extra2, output:hdmi-surround71-extra2

Merci pour votre attention.

Hors ligne

#2 27/12/2018 17:02:11

Refuznik
Membre
Inscription : 31/01/2007
Messages : 7 248

Re : [F29] Asus E200H - Pas de son (sortie factice)

Je crois que malheureusement que tu ne pourras pas l'utiliser avec le son (sauf si bien sur tu utilises un écran externe avec des enceintes par exemple vu que l'on voit que la sortie hdmi audio est active).

Et après plusieurs recherche le driver n'est pas inclus dans le kernel de base.
Donc tu vas te retrouver bloquer sur toutes les distributions linux.

Dernière modification par Refuznik (27/12/2018 17:06:59)

Hors ligne

#3 27/12/2018 17:08:13

Girafe Albinos
Membre
Inscription : 27/12/2018
Messages : 3

Re : [F29] Asus E200H - Pas de son (sortie factice)

Merci pour ta réponse.

C'est ballot.. N'existe t-il pas un script permettant d'ajouter un driver "maison" au kernel de F29 ?

Hors ligne

#4 27/12/2018 17:40:12

Refuznik
Membre
Inscription : 31/01/2007
Messages : 7 248

Re : [F29] Asus E200H - Pas de son (sortie factice)

Nan j'ai trouvé ce script https://gist.github.com/heikomat/3fe272 … b901a92257 pour les distributions basé sur debian (ubuntu, mint et elementary) sur cette page que tu as surement vu mais c'est tout.

En tout cas le codec est dans la branche dev. du kernel donc tu l'auras peut-être dans la version 4.20 mais ça va prendre un peu de temps.

Ou autrement tu tentes d'installer une ubuntu et de patcher le kernel.

Dernière modification par Refuznik (27/12/2018 17:41:05)

Hors ligne

#5 29/12/2018 19:32:56

Girafe Albinos
Membre
Inscription : 27/12/2018
Messages : 3

Re : [F29] Asus E200H - Pas de son (sortie factice)

Merci pour tes réponses !
Je vais attendre la prochaine version du kernel et on verra si ça fonctionne ...

Hors ligne

#6 29/12/2018 21:04:19

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 4 533
Site Web

Re : [F29] Asus E200H - Pas de son (sortie factice)

Il y a un rapport de bug en cours https://bugzilla.kernel.org/show_bug.cgi?id=115531.


F29_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F29_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F29_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

Pied de page des forums