Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Arrêt de maintenance pour Fedora 28

#1 01/06/2018 22:00:34

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 556
Site Web

Nextcloud 13 ...

Et bien voilà, j'utilise NextCloud en version 13 en version officiel en provenance de l'éditeur https://nextcloud.com/
J'ai un gros souci avec le plugins TALK au niveau de l'audio et la vidéo sur mon poste principale alors que ce n'est pas le cas sur un autre. En fait je n'ai pas d'affichage de la caméra de l'autre utilisateur, ni l'audio et vice versa.

Je ne sais pas trop d'où provient le problème, j'ai testé avec Firefox, konqueror et un autre navigateur toujours avec le même souci.
J'ai aussi désactivé le pare feu et selinux, mais c'est toujours le même problème, je n'ai toujours pas de retour audio/vidéo. Là je sèche sachant que cela ne le fait pas sur l'autre poste.

Une petite idée?


AMD Ryzen 7 2700X + MSI Gaming Pro Carbon X470, 32Go de RAM DDR4 3200@3333Mhz Gskill Trident Z RBG CL14, AMD Radeon RX590 Sapphire Nitro+ Special Edition 8Go GDDR5
SSD Samsung : 1x 970 NVME (PCI-express 3.0x4) 500Go + 1x 850 EVO 250Go + 2x 860 EVO 500Go + 2x1To 860 QVO  / HDD : 1x2To WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red
Boitier GMT Bequiet Dark 900 + Lepa 800W 80+gold

Hors ligne

#2 14/06/2018 09:24:42

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 556
Site Web

Re : Nextcloud 13 ...

Bon pas de réponse sur le sujet.

J'avance donc petit à petit de mon coté, il semble que cela soit un souci avec la version de PHP installé sur le serveur. Du coup je vois avec php73 de chez remi pour CentOS 7 (version de php fourni de base 5.xx alors que l'on est à la 7.xx), car je n'ai pas eu ce problème sur une Fedora 28 de test.

J'ai profité d'un souci avec mon serveur sous CentOS 7.5 pour repartir sur de bonnes bases. Du coup je vais plus en profondeur, surtout niveau sécurité et fonctionnalités.


AMD Ryzen 7 2700X + MSI Gaming Pro Carbon X470, 32Go de RAM DDR4 3200@3333Mhz Gskill Trident Z RBG CL14, AMD Radeon RX590 Sapphire Nitro+ Special Edition 8Go GDDR5
SSD Samsung : 1x 970 NVME (PCI-express 3.0x4) 500Go + 1x 850 EVO 250Go + 2x 860 EVO 500Go + 2x1To 860 QVO  / HDD : 1x2To WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red
Boitier GMT Bequiet Dark 900 + Lepa 800W 80+gold

Hors ligne

#3 14/06/2018 09:39:54

remi
Crazy PHP packages monkey... !
Rédacteur Wiki
Lieu : Champagne...
Inscription : 16/10/2004
Messages : 5 567
Site Web

Re : Nextcloud 13 ...

> Du coup je vois avec php73 de chez remi pour CentOS 7

T'as pas peur ;)
Même Fedora rawhide est encore en 7.2 :p

> version de php fourni de base 5.xx alors que l'on est à la 7.xx

Pas tout à fait vrai, C7 dispose de PHP 5.4 (base), 7.0 et 7.1 (SCL)
https://developers.redhat.com/blog/2017 … tion-tips/

J'ai un Nextcloud 13 qui tourne sans problème sur mon dédié (CentOS 6... + mon dépôt, évidement)

M'enfin, on est un peu hors sujet du coup.

Dernière modification par remi (14/06/2018 09:40:08)

Hors ligne

#4 14/06/2018 13:38:00

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 556
Site Web

Re : Nextcloud 13 ...

Bah de toute manière rien de grave, je sauvegarde régulièrement en plusieurs point. Du coup même en cas de soucis majeur je remonte le tout rapidement (ce qui vient d'être le cas, ce qui est un peu pénible même si cela m'a permis blinder plus en profondeur le système).

Je peux repasser à la 7.2  par remplacement de la version de PHP dans la conf si nécessaire.

Par contre je vois un net bénéfice niveau performance sur NextCloud 13 depuis le passage à cette version de php. Et encore je n'ai pas fini de faire les modifications des fichiers de configuration.

Je test ce soir si cela résout mon souci avec "TALK", le reste fonctionnant très bien. Sinon tu n'aurais pas une petite idée tant que je te tiens?

A voir aussi le souci que j'ai pour l’envoie de la position du smartphone.

Dernière modification par VINDICATORs (14/06/2018 14:31:15)


AMD Ryzen 7 2700X + MSI Gaming Pro Carbon X470, 32Go de RAM DDR4 3200@3333Mhz Gskill Trident Z RBG CL14, AMD Radeon RX590 Sapphire Nitro+ Special Edition 8Go GDDR5
SSD Samsung : 1x 970 NVME (PCI-express 3.0x4) 500Go + 1x 850 EVO 250Go + 2x 860 EVO 500Go + 2x1To 860 QVO  / HDD : 1x2To WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red
Boitier GMT Bequiet Dark 900 + Lepa 800W 80+gold

Hors ligne

#5 15/06/2018 22:01:24

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 556
Site Web

Re : Nextcloud 13 ...

Bon résultat des courses, le problème soulevé sur le sujet n'est toujours pas résolu. Je vais refaire un test sur l'autre machine la semaine prochaine, il est possible que ce soit simplement un souci sur celle-ci (voir signature).

J'ai fais les modifications pour prendre en charge php 7.2, mais je galère un peu avec la configuration du php.ini qui n'est pas prise en compte (modification lié aux performance). Ainsi qu'un souci avec la configuration du serveur du certificat let's encrypt qui semble poser quelques soucis. Mais bon cela n'empêche pas le bon fonctionnement.


AMD Ryzen 7 2700X + MSI Gaming Pro Carbon X470, 32Go de RAM DDR4 3200@3333Mhz Gskill Trident Z RBG CL14, AMD Radeon RX590 Sapphire Nitro+ Special Edition 8Go GDDR5
SSD Samsung : 1x 970 NVME (PCI-express 3.0x4) 500Go + 1x 850 EVO 250Go + 2x 860 EVO 500Go + 2x1To 860 QVO  / HDD : 1x2To WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red
Boitier GMT Bequiet Dark 900 + Lepa 800W 80+gold

Hors ligne

#6 30/06/2018 08:32:47

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 556
Site Web

Re : Nextcloud 13 ...

Je vais revoir encore la configuration de mon serveur, ayant encore pas mal de chose à modifier/améliorer.

Donc le souci avec "Talk" ("Conversation" en français) n'en ai plus un. Il y a juste un souci de performance qui semble plus lié au serveur (l'Atom n2800 c'est quand même très limite pour ce genre de chose...) qu'à autre chose. Je verrai pour revoir cela l'année prochaine (prévision de déménagement de tout les cotés tongue).


AMD Ryzen 7 2700X + MSI Gaming Pro Carbon X470, 32Go de RAM DDR4 3200@3333Mhz Gskill Trident Z RBG CL14, AMD Radeon RX590 Sapphire Nitro+ Special Edition 8Go GDDR5
SSD Samsung : 1x 970 NVME (PCI-express 3.0x4) 500Go + 1x 850 EVO 250Go + 2x 860 EVO 500Go + 2x1To 860 QVO  / HDD : 1x2To WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red
Boitier GMT Bequiet Dark 900 + Lepa 800W 80+gold

Hors ligne

Pied de page des forums