Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Rencontrez Borsalinux-fr aux RMLL à Strasbourg du 7 au 12 juillet

#1 27/05/2018 16:00:09

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

[Résolu] Problème de connexion multi utilisateur

Bonjour,

Depuis quelque temps suite à une mise à jour il y a environ 2 semaines, lorsque je souhaite basculer d'un utilisateur à un autre au choix de l'utilisateur il m'affiche un message en rouge "mot de passe incorrect" alors que je n'ai juste que sélectionné l'utilisateur. Je renseigne le mot de passe me connecte à ce compte puis si je veux changer d'utilisateur je n'ai plus la touche "changer d'utilisateur" mais juste fermer la session. du coup je passe soit par le raccourci "Super+l" ou alors verrouiller la session et donc ensuite "choisir un autre utilisateur", et là je renseigne le mot de passe du compte selectionné et il essaie de se connecter puis reviens sur l'écran de connexion et si je souhaite me reconnecté sur l'autre utilisateur il ne veux plus .... Obligé de redémarrer le pc

Si vous avez des idées ...

ps: sous gnome 3.28.2 et wayland (même phénomène sous xorg)
Fedora 28 kernel 4.16.11-300.fc28.x86_64

MS du 23/07/2018
kernel 4.17..7-200.fc28.x86_64

d'avance merci
Franck

Dernière modification par Franck35 (23/07/2018 11:46:41)

Hors ligne

#2 27/05/2018 17:03:38

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 21 091

Re : [Résolu] Problème de connexion multi utilisateur

J'ai pas d'idée sur la bug précis mais pourquoi redémarrer ? On passe en console, sous root et on fait un

systemctl restart gdm


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#3 27/05/2018 17:14:15

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : [Résolu] Problème de connexion multi utilisateur

je n'ai plus accès au mode console je suis à l'invite de connexion utilisateur ...

j'essaierai en connexion ssh la prochaine fois ... Merci pour cette info :)

nouvo09 a écrit :

J'ai pas d'idée sur la bug précis mais pourquoi redémarrer ? On passe en console, sous root et on fait un

systemctl restart gdm

Dernière modification par Franck35 (27/05/2018 17:17:56)

Hors ligne

#4 27/05/2018 17:22:00

Refuznik
Membre
Inscription : 31/01/2007
Messages : 6 924

Re : [Résolu] Problème de connexion multi utilisateur

Tu as des messages d'erreur dans tes logs correspondant ?
As tu regardé dans Divers => Journal des alertes selinux et Signalement des problèmes si tu n'avais pas des erreurs ?

Hors ligne

#5 27/05/2018 17:48:06

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : [Résolu] Problème de connexion multi utilisateur

Ca ne fonctionne pas : plus d'interface graphique après cette commande ... redémarrage et ok


nouvo09 a écrit :

J'ai pas d'idée sur la bug précis mais pourquoi redémarrer ? On passe en console, sous root et on fait un

systemctl restart gdm

Hors ligne

#6 27/05/2018 17:55:08

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : [Résolu] Problème de connexion multi utilisateur

J'ai bien des alertes dans le journal mais je ne sais pas les interpréter ...

la dernière mais ne correspond pas au bug car je l'ai refait à l'instant et cette alerte date du 24 mai

SELinux interdit à vboxdrv.sh d'utiliser l'accès create sur le fichier vbox-install.log.

*****  Le greffon catchall (100. de confiance) suggère   *********************

Si vous pensez que vboxdrv.sh devrait être autorisé à accéder create sur vbox-install.log file par défaut.
Alors vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Faire
autoriser cet accès pour le moment en exécutant :
# ausearch -c "vboxdrv.sh" --raw | audit2allow -M my-vboxdrvsh
# semodule -X 300 -i my-vboxdrvsh.pp

Informations complémentaires :
Contexte source               system_u:system_r:init_t:s0
Contexte cible                system_u:object_r:var_log_t:s0
Objets du contexte            vbox-install.log [ file ]
Source                        vboxdrv.sh
Chemin de la source           vboxdrv.sh
Port                          <Inconnu>
Hôte                          bequiet-bureau
Paquets RPM source           
Paquets RPM cible             
RPM de la statégie            selinux-policy-3.14.1-25.fc28.noarch
Selinux activé                True
Type de stratégie             targeted
Mode strict                   Enforcing
Nom de l'hôte                 bequiet-bureau
Plateforme                    Linux bequiet-bureau 4.16.11-300.fc28.x86_64 #1
                              SMP Tue May 22 18:29:09 UTC 2018 x86_64 x86_64
Compteur d'alertes            18
Première alerte               2018-03-12 12:06:31 CET
Dernière alerte               2018-05-24 22:00:27 CEST
ID local                      137d6ad8-5792-434b-a8ab-c5d2f8e85c79

Messages d'audit bruts
type=AVC msg=audit(1527192027.225:102): avc:  denied  { create } for  pid=887 comm="vboxdrv.sh" name="vbox-install.log" scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:var_log_t:s0 tclass=file permissive=0


Hash: vboxdrv.sh,init_t,var_log_t,file,create



Refuznik a écrit :

Tu as des messages d'erreur dans tes logs correspondant ?
As tu regardé dans Divers => Journal des alertes selinux et Signalement des problèmes si tu n'avais pas des erreurs ?

Hors ligne

#7 27/05/2018 18:00:35

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 21 091

Re : [Résolu] Problème de connexion multi utilisateur

Alors passe SElinux sur permissive tu verras bien si ça  change quelque chose.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#8 23/07/2018 10:53:58

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : [Résolu] Problème de connexion multi utilisateur

Après des mois d'attente toujours le même problème ...

Le pb ne vient pas de SElinux car même désactivé ça ne change rien ?

Comment faire remonter ce soucis pour une future correction ?

Hors ligne

#9 23/07/2018 11:17:03

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 5 912
Site Web

Re : [Résolu] Problème de connexion multi utilisateur

Il y avait un bug de temps en temps où gdm repassait en QWERTY, malgré que le clavier FR soit sélectionné.

Sinon pour remonter un bug https://doc.fedora-fr.org/wiki/Apprendr … r_un_bogue


Linux, ya moins bien, mais c'est plus chèr!!!
Ingénieur Systèmes&Réseaux dans l'OpenSource depuis + de 10 ans

Hors ligne

#10 23/07/2018 11:20:48

tetedecrocro
Membre
Inscription : 09/06/2006
Messages : 108

Re : [Résolu] Problème de connexion multi utilisateur

Télécharge le dernier kernel  4.17.7-200.fc28 qui vient d'arriver ce matin en version stable.
Essaye de démarrer sur le nouveau kernel, il te reste cette chance car à priori c'est depuis ta mise à jour donc d'un ancien kernel corrompu.


Fedora 28 XFCE
Linux c'est comme visiter une galaxie de planètes mais on ne connait jamais tout, c'est trop vaste.

Hors ligne

#11 23/07/2018 11:27:44

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : [Résolu] Problème de connexion multi utilisateur

Bonjour Madko,

Je te confirme que c'est bien un bugg de gestion de session utilisateur et non un bugg clavier ...

Quand je mets un mauvais mot de passe il te le dit ...

Donc pas d’erreur de mot de passe

Merci pour ton lien :)

madko a écrit :

Il y avait un bug de temps en temps où gdm repassait en QWERTY, malgré que le clavier FR soit sélectionné.

Sinon pour remonter un bug https://doc.fedora-fr.org/wiki/Apprendr … r_un_bogue

Dernière modification par Franck35 (24/07/2018 07:17:18)

Hors ligne

#12 23/07/2018 11:29:07

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : [Résolu] Problème de connexion multi utilisateur

Bonjour TếtedeCrocro,

La mise est faite et cela ne change rien du au pb ....

Mais merci quand même j'y ai cru :)

tetedecrocro a écrit :

Télécharge le dernier kernel  4.17.7-200.fc28 qui vient d'arriver ce matin en version stable.
Essaye de démarrer sur le nouveau kernel, il te reste cette chance car à priori c'est depuis ta mise à jour donc d'un ancien kernel corrompu.

Dernière modification par Franck35 (23/07/2018 11:47:36)

Hors ligne

#13 23/07/2018 11:48:42

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : [Résolu] Problème de connexion multi utilisateur

Je retente sur une VM propre pour écarter un pb sur mon insta ...

Hors ligne

#14 23/07/2018 12:29:20

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : [Résolu] Problème de connexion multi utilisateur

Même topo sur machine neuve ...

Franck35 a écrit :

Je retente sur une VM propre pour écarter un pb sur mon insta ...

Hors ligne

#15 23/07/2018 13:39:38

tetedecrocro
Membre
Inscription : 09/06/2006
Messages : 108

Re : [Résolu] Problème de connexion multi utilisateur

Après le kernel installez il y a une autre mise à jour à faire, mais il faut rebooter ta machine puis:
dnf upgrade
Des paquets se mettront à jour, à partir de là tu pourras faire un essai.


Fedora 28 XFCE
Linux c'est comme visiter une galaxie de planètes mais on ne connait jamais tout, c'est trop vaste.

Hors ligne

#16 23/07/2018 13:59:00

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : [Résolu] Problème de connexion multi utilisateur

Après le kernel même après un redémarrage et un dnf update et dnf update --refresh ... plus de mise à jour disponible
Le système est à jour :)

[franck@localhost ~]$ sudo dnf update
[sudo] Mot de passe de franck : 
Dernière vérification de l’expiration des métadonnées effectuée il y a 1:28:46 le lun. 23 juil. 2018 12:27:21 CEST.
Dépendances résolues.
Rien à faire.
Terminé !
[franck@localhost ~]$ sudo dnf update --refresh
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:00:00 le lun. 23 juil. 2018 13:56:24 CEST.
Dépendances résolues.
Rien à faire.
Terminé !


Testé avec Gnome et Xorg

Teste avec une vm tu verras :)

tetedecrocro a écrit :

Après le kernel installez il y a une autre mise à jour à faire, mais il faut rebooter ta machine puis:
dnf upgrade
Des paquets se mettront à jour, à partir de là tu pourras faire un essai.

Hors ligne

#17 23/07/2018 14:18:33

tetedecrocro
Membre
Inscription : 09/06/2006
Messages : 108

Re : [Résolu] Problème de connexion multi utilisateur

Franck35 a dit :
Après le kernel même après un redémarrage et un dnf update et dnf update --refresh ... plus de mise à jour disponible
Le système est à jour :)

Mille sabords !!
Attendons quelqu'un de compétent, bonne chance.

Dernière modification par tetedecrocro (23/07/2018 14:43:07)


Fedora 28 XFCE
Linux c'est comme visiter une galaxie de planètes mais on ne connait jamais tout, c'est trop vaste.

Hors ligne

#18 23/07/2018 15:08:00

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 16 982
Site Web

Re : [Résolu] Problème de connexion multi utilisateur

Perso j'ai pris l'habitude de faire un :

dnf clean all

avant l'upgrade.

D'ailleurs on utilise "upgrade" à la place de "update" avec dnf pour rappel.

Parfois c'est les fichiers de configuration de l’utilisateur qui posent problèmes. A voir si c'est le cas avec un nouvel utilisateur.


Intel i7 4771 + MSI Z87-GD65 Gaming, 24Go de RAM DDR3 1866Mhz@2200Mhz Corsair Vengeance C9, ATI R9 290x 4Go GDDR5
Lepa800W 80+gold, SSD Samsung 850 EVO 250Go + 2x2To RAID1 WD black 64Mo + 1x2to WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red

Hors ligne

#19 23/07/2018 16:59:49

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : [Résolu] Problème de connexion multi utilisateur

Merci pour cette précision, je ne savais pas, je l'utilise avec debian seulement

Je ne pense pas que ça vienne de mon système car même avec une insta récente et propre j'ai le même phénomène

VINDICATORs a écrit :

Perso j'ai pris l'habitude de faire un :

dnf clean all

avant l'upgrade.

D'ailleurs on utilise "upgrade" à la place de "update" avec dnf pour rappel.

Parfois c'est les fichiers de configuration de l’utilisateur qui posent problèmes. A voir si c'est le cas avec un nouvel utilisateur.

Hors ligne

#20 23/07/2018 17:01:19

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : [Résolu] Problème de connexion multi utilisateur

Le plus simple serait quelqu'un testé en réel sur sa machine et me dise ce qu'il en retourne ?

Hors ligne

#21 24/07/2018 03:11:56

Heldwin
Charlie
Inscription : 07/10/2008
Messages : 4 070

Re : [Résolu] Problème de connexion multi utilisateur

Bonjour,

https://bugzilla.redhat.com/show_bug.cgi?id=1583240

Il semble qu'il y ait un patch upstream, donc la correction devrait arriver à un moment ou à un autre, quand il y aura une mise à jour de gdm.

EDIT:

ou alors downgrader gdm en attendant, car le dernier post indique que cela vient de la dernière mise à jour de gdm,
et que cela refonctionne ensuite.

Je n'utilise pas vraiment gnome, mais d'après un test, le downgrade fonctionne chez moi,
à part qu'il faut passer par le lock d'écran pour switcher d'utilisateur.

Dernière modification par Heldwin (24/07/2018 03:21:46)


"The only way to achieve the impossible is to believe it’s possible"

Hors ligne

#22 24/07/2018 07:04:48

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : [Résolu] Problème de connexion multi utilisateur

Bonjour Heldwin,

Merci pour ta réponse, effectivement en Downgradant GDM ça fonctionne nickel

Bonne journée et encore Merci :)

Heldwin a écrit :

Bonjour,

https://bugzilla.redhat.com/show_bug.cgi?id=1583240

Il semble qu'il y ait un patch upstream, donc la correction devrait arriver à un moment ou à un autre, quand il y aura une mise à jour de gdm.

EDIT:

ou alors downgrader gdm en attendant, car le dernier post indique que cela vient de la dernière mise à jour de gdm,
et que cela refonctionne ensuite.

Je n'utilise pas vraiment gnome, mais d'après un test, le downgrade fonctionne chez moi,
à part qu'il faut passer par le lock d'écran pour switcher d'utilisateur.

Hors ligne

#23 24/07/2018 10:25:11

tetedecrocro
Membre
Inscription : 09/06/2006
Messages : 108

Re : [Résolu] Problème de connexion multi utilisateur

Ah ! je me doutais bien qu'une mise à jour réglerez ce problème.

Franck35 il te faut mettre en résolu wink


Fedora 28 XFCE
Linux c'est comme visiter une galaxie de planètes mais on ne connait jamais tout, c'est trop vaste.

Hors ligne

#24 24/07/2018 10:31:09

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : [Résolu] Problème de connexion multi utilisateur

Salut, oui, j'attends la mise à jour du correctif de gnome pour la passer en résolu

tetedecrocro a écrit :

Ah ! je me doutais bien qu'une mise à jour réglerez ce problème.

Franck35 il te faut mettre en résolu wink

Dernière modification par Franck35 (24/07/2018 10:53:25)

Hors ligne

#25 25/07/2018 00:21:25

Heldwin
Charlie
Inscription : 07/10/2008
Messages : 4 070

Re : [Résolu] Problème de connexion multi utilisateur

tetedecrocro a écrit :

Ah ! je me doutais bien qu'une mise à jour réglerez ce problème.

Ca c'est évident :)
Pour ce genre de problème, c'est sûr qu'une mise à jour résoudra le problème, le tout est de savoir quand elle viendra :)


"The only way to achieve the impossible is to believe it’s possible"

Hors ligne

Pied de page des forums