Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Rencontrez Borsalinux-fr aux RMLL à Strasbourg du 7 au 12 juillet

#1 25/05/2018 13:51:14

Refuznik
Membre
Inscription : 31/01/2007
Messages : 6 855

[Résolu] GDM crash

Suite à une mise à jour ce matin (de tête il y avait le terminal et un nouveau noyau 4.16.11-300), GDM m'affiche l'éternel phrase :
- Oh mince ! Quelque chose s'est mal passé. Un problème est survenu et le système ne peut pas se récupérer. Déconnectez vous et ré-essayez à nouveau. 
J'ai bien tenté de rebooter sur un ancien noyau mais le problème persiste.
La seule solution pour l'instant que j'ai trouvé et de lancer ma session via terminal avec un startx qui fonctionne sans problème.

Edit : bon j'ai trouvé la solution c'était selinux qui bloquait l'ouverture de GDM.
Résolu avec un

ausearch -c "gnome-session-c" --raw | audit2allow -M my-gnomesessionc 
semodule -X 300 -i my-gnomesessionc.pp

Dernière modification par Refuznik (25/05/2018 23:28:29)

Hors ligne

#2 25/05/2018 17:31:23

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 845
Site Web

Re : [Résolu] GDM crash

Tu as quelle version de selinux-policy ?
Je n'ai pas eu de souci avec selinux-policy-targeted-3.14.1-25.fc28.noarch et selinux-policy-3.14.1-25.fc28.noarch.

$ rpm -qa selinux\*

F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F27_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F27_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F27_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#3 25/05/2018 19:41:20

gueulderack
Membre
Inscription : 15/06/2011
Messages : 215

Re : [Résolu] GDM crash

Refuznik a écrit :

Suite à une mise à jour ce matin (de tête il y avait le terminal et un nouveau noyau 4.16.11-300), GDM m'affiche l'éternel phrase :
- Oh mince ! Quelque chose s'est mal passé. Un problème est survenu et le système ne peut pas se récupérer. Déconnectez vous et ré-essayez à nouveau. 
J'ai bien tenté de rebooter sur un ancien noyau mais le problème persiste.
La seule solution pour l'instant que j'ai trouvé et de lancer ma session via terminal avec un startx qui fonctionne sans problème.

Edit : bon j'ai trouvé la solution c'était selinux qui bloquait l'ouverture de GDM.
Résolu avec un ausearch -c "gnome-session-c" --raw | audit2allow -M my-gnomesessionc et semodule -X 300 -i my-gnomesessionc.pp


J'ai exactement le même problème que toi. Par contre, quand je tape

sudo ausearch -c "gnome-session-c" --raw | audit2allow -M my-gnomesessionc et semodule -X 300 -i my-gnomesessionc.pp

çà me retourne

audit2allow: error: no such option: -X 

Pourquoi moi çà ne marche pas? Snif!

Merci

Hors ligne

#4 25/05/2018 19:42:06

gueulderack
Membre
Inscription : 15/06/2011
Messages : 215

Re : [Résolu] GDM crash

Nicosss a écrit :

Tu as quelle version de selinux-policy ?
Je n'ai pas eu de souci avec selinux-policy-targeted-3.14.1-25.fc28.noarch et selinux-policy-3.14.1-25.fc28.noarch.

$ rpm -qa selinux\*

J'ai bien les même version. Est-ce que tu utilises aussi kmod, ou bien nouveau?

Hors ligne

#5 25/05/2018 19:59:06

Refuznik
Membre
Inscription : 31/01/2007
Messages : 6 855

Re : [Résolu] GDM crash

Alors pour répondre :
J'utilise le kmod-nvidia.

Pour selinux c'est :
selinux-policy-3.14.1-25.fc28.noarch
selinux-policy-targeted-3.14.1-25.fc28.noarch

@gueulderack, c'est en en deux lignes tu n'as pas vu mon "et" dans la ligne de commande.
Fait en 1er
ausearch -c "gnome-session-c" --raw | audit2allow -M my-gnomesessionc
Puis après :
semodule -X 300 -i my-gnomesessionc.pp
Reboot et ça devrait fonctionner sans problème.

Dernière modification par Refuznik (25/05/2018 20:03:18)

Hors ligne

#6 25/05/2018 20:06:19

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 845
Site Web

Re : [Résolu] GDM crash

Pas de kmod-* pour moi. J'utilise radeon.

@Refuznik, tu pourrais utiliser les balises code <> https://forums.fedora-fr.org/help.php#bbcode pour que tes posts soient plus lisibles.


F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F27_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F27_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F27_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#7 25/05/2018 21:38:33

gueulderack
Membre
Inscription : 15/06/2011
Messages : 215

Re : [Résolu] GDM crash

Refuznik a écrit :

Alors pour répondre :
J'utilise le kmod-nvidia.

Pour selinux c'est :
selinux-policy-3.14.1-25.fc28.noarch
selinux-policy-targeted-3.14.1-25.fc28.noarch

@gueulderack, c'est en en deux lignes tu n'as pas vu mon "et" dans la ligne de commande.
Fait en 1er
ausearch -c "gnome-session-c" --raw | audit2allow -M my-gnomesessionc
Puis après :
semodule -X 300 -i my-gnomesessionc.pp
Reboot et ça devrait fonctionner sans problème.

Merde, non je n'avais pas vu. J'ai honte:roll:! Mais merci bea&ucoup, çà fonctionne correctement maintenant.

Hors ligne

Pied de page des forums