Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Un nouveau logo pour Fedora ?

#1 03/02/2018 10:14:09

jibel
jibel
Lieu : bruxelles
Inscription : 13/06/2017
Messages : 101

Probleme d'installe de paquets

Bonjour,
Voila que je ne pige pas sur la manip commande terminal qui s’interrompt ? D’où vient ce PB ? Je ne sais pas! par contre j'ai 15 ou plus paquets d'outils, vokoscreen, kazam, green-recorder , etcher, synaptic, apper, muon qui  sont absolument impossible a installer avec DNF ou YUM ?
Je suis aller consulter le WIKI de fedora pour voir ce qu'il fallait faire ! Consulter le :etc/dnf.dnf/ conf  dans lequel je n'ai rien vu ? Impossible d'installer skype en RPM dans fedora 27 KDE alors que dans fedora 64 bits basique27  skype64 rpm  a été installé...
Alors je ne vois pas ce qu'il me faudrait faire ... J'ai aussi eu une surprise apres que fedora KDEa été installé sans PB....enfin plus beaucoup ! Un avertissement d'installe des MàJ de +/- 600 paquets.. J'ai lancé cette MàJ ça a été fait mais partiellement  ? interruption de la MàJ et voila... Je ne sais pas ce qui c'est passé... voila 

 [root@localhost jibel]# dnf install dnfdragora*
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:38:00 le sam 03 fév 2018 08:28:50 CET.
Le paquet dnfdragora-1.0.1-9.git20180108.b0e8a66.fc27.noarch est déjà installé, ignorer
Dépendances résolues.
=====================================================================================================================================================
 Paquet                               Architecture             Version                                               Dépôt                     Taille
=====================================================================================================================================================
Installation de :
 dnfdragora-updater                   noarch                   1.0.1-9.git20180108.b0e8a66.fc27                      updates                    20 k
Installation des dépendances:
 libimagequant                        x86_64                   2.11.7-1.fc27                                         updates                    61 k
 python3-olefile                      noarch                   0.44-3.fc27                                           fedora                    1.1 M
 python3-pillow                       x86_64                   4.3.0-1.fc27                                          fedora                    591 k
 python3-pystray                      noarch                   0.14.3-2.fc27                                         fedora                     63 k
 python3-sh                           noarch                   1.12.14-2.fc27                                        fedora                     73 k
 python3-xlib                         noarch                   0.19-2.fc27                                           fedora                    215 k

Résumé de la transaction
=====================================================================================================================================================
Installer  7 Paquets

Taille totale des téléchargements : 2.1 M
Taille des paquets installés : 7.3 M
Voulez-vous continuer ? [o/N] :o
Téléchargement des paquets :

Les paquets téléchargés ont été mis en cache jusqu’à la prochaine transaction réussie.
Vous pouvez supprimer les paquets en cache en exécutant « dnf clean packages ».
Erreur : Erreur de téléchargement des paquets :
  Curl error (56): Failure when receiving data from the peer for https://mirrors.fedoraproject.org/metalink?repo=updates-released-f27&arch=x86_64 [Recv failure: Connection reset by peer]
[root@localhost jibel]# 

Plus grande est la face , plus grand est le dos.....
Hybryde 14.04, MX16, Debian8, X8 deb Voyager, emmabuntus 3, Handy-linux 2.2,  Mint 17, Voyager 16.04 X2 , Xubuntu 16.04, Kubuntu 16.10, et OpenSuse leap

Hors ligne

#2 03/02/2018 17:16:55

Edouard_le_homard
Membre
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 421

Re : Probleme d'installe de paquets

Hello,
Quelle partie du curl error n'as tu pas compris ?


Asus VivoBook S 15 Fedora 29 x86_64 KDE

Hors ligne

#3 03/02/2018 17:39:44

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 656

Re : Probleme d'installe de paquets

jibel a écrit :

Je ne sais pas ce qui c'est passé... voila

La réponse est dans le message:

Erreur : Erreur de téléchargement des paquets :
  Curl error (56): Failure when receiving data from the peer for https://mirrors.fedoraproject.org/metalink?repo=updates-released-f27&arch=x86_64 [Recv failure: Connection reset by peer]

Si tu veux en savoir plus, tu fais une recherche sur Google sur "Connection reset by peer" , même google.be a la réponse:

https://www.google.be/search?source=hp& … puEPqoK8qo

Que faire après cette erreur ?

La aussi tu as la réponse dans le message:

Les paquets téléchargés ont été mis en cache jusqu’à la prochaine transaction réussie.
Vous pouvez supprimer les paquets en cache en exécutant « dnf clean packages ».

Et tu recommences....

Hors ligne

#4 06/02/2018 11:01:14

jibel
jibel
Lieu : bruxelles
Inscription : 13/06/2017
Messages : 101

Re : Probleme d'installe de paquets

@tous,
Me revoilou , aujourd'hui après QQs jours de non utilisation de fedora27 KDE !  Voila, il n'est plus que le seul OSs libres Fedora qui est, encore,  dans ce disque dur externe!
Pourquoi ? Parce que j'ai préféré supprimer  la version gnome. Mais il y a eu un twist auquel je ne m'attendais pas. Après la suppression de la gnome , au restart je vois qu'il m'est impossible de lancer la fedo KDE !! Aie , aie , qu'est-ce que j'ai fais? hein? tout bêtement lancer ma clé USB dans laquelle se trouve B.R.D. (Boot-Repair.Disk) et refait  une opération pour que le grub soit installé dans  la fedo Kde , que la fedo27 Kde soit OK pour être lancé.. C'est ce qui se passe ce matin...Voila ! Merci
2°) les conseils qui m'ont étés donnés ont étés difficiles pour moi qui parle l'anglais "basique" ce qui est gênant pour voir lire et comprendre ce qui n'avait rien a voir avec les PBs que j'ai cités !
3°)

 [jibel@localhost ~]$ su
Mot de passe : 
[root@localhost jibel]# dnf upgrade
Erreur : Échec de la synchronisation du cache pour le dépôt « updates »
[root@localhost jibel]#

Revoila encore cet ennui , a chaque installe d'un logiciel ou d'une MàJ , cela reste bloqué dans ce "dépôt updates" que j'ai eu beau chercher sans le trouver dans /etc/dnf/dng.conf/
Après plusieurs jours d'arrêt de la fedo,  j'ai pu croire que ce systeme de synchronisation sera "rouvert " pour débloquer les logiciels bloqués et de leurs installations  !! Ça n'est pas le cas !
4°) Quand j'installe de temps en temps un logiciel dans la fedo avec DNF install XXX cela se fait .. Si ce logiciel est OK pour son installe, mais si j'utilise "discover" la c'est carrément autre chose le nombre d'installes des logiciels restent bloqués , ne se font pas correctement , juste avec QQs jours de retard.. ! ! !
Impossible d'installer au moins 10 logiciels qui ne sont même pas dans cette bibliothèque de la fedora. par exemple skypeforlinux.64 que j'ai pourtant avec son paquet en RPM impossible a installer dans la fedora KDE? il y a une belle astuce qui me manque de ce qui doit être fait lors des installes non conforme a la fedora KDE? ? ?
5°) Je ne sais pas si je vais continuer avec la fedo 27 KDE? Lors de l'installe de la fedo gnome27 je n'appréciais pas gnome et j'ai eu ce conseil d'installer plasma KDE comme second environnements ! Très bien! C'était la seule chose que je ne faisais jamais  d'installer des environnements en pagaille!
Par contre , je dois faire une confidence , j'ai un OS avec 10 environnements installés dans cet OS ou il est possible de changer l’environnement en ...15 secondes, de revenir vers un autre dans le même temps .... Et voila !
Merci et bonne journée.... pint


Plus grande est la face , plus grand est le dos.....
Hybryde 14.04, MX16, Debian8, X8 deb Voyager, emmabuntus 3, Handy-linux 2.2,  Mint 17, Voyager 16.04 X2 , Xubuntu 16.04, Kubuntu 16.10, et OpenSuse leap

Hors ligne

#5 06/02/2018 11:14:52

Edouard_le_homard
Membre
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 421

Re : Probleme d'installe de paquets

 /etc/dnf/dng.conf/

tu voulais probablement dire  /etc/dnf/dnf.conf ; et de plus dnf.conf est un fichier et non un dossier. Les dépôts sont configurés dans /etc/yum.repos.d, comme mentionné dans la doc...

Je  n'utilise jamais les GUI, toujours dnf via le terminal. Je n'ai jamais eu de soucis. Lance un dnf clean all pour voir ? Tu es bien connecté à Internet ? Quel est le retour de dnf repolist all ?

> par exemple skypeforlinux.64 que j'ai pourtant avec son paquet en RPM impossible a installer dans la fedora KDE?
comment procèdes tu ? aucun problème de mon côté.


Asus VivoBook S 15 Fedora 29 x86_64 KDE

Hors ligne

#6 06/02/2018 14:25:13

jibel
jibel
Lieu : bruxelles
Inscription : 13/06/2017
Messages : 101

Re : Probleme d'installe de paquets

Edouard_le_homard a écrit :
 /etc/dnf/dng.conf/

tu voulais probablement dire  /etc/dnf/dnf.conf ; et de plus dnf.conf est un fichier et non un dossier. Les dépôts sont configurés dans /etc/yum.repos.d, comme mentionné dans la doc...

Je  n'utilise jamais les GUI, toujours dnf via le terminal. Je n'ai jamais eu de soucis. Lance un dnf clean all pour voir ? Tu es bien connecté à Internet ? Quel est le retour de dnf repolist all ?

> par exemple skypeforlinux.64 que j'ai pourtant avec son paquet en RPM impossible a installer dans la fedora KDE?
comment procèdes tu ? aucun problème de mon côté.

C'est très curieux....

 [jibel@localhost ~]$ dnf clean all
0 fichier supprimé
[jibel@localhost ~]$ dnf repolist all
Erreur : Échec de la synchronisation du cache pour le dépôt « updates »[

Qu'est-ce que c'est que ce bazar, jamais je n'ai eu ça dans un autre OS? J'ai regardé ce qui était dans le fichier fedora.repo.list

 name=Fedora $releasever - $basearch - Test Updates

Ça n'est qu'un script ..Mais la en lisant je me suis aperçu que cela concernait " fedora release27"   ???
Est-ce la version en plasma KDE que j'ai gravé dans mon DVD-live ? J'ai des doutes et pas qu'un seul ?
Idem pour les installes avec le terminal et DNF qui restent bloquées , numlockx ? impossible! J'en passe et des meilleurs!  Idem avec discover ! pour certains logiciels qui s'installe quand fedora le veut !
Si tu as réussi, d’après ce que tu dis d'installer "skype"  alors pourquoi tu n'a pas précisé ce que  toi tu as fais ?? En me demandant ce que moi j'ai fais , bizarre non? demander les choses a l'envers ??  idem pour la lecture du wiki? le bon endroit ou tu semble avoir trouvé  la ou les bonnes astuces pour corriger ces PBs des catas.
Il est sur que de savoir tout et par cœur ce qui est écrit dans la doc. c'est important , mais quand je teste 1 ou des OSs que la plupart du temps,  jamais je n'ai eu ce style de PB avec mes 30/ 40 tests ou installes ! sauf avec la fedora, la c'est le bazar  !  Pas de synaptic refus de fedora, pas de  muon specifique pour KDe refus de fedora ! pas de apper refus de fedora ! etc etc Pourquoi je me suis emmêlés les crayons , alors qu'a aucun moment j'ai cru rater mon test/installe qui a produit des ennuis a tout but de champ !
Après avoir viré la fedora gnome..conserver le fedora plasma KDE.... Je n'ai jamais eu ça dans mes décisions de supprimer un OS installés....
Qu'en fait j'ai n'ai eu que 8 jours pas + pour arriver a ce résultat... Je ne suis pas un wikipedia sur pattes, alors je crois que faire un nez fort n'est pas au summum d'un test  wink
Pour finir voila ce que j'ai eu avec un camarade français qui m'a certifié qu'il n'y avait que le clavier Français lors de son test.
Si en France  il y a un "oseur" d'installer fedora, qu'il dise si lors de cette installe il y a une autre langue en France que le Français pour le clavier? Ça m'étonnerais !


Plus grande est la face , plus grand est le dos.....
Hybryde 14.04, MX16, Debian8, X8 deb Voyager, emmabuntus 3, Handy-linux 2.2,  Mint 17, Voyager 16.04 X2 , Xubuntu 16.04, Kubuntu 16.10, et OpenSuse leap

Hors ligne

#7 06/02/2018 15:06:55

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 389
Site Web

Re : Probleme d'installe de paquets

Bon... voilà ce que retourne le repo update chez moi à comparer avec le tien :

 cat /etc/yum.repos.d/fedora-updates.repo 
[updates]
name=Fedora $releasever - $basearch - Updates
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/
metalink=https://mirrors.fedoraproject.org/metalink?repo=updates-released-f$releasever&arch=$basearch&country=fr
enabled=1
repo_gpgcheck=0
type=rpm
gpgcheck=1
metadata_expire=6h
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

[updates-debuginfo]
name=Fedora $releasever - $basearch - Updates - Debug
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/debug/
metalink=https://mirrors.fedoraproject.org/metalink?repo=updates-released-debug-f$releasever&arch=$basearch&country=fr
enabled=0
repo_gpgcheck=0
type=rpm
gpgcheck=1
metadata_expire=6h
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

[updates-source]
name=Fedora $releasever - Updates Source
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/SRPMS/
metalink=https://mirrors.fedoraproject.org/metalink?repo=updates-released-source-f$releasever&arch=$basearch&country=fr
enabled=0
repo_gpgcheck=0
type=rpm
gpgcheck=1
metadata_expire=6h
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

Apper n'est plus vraiment actif, perso à part pour faire les mises à jours avec l'applet, je ne m'en sert plus.

Discover est quand même un peu encore en développement.

Utilise dnf-dragora qui est l'interface dans fedora qui remplace yumex, mais il est encore bancale par moment (plante sans raison, parfois un peu capricieux...).

skype s'installe très bien sans prise de tête pour la version proprio de Microsoft :
téléchargement :-> https://www.skype.com/fr/get-skype/
installation :

su -lc 'dnf install chemindelàoùcetrouvelerpm/skypeforlinux.rpm'

Voilà... Je ne sais toujours pas comment tu fais pour te prendre autant la tête, mais bon...

Pour l'histoire du belge/français/autreslangues... je ne sais pas comment tu as fait mais perso je t'ai déjà prouvé que cela ne posait pas de soucis. Pour dire, j'avais même l'installation que j'utilise en ce moment en suisse allemand de base (erreur de ma part à l'installation) et j'ai même réussi à l'avoir en Basque...

Au passage, les commandes dnf du style "clean all" "upgrade" et autres s'utilisent en super utilisateur.

Dernière modification par VINDICATORs (06/02/2018 15:12:35)


AMD Ryzen 7 2700X + MSI Gaming Pro Carbon X470, 32Go de RAM DDR4 3000@3133Mhz Gskill Ageia C16, AMD Radeon RX590 Sapphire Nitro+ Special Edition 8Go GDDR5
SSD Samsung : 1x 970 NVME (PCI-express 3.0x4) 500Go + 1x 850 EVO 250Go + 2x 860 EVO 500Go / HDD : 1x2To WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red
Boitier GMT Bequiet Dark 900 + Lepa 800W 80+gold

Hors ligne

#8 06/02/2018 16:30:45

jibel
jibel
Lieu : bruxelles
Inscription : 13/06/2017
Messages : 101

Re : Probleme d'installe de paquets

VINDICATORs a écrit :

Bon... voilà ce que retourne le repo update chez moi à comparer avec le tien :

 cat /etc/yum.repos.d/fedora-updates.repo 
[updates]
name=Fedora $releasever - $basearch - Updates
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/
metalink=https://mirrors.fedoraproject.org/metalink?repo=updates-released-f$releasever&arch=$basearch&country=fr
enabled=1
repo_gpgcheck=0
type=rpm
gpgcheck=1
metadata_expire=6h
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

[updates-debuginfo]
name=Fedora $releasever - $basearch - Updates - Debug
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/debug/
metalink=https://mirrors.fedoraproject.org/metalink?repo=updates-released-debug-f$releasever&arch=$basearch&country=fr
enabled=0
repo_gpgcheck=0
type=rpm
gpgcheck=1
metadata_expire=6h
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

[updates-source]
name=Fedora $releasever - Updates Source
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/SRPMS/
metalink=https://mirrors.fedoraproject.org/metalink?repo=updates-released-source-f$releasever&arch=$basearch&country=fr
enabled=0
repo_gpgcheck=0
type=rpm
gpgcheck=1
metadata_expire=6h
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

Apper n'est plus vraiment actif, perso à part pour faire les mises à jours avec l'applet, je ne m'en sert plus.
"C'est le moins qu'on puisse dire , idem pour apper et encore pas du tout pour synaptic.... Ça c'est logique"
Discover est quand même un peu encore en développement.

Ah bon  when it's new one not sure to be function right..... la j'ai eu des surprises, notamment avec "numlockx"

Utilise dnf-dragora qui est l'interface dans fedora qui remplace yumex, mais il est encore bancale par moment (plante sans raison, parfois un peu capricieux...).

What is that , WHAOU !
skype s'installe très bien sans prise de tête pour la version proprio de Microsoft :
téléchargement :-> https://www.skype.com/fr/get-skype/
installation :

 chemindelàoùcetrouvelerpm/skypeforlinux.rpm'

J'ai fais ça exactement : su -lc 'dnf install  / telechargement /skypeforlinux64.rpm'

Voilà... Je ne sais toujours pas comment tu fais pour te prendre autant la tête, mais bon...

"Je ne me prends pas la tête, juste  reflexions de ce qu'il y a entre des OSs legerement différents"

Pour l'histoire du belge/français/autreslangues... je ne sais pas comment tu as fait mais perso je t'ai déjà prouvé que cela ne posait pas de soucis. Pour dire, j'avais même l'installation que j'utilise en ce moment en suisse allemand de base (erreur de ma part à l'installation) et j'ai même réussi à l'avoir en Basque...

"Voila , il faut cliquer sur  "clavier" ! automatiquement il s'affichera dans la langue du pays ou l'on se trouve... logique..Mais comme l'a dit cezame il n'y avait pas de raison de trouver la langue Fr... Avec le nederlands-belgie pas de PB !!! C'est a mourir de rire ! Si un type comme moi français a un doute , j'ai cherché et trouvé le Fr azerty..rien de plus simple !"

Au passage, les commandes dnf du style "clean all" "upgrade" et autres s'utilisent en super utilisateur.

Ca c'est fait, 25 paquet éliminés ! !

 [root@localhost jibel]# dnf clean all
25 fichiers supprimés

Comme tu l'a  signalé c'est nouveau  produit de la fedora.... Bien vu ! et hop la  wink


Plus grande est la face , plus grand est le dos.....
Hybryde 14.04, MX16, Debian8, X8 deb Voyager, emmabuntus 3, Handy-linux 2.2,  Mint 17, Voyager 16.04 X2 , Xubuntu 16.04, Kubuntu 16.10, et OpenSuse leap

Hors ligne

#9 06/02/2018 16:45:53

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 389
Site Web

Re : Probleme d'installe de paquets

La base est la même, la philosophie est souvent différente, les évolutions en bien ou en mal aussi.

Fedora vas toujours de l'avant, c'est un bien et pas un bien. Si tu souhaite ralentir un peu les évolutions je te conseil de partir sur des distrib à support long comme CentOS pour rester dans le cadre "RedHat".

Après ce n'est pas nouveau que pour faire des clean/update/upgrade il faut être en root/super utilisateur, mais bon.

Moi quand je sélectionne Français comme langue j'ai le choix du clavier belge et cela fonctionne très bien. Mes amis belges l'on aussi donc je ne vois pas comment tu fais. Si il t'était possible de prendre des captures d'écrans pour nous montrer, cela aiderai peut être à y voir plus clair.

Pour les fichiers, c'est juste qu'il a fait le ménage dans les caches de DNF. Tant au niveau des paquets, que des informations sur les points de téléchargements, miroirs, méta-data, et autres...
Retente un (toujours en root):

dnf upgrade -y

AMD Ryzen 7 2700X + MSI Gaming Pro Carbon X470, 32Go de RAM DDR4 3000@3133Mhz Gskill Ageia C16, AMD Radeon RX590 Sapphire Nitro+ Special Edition 8Go GDDR5
SSD Samsung : 1x 970 NVME (PCI-express 3.0x4) 500Go + 1x 850 EVO 250Go + 2x 860 EVO 500Go / HDD : 1x2To WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red
Boitier GMT Bequiet Dark 900 + Lepa 800W 80+gold

Hors ligne

#10 06/02/2018 17:08:57

Edouard_le_homard
Membre
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 421

Re : Probleme d'installe de paquets

> J'ai fais ça exactement : su -lc 'dnf install  / telechargement /skypeforlinux64.rpm'
Tout s'explique...


Asus VivoBook S 15 Fedora 29 x86_64 KDE

Hors ligne

#11 06/02/2018 17:52:04

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 389
Site Web

Re : Probleme d'installe de paquets

Marrant chez moi ça donne dans ce style là :

su -lc 'dnf install /home/NomUtilisateur/Téléchargement/RPMs/skypeforslinux64.rpm'

Linux étant sensible à la case et aussi à la langue si tu lui donne de mauvaise informations à manger et bien... Le plat sera raté.

Le "su -lc ' ....' " permet de lancer une commande en root temporairement. Un peu à l'image de (bon rien que d'en prononcer le nom j'ai une crise d'urticaire maman!!!) sudo (ku)...
Cela évite de rabâcher toutes les 3 réponses (je suis optimiste là...) qu'il est obligatoire d'être en root.

Dernière modification par VINDICATORs (06/02/2018 17:53:47)


AMD Ryzen 7 2700X + MSI Gaming Pro Carbon X470, 32Go de RAM DDR4 3000@3133Mhz Gskill Ageia C16, AMD Radeon RX590 Sapphire Nitro+ Special Edition 8Go GDDR5
SSD Samsung : 1x 970 NVME (PCI-express 3.0x4) 500Go + 1x 850 EVO 250Go + 2x 860 EVO 500Go / HDD : 1x2To WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red
Boitier GMT Bequiet Dark 900 + Lepa 800W 80+gold

Hors ligne

#12 06/02/2018 18:49:55

Fifi
Membre
Lieu : Belgique
Inscription : 22/05/2006
Messages : 5 245

Re : Probleme d'installe de paquets

VINDICATORs a écrit :

Moi quand je sélectionne Français comme langue j'ai le choix du clavier belge et cela fonctionne très bien. Mes amis belges l'on aussi donc je ne vois pas comment tu fais. Si il t'était possible de prendre des captures d'écrans pour nous montrer, cela aiderai peut être à y voir plus clair.

Je confirme !!!

Par contre, dnf clean marche chez moi en simple utilisateur :

[fifi@localhost ~]$ dnf clean all
69 fichiers supprimés
[fifi@localhost ~]$

mais bon, autant le faire en root !

Edit : sorry, en root il supprime plus de fichiers ... bizarre ça ! :

[fifi@localhost ~]$ dnf clean all
69 fichiers supprimés
[fifi@localhost ~]$ su -
Mot de passe : 
[root@localhost ~]# dnf clean all
79 fichiers supprimés
[root@localhost ~]# 

Dernière modification par Fifi (06/02/2018 18:51:47)


Fedora 27-x86_64 - KDE 5 - Plasma 5.10 - ASUS M3A32-MVP Deluxe - AMD Phenom 8650 X3 - Nvidia GTX 260 ( avec le driver proprio Nvidia 340xx ) - 4 Go RAM Corsair - 1 disque dur WD de 1 To en Sata3 et un SSD Crucial de 256 Go ( disque de boot )
Multiboot Fedora - Centos 7.0  -  Windows 10 Pro - Systemrescuecd
firefox-56.0-5.fc26.x86_64  -  thunderbird-52.5.0-1.fc27.x86_64

Hors ligne

#13 06/02/2018 18:54:56

Fifi
Membre
Lieu : Belgique
Inscription : 22/05/2006
Messages : 5 245

Re : Probleme d'installe de paquets

jibel a écrit :

J'ai fais ça exactement : su -lc 'dnf install  / telechargement /skypeforlinux64.rpm'

1ère chose à faire avant de lancer ce genre de commande : localiser où se trouve le fichier qui a été téléchargé ...!!! T'es sûr que tu emploies linux depuis longtemps ???


Fedora 27-x86_64 - KDE 5 - Plasma 5.10 - ASUS M3A32-MVP Deluxe - AMD Phenom 8650 X3 - Nvidia GTX 260 ( avec le driver proprio Nvidia 340xx ) - 4 Go RAM Corsair - 1 disque dur WD de 1 To en Sata3 et un SSD Crucial de 256 Go ( disque de boot )
Multiboot Fedora - Centos 7.0  -  Windows 10 Pro - Systemrescuecd
firefox-56.0-5.fc26.x86_64  -  thunderbird-52.5.0-1.fc27.x86_64

Hors ligne

#14 06/02/2018 20:04:02

jibel
jibel
Lieu : bruxelles
Inscription : 13/06/2017
Messages : 101

Re : Probleme d'installe de paquets

Fifi a écrit :
jibel a écrit :

J'ai fais ça exactement : su -lc 'dnf install  / telechargement /skypeforlinux64.rpm'

1ère chose à faire avant de lancer ce genre de commande : localiser où se trouve le fichier qui a été téléchargé ...!!! T'es sûr que tu emploies linux depuis longtemps ???

C'est assez original d'avoir plusieurs versions des installes ... Ce qui est drôle c'est que dans la gnome made in fedora j'avais installé skype avec "clique droit sur le paquet , trois choix
j'ai lancé cette installe avec une possibilité (non ark, non dnf j'sais plus quoi) ce qui a installé skype et qui fonctionnait dans la fedo 27gnome... Quand j'ai constaté ça , que je ne pouvais pas installer Skype dans l'autre fedo 27 KDE ??? Qu'est-ce que c'est que ce bazar ?? J'ai ouvert une dernière fois  fedo gnome (connexion avec gnome, 3 possililités) et non KDE qui était aussi installé et je me suis aperçu que le tableau de bord  du bas  n'avait rien a faire la, puisque c'était la gnome qui a été lancé???
J'ai décidé de virer fedo gnome et hop la ! Re cata au restart de le KDE tout a été corrigé avec B.R.D.
C'est pour le moment OK  sauf avec les installes qui prennent un temps dingue , une ou deux  minutes avant  que la synchro des updates etc etc s’arrête sans rien faire ...
J'veux bien faire QQchose mais pas n'importe quoi? la y-a un solide soucis... Installer Skype ou autre chose  avec des paquets  RPM ouille ouille il manque  QQchose il devrait y avoir dans le matos le même outil pour l'installe d'u fedo !
Installer un paquet avec "gdebi" pour un paquet deb. et non RPM voila ou se trouve le big trouble shooting.... C'est ce que je crois, mélanger tout , c'est comme ci on tentait une mayonnaise .
Je suis avec linux-mint, debian, ou xubuntu , MX16 , Manjaro! un OS issus de Xubuntu la Voyager, et un OS installe  hybryde mon OS préféré  etc etc  déjà difficile aussi ...Mais quand même ça ne me pose plus  des PBs supers ennuyeux ! J'ai un camarade Fr  qui lui aussi des ennuis avec la fedo 27... Donc... Je ne dirais jamais qu'il faut faire ce que je fais ? jamais !  wink
Toutes mes installes sont en fonctions a n'importe quel moment de la journée... Jamais mon PC est fermé avec l'OS lancé , j'utilise xscreensaver  ou dans un OS plasma 4 kubuntu l'ecran d'economie ..Mon PC n'est jamais fermé.. Quand j'ai des arrivés de courriels , je suis averti des arrivés sonores ... Voila ce que je veux pour mon utilisation de mon PC 8!!  Jamais je ne dirais qu'il faut faire  comme moi, jamais encore une fois , c'est presque idiot..mais je m'amuse le plus possible.. Je suis surtout avec les OSs LTS ce qui est normal
En lisant les réponses on voit qu'il y a des bizarreries étrangiformes , trapézoïdales ... Ouais il faut s'habituer avec un OS différent , mais  il est nécessaire d'avoir des petites connaissances comme mézigue avec linux et autre OSs...J'avoue n'avoir jamais eu des ennuis avec tout le OSs ! Sauf ma tentative de ma fedo 27 et de mon manque d'infos...J'peux pas tout connaître en 8 jours sur des astuces ... OK Je retourne avec la fedo et faire ce qui a été demandé par VINDICATORs et Fifi
Si je me plante ? pourquoi être sur de continuer avec la fedo ?? grand mystère !


Plus grande est la face , plus grand est le dos.....
Hybryde 14.04, MX16, Debian8, X8 deb Voyager, emmabuntus 3, Handy-linux 2.2,  Mint 17, Voyager 16.04 X2 , Xubuntu 16.04, Kubuntu 16.10, et OpenSuse leap

Hors ligne

#15 06/02/2018 20:23:42

Fifi
Membre
Lieu : Belgique
Inscription : 22/05/2006
Messages : 5 245

Re : Probleme d'installe de paquets

Tu en fais tout un baratin, auquel je ne comprend rien du tout ... pour expliquer quoi ???


Fedora 27-x86_64 - KDE 5 - Plasma 5.10 - ASUS M3A32-MVP Deluxe - AMD Phenom 8650 X3 - Nvidia GTX 260 ( avec le driver proprio Nvidia 340xx ) - 4 Go RAM Corsair - 1 disque dur WD de 1 To en Sata3 et un SSD Crucial de 256 Go ( disque de boot )
Multiboot Fedora - Centos 7.0  -  Windows 10 Pro - Systemrescuecd
firefox-56.0-5.fc26.x86_64  -  thunderbird-52.5.0-1.fc27.x86_64

Hors ligne

#16 06/02/2018 20:33:05

Edouard_le_homard
Membre
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 421

Re : Probleme d'installe de paquets

Franchement cette discussion n'a ni queue ni tête... Je propose à la modération de verrouiller cette discussion.


Asus VivoBook S 15 Fedora 29 x86_64 KDE

Hors ligne

#17 06/02/2018 20:39:45

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 389
Site Web

Re : Probleme d'installe de paquets

Franchement? je renouvelle mon conseil. Avant de mettre en dur pour tester des trucs hasardeux VIRTUALISE! C'est rapide à mettre en place (en utilisant les outils inclus dans Fedora, Virtualbox ou autres solutions) et au moins cela évite de partir dans des choses inutiles si à la base tu as quelque chose qui tourne bien. C'est valable avec tout, même sous MS windows 10 il y a ce qu'il faut, voir même un HyperV qui est la solution propriétaire de Microsoft dans les version pro et entreprise. Même sous Mac OS ce doit être le cas (dsl pas plus d'info j'aime mettre les mains dans le cambouis et ce n'est pas toujours qu'une image wink ).

RPM au lieu de .deb? ce n'est pas nouveau! Tu as même d'autres distribution avec d'autres outils etc... Redhat/fedora, Debian c'est des distributions sources historique, comme slackware et d'autres (bon ça devient rare quand même), donc outils parfois différents, utilisations parfois différentes, philosophie différentes, etc... Même si à la base c'est basé sur la même chose.
Plasma/KDE versus Gnome? et bien oui c'est très différents! ce n'est pas nouveau non plus, cela doit dater d'au minimum 1998 au moins pour KDE (si mes souvenirs sont bon). Environnement différent, bureau différent, réglage différent, outils différent (bien que pouvant fonctionner n'importe où), philosophie différente, etc...

Tiens test à la vas vite :
Clique droit sur skypeforlinux64.rpm choix "Ouvrir avec" :

ARK (par défaut)
ou
discover
ou
dnfdragora package installer

Par défaut c'est ARK qui est l'archiveur (pour compresser/décompresser).
Il suffit de modifier le choix dans les propriétés et hop!

Dernière modification par VINDICATORs (06/02/2018 20:41:17)


AMD Ryzen 7 2700X + MSI Gaming Pro Carbon X470, 32Go de RAM DDR4 3000@3133Mhz Gskill Ageia C16, AMD Radeon RX590 Sapphire Nitro+ Special Edition 8Go GDDR5
SSD Samsung : 1x 970 NVME (PCI-express 3.0x4) 500Go + 1x 850 EVO 250Go + 2x 860 EVO 500Go / HDD : 1x2To WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red
Boitier GMT Bequiet Dark 900 + Lepa 800W 80+gold

Hors ligne

#18 06/02/2018 21:10:05

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 21/09/2005
Messages : 21 395

Re : Probleme d'installe de paquets

Ha il cause encore  ?


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

#19 06/02/2018 21:33:40

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 656

Re : Probleme d'installe de paquets

Edouard_le_homard a écrit :

Franchement cette discussion n'a ni queue ni tête... Je propose à la modération de verrouiller cette discussion.

J'ai déjà signalé à deux reprises cette discussion comme "troll"...

Hors ligne

#20 06/02/2018 22:32:25

Heldwin
Gilets jaunes
Inscription : 07/10/2008
Messages : 4 134

Re : Probleme d'installe de paquets

Fifi a écrit :

Edit : sorry, en root il supprime plus de fichiers ... bizarre ça ! :

[fifi@localhost ~]$ dnf clean all
69 fichiers supprimés
[fifi@localhost ~]$ su -
Mot de passe : 
[root@localhost ~]# dnf clean all
79 fichiers supprimés
[root@localhost ~]# 

Bah non, c'est normal (et comme tu aimes bien le répéter souvent, depuis le temps que tu es sur linux tu savais pas ça !? :))

$ dnf -v clean all
Loaded plugins: builddep, config-manager, copr, debug, debuginfo-install, download, etckeeper, generate_completion_cache, needs-restarting, playground, repoclosure, repograph, repomanage, reposync
DNF version: 2.7.5
cachedir: /var/tmp/dnf-heldwin-2oh0fqud
Cleaning data: dbcache packages metadata
0 fichier supprimé

Il y a un cache par utilisateur (voir la ligne "cachedir")

Dernière modification par Heldwin (06/02/2018 23:03:44)


"The only way to achieve the impossible is to believe it’s possible"

Hors ligne

#21 06/02/2018 23:10:20

Fifi
Membre
Lieu : Belgique
Inscription : 22/05/2006
Messages : 5 245

Re : Probleme d'installe de paquets

Heldwin a écrit :

Bah non, c'est normal (et comme tu aimes bien le répéter souvent, depuis le temps que tu es sur linux tu savais pas ça !? :))

Ben non, jamais fait avant autrement que sous root, c'est la première fois que j'essayais sous simple utilisateur. On apprend tous les jours ! wink wink wink

Dernière modification par Fifi (06/02/2018 23:10:45)


Fedora 27-x86_64 - KDE 5 - Plasma 5.10 - ASUS M3A32-MVP Deluxe - AMD Phenom 8650 X3 - Nvidia GTX 260 ( avec le driver proprio Nvidia 340xx ) - 4 Go RAM Corsair - 1 disque dur WD de 1 To en Sata3 et un SSD Crucial de 256 Go ( disque de boot )
Multiboot Fedora - Centos 7.0  -  Windows 10 Pro - Systemrescuecd
firefox-56.0-5.fc26.x86_64  -  thunderbird-52.5.0-1.fc27.x86_64

Hors ligne

#22 07/02/2018 10:58:28

jibel
jibel
Lieu : bruxelles
Inscription : 13/06/2017
Messages : 101

Re : Probleme d'installe de paquets

@Tous.....mais  un par un ,
Edouard  le molusque , si tu ne comprends rien tant pis pour toi ! accepter les avis qui ne sont pas critique mais objectifs mad
Diedierg NON je  ne suis pas trolliste je refuse ton avis, je déteste les trolls,  en fait je ne dis rien d'autre que  signaler ce qui ne va pas  ! :-xs
Fifi, ,  je ne suis pas un baratineur, je ne veux convaincre personne, mais je signale ce qui est anormal ! tongue
et dernier VINDICATORs,
J'ai suivi justement tes conseils que j'ai respectés, pour skype et DNF upgrade ou update dans cette option il y a eu 80 updates, venant de "Discover" au ralenti, qui se sont installés......Trois heures après ma fermeture et rouverture de fedo 27KDE...
Une fois que ces updates ont étés installés je voulais changer le fond d'écran... Grosse panique , plus de lancement "configurer le bureau "  ouille, ouille, ouille , qu'est-ce qui se passe encore ? Je me suis écroulé de rire  lol
Je ferme/rouvre fedo 27 KDE tout est OK ! ! !Ah bon ?  je tente l'installe de skype avec dnfdragora package installer  + de trois minutes sont passées avant ce splendide échec
Voila le résultat :
1517996081.png
Merci a tous d'accepter qu'un gars ne tient pas a être critique , encore une fois...Mais seulement signaler ce qui est anormal dans mes trois tentatives d'installes de fedo gnome et fedo KDE .
Qu'on est pas nécessairement au courant de tout ce qui doit être utilisé !
Que perso je viens d'un site ou il est possible d'y faire des "améliorations" dans n'importe quel OS; par contre je ne ferais pas de PUB pour la fedo, surtout des réponses qui sont limites dans ce forum par quelques uns!
Quand je signale que j'ai des ennuis, il n'est pas a dire que je ne connais rien avec Fedora27 ? c'est exact!  Croire que je suis la pour critiquer, certes non!
Tout le monde doit apprendre et savoir faire une installe d'une fedora , qu'on a besoin des certaines manips qui sont hors des habitudes des testeurs comme je le suis .. C'est tout , je vais retenter un dernière installe avec une clé USB en suivant ce qui m'a été conseillé..... Si l'installe produit des emmerdes comme celles que j'ai eu avec un étonnement a la limite de rire sous cape suite a ces anomalies  citées plus haut ...Désolé fedora prendra un autre chemin ....  hammer


Plus grande est la face , plus grand est le dos.....
Hybryde 14.04, MX16, Debian8, X8 deb Voyager, emmabuntus 3, Handy-linux 2.2,  Mint 17, Voyager 16.04 X2 , Xubuntu 16.04, Kubuntu 16.10, et OpenSuse leap

Hors ligne

#23 07/02/2018 12:37:32

Edouard_le_homard
Membre
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 421

Re : Probleme d'installe de paquets

Décidément, tu n'y vois pas plus clair en taxonomie qu'en informatique =)

Un peu de lecture te fera du bien.


Asus VivoBook S 15 Fedora 29 x86_64 KDE

Hors ligne

#24 07/02/2018 13:36:49

jibel
jibel
Lieu : bruxelles
Inscription : 13/06/2017
Messages : 101

Re : Probleme d'installe de paquets

Edouard_le_homard a écrit :

Décidément, tu n'y vois pas plus clair en taxonomie qu'en informatique =)

Un peu de lecture te fera du bien.

@Edouard_le_homard,
Enfin , j'ai cru entendre qu'on arrive a devenir plus intelligent pour sortir un mot de dico pour affirmer ce qu'on a de plus qu'une autre personne . lol
Quand je suis seul devant ma bécane , que personne ne peut s'aperçoit de mes ennuis , qu'on croit que ce que j'ai dis sur ce qui c'est passé n'est pas exact ! point barre... honk  hmm
Quand dans cet OS "innovateur" avec la version 27 dans lequel on ne peut avoir "etcher" ni "K3B" ni "kazam" ni "green-recorder" ni "synaptic" ça normal ! ni "libre-office Fr" ni "waterfox"  ni "qupzilla"  + un paquet de logiciels efficaces et faciles de leurs utilisations !
Que tu ose refuser de voir et comprendre qu'il y a effectivement un ennui avec l'installe de "Skype" que daemon a rencontré un solide trouble shooting...   
Qu'est-ce qu'il faut que j'en rajoute ? La connexion eth a comme nom "enp4s0" chose qui n'était jamais mentionné avec mon F.A.I ..... Dois-je encore en rajouter ... ?? @pluche   mad


Plus grande est la face , plus grand est le dos.....
Hybryde 14.04, MX16, Debian8, X8 deb Voyager, emmabuntus 3, Handy-linux 2.2,  Mint 17, Voyager 16.04 X2 , Xubuntu 16.04, Kubuntu 16.10, et OpenSuse leap

Hors ligne

#25 07/02/2018 13:56:14

Edouard_le_homard
Membre
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 421

Re : Probleme d'installe de paquets

> Enfin , j'ai cru entendre qu'on arrive a devenir plus intelligent pour sortir un mot de dico pour affirmer ce qu'on a de plus qu'une autre personne .
Merci d'écrire, comme le stipule les règles, d'écrire les messages dans la langue de Jean-Baptiste Poquelin (dit Molière). Parce que ton charabia n'est pas du français.

> Quand dans cet OS "innovateur" avec la version 27 dans lequel on ne peut avoir
Bah faut chercher un peu...

[root@desktop-edouard ~]# dnf info k3b
Dernière vérification de l’expiration des métadonnées effectuée il y a 2:11:16 le mer. 07 févr. 2018 11:37:38 CET.
Paquets installés
Nom          : k3b
Époque       : 1
Version      : 17.12.1
Révision     : 1.fc27
Architecture : x86_64
Taille       : 29 M
Source       : k3b-17.12.1-1.fc27.src.rpm
Dépôt        : @System
Depuis le dé : updates
Résumé       : CD/DVD/Blu-ray burning application
URL          : http://www.k3b.org/
Licence      : GPLv2+
Description  : K3b provides a comfortable user interface to perform most CD/DVD
             : burning tasks. While the experienced user can take influence in all
             : steps of the burning process the beginner may find comfort in the
             : automatic settings and the reasonable k3b defaults which allow a quick
             : start.
[root@desktop-edouard ~]# dnf info libreoffice-langpack-fr.x86_64
Dernière vérification de l’expiration des métadonnées effectuée il y a 2:12:15 le mer. 07 févr. 2018 11:37:38 CET.
Paquets installés
Nom          : libreoffice-langpack-fr
Époque       : 1
Version      : 5.4.4.2
Révision     : 4.fc27
Architecture : x86_64
Taille       : 2.1 M
Source       : libreoffice-5.4.4.2-4.fc27.src.rpm
Dépôt        : @System
Depuis le dé : updates
Résumé       : French language pack for LibreOffice
URL          : http://www.libreoffice.org/
Licence      : (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and MPLv2.0 and CC0
Description  : Provides additional French translations and resources for LibreOffice.
[root@desktop-edouard ~]# dnf info qupzilla
Dernière vérification de l’expiration des métadonnées effectuée il y a 2:12:37 le mer. 07 févr. 2018 11:37:38 CET.
Paquets disponibles
Nom          : qupzilla
Version      : 2.2.5
Révision     : 2.fc27
Architecture : i686
Taille       : 3.0 M
Source       : qupzilla-2.2.5-2.fc27.src.rpm
Dépôt        : updates
Résumé       : Modern web browser
URL          : http://www.qupzilla.com/
Licence      : GPLv3+ and BSD
Description  : QupZilla is a modern web browser based on QtWebEngine (which is itself based on
             : the Chromium core, i.e., Blink) and the Qt framework. It is designed to be
             : lightweight and fast and offers advanced functions such as
             : - an integrated advertisement blocker,
             : - a search engine manager,
             : - a SSL certificate manager,
             : - speed dial
             : - theming support, and
             : - seamless integration into your desktop environment.

Nom          : qupzilla
Version      : 2.2.5
Révision     : 2.fc27
Architecture : x86_64
Taille       : 2.8 M
Source       : qupzilla-2.2.5-2.fc27.src.rpm
Dépôt        : updates
Résumé       : Modern web browser
URL          : http://www.qupzilla.com/
Licence      : GPLv3+ and BSD
Description  : QupZilla is a modern web browser based on QtWebEngine (which is itself based on
             : the Chromium core, i.e., Blink) and the Qt framework. It is designed to be
             : lightweight and fast and offers advanced functions such as
             : - an integrated advertisement blocker,
             : - a search engine manager,
             : - a SSL certificate manager,
             : - speed dial
             : - theming support, and
             : - seamless integration into your desktop environment.

et ce qui n'est pas dispo, tu le compiles comme un grand !

> Que tu ose refuser de voir et comprendre qu'il y a effectivement un ennui avec l'installe de "Skype" que daemon a rencontré un solide trouble shooting...   
mailol je viens de l'installer !

[root@desktop-edouard Téléchargements]# dnf info skypeforlinux
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:00:28 le mer. 07 févr. 2018 13:52:54 CET.
Paquets installés
Nom          : skypeforlinux
Version      : 8.15.0.4
Révision     : 1
Architecture : x86_64
Taille       : 237 M
Source       : skypeforlinux-8.15.0.4-1.src.rpm
Dépôt        : @System
Depuis le dé : @commandline
Résumé       : Skype keeps the world talking, for free.
URL          : https://www.skype.com/
Licence      : Skype End User License Agreement
Description  : Skype keeps you together. Call, message and share with others.
             :  * It's free to download and join.
             :  * Call, instant message and send photos and documents to anyone else on Skype.
             :  * Easily text message anywhere in the world.
             :  * Get your friends together on a group call.
             : And that's just the start...

> La connexion eth a comme nom "enp4s0" chose qui n'était jamais mentionné avec mon F.A.I
Mais qu'est ce que le FAI vient faire là dedans ??? C'est le système qui nomme tes connexions, et tu peux l'appeler "eth", "enp4so" ou "boeufbourguignon" sans que ça change rien !

Oh lalala

Dernière modification par Edouard_le_homard (07/02/2018 13:57:13)


Asus VivoBook S 15 Fedora 29 x86_64 KDE

Hors ligne

Pied de page des forums