Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 34 n'est plus maintenu

#26 23/12/2017 13:54:25

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 685

Re : conflit de paquet pour RADEON R9

sérieux c'est ch...  de lire les réponses quand on n'a pas les commandes!


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#27 23/12/2017 14:17:25

Mexphil
Membre
Inscription : 12/03/2017
Messages : 70

Re : conflit de paquet pour RADEON R9

Pardon,
Voila les lignes qui m'ont été données par Vindicators au post #20 :

cat /proc/bus/pci/devices | grep VGA || lspci | grep VGA | colrm 1 4 ; \
cat /proc/cpuinfo | egrep "model name|MHz" ; \
xdpyinfo | egrep "version:|dimensions|depth of" ; \
glxinfo | egrep -A2 "rendering|OpenGL" ; \
uname -sr; \
dnf list mesa*; \

Que j'ai regroupé dans un seul truc parceque je savais pas où les couper.
et voici la réponse de ces lignes.
Le but est de savoir si le système utilise la carte graphiqueRadeon R9 ou non.

[Philippe@Host-001 ~]$ ./Documents/perso/geek/scriptdubonhomme.c
2.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
model name	: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz
cpu MHz		: 2494.174
model name	: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz
cpu MHz		: 2494.174
model name	: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz
cpu MHz		: 2494.174
model name	: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz
cpu MHz		: 2494.174
model name	: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz
cpu MHz		: 2494.174
model name	: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz
cpu MHz		: 2494.174
model name	: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz
cpu MHz		: 2494.174
model name	: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz
cpu MHz		: 2494.174
  dimensions:    3600x1080 pixels (953x286 millimeters)
  depth of root window:    24 planes
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
--
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.2.4
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
    GL_3DFX_texture_compression_FXT1, GL_AMD_conservative_depth, 
    GL_AMD_draw_buffers_blend, GL_AMD_seamless_cubemap_per_texture, 
--
OpenGL version string: 3.0 Mesa 17.2.4
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
    GL_3DFX_texture_compression_FXT1, GL_AMD_conservative_depth, 
    GL_AMD_draw_buffers_blend, GL_AMD_seamless_cubemap_per_texture, 
--
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.2.4
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:
    GL_ANGLE_texture_compression_dxt3, GL_ANGLE_texture_compression_dxt5, 
    GL_APPLE_texture_max_level, GL_EXT_blend_func_extended, 
Linux 4.14.7-300.fc27.x86_64
Dernière vérification de l’expiration des métadonnées effectuée il y a 1 day, 14:21:08 le jeu. 21 déc. 2017 22:08:37 CET.
Paquets installés
mesa-dri-drivers.x86_64                      17.2.4-2.fc27              @updates
mesa-filesystem.x86_64                       17.2.4-2.fc27              @updates
mesa-libEGL.x86_64                           17.2.4-2.fc27              @updates
mesa-libGL.x86_64                            17.2.4-2.fc27              @updates
mesa-libGLU.x86_64                           9.0.0-13.fc27              @fedora 
mesa-libOpenCL.x86_64                        17.2.4-2.fc27              @updates
mesa-libgbm.x86_64                           17.2.4-2.fc27              @updates
mesa-libglapi.x86_64                         17.2.4-2.fc27              @updates
mesa-libwayland-egl.x86_64                   17.2.4-2.fc27              @updates
mesa-libxatracker.x86_64                     17.2.4-2.fc27              @updates
Paquets disponibles
mesa-demos.x86_64                            8.3.0-9.fc27               updates 
mesa-dri-drivers.i686                        17.2.4-2.fc27              updates 
mesa-filesystem.i686                         17.2.4-2.fc27              updates 
mesa-libEGL.i686                             17.2.4-2.fc27              updates 
mesa-libEGL-devel.i686                       17.2.4-2.fc27              updates 
mesa-libEGL-devel.x86_64                     17.2.4-2.fc27              updates 
mesa-libGL.i686                              17.2.4-2.fc27              updates 
mesa-libGL-devel.i686                        17.2.4-2.fc27              updates 
mesa-libGL-devel.x86_64                      17.2.4-2.fc27              updates 
mesa-libGLES.i686                            17.2.4-2.fc27              updates 
mesa-libGLES.x86_64                          17.2.4-2.fc27              updates 
mesa-libGLES-devel.i686                      17.2.4-2.fc27              updates 
mesa-libGLES-devel.x86_64                    17.2.4-2.fc27              updates 
mesa-libGLU.i686                             9.0.0-13.fc27              fedora  
mesa-libGLU-devel.i686                       9.0.0-13.fc27              fedora  
mesa-libGLU-devel.x86_64                     9.0.0-13.fc27              fedora  
mesa-libGLw.i686                             8.0.0-11.fc27              fedora  
mesa-libGLw.x86_64                           8.0.0-11.fc27              fedora  
mesa-libGLw-devel.i686                       8.0.0-11.fc27              fedora  
mesa-libGLw-devel.x86_64                     8.0.0-11.fc27              fedora  
mesa-libOSMesa.i686                          17.2.4-2.fc27              updates 
mesa-libOSMesa.x86_64                        17.2.4-2.fc27              updates 
mesa-libOSMesa-devel.i686                    17.2.4-2.fc27              updates 
mesa-libOSMesa-devel.x86_64                  17.2.4-2.fc27              updates 
mesa-libOpenCL.i686                          17.2.4-2.fc27              updates 
mesa-libOpenCL-devel.i686                    17.2.4-2.fc27              updates 
mesa-libOpenCL-devel.x86_64                  17.2.4-2.fc27              updates 
mesa-libd3d.i686                             17.2.4-2.fc27              updates 
mesa-libd3d.x86_64                           17.2.4-2.fc27              updates 
mesa-libd3d-devel.i686                       17.2.4-2.fc27              updates 
mesa-libd3d-devel.x86_64                     17.2.4-2.fc27              updates 
mesa-libgbm.i686                             17.2.4-2.fc27              updates 
mesa-libgbm-devel.i686                       17.2.4-2.fc27              updates 
mesa-libgbm-devel.x86_64                     17.2.4-2.fc27              updates 
mesa-libglapi.i686                           17.2.4-2.fc27              updates 
mesa-libwayland-egl.i686                     17.2.4-2.fc27              updates 
mesa-libwayland-egl-devel.i686               17.2.4-2.fc27              updates 
mesa-libwayland-egl-devel.x86_64             17.2.4-2.fc27              updates 
mesa-libxatracker.i686                       17.2.4-2.fc27              updates 
mesa-libxatracker-devel.i686                 17.2.4-2.fc27              updates 
mesa-libxatracker-devel.x86_64               17.2.4-2.fc27              updates 
mesa-omx-drivers.x86_64                      17.2.4-2.fc27              updates 
mesa-vdpau-drivers.i686                      17.2.4-2.fc27              updates 
mesa-vdpau-drivers.x86_64                    17.2.4-2.fc27              updates 
mesa-vulkan-devel.i686                       17.2.4-2.fc27              updates 
mesa-vulkan-devel.x86_64                     17.2.4-2.fc27              updates 
mesa-vulkan-drivers.i686                     17.2.4-2.fc27              updates 
mesa-vulkan-drivers.x86_64                   17.2.4-2.fc27              updates 
[Philippe@Host-001 ~]$ 

Pratiquement debutant linux Fedora 27 Processeur Intel Core i7 Mémoire RAM 8 Go Type de mémoire vive installée DDR3 Capacité du disque dur 1000 Go Lecteur / Graveur DVD-Super Multi Carte graphique AMD Radeon™ R9 M265X Mémoire vidéo dédiée 2048 Mo -avec le pilote propriétaire- Ca pose le bonhomme hein ?? Webcam intégrée Résolution0.9 MP HD Carte son Contrôleur son DTS, Haut-parleurs Harman/Kardon Communication sans fil Wi-Fi Intel 11ac + agn Connectique 4 USB 4 USB 3.0 1 VGA Microphone intégré

Hors ligne

#28 23/12/2017 15:28:40

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 685

Re : conflit de paquet pour RADEON R9

Quand je vois çà

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile 

alors que chez moi ça renvoie çà:

OpenGL vendor string: X.Org
OpenGL renderer string: AMD CEDAR (DRM 2.50.0 / 4.14.7-300.fc27.x86_64, LLVM 4.0.1)

J'ai tendance à penser que c'est le pilote Intel qui gère.

Mais attendons ce que dira la grand maître.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#29 23/12/2017 19:24:16

Edouard_le_homard
Rédacteur Wiki
Rédacteur Wiki
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 654

Re : conflit de paquet pour RADEON R9

C'est moi ou la carte AMD n'apparait pas dans le lspci ?


Asus VivoBook S 15 Fedora 34 x86_64 KDE

Hors ligne

#30 23/12/2017 20:04:29

Mexphil
Membre
Inscription : 12/03/2017
Messages : 70

Re : conflit de paquet pour RADEON R9

non effectivement ça n'apparait pas.
Voici des lspci grep de mon ordinateur :

[Philippe@Host-001 ~]$ lspci | grep radeon
[Philippe@Host-001 ~]$ lspci | grep vga
[Philippe@Host-001 ~]$ lspci | grep RADEON
[Philippe@Host-001 ~]$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
[Philippe@Host-001 ~]$ 

Pratiquement debutant linux Fedora 27 Processeur Intel Core i7 Mémoire RAM 8 Go Type de mémoire vive installée DDR3 Capacité du disque dur 1000 Go Lecteur / Graveur DVD-Super Multi Carte graphique AMD Radeon™ R9 M265X Mémoire vidéo dédiée 2048 Mo -avec le pilote propriétaire- Ca pose le bonhomme hein ?? Webcam intégrée Résolution0.9 MP HD Carte son Contrôleur son DTS, Haut-parleurs Harman/Kardon Communication sans fil Wi-Fi Intel 11ac + agn Connectique 4 USB 4 USB 3.0 1 VGA Microphone intégré

Hors ligne

#31 24/12/2017 18:06:02

Edouard_le_homard
Rédacteur Wiki
Rédacteur Wiki
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 654

Re : conflit de paquet pour RADEON R9

Es tu sûr que la carte AMD est fonctionnelle ?

Dernière modification par Edouard_le_homard (24/12/2017 18:06:48)


Asus VivoBook S 15 Fedora 34 x86_64 KDE

Hors ligne

#32 25/12/2017 13:20:03

Mexphil
Membre
Inscription : 12/03/2017
Messages : 70

Re : conflit de paquet pour RADEON R9

Ben ecoute oui, en fait j'ai commencé avec Ubuntu -tout marche et la carte est bien reconnue- et un jour un type m'a dit qu'Ubuntu c'était Linux pour les crétins alors j'ai essayé d'installer débian qui ne veut pas s'installer sur mon ordinateur parcequ'il faut charger les microcodes xx et yy uwlwifi pour que le wifi marche.
C'est pour ça que j'ai essayé Fedora qui lui accepte de s'installer mais balance des messages d'erreur à l'extinction, -ca va trop vite pour que je le lise mais en gros ça dit "failed to qqc on ring 7 de Radeon qqc"-.
Dans mes fichiers de logs j'ai l'impression que j'ai que le démarrage.
edit 14h20
IL y a tout ça  au sujet de la carte graphique (enfin je crois pas qu'il y ait autre chose qui s'appelle radeon dans mon ordinateur)

[root@Host-001 Philippe]# journalctl -b | grep radeon > rechercheradeon.txt
[root@Host-001 Philippe]# cat -n rechercheradeon.txt 
     1	déc. 25 12:08:21 localhost.localdomain kernel: [drm] radeon kernel modesetting enabled.
     2	déc. 25 12:08:21 localhost.localdomain kernel: radeon 0000:01:00.0: VRAM: 2048M 0x0000000000000000 - 0x000000007FFFFFFF (2048M used)
     3	déc. 25 12:08:21 localhost.localdomain kernel: radeon 0000:01:00.0: GTT: 2048M 0x0000000080000000 - 0x00000000FFFFFFFF
     4	déc. 25 12:08:21 localhost.localdomain kernel: [drm] radeon: 2048M of VRAM memory ready
     5	déc. 25 12:08:21 localhost.localdomain kernel: [drm] radeon: 2048M of GTT memory ready.
     6	déc. 25 12:08:21 localhost.localdomain kernel: [drm] radeon: dpm initialized
     7	déc. 25 12:08:21 localhost.localdomain kernel: radeon 0000:01:00.0: WB enabled
     8	déc. 25 12:08:21 localhost.localdomain kernel: radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000080000c00 and cpu addr 0xffff8d305cc2cc00
     9	déc. 25 12:08:21 localhost.localdomain kernel: radeon 0000:01:00.0: fence driver on ring 1 use gpu addr 0x0000000080000c04 and cpu addr 0xffff8d305cc2cc04
    10	déc. 25 12:08:21 localhost.localdomain kernel: radeon 0000:01:00.0: fence driver on ring 2 use gpu addr 0x0000000080000c08 and cpu addr 0xffff8d305cc2cc08
    11	déc. 25 12:08:21 localhost.localdomain kernel: radeon 0000:01:00.0: fence driver on ring 3 use gpu addr 0x0000000080000c0c and cpu addr 0xffff8d305cc2cc0c
    12	déc. 25 12:08:21 localhost.localdomain kernel: radeon 0000:01:00.0: fence driver on ring 4 use gpu addr 0x0000000080000c10 and cpu addr 0xffff8d305cc2cc10
    13	déc. 25 12:08:21 localhost.localdomain kernel: radeon 0000:01:00.0: fence driver on ring 5 use gpu addr 0x0000000000075a18 and cpu addr 0xffff992202035a18
    14	déc. 25 12:08:21 localhost.localdomain kernel: radeon 0000:01:00.0: failed VCE resume (-22).
    15	déc. 25 12:08:21 localhost.localdomain kernel: radeon 0000:01:00.0: radeon: MSI limited to 32-bit
    16	déc. 25 12:08:21 localhost.localdomain kernel: radeon 0000:01:00.0: radeon: using MSI.
    17	déc. 25 12:08:21 localhost.localdomain kernel: [drm] radeon: irq initialized.
    18	déc. 25 12:08:21 localhost.localdomain kernel: [drm:r600_ring_test [radeon]] *ERROR* radeon: ring 0 test failed (scratch(0x850C)=0xCAFEDEAD)
    19	déc. 25 12:08:21 localhost.localdomain kernel: radeon 0000:01:00.0: disabling GPU acceleration
    20	déc. 25 12:08:22 localhost.localdomain kernel: [drm] Initialized radeon 2.50.0 20080528 for 0000:01:00.0 on minor 1
    21	déc. 25 12:09:00 localhost.localdomain kernel: radeon 0000:01:00.0: No VRAM object for PCIE GART.
    22	déc. 25 12:09:00 localhost.localdomain kernel: [drm:si_resume [radeon]] *ERROR* si startup failed on resume

edit 14h56
Je fouille sur tous les forums en tapant les message d'erreur eten affichant les fichiers un par un il y a du radeon dans ce fichier là aussi

[root@Host-001 proc]# cat modules | grep radeon
radeon 1470464 0 - Live 0xffffffffc0200000
i2c_algo_bit 16384 2 i915,radeon, Live 0xffffffffc00b5000
drm_kms_helper 167936 2 i915,radeon, Live 0xffffffffc017a000
ttm 98304 1 radeon, Live 0xffffffffc0151000
drm 372736 28 i915,radeon,drm_kms_helper,ttm, Live 0xffffffffc0056000
[root@Host-001 proc]# 

Edit de 17h20 :
J'ai installé ce paquet :  xorg-x11-drv-amdgpu.x86_64 -qui s'installe sans aucune dépendance- et redémarré. : Le résultat de

journalctl -b | grep radeon

est le même qu'à 14h20.
edit de 17h35
j'ai retiré le paquet xorg-x11-drv-amdgpu.x86_64 -qui se désinstalle sans aucune dépendance-
17H36
Je ne me sens moins seul : https://www.google.fr/search?dcr=0&ei=E … 4ddFSqHmHo
Edit 17h50
Le 23 décembre il manquait une majuscule dans ma commande lspci -Et soudain la lumière fut-

[root@Host-001 Philippe]# lspci | grep radeon
[root@Host-001 Philippe]# lspci | grep Radeon
01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus PRO [Radeon HD 8850M / R9 M265X] (rev ff)

edit de 18h06 Fort de mon succeès j'ai recommencé le script du #20 et vu dans la liste de paquets qu'un mesalibd3d était disponible.
Je l'ai installé mais la commande

journalctl -b | grep radeon > rechercheradeon.txt

me donne toujours GPU acceleration disabled et et MSI limited to 32 bits,
Edit de 18h19
j'installe le paquet

mesa-vulkan-devel.x86_64                                                                          17.2.4-2.fc27                                                                  updates 
mesa-vulkan-drivers.i686                                                                          17.2.4-2.fc27                                                                  updates 
mesa-vulkan-drivers.x86_64                                                                        17.2.4-2.fc27                                                                  updates 
[root@Host-001 Philippe]# dnf install mesa-vulkan-drivers.x86_64
Dernière vérification de l’expiration des métadonnées effectuée il y a 2:57:47 le lun. 25 déc. 2017 15:20:13 CET.
Dépendances résolues.
============================================================================
 Paquet                  Architecture
                                    Version               Dépôt       Taille
============================================================================
Installation de :
 mesa-vulkan-drivers     x86_64     17.2.4-2.fc27         updates     1.4 M
Installation des dépendances:
 vulkan                  x86_64     1.0.61.1-1.fc27       fedora      1.2 M
 vulkan-filesystem       noarch     1.0.61.1-1.fc27       fedora       10 k

Résumé de la transaction
============================================================================
Installer  3 Paquets

Taille totale des téléchargements : 2.6 M
Taille des paquets installés : 15 M
Voulez-vous continuer ? [o/N] :o
Téléchargement des paquets :
(1/3): vulkan-filesystem-1.0.61.1-1.fc27.no 123 kB/s |  10 kB     00:00    
(2/3): mesa-vulkan-drivers-17.2.4-2.fc27.x8 2.9 MB/s | 1.4 MB     00:00    
(3/3): vulkan-1.0.61.1-1.fc27.x86_64.rpm    569 kB/s | 1.2 MB     00:02    
----------------------------------------------------------------------------
Total                                       687 kB/s | 2.6 MB     00:03     
Test de la transaction en cours
La vérification de la transaction a réussi.
Lancement de la transaction de test
Transaction de test réussie.
Exécution de la transaction
  Préparation           :                                               1/1 
  Installation de       : vulkan-filesystem-1.0.61.1-1.fc27.noarch      1/3 
  Installation de       : vulkan-1.0.61.1-1.fc27.x86_64                 2/3 
  Exécution du scriptlet: vulkan-1.0.61.1-1.fc27.x86_64                 2/3 
  Installation de       : mesa-vulkan-drivers-17.2.4-2.fc27.x86_64      3/3 
  Vérification de       : mesa-vulkan-drivers-17.2.4-2.fc27.x86_64      1/3 
  Vérification de       : vulkan-1.0.61.1-1.fc27.x86_64                 2/3 
  Vérification de       : vulkan-filesystem-1.0.61.1-1.fc27.noarch      3/3 

Installé :
  mesa-vulkan-drivers.x86_64 17.2.4-2.fc27   vulkan.x86_64 1.0.61.1-1.fc27  
  vulkan-filesystem.noarch 1.0.61.1-1.fc27  

Terminé !
[root@Host-001 Philippe]# 

Dernière modification par Mexphil (25/12/2017 19:20:20)


Pratiquement debutant linux Fedora 27 Processeur Intel Core i7 Mémoire RAM 8 Go Type de mémoire vive installée DDR3 Capacité du disque dur 1000 Go Lecteur / Graveur DVD-Super Multi Carte graphique AMD Radeon™ R9 M265X Mémoire vidéo dédiée 2048 Mo -avec le pilote propriétaire- Ca pose le bonhomme hein ?? Webcam intégrée Résolution0.9 MP HD Carte son Contrôleur son DTS, Haut-parleurs Harman/Kardon Communication sans fil Wi-Fi Intel 11ac + agn Connectique 4 USB 4 USB 3.0 1 VGA Microphone intégré

Hors ligne

#33 25/12/2017 20:49:26

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 846
Site Web

Re : conflit de paquet pour RADEON R9

Bon si je résume c'est un pc portable (laptop) et tu utilise la puce graphique "discrète".

A mon avis : https://doc.fedora-fr.org/wiki/Prime

En espérant que tu n'as pas les pilotes libre radeon (tu n'utilise pas amdgpu, mais radeon/radeonsi!) blacklisté quelque part.


AMD R7 5800x X470 64Go DDR4 3.6Ghz, RX5700XT+AMD R7 2700x A320 + 32Go DDR4 3.2Ghz, rx6500xt 4Go
AMD R5 2600 A320, 32Go DDR4 1.8Ghz,1030GT 2Go + AMD A6 9500 A320, 16Go DDR4 2.1Ghz
ARM Rpi4 4Go, à venir Pine64 2xQuartzB 2Go

Hors ligne

#34 25/12/2017 21:01:14

Mexphil
Membre
Inscription : 12/03/2017
Messages : 70

Re : conflit de paquet pour RADEON R9

@Vindicators En désespoir de cause pendant que tu écrivais ça j'ai fais toute les lignes de cette page de doc
https://doc.fedora-fr.org/wiki/Carte_gr … tes_libres
Je me lance tout de suite dans celle de Prime.


Pratiquement debutant linux Fedora 27 Processeur Intel Core i7 Mémoire RAM 8 Go Type de mémoire vive installée DDR3 Capacité du disque dur 1000 Go Lecteur / Graveur DVD-Super Multi Carte graphique AMD Radeon™ R9 M265X Mémoire vidéo dédiée 2048 Mo -avec le pilote propriétaire- Ca pose le bonhomme hein ?? Webcam intégrée Résolution0.9 MP HD Carte son Contrôleur son DTS, Haut-parleurs Harman/Kardon Communication sans fil Wi-Fi Intel 11ac + agn Connectique 4 USB 4 USB 3.0 1 VGA Microphone intégré

Hors ligne

#35 25/12/2017 21:11:17

Mexphil
Membre
Inscription : 12/03/2017
Messages : 70

Re : conflit de paquet pour RADEON R9

J'ai commencé à faire les instuctions de la doc de Prime mais les réponses ne sont pas les mêmes que dans la doc, en plus je n'ai pas le dossier /sys/kernel/debug/vgaswitcheroo/switch et apparement ça sous entend que mon ordinateur n'est pas un "Optimus".
Plus loin ils dient qu'il faut le noyau 4.17 le mien est le 4.14.
J'ABANDONNE!!


Pratiquement debutant linux Fedora 27 Processeur Intel Core i7 Mémoire RAM 8 Go Type de mémoire vive installée DDR3 Capacité du disque dur 1000 Go Lecteur / Graveur DVD-Super Multi Carte graphique AMD Radeon™ R9 M265X Mémoire vidéo dédiée 2048 Mo -avec le pilote propriétaire- Ca pose le bonhomme hein ?? Webcam intégrée Résolution0.9 MP HD Carte son Contrôleur son DTS, Haut-parleurs Harman/Kardon Communication sans fil Wi-Fi Intel 11ac + agn Connectique 4 USB 4 USB 3.0 1 VGA Microphone intégré

Hors ligne

#36 25/12/2017 22:03:33

Mexphil
Membre
Inscription : 12/03/2017
Messages : 70

Re : conflit de paquet pour RADEON R9

Une question quand même avant d'abandonner :
Si je vais dans les bureaux de Red Hat à Paris avec mon ordinateur et que je dis à un mec que je le paie pour qu'il me regle le problème c'est possible ?


Pratiquement debutant linux Fedora 27 Processeur Intel Core i7 Mémoire RAM 8 Go Type de mémoire vive installée DDR3 Capacité du disque dur 1000 Go Lecteur / Graveur DVD-Super Multi Carte graphique AMD Radeon™ R9 M265X Mémoire vidéo dédiée 2048 Mo -avec le pilote propriétaire- Ca pose le bonhomme hein ?? Webcam intégrée Résolution0.9 MP HD Carte son Contrôleur son DTS, Haut-parleurs Harman/Kardon Communication sans fil Wi-Fi Intel 11ac + agn Connectique 4 USB 4 USB 3.0 1 VGA Microphone intégré

Hors ligne

#37 25/12/2017 22:33:25

Edouard_le_homard
Rédacteur Wiki
Rédacteur Wiki
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 654

Re : conflit de paquet pour RADEON R9

Objectivement, je serais toi je réinstallerais un système propre, et je n'installerais pas le.pilote proprio. Et joyeux Noël au passage !

Edit : pour Prime, la version spécifiée est la version minimum, la version que tu as devrait fonctionner. Je te conseille aussi d'apprendre à sauvegarder ton système ;)

Dernière modification par Edouard_le_homard (25/12/2017 22:36:24)


Asus VivoBook S 15 Fedora 34 x86_64 KDE

Hors ligne

#38 26/12/2017 11:30:22

Mexphil
Membre
Inscription : 12/03/2017
Messages : 70

Re : conflit de paquet pour RADEON R9

l'installation que j'utilise en ce moment est une installation normale cf 21/12 #18
Le driver libre n'a jamais fonctionné sur mon ordinateur.

Dernière modification par Mexphil (26/12/2017 12:37:43)


Pratiquement debutant linux Fedora 27 Processeur Intel Core i7 Mémoire RAM 8 Go Type de mémoire vive installée DDR3 Capacité du disque dur 1000 Go Lecteur / Graveur DVD-Super Multi Carte graphique AMD Radeon™ R9 M265X Mémoire vidéo dédiée 2048 Mo -avec le pilote propriétaire- Ca pose le bonhomme hein ?? Webcam intégrée Résolution0.9 MP HD Carte son Contrôleur son DTS, Haut-parleurs Harman/Kardon Communication sans fil Wi-Fi Intel 11ac + agn Connectique 4 USB 4 USB 3.0 1 VGA Microphone intégré

Hors ligne

#39 26/12/2017 13:20:49

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 685

Re : conflit de paquet pour RADEON R9

Mexphil a écrit :

Une question quand même avant d'abandonner :
Si je vais dans les bureaux de Red Hat à Paris avec mon ordinateur et que je dis à un mec que je le paie pour qu'il me regle le problème c'est possible ?

Si je peux me permettre, c'est à eux qu'il faut poser la question.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#40 26/12/2017 14:19:38

Mexphil
Membre
Inscription : 12/03/2017
Messages : 70

Re : conflit de paquet pour RADEON R9

Je trouve dommage d'avoir du bon matériel et de pas réussir à l'utiliser.
J'ai pas vraiment perdu mon temps :J'ai appris des trucs et je vais essayer avec centOS -d'abord avec le driver open -si ça marche très bien- et si ça marche pas avec le driver constructeur.
Sinon je retournerai sur ubuntu.
Joyeux Noel à vous aussi et bonne année!

Dernière modification par Mexphil (26/12/2017 14:21:00)


Pratiquement debutant linux Fedora 27 Processeur Intel Core i7 Mémoire RAM 8 Go Type de mémoire vive installée DDR3 Capacité du disque dur 1000 Go Lecteur / Graveur DVD-Super Multi Carte graphique AMD Radeon™ R9 M265X Mémoire vidéo dédiée 2048 Mo -avec le pilote propriétaire- Ca pose le bonhomme hein ?? Webcam intégrée Résolution0.9 MP HD Carte son Contrôleur son DTS, Haut-parleurs Harman/Kardon Communication sans fil Wi-Fi Intel 11ac + agn Connectique 4 USB 4 USB 3.0 1 VGA Microphone intégré

Hors ligne

#41 26/12/2017 19:04:14

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 846
Site Web

Re : conflit de paquet pour RADEON R9

Après je ne sais pas si la doc sur prime est à jours.

N'ayant pas de quoi voir comment fonctionne la chose, je n'ai pas d'idée plus profonde pour avancer et ajouter des infos dans la doc. Je laisse celles et ceux qui ont du recul sur le sujet le faire.

Le pilote propriétaire pour ton gpu est trop ancien. Le pilote libre est au dessus, là c'est juste une histoire de passer de l'intégré au gpu externe.

Reprise de ce site :
https://wiki.debian.org/fr/AtiHowTo
A voir si cela fonctionne, mais tu peux aussi faire ton retour.

Vérifiez si les deux cartes sont listées :

$ xrandr --listproviders

La liste ci-dessus doit livrer à la fois le nom des cartes et celui des pilotes associés. Afin que la carte Radeon gère le processus intensif graphique utilisez

$ xrandr --setprovideroffloadsink radeon Intel

Vous pouvez tester les paramètres où la sortie devrait AMD

$ DRI_PRIME=1 glxinfo | grep "OpenGL renderer"

Ainsi, en utilisant l'option DRI_PRIME, vous pourrez faire fonctionner des jeux et des films 3D qui ont besoin de capacités graphiques supplémentaires. 

Si c'est le cas fait le nous savoir que l'on puisse le rajouter dans la documentation.

Il me semble aussi qu'il y ai un utilitaire graphique pour gérer simplement la chose, mais il faut que je retouve.

Dernière modification par VINDICATORs (26/12/2017 19:11:08)


AMD R7 5800x X470 64Go DDR4 3.6Ghz, RX5700XT+AMD R7 2700x A320 + 32Go DDR4 3.2Ghz, rx6500xt 4Go
AMD R5 2600 A320, 32Go DDR4 1.8Ghz,1030GT 2Go + AMD A6 9500 A320, 16Go DDR4 2.1Ghz
ARM Rpi4 4Go, à venir Pine64 2xQuartzB 2Go

Hors ligne

#42 26/12/2017 19:45:12

Edouard_le_homard
Rédacteur Wiki
Rédacteur Wiki
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 654

Re : conflit de paquet pour RADEON R9

La doc est relativement récente (avril 2017), et sauf erreur de ma part les commandes indiquées devraient aboutir au bon résultat avec une carte AMD, sous réserve que les pilotes utilisés soient les pilotes libres. Les commandes que tu as listées sont dans notre doc aussi.

Il n'est pas clair pour moi si Wayland supporte Prime. Étant utilisateur de KDE, je n'ai pas encore fait le saut (instabilité de Wayland sous Plasma 5 et indisponibilité des bureaux virtuels). Cependant je peux toujours tester à mon retour à la maison (qq jours) pour savoir si Prime fonctionne sous Wayland.

L'utilitaire graphique dont tu parles existe pour Gnome depuis la 3.24, cf ici.

Dernière modification par Edouard_le_homard (26/12/2017 21:58:43)


Asus VivoBook S 15 Fedora 34 x86_64 KDE

Hors ligne

#43 08/03/2018 10:25:13

Mexphil
Membre
Inscription : 12/03/2017
Messages : 70

Re : conflit de paquet pour RADEON R9

@Edouard le homard je suis tes conseils avec quelques mois de retard.
Est-ce que c'est toi qui est caché derrière cette réponse de mon ordinateur ? :

[root@localhost sauvegardes]# tar cvpjf backup.tar.bz2 --exclude=/proc --exclude=/lost+found --exclude=backup.tar.bz2 --exclude=/mnt --exclude=/sys --exclude=/boot --exclude=/home/Philippe/Documents
[b]tar: Je refuse de créer un fichier d'archive vide (oui je suis lâche)[/b]
Pour en savoir davantage, faites : « tar --help » ou « tar --usage ».

Pratiquement debutant linux Fedora 27 Processeur Intel Core i7 Mémoire RAM 8 Go Type de mémoire vive installée DDR3 Capacité du disque dur 1000 Go Lecteur / Graveur DVD-Super Multi Carte graphique AMD Radeon™ R9 M265X Mémoire vidéo dédiée 2048 Mo -avec le pilote propriétaire- Ca pose le bonhomme hein ?? Webcam intégrée Résolution0.9 MP HD Carte son Contrôleur son DTS, Haut-parleurs Harman/Kardon Communication sans fil Wi-Fi Intel 11ac + agn Connectique 4 USB 4 USB 3.0 1 VGA Microphone intégré

Hors ligne

#44 08/03/2018 10:30:32

Edouard_le_homard
Rédacteur Wiki
Rédacteur Wiki
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 654

Re : conflit de paquet pour RADEON R9

?


Asus VivoBook S 15 Fedora 34 x86_64 KDE

Hors ligne

#45 08/03/2018 12:25:24

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 685

Re : conflit de paquet pour RADEON R9

Mexphil a écrit :

@Edouard le homard je suis tes conseils avec quelques mois de retard.
Est-ce que c'est toi qui est caché derrière cette réponse de mon ordinateur ? :

[root@localhost sauvegardes]# tar cvpjf backup.tar.bz2 --exclude=/proc --exclude=/lost+found --exclude=backup.tar.bz2 --exclude=/mnt --exclude=/sys --exclude=/boot --exclude=/home/Philippe/Documents
[b]tar: Je refuse de créer un fichier d'archive vide (oui je suis lâche)[/b]
Pour en savoir davantage, faites : « tar --help » ou « tar --usage ».

lis le man tar, la réponse est évidente.  (Rappelle toi la syntaxe: sujet verbe complément)


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#46 08/03/2018 13:14:04

Mexphil
Membre
Inscription : 12/03/2017
Messages : 70

Re : conflit de paquet pour RADEON R9

Nouvo9 un peu d'humour,
Ce qui m'amusait c'était le

(oui je suis lâche)

inséré dans la réponse de la commande.
Vu que c'est certainement un Français qui a rédigé ça je me demandais si c'était lui...


Pratiquement debutant linux Fedora 27 Processeur Intel Core i7 Mémoire RAM 8 Go Type de mémoire vive installée DDR3 Capacité du disque dur 1000 Go Lecteur / Graveur DVD-Super Multi Carte graphique AMD Radeon™ R9 M265X Mémoire vidéo dédiée 2048 Mo -avec le pilote propriétaire- Ca pose le bonhomme hein ?? Webcam intégrée Résolution0.9 MP HD Carte son Contrôleur son DTS, Haut-parleurs Harman/Kardon Communication sans fil Wi-Fi Intel 11ac + agn Connectique 4 USB 4 USB 3.0 1 VGA Microphone intégré

Hors ligne

#47 08/03/2018 14:16:36

Edouard_le_homard
Rédacteur Wiki
Rédacteur Wiki
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 654

Re : conflit de paquet pour RADEON R9

Je n'y croyais pas, et j'ai bien le même chez moi =)


Asus VivoBook S 15 Fedora 34 x86_64 KDE

Hors ligne

#48 04/04/2018 11:41:43

Mexphil
Membre
Inscription : 12/03/2017
Messages : 70

Re : conflit de paquet pour RADEON R9

Bonjour,
J'ai le noyau 4.15.14.300 -mon installation fedora 27 date d'hier soir-.
suite à la disponibilité et l'essai de fedora 28 beta qui bloque tout au démarrage de gnome je ressors ce fil :
à l'époque je n'avais pas compris ce qu'était GRUB, maintenant j'ai changé.
En appuyant sur E et en recopiant la ligne  suggérée au paragraphe 4.1. de
https://doc.fedora-fr.org/wiki/Carte_gr … _et_.2B.29
ça me disable toujours l'accélération graphique.
Dans la phrase :

radeon.si_support=0 amdgpu.si_support=1 radeon.cik_support=0 amdgpu.cik_support=1 amdgpu.exp_hw_support=1

On désactive les pilotes Radeon avec des zéros au profit des pilotes amdGPU avec des "1" n'est-ce pas ?
Ca marche pas pour moi.


Pratiquement debutant linux Fedora 27 Processeur Intel Core i7 Mémoire RAM 8 Go Type de mémoire vive installée DDR3 Capacité du disque dur 1000 Go Lecteur / Graveur DVD-Super Multi Carte graphique AMD Radeon™ R9 M265X Mémoire vidéo dédiée 2048 Mo -avec le pilote propriétaire- Ca pose le bonhomme hein ?? Webcam intégrée Résolution0.9 MP HD Carte son Contrôleur son DTS, Haut-parleurs Harman/Kardon Communication sans fil Wi-Fi Intel 11ac + agn Connectique 4 USB 4 USB 3.0 1 VGA Microphone intégré

Hors ligne

#49 04/04/2018 17:32:00

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 846
Site Web

Re : conflit de paquet pour RADEON R9

Cela dépend de l'architecture de ta puce (parfois le nom commercial ne dit pas la génération de l'architecture qui peut être juste un renommage). En GCN 1.1 cela fonctionne très bien. Par contre pas avec GCN 1.0 (au dernières nouvelle).

Voir le tableau par ici : https://www.x.org/wiki/RadeonFeature/#L … parameters

Après est ce que tu as installé le paquet xorg-x11-drv-amdgpu?


AMD R7 5800x X470 64Go DDR4 3.6Ghz, RX5700XT+AMD R7 2700x A320 + 32Go DDR4 3.2Ghz, rx6500xt 4Go
AMD R5 2600 A320, 32Go DDR4 1.8Ghz,1030GT 2Go + AMD A6 9500 A320, 16Go DDR4 2.1Ghz
ARM Rpi4 4Go, à venir Pine64 2xQuartzB 2Go

Hors ligne

Pied de page des forums