Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Représenter Fedora au Capitole du Libre 2019

#1 27/11/2017 10:43:38

jeannot
Membre
Lieu : Pierreval
Inscription : 08/08/2005
Messages : 672

[Résolu] Désactiver NetworkManager-wait-online impossible

Bonjour,
Plusieurs intervenants conseillent la désactivation du service  NetworkManager-wait-online.
Je ne sais pas par quel mystère je n'arrive pas au résultat escompté.
Je suis sous fedora 26 en 86x64
Voici les commandes utilisées en root :

 systemctl stop NetworkManager-wait-online.service
systemctl disable NetworkManager-wait-online.service

J'ai réalisé la me commande avec dnf

systemctl disable dnf-makecache.service

qui elle a réussie.
Une idée de mon problème ou une erreur de ma part.
Merci d'avance

Hors ligne

#2 27/11/2017 13:13:44

Mister_G
Membre
Lieu : Rouen (76)
Inscription : 07/05/2007
Messages : 654

Re : [Résolu] Désactiver NetworkManager-wait-online impossible

tu étais bien root pour les 2 premières commandes ?


i7 870 - 16 Go - gtx 970 - ssd 500 Go - Win 10 +  ssd 250 Go - F27 64 Fluxbox - 28" hanns g
lenovo i5- 4 Go - ssd 128 Go - debian sid 32 Fluxbox  - 15.6"

Hors ligne

#3 27/11/2017 13:58:25

chepioq
FEDORA FOR EVER
Lieu : a l'est de marseille
Inscription : 07/06/2006
Messages : 7 293

Re : [Résolu] Désactiver NetworkManager-wait-online impossible

Il existe des services qui ne peuvent pas se désactiver, comme NetworkManager-wait-online.service.
Dans ce cas il faut appliquer une autre commande :

systemctl mask NetworkManager-wait-online.service

Tout est dans tout... et réciproquement...
C'est quoi un chalumeau??? C'est un dromaludaire à deux bosses...
Quand le sage montre la lune l'imbécile regarde le doigt...
1277887812.gif

Hors ligne

#4 27/11/2017 17:11:06

jeannot
Membre
Lieu : Pierreval
Inscription : 08/08/2005
Messages : 672

Re : [Résolu] Désactiver NetworkManager-wait-online impossible

Merci pour vos réponses
Pour Mister_G : oui ces commandes sont bien réalisées en root
Pour chepioq : je ne connaissais pas cela et dans la doc sur sytemd sauf erreur de lecture il n'est pas fait mention de services non "disable".
Question subsidiaire par le passé il y avait un "module" qui permettait d'agir sur les services disparu ?
A+

Hors ligne

#5 27/11/2017 17:17:14

Mister_G
Membre
Lieu : Rouen (76)
Inscription : 07/05/2007
Messages : 654

Re : [Résolu] Désactiver NetworkManager-wait-online impossible

j'ai aussi appris quelque chose smile
aucune idée pour la question subsidiaire.


i7 870 - 16 Go - gtx 970 - ssd 500 Go - Win 10 +  ssd 250 Go - F27 64 Fluxbox - 28" hanns g
lenovo i5- 4 Go - ssd 128 Go - debian sid 32 Fluxbox  - 15.6"

Hors ligne

#6 27/11/2017 18:14:31

chepioq
FEDORA FOR EVER
Lieu : a l'est de marseille
Inscription : 07/06/2006
Messages : 7 293

Re : [Résolu] Désactiver NetworkManager-wait-online impossible

jeannot a écrit :

.............................................
Pour chepioq : je ne connaissais pas cela et dans la doc sur sytemd sauf erreur de lecture il n'est pas fait mention de services non "disable".
...................................

J'ai été un peu vite, en réalité il y a des services qu'on ne peut désactiver car ils sont requis par d'autres services (ou targets)
Dans le cas de NetworkManager-wait-online.service on peut voir dans son fichier de configuration :

[Unit]
Description=Network Manager Wait Online
Documentation=man:nm-online(1)
Requires=NetworkManager.service
After=NetworkManager.service
Before=network-online.target

[Service]
Type=oneshot
ExecStart=/usr/bin/nm-online -s -q --timeout=30
RemainAfterExit=yes

[Install]
WantedBy=network-online.target

Ce service est requis par network-online.target, qui peut aussi être "disabled" mais dans ce cas tu n'auras pas de connexion internet au démarrage, il faudra lancer ta connexion "à la main"

systemctl mask permet d'empêcher NetworkManager-wait-online.service de se lancer sans impacter network-online.target.

Je me demande si je suis assez clair.


Tout est dans tout... et réciproquement...
C'est quoi un chalumeau??? C'est un dromaludaire à deux bosses...
Quand le sage montre la lune l'imbécile regarde le doigt...
1277887812.gif

Hors ligne

#7 27/11/2017 18:28:41

jeannot
Membre
Lieu : Pierreval
Inscription : 08/08/2005
Messages : 672

Re : [Résolu] Désactiver NetworkManager-wait-online impossible

Oui c'est clair comme explication même pour un pépé.
Merci A+

Hors ligne

#8 27/11/2017 19:00:57

chepioq
FEDORA FOR EVER
Lieu : a l'est de marseille
Inscription : 07/06/2006
Messages : 7 293

Re : [Résolu] Désactiver NetworkManager-wait-online impossible

jeannot a écrit :

Oui c'est clair comme explication même pour un pépé.
Merci A+

C'est parce que je suis aussi un pépé big_smile


Tout est dans tout... et réciproquement...
C'est quoi un chalumeau??? C'est un dromaludaire à deux bosses...
Quand le sage montre la lune l'imbécile regarde le doigt...
1277887812.gif

Hors ligne

#9 27/11/2017 21:59:13

Fifi
Membre
Lieu : Belgique
Inscription : 22/05/2006
Messages : 5 245

Re : [Résolu] Désactiver NetworkManager-wait-online impossible

Mmmmh, chepioq, chez moi disable NetworkManager-wait-online.service, ça fonctionne :

[fifi@localhost ~]$ su -
Mot de passe : 
[root@localhost ~]# systemctl status NetworkManager-wait-online.service
● NetworkManager-wait-online.service - Network Manager Wait Online
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager-wait-online.service; e
   Active: inactive (dead)
     Docs: man:nm-online(1)
[root@localhost ~]# systemctl disable NetworkManager-wait-online.service
Removed /etc/systemd/system/network-online.target.wants/NetworkManager-wait-online.service.
[root@localhost ~]# systemd-analyze blame
          3.198s dracut-initqueue.service
          1.608s cups.service
          1.369s systemd-udev-settle.service
           674ms firewalld.service
           643ms WD1000\x2d3.mount
           600ms WD1000\x2d4.mount
           569ms dev-sda3.device
           539ms initrd-switch-root.service
           429ms upower.service
           380ms T\xc3\xa9l\xc3\xa9chargements.mount
           379ms akmods.service
           315ms chronyd.service
           305ms jexec.service
           250ms udisks2.service
           227ms systemd-logind.service
           174ms rtkit-daemon.service
           167ms akmods-shutdown.service
           153ms rsyslog.service
           149ms dracut-pre-pivot.service
           140ms auditd.service
           130ms user@1000.service
           127ms systemd-journal-flush.service
           121ms polkit.service
           119ms systemd-udev-trigger.service
           106ms initrd-parse-etc.service
           104ms systemd-udevd.service
            91ms dracut-cmdline.service
            77ms systemd-tmpfiles-clean.service
            75ms systemd-tmpfiles-setup.service
            62ms fedora-readonly.service
            59ms NetworkManager.service
            58ms systemd-tmpfiles-setup-dev.service
            51ms colord.service
            46ms systemd-fsck-root.service
            44ms proc-sys-fs-binfmt_misc.mount
            40ms systemd-fsck@dev-disk-by\x2duuid-1f60902c\x2d9eab\x2d4e77\x2db0
            37ms fedora-import-state.service
            35ms dracut-pre-udev.service
            33ms systemd-journald.service
            24ms systemd-remount-fs.service
            22ms rc-local.service
            22ms systemd-user-sessions.service
            19ms sys-kernel-debug.mount
            16ms systemd-update-utmp-runlevel.service
            16ms systemd-sysctl.service
            16ms dev-disk-by\x2duuid-85f21436\x2d0145\x2d4bf3\x2d8f9b\x2da5f1fc3
            14ms initrd-cleanup.service
            14ms tmp.mount
            13ms sysroot.mount
            12ms dev-hugepages.mount
            12ms kmod-static-nodes.service
            11ms home.mount
             8ms systemd-update-utmp.service
             8ms initrd-udevadm-cleanup-db.service
             7ms systemd-random-seed.service
             6ms dev-mqueue.mount
             5ms dracut-shutdown.service
             4ms sys-fs-fuse-connections.mount
             3ms sys-kernel-config.mount
[root@localhost ~]# systemctl enable NetworkManager-wait-online.service 
Created symlink /etc/systemd/system/network-online.target.wants/NetworkManager-wait-online.service → /usr/lib/systemd/system/NetworkManager-wait-online.service.
[root@localhost ~]# systemctl disable NetworkManager-wait-online.service
Removed /etc/systemd/system/network-online.target.wants/NetworkManager-wait-online.service.
[root@localhost ~]# systemctl start NetworkManager-wait-online.service
[root@localhost ~]# systemctl status NetworkManager-wait-online.service
● NetworkManager-wait-online.service - Network Manager Wait Online
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager-wait-online.service; d
   Active: active (exited) since Mon 2017-11-27 20:54:56 CET; 16s ago
     Docs: man:nm-online(1)
  Process: 5087 ExecStart=/usr/bin/nm-online -s -q --timeout=30 (code=exited, st
 Main PID: 5087 (code=exited, status=0/SUCCESS)

nov 27 20:54:56 localhost.localdomain systemd[1]: Starting Network Manager Wait 
nov 27 20:54:56 localhost.localdomain systemd[1]: Started Network Manager Wait O
[root@localhost ~]# 
[root@localhost ~]# systemctl stop NetworkManager-wait-online.service
[root@localhost ~]# systemctl status NetworkManager-wait-online.service
● NetworkManager-wait-online.service - Network Manager Wait Online
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager-wait-online.service; d
   Active: inactive (dead) since Mon 2017-11-27 20:55:38 CET; 13s ago
     Docs: man:nm-online(1)
  Process: 5087 ExecStart=/usr/bin/nm-online -s -q --timeout=30 (code=exited, st
 Main PID: 5087 (code=exited, status=0/SUCCESS)

nov 27 20:54:56 localhost.localdomain systemd[1]: Starting Network Manager Wait 
nov 27 20:54:56 localhost.localdomain systemd[1]: Started Network Manager Wait O
nov 27 20:55:38 localhost.localdomain systemd[1]: Stopped Network Manager Wait O
[root@localhost ~]# 

Fedora 27-x86_64 - KDE 5 - Plasma 5.10 - ASUS M3A32-MVP Deluxe - AMD Phenom 8650 X3 - Nvidia GTX 260 ( avec le driver proprio Nvidia 340xx ) - 4 Go RAM Corsair - 1 disque dur WD de 1 To en Sata3 et un SSD Crucial de 256 Go ( disque de boot )
Multiboot Fedora - Centos 7.0  -  Windows 10 Pro - Systemrescuecd
firefox-56.0-5.fc26.x86_64  -  thunderbird-52.5.0-1.fc27.x86_64

Hors ligne

#10 28/11/2017 09:03:34

chepioq
FEDORA FOR EVER
Lieu : a l'est de marseille
Inscription : 07/06/2006
Messages : 7 293

Re : [Résolu] Désactiver NetworkManager-wait-online impossible

Chez cela le faisait aussi, mais au redémarrage suivant, NetworkManager-wait-online.service etait de nouveau activé.
Avec systemctl mask plus de NetworkManager-wait-online.service, même après un redémarrage.


Tout est dans tout... et réciproquement...
C'est quoi un chalumeau??? C'est un dromaludaire à deux bosses...
Quand le sage montre la lune l'imbécile regarde le doigt...
1277887812.gif

Hors ligne

#11 28/11/2017 09:08:13

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 721
Site Web

Re : [Résolu] Désactiver NetworkManager-wait-online impossible

Bizarre quand même???!!!??? vu que "disable" c'est sensé faire ce que cela dit...


AMD Ryzen 7 2700X + MSI Gaming Pro Carbon X470, 32Go de RAM DDR4 3200@3333Mhz Gskill Trident Z RBG CL14, AMD Radeon RX590 Sapphire Nitro+ Special Edition 8Go GDDR5
SSD Samsung : 1x 970 NVME (PCI-express 3.0x4) 500Go + 1x 850 EVO 250Go + 2x 860 EVO 500Go + 2x1To 860 QVO  / HDD : 1x2To WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red
Boitier GMT Bequiet Dark 900 + Lepa 800W 80+gold

Hors ligne

#12 28/11/2017 14:19:29

GOGI
Membre
Inscription : 09/06/2017
Messages : 84

Re : [Résolu] Désactiver NetworkManager-wait-online impossible

VINDICATORs a écrit :

Bizarre quand même???!!!??? vu que "disable" c'est sensé faire ce que cela dit...

Pas tout à fait, enfin pas forcément comme on pourrait le croire... wink

La commande

systemctl disable 

permet de désactiver le démarrage automatique au boot d'un service "par lui-même", l'ordre de démarrage sera ordonnancé par les dépendances éventuellement inscrites dans son fichier de configuration.

Mais ce n'est pas parce qu'un service est désactivé par cette commande qu'il ne sera pas démarré au boot quand même... Il suffit pour celà qu'un autre service ait comme dépendance dans son fichier de configuration sous l'option "Requires" ou "BindsTo" par exemple, le service cité plus haut, pour que celui-ci soit démarré alors qu'il est bien désactivé par défaut.
C'est pourquoi il vaut mieux utiliser la commande

systemctl mask

plutôt, qui elle va créer un lien symbolique vers "/dev/null", et dans ce cas quoi qu'il arrive le service masqué ne sera pas lancé car il n'y aura rien à lire dans son fichier de configuration...
Vous pourrez toujours vérifier avec la commande

systemctl cat 

.

Et deuxième raison de préférer la commande

systemctl mask

, tout simplement car celle-ci fonctionnera avec n'importe quelle unité de systemd que l'on souhaite désactiver pour de bon (service, socket, target, mount, ...), ce qui n'est pas le cas avec la commande

systemctl disable

(exemple des unités dites "static").

Dernière modification par GOGI (28/11/2017 14:20:31)


__gogi__

Hors ligne

#13 28/11/2017 15:42:48

Mister_G
Membre
Lieu : Rouen (76)
Inscription : 07/05/2007
Messages : 654

Re : [Résolu] Désactiver NetworkManager-wait-online impossible

merci pour l'explication, c'est très clair smile


i7 870 - 16 Go - gtx 970 - ssd 500 Go - Win 10 +  ssd 250 Go - F27 64 Fluxbox - 28" hanns g
lenovo i5- 4 Go - ssd 128 Go - debian sid 32 Fluxbox  - 15.6"

Hors ligne

#14 28/11/2017 20:31:25

Fifi
Membre
Lieu : Belgique
Inscription : 22/05/2006
Messages : 5 245

Re : [Résolu] Désactiver NetworkManager-wait-online impossible

Super les infos ! J'ai appris quelque chose !!! Merci.


Fedora 27-x86_64 - KDE 5 - Plasma 5.10 - ASUS M3A32-MVP Deluxe - AMD Phenom 8650 X3 - Nvidia GTX 260 ( avec le driver proprio Nvidia 340xx ) - 4 Go RAM Corsair - 1 disque dur WD de 1 To en Sata3 et un SSD Crucial de 256 Go ( disque de boot )
Multiboot Fedora - Centos 7.0  -  Windows 10 Pro - Systemrescuecd
firefox-56.0-5.fc26.x86_64  -  thunderbird-52.5.0-1.fc27.x86_64

Hors ligne

#15 28/11/2017 21:57:22

jeannot
Membre
Lieu : Pierreval
Inscription : 08/08/2005
Messages : 672

Re : [Résolu] Désactiver NetworkManager-wait-online impossible

Eh bien ma question a donnée de fameux résultats avec un petit nouveau qui donne l'impression d'être un expert bien utile aux pépés.
Merci à tous.
A+

Hors ligne

Pied de page des forums