Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Clap de fin pour Fedora Linux 35 !

#1 15/12/2016 16:16:29

joshw
Membre
Inscription : 22/08/2016
Messages : 315

[Résolu] Montage HDD SATA n'est plus automatique

Bonjour,

Voilà, je viens de réinstaller F25 (à partir de zéro), seulement avant mon 2ième disque dur était reconnu (monté) automatiquement.
Hors maintenant, je voudrais récupérer un backup et je reçois le message d'erreur suivant :

"Error mounting  /dev/sda5 at /run/media/Joshw/Data: Command-line 'mount -t "ntfs" -o "uhelper=udisks2, nodev,nosuid,uid=1000,gid=1000" "/dev/sda5" "/run/media/Joshw/Data"' exited with non-zero exit status 14:"

"The disk contains an unclean file system (0,0)."

"Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda5': operation not permitted.
The NTFS partition is in an unsafe state. Please resume and shutdown Windows Fully (no ibernation or fast restarting), or mount the wolume read-only with the 'ro' mount option."

Je me suis dirigé vers grub2 qui est déja installé !
Donc, je me suis référé à cette discussion.
Ensuite, j'ai tapé cette commande avec succès :

# grub2-mkconfig -o /boot/grub2/grub.cfg

J'ai également essayé ceci (je ne suis pas sûr de la commande) :

[joshw@localhost ~]$ su -lc 'mount -t "ntfs" -o "uhelper=udisks2, nodev,nosuid,uid=1000,gid=1000" "/dev/sda5" "/run/media/Joshw/Data"'
Mot de passe : 
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda5': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Avant mon ordi démarrait automatiquement sur le disque Fedora, maintenant il démarre sur Win10.
Je voudrais retourné à la configuration gérée par grub2 (qui propose bien un menu vers Win10).
Peut-être regarder dans le BIOS si quelque chose à changé ?

Il est vrai aussi, que dans la précipitation, pensant que le pc était éteint, j'ai débranché un disque à chaud !
Mais, j'ai démarré sans souci sur celui-ci ! Peut-être un fichier crash quelque part à regarder ?

Pourriez-vous m'aider s'il vous plaît ?

Joshw


Fedora Workstation 37 - processeur x86_64 - Mémoire : 7,7 Gio -  Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz -GNOME Version 43.2 - Débuter avec un terminal - MDN - w3schools

Hors ligne

#2 15/12/2016 16:20:40

joshw
Membre
Inscription : 22/08/2016
Messages : 315

Re : [Résolu] Montage HDD SATA n'est plus automatique

Peut-être que la réponse se trouve ici (tuto) ?

Je me heurte à ceci :

[root@localhost ~]# mkdir -p /window/C
[root@localhost ~]# mkdir /windows/D
mkdir: impossible de créer le répertoire « /windows/D »: No such file or directory

La première commande passe avec succès, mais la seconde non.

Pour info :

[root@localhost ~]# lsmod | grep fuse
fuse                  102400  3
[root@localhost ~]# 
tuto mentionné ci-dessus a écrit :

Cette commande liste les modules chargés et en extrait "fuse"; si elle ne renvoie rien, fuse n'est pas chargé. Pour charger fuse (si l'installation du rpm n'a pas permis ce chargement) :

La commande ne renvoie rien :

[root@localhost ~]# modprobe fuse
[root@localhost ~]# 
#dnf install fuse
Vérification de l'expiration des métadonnées effectuée il y a 0:46:31 sur Thu Dec 15 15:13:14 2016.
Le paquet fuse-2.9.7-1.fc25.x86_64 est déjà installé, ignorer
Dépendances résolues.
Rien à faire.
Terminé !

Dernière modification par joshw (15/12/2016 17:12:05)


Fedora Workstation 37 - processeur x86_64 - Mémoire : 7,7 Gio -  Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz -GNOME Version 43.2 - Débuter avec un terminal - MDN - w3schools

Hors ligne

#3 15/12/2016 17:00:10

hechmi50
Membre
Inscription : 21/08/2007
Messages : 2 196

Re : [Résolu] Montage HDD SATA n'est plus automatique

Fais attention à la ligne de commande, le moindre caractère a son importance.
Le répertoire Windows n'existe pas, tu as crée précédemment un répertoire Window.
fuse est chargé, c'est plus la peine de faire un modprobe fuse.

Dernière modification par hechmi50 (15/12/2016 17:03:32)


fedorauser.png
Dell Latitude E5540 - i5-4210U - Ram: 8 Gb - VGA: Intel Haswell-ULT -  Wireless: Intel 7260 - Storage: SSD Sata 240 Go
Fedora 36 Gnome-Shell

Hors ligne

#4 15/12/2016 17:17:19

joshw
Membre
Inscription : 22/08/2016
Messages : 315

Re : [Résolu] Montage HDD SATA n'est plus automatique

Ah oui, j'ai fait une faute de frappe comment je peux rectifier cela ? rm ?


Fedora Workstation 37 - processeur x86_64 - Mémoire : 7,7 Gio -  Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz -GNOME Version 43.2 - Débuter avec un terminal - MDN - w3schools

Hors ligne

#5 15/12/2016 17:19:58

hechmi50
Membre
Inscription : 21/08/2007
Messages : 2 196

Re : [Résolu] Montage HDD SATA n'est plus automatique

rm -rf /Window

et tu recommences.
ou simplement renommer Window

mv /Window /Windows

Dernière modification par hechmi50 (15/12/2016 17:28:24)


fedorauser.png
Dell Latitude E5540 - i5-4210U - Ram: 8 Gb - VGA: Intel Haswell-ULT -  Wireless: Intel 7260 - Storage: SSD Sata 240 Go
Fedora 36 Gnome-Shell

Hors ligne

#6 15/12/2016 17:27:39

joshw
Membre
Inscription : 22/08/2016
Messages : 315

Re : [Résolu] Montage HDD SATA n'est plus automatique

Merci !


Fedora Workstation 37 - processeur x86_64 - Mémoire : 7,7 Gio -  Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz -GNOME Version 43.2 - Débuter avec un terminal - MDN - w3schools

Hors ligne

#7 15/12/2016 17:41:01

joshw
Membre
Inscription : 22/08/2016
Messages : 315

Re : [Résolu] Montage HDD SATA n'est plus automatique

Le paragraphe 2.5 du tuto explique comment configurer le fichier /etc/fstab, mais avec la commande "fdisk -l", je ne vois pas la forme "/dev/hda2"

Il y a ceci :

[root@localhost etc]# fdisk -l
Disque /dev/sda : 1,8 TiB, 2000398934016 octets, 3907029168 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0xfeb9ffbc

Périphérique Amorçage      Début        Fin   Secteurs Taille Id Type
/dev/sda1    *              2048  757616639  757614592 361,3G  7 HPFS/NTFS/exFAT
/dev/sda2              757616640  758538239     921600   450M 27 TFS WinRE masqu
/dev/sda3              758538240 1987338239 1228800000   586G  5 Étendue
/dev/sda4             1987338240 3907028991 1919690752 915,4G  7 HPFS/NTFS/exFAT
/dev/sda5              758540288 1613783039  855242752 407,8G  7 HPFS/NTFS/exFAT

Les entrées de la table de partitions ne sont pas dans l'ordre du disque.

Voici ce que j'ai mis dans le fichier fstab :

[root@localhost etc]# mv /window /windows
[root@localhost etc]# mkdir /window/D
mkdir: impossible de créer le répertoire « /window/D »: No such file or directory
[root@localhost etc]# mkdir /windows/D
[root@localhost etc]# cat fstab

#
# /etc/fstab
# Created by anaconda on Wed Dec 14 19:17:17 2016
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/fedora-root /                       ext4    defaults        1 1
UUID=264979e5-35dc-4e93-b013-82d5df2609c9 /boot                   ext4    defaults        1 2
/dev/mapper/fedora-home /home                   ext4    defaults        1 2
/dev/mapper/fedora-swap swap                    swap    defaults        0 0

# Disque Windows 10

/dev/sda /windows/C	ntfs-3g silent,unmask=0002,utf8=true

Fedora Workstation 37 - processeur x86_64 - Mémoire : 7,7 Gio -  Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz -GNOME Version 43.2 - Débuter avec un terminal - MDN - w3schools

Hors ligne

#8 15/12/2016 17:59:35

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 936

Re : [Résolu] Montage HDD SATA n'est plus automatique

Tu nous dis que tu as ce message d'erreur. Mais tu n'en fais rien pourtant la solution est là, il suffit de lire et d'exécuter au lieu de s'agiter

The disk contains an unclean file system (0, 0). Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda5': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting)

C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#9 15/12/2016 18:00:26

winmandrake
Rédacteur Wiki
Rédacteur Wiki
Inscription : 08/07/2008
Messages : 1 401

Re : [Résolu] Montage HDD SATA n'est plus automatique

Il faut identifier ton disque dans fstab.

Donc, c'est au choix, pour toi, /dev/sda4 ou /dev/sda6.

Tu devrai avoir ceci :

/dev/sda4 /windows/C	ntfs-3g silent,unmask=0002,utf8=true  1 2

Je te conseil de faire un mount -a pour tester si ton fichier fstab est bien fonctionnel avant de redémarrer et de devoir réparer fstab en ligne de commande uniquement car problème de montage de disque et donc arrêt à ce moment.


Mon pc : AMD R5-5600X sur Asus Prime B450M-A, 16 Go ram, Nvidia 2060Ti (6Go), SSD Samsung 850 EVO (250 Go) + black caviar de 1To.

Hors ligne

#10 15/12/2016 18:03:48

joshw
Membre
Inscription : 22/08/2016
Messages : 315

Re : [Résolu] Montage HDD SATA n'est plus automatique

@Nouvo,

Pour info, j'ai fermé windows normalement et en ce qui concerne le montage j'essaye via le tuto

Je posté ce message car quand j'avais F24, je n'avais pas ce souci, je débute encore...

Pour info, ça me permet de m'y retrouver par la suite et peut-être à d'autres ?

Dernière modification par joshw (15/12/2016 18:07:03)


Fedora Workstation 37 - processeur x86_64 - Mémoire : 7,7 Gio -  Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz -GNOME Version 43.2 - Débuter avec un terminal - MDN - w3schools

Hors ligne

#11 15/12/2016 18:26:45

joshw
Membre
Inscription : 22/08/2016
Messages : 315

Re : [Résolu] Montage HDD SATA n'est plus automatique

--suite--

Pour info, j'ai mofifié le fichier fstab :

[root@localhost etc]# mount /dev/sda5
mount: impossible de trouver /dev/sda5 dans /etc/fstab
[root@localhost etc]# vim fstab
[root@localhost etc]# cat fstab

#
# /etc/fstab
# Created by anaconda on Wed Dec 14 19:17:17 2016
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/fedora-root /                       ext4    defaults        1 1
UUID=264979e5-35dc-4e93-b013-82d5df2609c9 /boot                   ext4    defaults        1 2
/dev/mapper/fedora-home /home                   ext4    defaults        1 2
/dev/mapper/fedora-swap swap                    swap    defaults        0 0

# Disque Windows 10

/dev/sda4 	/windows/C	ntfs-3g 	silent,unmask=0002,utf8=true
/dev/sda4    	/windows/D      ntfs-3g 	silent,umask=0002,utf8=true

J'imagine qu'après je dois faire un :

mount /dev/sda4

Ce qui donne :

[root@localhost etc]# mount /dev/sda4
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda4': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Dernière modification par joshw (15/12/2016 18:28:37)


Fedora Workstation 37 - processeur x86_64 - Mémoire : 7,7 Gio -  Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz -GNOME Version 43.2 - Débuter avec un terminal - MDN - w3schools

Hors ligne

#12 15/12/2016 19:09:05

CabSud
Membre
Lieu : Cyber Espace
Inscription : 25/08/2010
Messages : 408

Re : [Résolu] Montage HDD SATA n'est plus automatique

Ça m'est arrivé il y a quelques mois, hélas je ne me souviens plus exactement de la solution, la mémoire ... :/
Mais ayant trouvé la solution sur le net elle doit être facilement accessible j'imagine, en cherchant bien.

Tout ce que je peux dire c'est que:
1°) je n'ai pas eu besoin de modifier les options de montage de la partition NTFS.
2°) de mémoire la solution a été réalisée depuis Windows10 et le bios, mais rien depuis Fedora.


Je suis d'accord avec ce qu'a dit @nouvo09, prends le temps de lire attentivement le message d'erreur pour comprendre, ça évite d'aller dans tous les sens.
Dans un premier temps effectues toutes les recommandations listées dans le message d'erreur (désactivation du fastboot ainsi que de l'hibernation, pas obligatoire mais il me semble l'avoir fait).

PS:
Je crois que la solution se situait, entre autres choses, autour d'une vérification de fichier de la partition problématique depuis Windows, (fck) en ligne de commande (à confirmer...).
Tout ce que je dis là s'est déroulé durant mon utilisation de Fedora23, mais je crois que ton problème n'a rien à voir avec Fedora alors sa version n'est pas importante je pense mais je le précise quand même au cas où.

Bonne chance & bon courage !

@+

Hors ligne

#13 15/12/2016 19:18:21

winmandrake
Rédacteur Wiki
Rédacteur Wiki
Inscription : 08/07/2008
Messages : 1 401

Re : [Résolu] Montage HDD SATA n'est plus automatique

une fois ton fichier fstab mofié :

mount -a

Tout devrai se monter.

Pour monter une partition ou disque il faut la commande mount, la partition et le dossier cible.
Donc ta commande devrai être :

mount /dev/sda4 /windows/C

Au fait, as-tu vérifié les droits de tes dossier pour pouvoir accéder et modifier tes partitions nouvellement montées ?


Mon pc : AMD R5-5600X sur Asus Prime B450M-A, 16 Go ram, Nvidia 2060Ti (6Go), SSD Samsung 850 EVO (250 Go) + black caviar de 1To.

Hors ligne

#14 15/12/2016 19:26:53

Mongos
openAddict & pinguAddict
Lieu : IdF
Inscription : 25/06/2007
Messages : 879

Re : [Résolu] Montage HDD SATA n'est plus automatique

joshw a écrit :

@Nouvo,

Pour info, j'ai fermé windows normalement...

C'est quel windows ? Et comment as-tu fermé normalement ? Car selon la version, ça peut être mis en hibernation par défaut, au lieu de l'arrêter.

Pour éviter ce genre de soucis, j'utilise cette commande sous windows :

shutdown /s /f /t 0 

Il n'y a pas de problème, juste des solutions

Hors ligne

#15 15/12/2016 20:03:18

joshw
Membre
Inscription : 22/08/2016
Messages : 315

Re : [Résolu] Montage HDD SATA n'est plus automatique

Bonsoir et merci pour vos réponses !

Finalement le problème est résolu en bootant sur Win10 et en applicant la commande :

shutdown /s /f 
# L'option /t 0 a été refusée peut-être est-ce /t:0 ?

Pour ce qui est de la gestion du démarrage (dual boot) grub2 fait le reste et je boot bien depuis Fedora.
J'ai bien accès à mes données !

Merci à tous !
Bonne soirée !

Joshw

Dernière modification par joshw (15/12/2016 20:06:46)


Fedora Workstation 37 - processeur x86_64 - Mémoire : 7,7 Gio -  Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz -GNOME Version 43.2 - Débuter avec un terminal - MDN - w3schools

Hors ligne

#16 15/12/2016 20:47:39

Fifi
Membre
Lieu : Belgique
Inscription : 22/05/2006
Messages : 5 257

Re : [Résolu] Montage HDD SATA n'est plus automatique

Bonsoir joshw,
Comme toi j'ai une partition NTFS qui doit normalement être montée au démarrage de Fedora. Mon /etc/fstab a été paramétré pour ça.
Mais, parfois, cette partition ne se monte pas si je l'ai employée auparavant dans Windows 10 avant de booter sur Fedora et donc j'ai Fedora qui se lance en mode rescue et, si je consulte le journalctl, j'ai un message d'erreur comme toi : exemple :

Dec  6 07:47:31 localhost mount: The disk contains an unclean file system (0, 0).
Dec  6 07:47:31 localhost mount: Metadata kept in Windows cache, refused to mount.
Dec  6 07:47:31 localhost mount: Failed to mount '/dev/sdb8': Opération non permise
Dec  6 07:47:31 localhost mount: The NTFS partition is in an unsafe state. Please resume and shutdown
Dec  6 07:47:31 localhost mount: Windows fully (no hibernation or fast restarting), or mount the volume
Dec  6 07:47:31 localhost mount: read-only with the 'ro' mount option.
Dec  6 07:47:31 localhost systemd: WD1000\x2d4.mount: Mount process exited, code=exited status=14
Dec  6 07:47:31 localhost systemd: Failed to mount /WD1000-4.

La solution que j'emploie dans ce cas là est de rebooter sur Windows, de sélectionner la " Vérification du disque " dans les propriétés du disque ( ou plutôt de la partition ) en question et de la lancer même si Windows me dit qu'il n'y a pas d'erreur. Je pense que ça équivaut à un chkdsk .
Dès que c'est fait, je reboote sur Fedora et plus de problème.

Voilà, si ça peut te donner une piste ...

Quelqu'un a une explication pour ce phénomène ?

Edit : j'ai donc pris l'habitude de lancer cette vérification du disque systématiquement avant de quitter Windows !

Dernière modification par Fifi (15/12/2016 20:50:18)


Fedora 31-x86_64 - KDE 5 - Plasma 5.17 - Gigabyte B450 Aorus Elite - AMD Ryzen 7 2700 - Nvidia GTX 1650 Super Windforce ( avec le driver proprio Nvidia ) - 16 Go RAM Corsair - 1 disque dur WD de 2 To en Sata3 et un SSD Crucial de 256 Go ( disque de boot )
Multiboot Fedora - Centos 7.0  -  Windows 10 Pro - Systemrescuecd
brave-browser-1.2.43-1.fc31.x86_64  -  thunderbird-68.4.1-1.fc31.x86_64

Hors ligne

#17 15/12/2016 21:26:27

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 936

Re : [Résolu] Montage HDD SATA n'est plus automatique

Oui en même temps les explications de vote une fois que la solution a été trouvée, ça n'a beaucoup d'intérêt.

La morale c'est encore une fois que les messages d'erreur n'ont pas pour vocation de décorer un écran. Lorsqu'il y en a ul faut les lire. Et là, si on ne comprend pas, c'est le moment d'interroger le forum.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#18 15/12/2016 23:56:34

Fifi
Membre
Lieu : Belgique
Inscription : 22/05/2006
Messages : 5 257

Re : [Résolu] Montage HDD SATA n'est plus automatique

nouvo09 a écrit :

Oui en même temps les explications de vote une fois que la solution a été trouvée, ça n'a beaucoup d'intérêt.

La morale c'est encore une fois que les messages d'erreur n'ont pas pour vocation de décorer un écran. Lorsqu'il y en a ul faut les lire. Et là, si on ne comprend pas, c'est le moment d'interroger le forum.

Ok
Et sinon : l'explication du problème ???


Fedora 31-x86_64 - KDE 5 - Plasma 5.17 - Gigabyte B450 Aorus Elite - AMD Ryzen 7 2700 - Nvidia GTX 1650 Super Windforce ( avec le driver proprio Nvidia ) - 16 Go RAM Corsair - 1 disque dur WD de 2 To en Sata3 et un SSD Crucial de 256 Go ( disque de boot )
Multiboot Fedora - Centos 7.0  -  Windows 10 Pro - Systemrescuecd
brave-browser-1.2.43-1.fc31.x86_64  -  thunderbird-68.4.1-1.fc31.x86_64

Hors ligne

#19 16/12/2016 00:14:19

Fifi
Membre
Lieu : Belgique
Inscription : 22/05/2006
Messages : 5 257

Re : [Résolu] Montage HDD SATA n'est plus automatique

CabSud a écrit :

Ça m'est arrivé il y a quelques mois, hélas je ne me souviens plus exactement de la solution, la mémoire ... :/
Mais ayant trouvé la solution sur le net elle doit être facilement accessible j'imagine, en cherchant bien.

Tout ce que je peux dire c'est que:
1°) je n'ai pas eu besoin de modifier les options de montage de la partition NTFS.
2°) de mémoire la solution a été réalisée depuis Windows10 et le bios, mais rien depuis Fedora.


Je suis d'accord avec ce qu'a dit @nouvo09, prends le temps de lire attentivement le message d'erreur pour comprendre, ça évite d'aller dans tous les sens.
Dans un premier temps effectues toutes les recommandations listées dans le message d'erreur (désactivation du fastboot ainsi que de l'hibernation, pas obligatoire mais il me semble l'avoir fait).

PS:
Je crois que la solution se situait, entre autres choses, autour d'une vérification de fichier de la partition problématique depuis Windows, (fck) en ligne de commande (à confirmer...).
Tout ce que je dis là s'est déroulé durant mon utilisation de Fedora23, mais je crois que ton problème n'a rien à voir avec Fedora alors sa version n'est pas importante je pense mais je le précise quand même au cas où.

Bonne chance & bon courage !

@+

Je suis d'accord avec toi, CabSud, tu rejoins ce que je pense. Mais je n'ai pas l'explication du problème !


Fedora 31-x86_64 - KDE 5 - Plasma 5.17 - Gigabyte B450 Aorus Elite - AMD Ryzen 7 2700 - Nvidia GTX 1650 Super Windforce ( avec le driver proprio Nvidia ) - 16 Go RAM Corsair - 1 disque dur WD de 2 To en Sata3 et un SSD Crucial de 256 Go ( disque de boot )
Multiboot Fedora - Centos 7.0  -  Windows 10 Pro - Systemrescuecd
brave-browser-1.2.43-1.fc31.x86_64  -  thunderbird-68.4.1-1.fc31.x86_64

Hors ligne

#20 16/12/2016 01:19:15

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 936

Re : [Résolu] Montage HDD SATA n'est plus automatique

Elle était donnée dans le post #12


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#21 16/12/2016 10:14:39

Fifi
Membre
Lieu : Belgique
Inscription : 22/05/2006
Messages : 5 257

Re : [Résolu] Montage HDD SATA n'est plus automatique

nouvo09 a écrit :

Elle était donnée dans le post #12

La solution au problème, oui, mais ça je l'avais trouvée bien avant.
Ce que je voudrais comprendre c'est la cause du problème : pourquoi une partition NTFS consultée ( lecture-écriture ) sous Windows et quittée proprement se révèle non-montable par Fedora par le fstab ensuite si aucun chkdsk n'a été fait sous Windows avant de rebooter.


Fedora 31-x86_64 - KDE 5 - Plasma 5.17 - Gigabyte B450 Aorus Elite - AMD Ryzen 7 2700 - Nvidia GTX 1650 Super Windforce ( avec le driver proprio Nvidia ) - 16 Go RAM Corsair - 1 disque dur WD de 2 To en Sata3 et un SSD Crucial de 256 Go ( disque de boot )
Multiboot Fedora - Centos 7.0  -  Windows 10 Pro - Systemrescuecd
brave-browser-1.2.43-1.fc31.x86_64  -  thunderbird-68.4.1-1.fc31.x86_64

Hors ligne

#22 16/12/2016 11:40:47

joshw
Membre
Inscription : 22/08/2016
Messages : 315

Re : [Résolu] Montage HDD SATA n'est plus automatique

Pour éviter d'amener d'autres personnes dans l'erreur. Hier, après avoir modifier le fichier /etc/fstab
Fedora 25 ne voulait plus démarrer normalement, par frustration, j'ai recommencé l'installation à partir de zéro, cette fois, en laissant branché mon disque Win 10 branché.

Après l'installation, j'ai appliqué la commande mentionnée au #post15, ce qui a résolu le souci.
Je ne savais pas non plus au départ que Win10 passait en mode hibernation quand on lui demande d'éteindre le pc.

Aujourd'hui, donc après la dernière installation de F25, je n'ai plus modifié le fichier /etc/fstab
qui a pour configuration par défaut celle-ci :

[Joshw@localhost ~]$ cat /etc/fstab

#
# /etc/fstab
# Created by anaconda on Thu Dec 15 18:16:56 2016
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/fedora-root /                       ext4    defaults        1 1
UUID=259f419a-648f-4369-bfae-e47af8fe532e /boot                   ext4    defaults        1 2
/dev/mapper/fedora-home /home                   ext4    defaults        1 2
/dev/mapper/fedora-swap swap                    swap    defaults        0 0

Aussi, à l'avenir, je tâcherai de ne plus poster une discussion trop rapidement.
Ceci, étant dit, si je ne l'avais pas fait, ça m'aurait pris beaucoup plus de temps pour comprendre que je n'avais pas fermé Win10 complètement.

Dernière modification par joshw (16/12/2016 11:49:33)


Fedora Workstation 37 - processeur x86_64 - Mémoire : 7,7 Gio -  Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz -GNOME Version 43.2 - Débuter avec un terminal - MDN - w3schools

Hors ligne

#23 16/12/2016 14:45:40

Fifi
Membre
Lieu : Belgique
Inscription : 22/05/2006
Messages : 5 257

Re : [Résolu] Montage HDD SATA n'est plus automatique

joshw a écrit :

Je ne savais pas non plus au départ que Win10 passait en mode hibernation quand on lui demande d'éteindre le pc.

Tu peux le paramétrer autrement si tu veux ... smile

Je ne vois pas de partition NTFS dans ton fstab ... Elle n'est donc pas montée automatiquement au boot de Fedora.

Edit : pour ma question précédente, c'est avec cette partition que j'ai des problèmes : WD1000-4

[fifi@localhost ~]$ cat /etc/fstab

#
# /etc/fstab
# Created by anaconda on Fri Sep  4 13:31:06 2015
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=d325e864-f689-42ce-be5e-6e3fbf0952b6 /                       ext4    defaults,noatime        1 1
UUID=1f60902c-9eab-4e77-b0d1-b8a63a82288e /home                   ext4    defaults,noatime        1 2
UUID=321712b7-a0c4-4d8c-a093-39a192d74959 swap                    swap    defaults        0 0
UUID=5828F21D70381B3C   /WD1000-4   ntfs-3g     defaults    0 0

[fifi@localhost ~]$ 

Dernière modification par Fifi (16/12/2016 14:52:00)


Fedora 31-x86_64 - KDE 5 - Plasma 5.17 - Gigabyte B450 Aorus Elite - AMD Ryzen 7 2700 - Nvidia GTX 1650 Super Windforce ( avec le driver proprio Nvidia ) - 16 Go RAM Corsair - 1 disque dur WD de 2 To en Sata3 et un SSD Crucial de 256 Go ( disque de boot )
Multiboot Fedora - Centos 7.0  -  Windows 10 Pro - Systemrescuecd
brave-browser-1.2.43-1.fc31.x86_64  -  thunderbird-68.4.1-1.fc31.x86_64

Hors ligne

Pied de page des forums