Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora Linux 37 est disponible !

#1 15/11/2015 18:32:29

elbelo69
Membre
Lieu : Lyon
Inscription : 03/09/2007
Messages : 358

[Résolu] VLC et

Bonjour,
Depuis quelques temps, quand je regarde une vidéo avec VLC, j'ai un message d'erreur dans la console :

Failed to open VDPAU backend libvdpau_va_gl.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type

Mais la vidéo et le son était ok.
Comme j'avais un peu de temps, je me suis dis que j'allais régler le problème. J'ai donc installé le package libvdpau-va-gl, qui a tiré comme dépendances :

Installation de :
 libva-intel-driver                               x86_64                               1.5.1-1.fc22                                rpmfusion-free                               265 k
 libvdpau-va-gl                                   x86_64                               0.3.4-6.fc22                                rpmfusion-free                                66 k

Suite a cette installations et quelques mises à jour (je ne fais les update qu'une fois pas mois, uniquement après avoir dumper ma machine avec CloneZilla :o) ), un petit reboot.
Et me voila incapable de regarder une vidéo avec VLC :


vincent@vfx Vidéos]$ vlc Pixels.mkv 
VLC media player 2.2.2 Weatherwax (revision 2.2.1-161-g360f42e)
[0000000001d3f118] core libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.
[VS] Software VDPAU backend library initialized
libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_37
libva info: va_openDriver() returns 0
[00007f4c68c2f558] avcodec decoder: Using OpenGL/VAAPI/libswscale backend for VDPAU for hardware decoding.
[00007f4c34001268] vdpau_display vout display error: video mixer surface width capabilities query failure: VDP_STATUS_NO_IMPLEMENTATION
[VS] error (vdpVideoSurfaceGetBitsYCbCr): not implemented conversion VA FOURCC  -> VDP_YCBCR_FORMAT_YV12
[00007fa834e73ef8] vdpau_chroma filter error: video surface export failure: VDP_STATUS_INVALID_Y_CB_CR_FORMAT
[VS] error (vdpVideoSurfaceGetBitsYCbCr): not implemented conversion VA FOURCC  -> VDP_YCBCR_FORMAT_YV12
[00007fa834e73ef8] vdpau_chroma filter error: video surface export failure: VDP_STATUS_INVALID_Y_CB_CR_FORMAT
[VS] error (vdpVideoSurfaceGetBitsYCbCr): not implemented conversion VA FOURCC  -> VDP_YCBCR_FORMAT_YV12
[00007fa834e73ef8] vdpau_chroma filter error: video surface export failure: VDP_STATUS_INVALID_Y_CB_CR_FORMAT
[VS] error (vdpVideoSurfaceGetBitsYCbCr): not implemented conversion VA FOURCC  -> VDP_YCBCR_FORMAT_YV12
[00007fa834e73ef8] vdpau_chroma filter error: video surface export failure: VDP_STATUS_INVALID_Y_CB_CR_FORMAT
[h264 @ 0x7fa860dadba0] hardware accelerator failed to decode picture
[h264 @ 0x7fa860e44680] hardware accelerator failed to decode picture                                                                                                                 
[h264 @ 0x7fa860cd1c60] hardware accelerator failed to decode picture                                                                                                                 
[h264 @ 0x7fa860d170a0] hardware accelerator failed to decode picture                                                                                                                 
[h264 @ 0x7fa860dadba0] hardware accelerator failed to decode picture                                                                                                                 
[h264 @ 0x7fa860e44680] hardware accelerator failed to decode picture                                                                                                                 
[h264 @ 0x7fa860cd1c60] hardware accelerator failed to decode picture                                                                                                                 
[h264 @ 0x7fa860d170a0] hardware accelerator failed to decode picture       
....                                 

Comme j'utilise Bumblebee, j'essaye avec optirun :

[vincent@vfx Vidéos]$ optirun vlc Pixels.mkv 
VLC media player 2.2.2 Weatherwax (revision 2.2.1-161-g360f42e)
[0000000001526448] core libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.
[VS] Software VDPAU backend library initialized
libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_37
libva info: va_openDriver() returns 0
[00007f140cc0e1d8] avcodec decoder: Using OpenGL/VAAPI/libswscale backend for VDPAU for hardware decoding.
[h264 @ 0x7f140ccd6a80] hardware accelerator failed to decode picture
[h264 @ 0x7f140cd1bf00] hardware accelerator failed to decode picture                                                                                                                 
[h264 @ 0x7f140cdb2a20] hardware accelerator failed to decode picture                                                                                                                 
[h264 @ 0x7f140ce49540] hardware accelerator failed to decode picture                                                                                                                 
[h264 @ 0x7f140ccd6a80] hardware accelerator failed to decode picture                                                                                                                 
[h264 @ 0x7f140cd1bf00] hardware accelerator failed to decode picture                                                                                                                 
[00007f13c4001268] vdpau_display vout display error: video mixer surface width capabilities query failure: VDP_STATUS_NO_IMPLEMENTATION
....

J'utilise KDE et le kernel 4.2.6-200.fc22.x86_64.


Quelqu'un a ce problème ? Ma solution a été de désinstaller cette librairie mais du coup j'ai toujours un message d'erreur dans la console ...
Une idée, une explication ?

D'avance merci

Hors ligne

#2 17/11/2015 00:47:41

fsociety
Membre
Inscription : 01/11/2015
Messages : 35

Re : [Résolu] VLC et

Bonjour elbelo,

Quelle est ta carte graphique et ta version de  bumblebee ?

Hors ligne

Pied de page des forums