Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Rétrospective de l'adoption du nouveau logo de Fedora

#1 11/10/2015 23:05:05

hitec-user
Membre
Inscription : 18/03/2007
Messages : 260

OpenBVE ne se lance pas

Bonsoir les Fedoristes,

Je suis sur Fedora 22.

Après avoir découvert la présentation du simulateur de trains Open BVE, j'ai suivi les indications trouvées sur ce site pour l'essayer mais là... frustration, impossible de le lancer.

Quand je fais :

$cd "chemin d'accès au dossier contenant OpenBVE"
$mono ./OpenBve.exe

j'obtiens ceci :

...
#5  0x00007f7ebd97e8b9 in gdip_load_png_image_from_file_or_stream () from /lib64/libgdiplus.so.0
#6  0x00007f7ebd961cdd in GdipLoadImageFromFile () from /lib64/libgdiplus.so.0
#7  0x00000000402c662e in ?? ()
#8  0x00000000024d0750 in ?? ()
#9  0x00007f7eaeee9498 in ?? ()
#10 0x00007ffd4451b9b8 in ?? ()
#11 0x00000000405fc1f8 in ?? ()
#12 0x0000000000000017 in ?? ()
#13 0x00007ffd4451ba60 in ?? ()
#14 0x00007ffd4451b970 in ?? ()
#15 0x00007f7eaeee8af8 in ?? ()
#16 0x00007f7eaeee8af8 in ?? ()
#17 0x00007f7eaeee9498 in ?? ()
#18 0x00007f7eaeee9498 in ?? ()
#19 0x00000000402c656c in ?? ()
#20 0x00007f7eaeee8af8 in ?? ()
#21 0x00007f7eb3641000 in ?? ()
#22 0x0000000000000000 in ?? ()

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

Abandon (core dumped)

Quelqu'un a-t-il déjà réussi à le faire fonctionner?

Cordialement,


hitec-user <Promoteur du libre>
Avant de vénérer un dieu, vénérons et respectons notre Mère nourricière LA TERRE.
Visitez http://libreeco.free.fr

Hors ligne

#2 12/10/2015 19:13:19

shnoulle
FreePoste Addict
Lieu : Roubaix
Inscription : 07/07/2006
Messages : 1 377
Site Web

Re : OpenBVE ne se lance pas

Salut,

Sur ce site : https://sites.google.com/site/bvefrance … -installer

Pour exécuter OpenBVE sur une distribution Linux, vous devez télécharger l'archive Windows et la décompresser au sein de votre système de fichier. Les mêmes dépendances sont requises :

    TAO, décompressez le contenu de l'archive dans le dossier de OpenBVE
    SDL, procurez-vous le fichier le mieux adapté à votre système
    OpenAL, qu'il faudra compiler si vous ne trouvez pas de fichier exécutable
    Mono, qui vise à reproduire un environnement d'exécution Microsoft .NET

SDL et OpenAl doivent être installable via les dépots (?), Mono tu l'as déjà. Mais peut être TAO ?

Denis


En train de lire FAQ - DOC

Hors ligne

#3 13/10/2015 00:22:01

hitec-user
Membre
Inscription : 18/03/2007
Messages : 260

Re : OpenBVE ne se lance pas

Bonsoir Shnoulle,

Pour SDL et OpenAL, j'ai effectivement les dernières versions installées depuis les dépôts.
Pour TAO, effectivement voilà une étape à côté de laquelle je suis passé.
Je vais donc tester ça et je reviens dès que possible (retours tardifs du taf !).

Bonne nuit.


hitec-user <Promoteur du libre>
Avant de vénérer un dieu, vénérons et respectons notre Mère nourricière LA TERRE.
Visitez http://libreeco.free.fr

Hors ligne

#4 13/10/2015 10:19:34

CS
Membre
Lieu : B-L
Inscription : 09/09/2008
Messages : 233

Re : OpenBVE ne se lance pas

Il y a quelques années, j'avais fait tourner Open BVE sous Fedora. Il avait fallu aussi recompiler certains parties en modifiant au préalable une série de path dans le fichier de configuration. Je ne me rapelle plus tout ce que j'avais bricolé à l'époque, mais j'en avais bavé.


C.S.

Intel i7-cpu 920-2,67Ghz  MB: P6TDeluxeV2 Nvidia 9500GT, 8Gb DDR3, F24 x86_64  Mate-Compiz

Hors ligne

#5 13/10/2015 16:04:30

winmandrake
Rédacteur Wiki
Rédacteur Wiki
Inscription : 08/07/2008
Messages : 1 290

Re : OpenBVE ne se lance pas

Après une petite recherche :

openBVE

openBVE is a free train simulator: it only runs on Linux with the use of a Windows emulator such as Mono.

Installation instructions:

    Download openBVE from their website at trainsimframework.org and expand the openbve_stable.zip file into a local directory
    Download Tao from the same website (trainsimframework.org) and expand the tao.zip file into the same directory as above
    Install the SDL libraries from the Command Line using sudo yum install SDL* (Fedora/RHEL) or sudo apt-get install SDL* (Ubuntu/Mint/Puppy/Debian/etc)
    Install the openAL libraries from the Command Line using sudo yum install openal* (Fedora/RHEL) or sudo apt-get install openal* (Ubuntu/Mint/Puppy/Debian/etc)
    Install the mono libraries from the Command Line using sudo yum install mono-* (Fedora/RHEL) or sudo apt-get install mono-* (Ubuntu/Mint/Puppy/Debian/etc)
    Run the application from the Command Line using mono OpenBve.exe

Mais : "mono version 2.10.8-5. This is the version that came packaged with Fedora 20. Basically I just erased the newer mono packages from fedora 21 and installed the older Fedora 20 mono packages . So far it's the only way I have been able to get OpenBve to work on Fedora 21." => http://forums.bvestation.com/index.php?topic=2802.0


Mon pc : AMD R5-2400G sur Asus Prime B450M-A, 16 Go ram, Nvidia 1050Ti (4Go), SSD Samsung 850 EVO (250 Go) + black caviar de 1To.

Hors ligne

#6 19/10/2015 16:46:57

hitec-user
Membre
Inscription : 18/03/2007
Messages : 260

Re : OpenBVE ne se lance pas

Bonjour Winmandrake,

J'avais fait pas mal de recherches, mais mon anglais n'étant pas optimal, je suis apparemment passé à côté de cette information.

Je vais donc tester en remplaçant la version f22 de Mono par celle de f20.

Je ne suis pas chez moi pour le moment mais je mettrai un retour d'expérience dès que possible.

Merci pour ton aide.

Cordialement.


hitec-user <Promoteur du libre>
Avant de vénérer un dieu, vénérons et respectons notre Mère nourricière LA TERRE.
Visitez http://libreeco.free.fr

Hors ligne

Pied de page des forums