Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Rétrospective de l'adoption du nouveau logo de Fedora

#1 29/08/2015 17:31:24

fedoix
Membre
Inscription : 26/07/2010
Messages : 128
Site Web

Sortie de unity (gaming) sur debian : une prochaine version rpm ?

Bonjour,


Je constate que la plateforme de jeux unity est sortie en bêta pour la distribution debian unity.
Je n'ai pas réussi à convertir le fichier .deb deb en un .rpm avec l'utilitaire alien.
Quelqu'un a t il réussi à le faire ?
Un espoir que l'on puisse jouer à des blockbuster comme call of duty sur linux ?


Great ! We have snakes under crack !

Hors ligne

#2 29/08/2015 22:07:12

titijhajha
Membre
Lieu : Digne-les-Bains
Inscription : 23/06/2011
Messages : 992
Site Web

Re : Sortie de unity (gaming) sur debian : une prochaine version rpm ?

Je ne connaissais pas merci pour l'info.
Je ne vois rien pour les autres distributions en dehors d' Ubuntu

Un espoir que l'on puisse jouer à des blockbuster comme call of duty sur linux ?

C'est apparemment déjà possible via Playonlinux


« Si tu ne trouves pas la vérité à l'endroit où tu es, où espères-tu la trouver? » - Eihei Dōgen
Desktop :  Ubuntu 15.10 - Portable :  Fedora 23 - Portable Asus de madame: Linux Mint 17.2

Hors ligne

#3 15/09/2015 10:47:48

ottovonstein
Membre
Inscription : 10/03/2010
Messages : 121

Re : Sortie de unity (gaming) sur debian : une prochaine version rpm ?

Bonjour,
J'ai entendu cette chouette nouvelle! Bien sur l'outil est gratuit pas libre... Mais tellement répandu! J'en ai souvent besoin dans mes projets étudiants... Du coup faut rester à l'école pour pouvoir boucler les projets puisque ça ne marche pas à la maison... Sniff
Si jamais un portage sur fedora du .DEB était d'actualité je resterait fidèle, sinon je devrait peut être bientôt envisager un changement de distro... Ça ne me dit pourtant rien!

C'est un peu agaçant que Ubuntu soit toujours l'arbre qui cache la forêt pour les non linuxiens... Du coup on est souvent servit les derniers pour ce genre de portage. Enfin bon... Pour l'instant vive le BGE !

Bonne journée :)

Après un passage de deb à rpm grâce a Alien  voici ce que me dit poliment mon terminal

# rpm -ivh unity-editor-5.1.0f3-2.x86_64.rpm 
error: Failed dependencies:
	/usr/local/bin/python is needed by unity-editor-5.1.0f3-2.x86_64
	libCg.so is needed by unity-editor-5.1.0f3-2.x86_64
	libGeometryToolbox.so()(64bit) is needed by unity-editor-5.1.0f3-2.x86_64
	libTextureConverter.so()(64bit) is needed by unity-editor-5.1.0f3-2.x86_64
	libUnwrap.so()(64bit) is needed by unity-editor-5.1.0f3-2.x86_64
	libcapi-appfw-app-common.so.0 is needed by unity-editor-5.1.0f3-2.x86_64
	libcapi-appfw-app-control.so.0 is needed by unity-editor-5.1.0f3-2.x86_64
	libcapi-appfw-application.so.0 is needed by unity-editor-5.1.0f3-2.x86_64
	libcapi-location-manager.so.0 is needed by unity-editor-5.1.0f3-2.x86_64
	libcapi-media-audio-io.so.0 is needed by unity-editor-5.1.0f3-2.x86_64
	libcapi-media-camera.so.0 is needed by unity-editor-5.1.0f3-2.x86_64
	libcapi-media-metadata-extractor.so is needed by unity-editor-5.1.0f3-2.x86_64
	libcapi-media-player.so.0 is needed by unity-editor-5.1.0f3-2.x86_64
	libcapi-media-tool.so.0 is needed by unity-editor-5.1.0f3-2.x86_64
	libcapi-system-device.so.0 is needed by unity-editor-5.1.0f3-2.x86_64
	libcapi-system-info.so.0 is needed by unity-editor-5.1.0f3-2.x86_64
	libcapi-system-sensor.so.0 is needed by unity-editor-5.1.0f3-2.x86_64
	libcapi-system-system-settings.so.0 is needed by unity-editor-5.1.0f3-2.x86_64
	libcef.so()(64bit) is needed by unity-editor-5.1.0f3-2.x86_64
	libcrypto.so.1.0.0 is needed by unity-editor-5.1.0f3-2.x86_64
	libdl.so.2(GLIBC_2.4) is needed by unity-editor-5.1.0f3-2.x86_64
	libdlog.so.0 is needed by unity-editor-5.1.0f3-2.x86_64
	libecore.so.1 is needed by unity-editor-5.1.0f3-2.x86_64
	libecore_evas.so.1 is needed by unity-editor-5.1.0f3-2.x86_64
	libecore_imf.so.1 is needed by unity-editor-5.1.0f3-2.x86_64
	libefl-extension.so.0 is needed by unity-editor-5.1.0f3-2.x86_64
	libelementary.so.1 is needed by unity-editor-5.1.0f3-2.x86_64
	libevas.so.1 is needed by unity-editor-5.1.0f3-2.x86_64
	libfreeimage.so.3()(64bit) is needed by unity-editor-5.1.0f3-2.x86_64
	libgcc_s.so.1(GCC_3.5) is needed by unity-editor-5.1.0f3-2.x86_64
	libpq.so.5()(64bit) is needed by unity-editor-5.1.0f3-2.x86_64
	libstdc++.so.6(CXXABI_ARM_1.3.3) is needed by unity-editor-5.1.0f3-2.x86_64
	libumbraoptimizer64.so()(64bit) is needed by unity-editor-5.1.0f3-2.x86_64

voici ce que me donne après un petite session de copieCollage dnf search

dnf search libCg libGeometryToolbox libTextureConverter libUnwra libcapi-appfw-app-common libcapi-appfw-app-control libcapi-appfw-application libcapi-location-manager libcapi-media-audio-io libcapi-media-camera  libcapi-media-metadata-extractor libcapi-media-player libcapi-media-tool libcapi-system-device libcapi-system-info libcapi-system-sensor libcapi-system-system-settings libcef libcrypto libdl libdlog libecore libecore_evas libecore_imf libefl-extension libelementary libevas libfreeimage libgcc_s libpq libstdc++ libumbraoptimizer64
Last metadata expiration check performed 1:11:48 ago on Tue Sep 15 13:26:50 2015.
========================================================== N/S Matched: libstdc++ ==========================================================
libstdc++.x86_64 : GNU Standard C++ Library
libstdc++.i686 : GNU Standard C++ Library
============================================================ N/S Matched: libCg ============================================================
libCg.x86_64 : NVIDIA Cg Toolkit shared support library
libCg.i686 : NVIDIA Cg Toolkit shared support library
============================================================ N/S Matched: libpq ============================================================
libpqxx-devel.i686 : Development tools for libpqxx
libpqxx-devel.x86_64 : Development tools for libpqxx
libpqxx-doc.noarch : Developer documentation for libpqxx
============================================================ N/S Matched: libCg ============================================================
libcgroup-pam.x86_64 : A Pluggable Authentication Module for libcgroup
libcgi-devel.i686 : Header files and libraries for LibCGI development
libcgi-devel.x86_64 : Header files and libraries for LibCGI development
libcgroup-tools.x86_64 : Command-line utility programs, services and daemons for libcgroup
========================================================== N/S Matched: libstdc++ ==========================================================
libstdc++-docs.x86_64 : Documentation for the GNU standard C++ library
libstdc++-devel.x86_64 : Header files and libraries for C++ development
libstdc++-devel.i686 : Header files and libraries for C++ development
libstdc++-static.i686 : Static libraries for the GNU standard C++ library
libstdc++-static.x86_64 : Static libraries for the GNU standard C++ library
compat-libstdc++-33.x86_64 : Compatibility standard C++ libraries
compat-libstdc++-33.i686 : Compatibility standard C++ libraries
compat-libstdc++-296.i686 : Compatibility 2.96-RH standard C++ libraries
============================================================ N/S Matched: libpq ============================================================
libpqxx.i686 : C++ client API for PostgreSQL
libpqxx.x86_64 : C++ client API for PostgreSQL
============================================================ N/S Matched: libCg ============================================================
libcgi.i686 : CGI easy as C
libcgi.x86_64 : CGI easy as C
libcgroup.x86_64 : Library to control and monitor control groups
libcgroup.i686 : Library to control and monitor control groups
libcgroup-devel.i686 : Development libraries to develop applications that utilize control groups
libcgroup-devel.x86_64 : Development libraries to develop applications that utilize control groups
============================================================ N/S Matched: libpq ============================================================
nodejs-pg.x86_64 : PostgreSQL client for Node.js - pure JavaScript and libpq with the same API

Ai je la moindre chance que ça marche si j'installe toutes ces dépendances; ou bien y a t'il trop de différences entre les noms/versions/localisations de ces librairies entre Ubuntu et F22?

Bas quoi faut bien se lancer!

EDIT :
Je suis pas au bon endroit? Aucun commentaire? Tant pis; Unity attendra!

Re EDIT

http://www.omgubuntu.co.uk/2015/08/unity3d-linux-build

A noter l'instaleur agnostic proposé sur cette page.

Dernière modification par ottovonstein (07/10/2015 14:42:21)


Otto! Rocking for a free World!!!

Hors ligne

Pied de page des forums