Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 34 n'est plus maintenu

#101 02/07/2014 16:53:52

carmy42
Membre
Inscription : 18/01/2014
Messages : 23

Re : Fedora 20 sur l'Acer C720P

(à noter qu'après une hibernation, je rallume, le trackpad ne fonctionne pas, si je mets en veille et je le réveille le trackpad fonctionne à nouveau)

Hors ligne

#102 03/07/2014 18:22:37

Yannick@ekiga
Rédacteur Wiki
Rédacteur Wiki
Inscription : 18/12/2013
Messages : 251

Re : Fedora 20 sur l'Acer C720P

Yannick@ekiga a écrit :
iamchocho a écrit :

Yannick,
Thank you for the updated script, Its working for me on 3.14.8, unfortunatly I still have not been able to figure out what I broke on my system that is preventing sleep.  Still no tpm modules loading on my c720 even with this latest kernel & your patches.  I guess I may have to reinstall at some point to get it working.

Hi, There is indeed something broken with sleep in kernel 3.14.8: after a fresh boot, sleep is not working properly here (I have to reopen the lid to activate it), beside wifi do not wake up by itself, I have to disable/enable it to get it work after sleep. This was not the case with 3.14.7.

I do not have time at the moment to fill a report, nor investigate.

Thank you for pointing to this issue.

After updating to 3.14.9 + the script, everything seems fine again. Can you please confirm, iamchocho?

Hors ligne

#103 04/07/2014 19:36:36

iamchocho
Membre
Inscription : 02/05/2014
Messages : 12

Re : Fedora 20 sur l'Acer C720P

Yannick@ekiga a écrit :
Yannick@ekiga a écrit :
iamchocho a écrit :

Yannick,
Thank you for the updated script, Its working for me on 3.14.8, unfortunatly I still have not been able to figure out what I broke on my system that is preventing sleep.  Still no tpm modules loading on my c720 even with this latest kernel & your patches.  I guess I may have to reinstall at some point to get it working.

Hi, There is indeed something broken with sleep in kernel 3.14.8: after a fresh boot, sleep is not working properly here (I have to reopen the lid to activate it), beside wifi do not wake up by itself, I have to disable/enable it to get it work after sleep. This was not the case with 3.14.7.

I do not have time at the moment to fill a report, nor investigate.

Thank you for pointing to this issue.

After updating to 3.14.9 + the script, everything seems fine again. Can you please confirm, iamchocho?

Yes I am updating now to confirm.  I suspect I may still have problems as I think I screwed something up on my system at some point.  I will update once I have patches applied.

Update:  It is still not working for me, as I suspected I think I have some other problem.  'lsmod | grep tpm' still returns no results on my system.  I have had this problem for some time even on kernel versions that you had working fine.

Dernière modification par iamchocho (04/07/2014 20:14:33)

Hors ligne

#104 04/07/2014 23:10:51

Yannick@ekiga
Rédacteur Wiki
Rédacteur Wiki
Inscription : 18/12/2013
Messages : 251

Re : Fedora 20 sur l'Acer C720P

iamchocho a écrit :
Yannick@ekiga a écrit :
Yannick@ekiga a écrit :

Hi, There is indeed something broken with sleep in kernel 3.14.8: after a fresh boot, sleep is not working properly here (I have to reopen the lid to activate it), beside wifi do not wake up by itself, I have to disable/enable it to get it work after sleep. This was not the case with 3.14.7.

I do not have time at the moment to fill a report, nor investigate.

Thank you for pointing to this issue.

After updating to 3.14.9 + the script, everything seems fine again. Can you please confirm, iamchocho?

Yes I am updating now to confirm.  I suspect I may still have problems as I think I screwed something up on my system at some point.  I will update once I have patches applied.

Update:  It is still not working for me, as I suspected I think I have some other problem.  'lsmod | grep tpm' still returns no results on my system.  I have had this problem for some time even on kernel versions that you had working fine.

Be sure to have all this in place:

Create the file /etc/tmpfiles.d/cros-acpi-wakeup.conf

# /etc/tmpfiles.d/cros-acpi-wakeup.conf
w /proc/acpi/wakeup - - - - EHCI
w /proc/acpi/wakeup - - - - HDEF
w /proc/acpi/wakeup - - - - XHCI
w /proc/acpi/wakeup - - - - LID0
w /proc/acpi/wakeup - - - - TPAD
w /proc/acpi/wakeup - - - - TSCR

Create the file /usr/lib/systemd/system-sleep/cros-sound-suspend.sh

#!/bin/bash

case $1/$2 in
  pre/*)
    # Kill flash plugin as it prevent suspend
    pgrep -f flashplayer | xargs kill >/dev/null 2>&1
    # Unbind ehci for preventing error 
    echo -n "0000:00:1d.0" | tee /sys/bus/pci/drivers/ehci-pci/unbind
    # Unbind snd_hda_intel for sound
    echo -n "0000:00:1b.0" | tee /sys/bus/pci/drivers/snd_hda_intel/unbind
    echo -n "0000:00:03.0" | tee /sys/bus/pci/drivers/snd_hda_intel/unbind
    ;;
  post/*)
    # Bind ehci for preventing error 
    echo -n "0000:00:1d.0" | tee /sys/bus/pci/drivers/ehci-pci/bind
    # bind snd_hda_intel for sound
    echo -n "0000:00:1b.0" | tee /sys/bus/pci/drivers/snd_hda_intel/bind
    echo -n "0000:00:03.0" | tee /sys/bus/pci/drivers/snd_hda_intel/bind
    ;;
esac

Make it exec:

# chmod +x /usr/lib/systemd/system-sleep/cros-sound-suspend.sh

Edit  grub's configuration file /etc/default/grub :
Add this line at the end:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash tpm_tis.force=1 tpm_tis.interrupts=0"

Update grub :

# grub2-mkconfig -o /boot/grub2/grub.cfg

Reboot.

Dernière modification par Yannick@ekiga (04/07/2014 23:11:42)

Hors ligne

#105 05/07/2014 17:28:40

iamchocho
Membre
Inscription : 02/05/2014
Messages : 12

Re : Fedora 20 sur l'Acer C720P

Yannick@ekiga a écrit :
iamchocho a écrit :
Yannick@ekiga a écrit :

After updating to 3.14.9 + the script, everything seems fine again. Can you please confirm, iamchocho?

Yes I am updating now to confirm.  I suspect I may still have problems as I think I screwed something up on my system at some point.  I will update once I have patches applied.

Update:  It is still not working for me, as I suspected I think I have some other problem.  'lsmod | grep tpm' still returns no results on my system.  I have had this problem for some time even on kernel versions that you had working fine.

Be sure to have all this in place:

Create the file /etc/tmpfiles.d/cros-acpi-wakeup.conf

# /etc/tmpfiles.d/cros-acpi-wakeup.conf
w /proc/acpi/wakeup - - - - EHCI
w /proc/acpi/wakeup - - - - HDEF
w /proc/acpi/wakeup - - - - XHCI
w /proc/acpi/wakeup - - - - LID0
w /proc/acpi/wakeup - - - - TPAD
w /proc/acpi/wakeup - - - - TSCR

Create the file /usr/lib/systemd/system-sleep/cros-sound-suspend.sh

#!/bin/bash

case $1/$2 in
  pre/*)
    # Kill flash plugin as it prevent suspend
    pgrep -f flashplayer | xargs kill >/dev/null 2>&1
    # Unbind ehci for preventing error 
    echo -n "0000:00:1d.0" | tee /sys/bus/pci/drivers/ehci-pci/unbind
    # Unbind snd_hda_intel for sound
    echo -n "0000:00:1b.0" | tee /sys/bus/pci/drivers/snd_hda_intel/unbind
    echo -n "0000:00:03.0" | tee /sys/bus/pci/drivers/snd_hda_intel/unbind
    ;;
  post/*)
    # Bind ehci for preventing error 
    echo -n "0000:00:1d.0" | tee /sys/bus/pci/drivers/ehci-pci/bind
    # bind snd_hda_intel for sound
    echo -n "0000:00:1b.0" | tee /sys/bus/pci/drivers/snd_hda_intel/bind
    echo -n "0000:00:03.0" | tee /sys/bus/pci/drivers/snd_hda_intel/bind
    ;;
esac

Make it exec:

# chmod +x /usr/lib/systemd/system-sleep/cros-sound-suspend.sh

Edit  grub's configuration file /etc/default/grub :
Add this line at the end:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash tpm_tis.force=1 tpm_tis.interrupts=0"

Update grub :

# grub2-mkconfig -o /boot/grub2/grub.cfg

Reboot.

I confirmed these are all in place and updated grub again, still the same behavior.  When my system wakes it starts from seabios just like when powering on for the first time.

Hors ligne

#106 12/07/2014 01:02:00

Yannick@ekiga
Rédacteur Wiki
Rédacteur Wiki
Inscription : 18/12/2013
Messages : 251

Re : Fedora 20 sur l'Acer C720P

[FR] Nouvelle version du script pour le noyau 3.15.4 :
[EN] New script version for kernel 3.15.4:
https://bugzilla.redhat.com/attachment.cgi?id=917452

Hors ligne

#107 16/07/2014 04:18:01

iamchocho
Membre
Inscription : 02/05/2014
Messages : 12

Re : Fedora 20 sur l'Acer C720P

Just got my new SSD upgrade to 128GB so I reinstalled fresh and am still having issues getting my system to wake from suspend.  I verified again that my GRUB_CMDLINE_LINUX_DEFAULT is set correctly and exactly as above.  I found that if I boot the kernel with debug then it does wake from sleep but the touchpad does not work with this kernel.  With the normal kernel I still see no results from running 'lsmod | grep tpm' however in the debug kernel there are 3 items.  Very strange & frustrating behavior, I wonder what I could be missing or doing wrong.

I am running the KDE spin of Fedora 20 and not gnome but I would not think that would make a difference for this.

Hors ligne

#108 16/07/2014 10:15:15

Yannick@ekiga
Rédacteur Wiki
Rédacteur Wiki
Inscription : 18/12/2013
Messages : 251

Re : Fedora 20 sur l'Acer C720P

iamchocho a écrit :

Just got my new SSD upgrade to 128GB so I reinstalled fresh and am still having issues getting my system to wake from suspend.  I verified again that my GRUB_CMDLINE_LINUX_DEFAULT is set correctly and exactly as above.  I found that if I boot the kernel with debug then it does wake from sleep but the touchpad does not work with this kernel.  With the normal kernel I still see no results from running 'lsmod | grep tpm' however in the debug kernel there are 3 items.  Very strange & frustrating behavior, I wonder what I could be missing or doing wrong.

I am running the KDE spin of Fedora 20 and not gnome but I would not think that would make a difference for this.

Weird... Let's try some checks:
Fisrt, this is what I have here on a working setup:

$ lsmod | grep tpm
tpm_tis                18484  0 
tpm_infineon           17131  0 
tpm                    35153  2 tpm_tis,tpm_infineon

Modules are from:

$ find /lib/modules/`uname -r`/ -name 'tpm*'
/lib/modules/3.15.4-200.fc20.x86_64/extra/drivers/char/tpm
/lib/modules/3.15.4-200.fc20.x86_64/extra/drivers/char/tpm/tpm_tis.ko
/lib/modules/3.15.4-200.fc20.x86_64/extra/drivers/char/tpm/tpm_infineon.ko
/lib/modules/3.15.4-200.fc20.x86_64/extra/drivers/char/tpm/tpm_atmel.ko
/lib/modules/3.15.4-200.fc20.x86_64/extra/drivers/char/tpm/tpm_nsc.ko
/lib/modules/3.15.4-200.fc20.x86_64/kernel/drivers/char/hw_random/tpm-rng.ko
/lib/modules/3.15.4-200.fc20.x86_64/kernel/drivers/char/tpm
/lib/modules/3.15.4-200.fc20.x86_64/kernel/drivers/char/tpm/tpm.ko

Do you have the 3 modules the kernel here loads? (tmp.ko, tpm_tis.ko and tpm_infineon.ko)

If so, try to load manually:

$ su -c 'modprobe -a tpm'

and check what have been loaded:

$ lsmod | grep tpm

Dernière modification par Yannick@ekiga (16/07/2014 10:17:40)

Hors ligne

#109 16/07/2014 19:40:58

iamchocho
Membre
Inscription : 02/05/2014
Messages : 12

Re : Fedora 20 sur l'Acer C720P

Yes, it is very weird.  Last night I got frustrated and so I reinstalled again this time with regular Fedora 20 w/ Gnome rather than the kde spin and now the tpm modules are loading ok and sleep is working.  It is a but unstable after waking sometimes but I suspect that is because I have not fully implimented the sound + sleep items yet.  After I got it working I did a groupinstall of kde and it seems ok.  Very strange as I would not have expected the default window manager packaged in the distro to impact this.

This is now what I see for lsmod:

lsmod | grep tpm
tpm_tis                18484  0 
tpm_infineon           17131  0 
tpm                    35153  2 tpm_tis,tpm_infineon

When it was not working with the KDE spin this same lsmod would return no tpm modules at all.  WIth KDE spin I would get two kernel options in grub after each kernel update, one with just the kernel name, the other had +debug at the end.  After updating grub it would re-order the +debug version to the top of the boot list instead of second, and in that debug version I would get the above list of tpm modules loaded however in the normal kernel I would get none.  I did try to manually load them with modprobe tpm but I dont believe I had tried -a. 
Also I do know that /lib/modules/3.15.4-200.fc20.x86_64/kernel/drivers/char/tpm/tpm.ko was present as I did check to make sure it was there and permissions where correct but I did not go look for the others under extra/drivers/char/tpm  I may re-load the KDE spin again and try some more investigation.

Thanks for all your help & work on the script to get everything else working.

Dernière modification par iamchocho (16/07/2014 22:03:11)

Hors ligne

#110 17/07/2014 00:09:39

iamchocho
Membre
Inscription : 02/05/2014
Messages : 12

Re : Fedora 20 sur l'Acer C720P

I just reinstalled the KDE spin, updated and patched and same behavior with tpm modules missing so it is something specific to the KDE spin.  After upading, then applying your patch & other changes listed here I still have no result from lsmod for tpm, I was able to force it with modprobe but only for tpm, not the other two modules that go with it:

$ lsmod |grep tpm
$ su -c 'modprobe -a tpm'
$ lsmod | grep tpm
tpm                    35153  0 
$ 

Looks like I am missing the modules themselves:

$ find /lib/modules/`uname -r`/ -name 'tpm*'
/lib/modules/3.15.4-200.fc20.x86_64/kernel/drivers/char/hw_random/tpm-rng.ko
/lib/modules/3.15.4-200.fc20.x86_64/kernel/drivers/char/tpm
/lib/modules/3.15.4-200.fc20.x86_64/kernel/drivers/char/tpm/tpm.ko

Hors ligne

#111 17/07/2014 00:34:09

Yannick@ekiga
Rédacteur Wiki
Rédacteur Wiki
Inscription : 18/12/2013
Messages : 251

Re : Fedora 20 sur l'Acer C720P

It seems the KDE spin lacks the "extra" folder. As I understand how this should work, we pass a command via grub to force the load of the tmp_tis module, which probably will depend on tpm itself. As you do not have tpm_tis in the KDE spin kernel, this fail. Thus no suspend using this spin.

It seems the KDE spin do not install the package kernel-modules-extra by default.

I do have it in the Gnome spin :

$ yum list installed | grep kernel-modules-extra
kernel-modules-extra.x86_64    3.14.8-200.fc20      @updates                    
kernel-modules-extra.x86_64    3.14.9-200.fc20      @updates                    
kernel-modules-extra.x86_64    3.15.4-200.fc20      @updates

                   

And this package provides what we need:

$ repoquery --list kernel-modules-extra | grep tpm
/lib/modules/3.15.4-200.fc20.x86_64/extra/drivers/char/tpm
/lib/modules/3.15.4-200.fc20.x86_64/extra/drivers/char/tpm/tpm_atmel.ko
/lib/modules/3.15.4-200.fc20.x86_64/extra/drivers/char/tpm/tpm_infineon.ko
/lib/modules/3.15.4-200.fc20.x86_64/extra/drivers/char/tpm/tpm_nsc.ko
/lib/modules/3.15.4-200.fc20.x86_64/extra/drivers/char/tpm/tpm_tis.ko

Try install it:

$ su -c 'yum install kernel-modules-extra'

Hopefully, this will fix your issue.

Dernière modification par Yannick@ekiga (17/07/2014 00:46:10)

Hors ligne

#112 17/07/2014 00:51:47

iamchocho
Membre
Inscription : 02/05/2014
Messages : 12

Re : Fedora 20 sur l'Acer C720P

If I boot the +debug kernel the tpm modules do load and sleep works:

$ lsmod | grep tpm
tpm_tis                18484  0 
tpm_infineon           17131  0 
tpm                    35379  2 tpm_tis,tpm_infineon

In this kernel my extra folder is also there:

$  find /lib/modules/`uname -r`/ -name 'tpm*'
/lib/modules/3.15.4-200.fc20.x86_64+debug/kernel/drivers/char/hw_random/tpm-rng.ko
/lib/modules/3.15.4-200.fc20.x86_64+debug/kernel/drivers/char/tpm
/lib/modules/3.15.4-200.fc20.x86_64+debug/kernel/drivers/char/tpm/tpm.ko
/lib/modules/3.15.4-200.fc20.x86_64+debug/extra/drivers/char/tpm
/lib/modules/3.15.4-200.fc20.x86_64+debug/extra/drivers/char/tpm/tpm_tis.ko
/lib/modules/3.15.4-200.fc20.x86_64+debug/extra/drivers/char/tpm/tpm_infineon.ko
/lib/modules/3.15.4-200.fc20.x86_64+debug/extra/drivers/char/tpm/tpm_atmel.ko
/lib/modules/3.15.4-200.fc20.x86_64+debug/extra/drivers/char/tpm/tpm_nsc.ko

I guess I will start working on getting a bug logged.

EDIT: Fixed my issue.  The KDE spin does not install the package kernel-modules-extra but does install kernel-debug-modules-extra by default.  I installed kernel-modules-extra, ran depmod -a tpm, and rebooted and how I see all 3 tpm modules loaded and suspend and resume works.  Thanks Yannick for your help,  Now I need to find out if that is expected, I wouldnt think so.

Dernière modification par iamchocho (17/07/2014 05:35:13)

Hors ligne

#113 17/07/2014 09:41:19

Yannick@ekiga
Rédacteur Wiki
Rédacteur Wiki
Inscription : 18/12/2013
Messages : 251

Re : Fedora 20 sur l'Acer C720P

[FR] Nouvelle version du script (13) : règle le soucis de veille pour la version KDE de fedora 20 (voire d'autres versions...)
[EN] New script version (13): fix suspend for the KDE spin (and maybe other spins)
https://bugzilla.redhat.com/attachment.cgi?id=918624

Hors ligne

#114 22/07/2014 23:42:05

gmillz
Membre
Inscription : 22/07/2014
Messages : 1

Re : Fedora 20 sur l'Acer C720P

So suspend was working fine for a while. Then I decided to apply the media keys fixes in this thread. well I reverted that and it broke suspend. I verified I still have all the suspend scripts in place. The problem is it never suspends. And when I try to suspend a second time I get an error saying suspend is already in progress.

Kernel Version: 3.15.6-200.fc20.x86_64

Hors ligne

#115 23/07/2014 12:41:11

Yannick@ekiga
Rédacteur Wiki
Rédacteur Wiki
Inscription : 18/12/2013
Messages : 251

Re : Fedora 20 sur l'Acer C720P

@gmillz,

I don't understand how "the media keys fixes" could broke suspend. This fix is just a bunch of tools to tell the X server some keys should behave differently. Without some errors log, I have no clue what's wrong.

Maybe try something like that to find an error:

$ journalctl --dmesg | grep PM:

Hors ligne

#116 11/08/2014 13:58:21

Yannick@ekiga
Rédacteur Wiki
Rédacteur Wiki
Inscription : 18/12/2013
Messages : 251

Re : Fedora 20 sur l'Acer C720P

Bonne nouvelle : le code pour le pavé tactile et l'écran tactile sont intégrés au noyau !
cf. https://git.kernel.org/cgit/linux/kerne … fa06360c28

On aura ça dans linux 3.17.

Hors ligne

#117 17/08/2014 12:49:40

L3M
Membre
Inscription : 17/08/2014
Messages : 8

Re : Fedora 20 sur l'Acer C720P

Bonjour,
Quelqu'un à réussi à patcher les derniers kernels ( 3.15.8 à 3.15.10 ) pour faire fonctionner le touchpad et le touchscreen ?

Hors ligne

#118 17/08/2014 22:27:08

zeig
Membre
Inscription : 17/08/2014
Messages : 9

Re : Fedora 20 sur l'Acer C720P

L3M a écrit :

Bonjour,
Quelqu'un à réussi à patcher les derniers kernels ( 3.15.8 à 3.15.10 ) pour faire fonctionner le touchpad et le touchscreen ?

Oui, dans le script de Yannick, il faut remplacer l'URL "https://raw.githubusercontent.com/masmu … idrv.patch" (qui n'est plus valide, car pour la version 3.16 du kernel cela ne passera pas par un patch), par celle-ci:

https://raw.githubusercontent.com/masmu … idrv.patch


J'en profite pour demander si quelqu'un a une config XKBComp opérationnelle ?
La mienne (pour PageUp,PageDown,Home,End avec Alt Gr + Arrows) pour le moment:

.xkb/myxkb:
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(azerty)" };
        xkb_types     { include "complete+mytypes(super_level2)"        };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+fr(oss)+us:2+inet(evdev)+mysymbols(super_arrows_home_end)"  };
        xkb_geometry  { include "pc(pc104)"     };
};

.xkb/symbols/mysymbols:
xkb_symbols "super_arrows_home_end" {
    key <LEFT>  {
        type[Group1] = "SUPER_LEVEL2",
        symbols[Group1] = [    Left,   Home      ]
    };
    key <RGHT>  {
        type[Group1] = "SUPER_LEVEL2",
        symbols[Group1] = [    Right,  End       ]
    };
    key <UP>  {
        type[Group1] = "SUPER_LEVEL2",
        symbols[Group1] = [    Up,  Prior       ]
    };
    key <DOWN>  {
        type[Group1] = "SUPER_LEVEL2",
        symbols[Group1] = [    Down,  Next       ]
    };
    key <BKSP>  {
        type[Group1] = "SUPER_LEVEL2",
        symbols[Group1] = [    BackSpace,  Delete       ]
    };

};

.xkb/types/mytypes:
partial
xkb_types "super_level2" {
    Virtual_modifiers Super;
    type "SUPER_LEVEL2" {
        modifiers= Mod5;
        map[Mod5]= Level2;
        level_name[Level1]= "Base";
        level_name[Level2]= "Super";
    };
};

Lancement: xkbcomp -I$HOME/.xkb ~/.xkb/mykbd $DISPLAY >/dev/null 2>&1

Firefox n'honore pas le Home & End...

Hors ligne

#119 18/08/2014 09:18:09

L3M
Membre
Inscription : 17/08/2014
Messages : 8

Re : Fedora 20 sur l'Acer C720P

zeig a écrit :
L3M a écrit :

Bonjour,
Quelqu'un à réussi à patcher les derniers kernels ( 3.15.8 à 3.15.10 ) pour faire fonctionner le touchpad et le touchscreen ?

Oui, dans le script de Yannick, il faut remplacer l'URL "https://raw.githubusercontent.com/masmu … idrv.patch" (qui n'est plus valide, car pour la version 3.16 du kernel cela ne passera pas par un patch), par celle-ci:

https://raw.githubusercontent.com/masmu … idrv.patch

Merci ça marche impecc :)

Hors ligne

#120 19/08/2014 23:06:03

zeig
Membre
Inscription : 17/08/2014
Messages : 9

Re : Fedora 20 sur l'Acer C720P

Pour ceux qui voudraient vraiment éteindre le laptop (plus aucun clignotement de la led power) après un hibernate (via systemd), il faut rajouter dans /etc/systemd/sleep.conf:

[Sleep]
HibernateState=disk
HibernateMode=shutdown

Hors ligne

#121 20/08/2014 00:26:55

Yannick@ekiga
Rédacteur Wiki
Rédacteur Wiki
Inscription : 18/12/2013
Messages : 251

Re : Fedora 20 sur l'Acer C720P

L3M a écrit :
zeig a écrit :
L3M a écrit :

Bonjour,
Quelqu'un à réussi à patcher les derniers kernels ( 3.15.8 à 3.15.10 ) pour faire fonctionner le touchpad et le touchscreen ?

Oui, dans le script de Yannick, il faut remplacer l'URL "https://raw.githubusercontent.com/masmu … idrv.patch" (qui n'est plus valide, car pour la version 3.16 du kernel cela ne passera pas par un patch), par celle-ci:

https://raw.githubusercontent.com/masmu … idrv.patch

Merci ça marche impecc :)

Merci !
J'ai mis à jour le script :
https://bugzilla.redhat.com/attachment.cgi?id=928540

Hors ligne

#122 21/08/2014 00:37:04

gregjo
Membre
Inscription : 21/08/2014
Messages : 3

Re : Fedora 20 sur l'Acer C720P

Hi, Yannick,

Thanks for all the work you've put into helping Fedora work better on Chromebooks.

I'm having a problem with Version 14 of your script file.

I am running a C720. I'm using the 3.15.10 kernel.

The error is on line 65:

./touchpad-touchscreen-V14.sh: line 65: cd: /root/rpmbuild/BUILD/kernel-3.15.fc20/linux-3.15.10-200.fc20.i686+PAE: No such file or directory

I believe the error may be related to you using the 64-bit version of Fedora, while I'm using the 32-bit version.

The directory isn't named correctly to match the script:

# pwd
/root/rpmbuild/BUILD/kernel-3.15.fc20
# ls
linux-3.15.10-200.fc20.i686   vanilla-3.15

I see that the script uses "uname -r" for the archkernver. For my machine, "uname -r" produces:

# uname -r
3.15.10-200.fc20.i686+PAE

I can't see where I should modify the script to make it work with 32-bit Fedora. Can you help me? Thanks.

Hors ligne

#123 21/08/2014 07:20:59

ck32
Membre
Inscription : 20/08/2014
Messages : 19

Re : Fedora 20 sur l'Acer C720P

Bonjour Yannick et aux autres contributeurs.

Je viens de suivre le tuto et ai réussi à installer Fedora 20 sur mon Acer C720P. Le tuto est très bien fait et permet à un noob sur linux et Fedora de réussir cette installation. Merci beaucoup pour le travail, les mises à jour et tous les contributeurs. J'ai suivi le dernier tuto et tout à bien fonctionné le touchpad fonctionne bien, l'ecran tactile aussi. La mise en veille fonctionne bien en fermant l'ecran et en appuyant sur le bouton en haut à droite. Le retour de veille également.

Lors de l'installation j'ai eu des doutes à trois reprises :
- Le scriptv14 du premier post me retournait une erreur sur l'obtention de certaines sources. J'ai utilisé celui a jour du post #121
- Lors du partitionnement du disque, quelle quantité de disque dur affecter à Fedora ? J'ai choisi 13Go sur les 29 disponible en libre dans mon PC.
- Le scripte v14 s'est arrêté lors de mes deux premières tentative me rapportant des erreurs à la ligne 76... concernant wget. Il a fallu l'installer manuellement en ligne de commande (Merci google). Le reste n'a pas posé de problème jusqu'à présent.

J'ai toutefois une question sur la partie du tuto qui permet la reconfiguration des touches multimédia, que je n'ai pas encore faite. Après le téléchargement et l'installation des quatre logiciels xbindkeys, xbacklight, xdotool et xvkbd, il faut créer le fichier config mais où le placer et comment le nommer ? C'est peut-être évident pour des utilisateurs avertis de linux mais pour des débutants, on se demande où le mettre et comment l'appeler.

Voilà mon retour sur cette installation faite hier soir.
Merci encore

Hors ligne

#124 26/08/2014 11:15:09

zeig
Membre
Inscription : 17/08/2014
Messages : 9

Re : Fedora 20 sur l'Acer C720P

Pour ceux qui auraient des corruptions d'image après un hibernate / resume:
The latest version of Intel drivers:
https://01.org/linuxgraphics/downloads

Avec l'acceleration SNA cela marche aussi:
Option      "AccelMethod"     "sna"

+ désactivation du support hardware (VA-API) pour les vidéos avec Firefox:

yum remove libva-intel-driver

Dernière modification par zeig (27/08/2014 15:23:41)

Hors ligne

#125 10/09/2014 18:18:33

gregjo
Membre
Inscription : 21/08/2014
Messages : 3

Re : Fedora 20 sur l'Acer C720P

I solved my problem with using the V14 script to get the touchpad working when using the 32-bit version of Fedora 20. By default, the PAE kernel was installed. This caused problems with the script. With a 2GB machine, the PAE kernel didn't make much sense for me. So I edited /etc/sysconfig/kernel and set DEFAULTKERNEL=kernel, rather than kernel-PAE. Then 'yum install kernel'. Reboot, and I was now using the non-PAE kernel. After that, the touchpad script worked fine.

Hors ligne

Pied de page des forums