Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Assemblée Générale Ordinaire de Borsalinux-fr le 22 février à Paris

#1 17/06/2009 00:37:11

inouire
Membre
Inscription : 01/06/2009
Messages : 125

écran inversé...

Bonjour, mon problème est le suivant: j'ai par malheur cliqué sur "Inverser" dans le menu de l'applet d'affichage (sous gnome)

Résultat à chaque ouverture de session maintenant mon écran est totalement inversé (le bas en haut, la gauche à droite). De plus seule la session s'ouvre, la petite musique se déclenche, et boum, voilà je vois juste mon fond d'écran avec ma souris à l'envers. Pas de Barre de menu, rien quoi.
Donc pas moyen de "recliquer" sur l'applet d'affichage...:-(

Il me reste les tty...ou l'édition du xorg.conf peut être ?  Mais je sais vraiment pas quoi faire...

Si quelqu'un peut m'aider, là mon fedora est juuste totalement inutilisable...je suis sous windows:idea:

Dernière modification par inouire (17/06/2009 19:22:28)

Hors ligne

#2 17/06/2009 12:50:49

aadelmar
Membre
Lieu : Pessac
Inscription : 08/09/2008
Messages : 254
Site Web

Re : écran inversé...

Si tu veux le faire en cliquant :
met ton écran à l'enver le temps de réctifier
ou par /etc/xorg.conf:
Option "RandRRotation" "on"
ou alors dans ton home tu dois avoir le fichier qui a été modifier.
Si dés le début l'écran est inversé c'est gdm

Hors ligne

#3 17/06/2009 14:43:04

inouire
Membre
Inscription : 01/06/2009
Messages : 125

Re : écran inversé...

bon en fait pour me sortir de ce pétrin, j'ai dû créer un nouvel utilisateur...qui lui avait un gnome "normal" par défaut....

De là jai pû tester la commande

xrandr --orientation normal

et d'ailleurs ou peut orienter dans le sens qu'on veut (right left reverse)
et donc ça doit être compiz qui fait que le "reverse" empeche tout affichage correct du bureau !

La solution: (pour ceux que ça interesserait)
Il faut donc:
-ouvrir une session gnome avec l'utilisateur qui a réglé "à l'envers"
-malgré le fait qu'on ne voit rien, ouvrir un terminal (alt+T normalement). rien ne s'affiche.
-taper, à l'aveugle (!!!)

xrandr --orientation normal

- et pouf ça rentre dans l'ordre.... c'est marrant le coup de taper à l'aveugle quand même...

pour que par défaut le bureau soit bien droit, utiliser l'applet d'affichage et appliquer le réglage normal, ou bien rajouter la commande précédente au .bash_profile qui est dans votre répertoire utilisateur

RESOLU  smile

EDIT: les fichiers de config de l'affichage sur les écrans sont situés dans dans le home: .config/monitors.xml
On peut utiliser la commande

find ~ -mmin 1

pour retrouver les fichiers qui ont été modifiés dans la minute précedente

Dernière modification par inouire (17/06/2009 19:16:46)

Hors ligne

#4 10/03/2017 14:08:24

taj
Taj
Lieu : Rabat
Inscription : 24/09/2010
Messages : 197

Re : écran inversé...

Merci !!

Hors ligne

Pied de page des forums