Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 30 est mort ce soir

#1 11/03/2007 01:29:52

OuiOuiZnotDead
Membre
Inscription : 11/03/2007
Messages : 6

Problème Configuration ipw2200

Bonjour,
Je suis un nouveau de linux et donc de fedora.
Voila mon problème:
Je souhaite activer ma carte wifi ipw2200, j'ai donc suivit le tuto proposé sur le site et installé tous se qu'il faut (enfin je crois).
Cependant je n'arrive toujours pas a activer ma carte.
Voici quelques rapport après l'execution de commande:

Impossible d'activer le périphérique réseau eth1
Définition des informations IP pour eth1. échoué. Aucun lien n'a été trouvé. Vérifier le câble ?

[root@localhost ~]# lsmod | grep ipw
ipw2200               112037  0 
ieee80211              34953  1 ipw2200

[root@localhost ~]# dmesg | grep ipw
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.1.2kmprq
ipw2200: Copyright(c) 2003-2006 Intel Corporation
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: Detected geography ZZR (14 802.11bg channels, 0 802.11a channels)

[root@localhost ~]# dmesg | grep ieee
ieee80211_crypt: registered algorithm 'NULL'
ieee80211: 802.11 data/management/control stack, git-1.1.13
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
ieee1394: Initialized config rom entry `ip1394'
ieee1394: Host added: ID:BUS[0-00:1023]  GUID[00030d4971e19116]
eth1: NETDEV_TX_BUSY returned; driver should report queue full via ieee_device->is_queue_full.

Donc si il y a quelqu'un qui pouvait m'aider, si ça se trouve il y a juste quelque chose a activer merci!

Dernière modification par OuiOuiZnotDead (11/03/2007 01:43:08)

Hors ligne

#2 11/03/2007 01:46:43

slashdada
Membre
Inscription : 20/06/2006
Messages : 228

Re : Problème Configuration ipw2200

yum install wifi-radar

L'outil magique pour la configuration du wifi sous gnome (en tout cas pour moi) big_smile

Hors ligne

#3 11/03/2007 10:02:38

herrib
Retraité
Lieu : Rennes
Inscription : 04/12/2004
Messages : 3 736

Re : Problème Configuration ipw2200

Bonjour,

Précise sans doute en préalable ta configuration car la mise en oeuvre du chipset ipw2200bg pour certaines configurations présente des caractéristiques ... remarquables.

Le message "Définition des informations IP pour eth1. échoué. Aucun lien n'a été trouvé. Vérifier le câble ?" semble laisser penser que le périphérique n'est pas pleinement initialisé.

Le firmware est-il correctement installé?

Au-delà, est-ce qu'il existe un switch logiciel / matériel concernant le Wifi?


Solaris 11, Scientific Linux 6.1. FC15 en virtualisation.

Hors ligne

#4 11/03/2007 12:08:35

OuiOuiZnotDead
Membre
Inscription : 11/03/2007
Messages : 6

Re : Problème Configuration ipw2200

Merci pour les réponses rapide,

Le firmware est-il correctement installé?: je ne sais pas , comment peut on vérifier?

Configuration:

os:Fedora 2.6.18-1.2798.fc6
Portable fujitsu Siemens amilo M3438
multiboot grub:XP-FEDORA 6
Centrino 1.86 GHz
1024 ram (2*512)
Nvidia FX GO 6800 (256 ram)
intel wireles 2200BG
DD:2*80Go en SATA (pas de raid particulier)

Il y a un switch matériel, a l'avant du portable. Je ne sais pas si il y a aussi un switch logiciel.
Avec windows la carte se connecte sans problème, je ne pense donc pas que sa vienne d'un switch.

Hors ligne

#5 11/03/2007 12:23:21

slobberbone
Ancien Ambassadeur Fedora
Rédacteur Wiki
Lieu : Caen
Inscription : 20/02/2006
Messages : 1 265
Site Web

Re : Problème Configuration ipw2200

que te donne iwconfig et ifconfig?

as-tu une interface du genre tmp_245463573 ????

Hors ligne

#6 11/03/2007 12:46:31

herrib
Retraité
Lieu : Rennes
Inscription : 04/12/2004
Messages : 3 736

Re : Problème Configuration ipw2200

Le préalable consiste à vérifier l'installation du firmware:

# ls -l /lib/firmware/
total 1204
-rw-r--r-- 1 root root  12007 aoû 11  2005 ipw2200-2.4-LICENSE
-rw-r--r-- 1 root root  12007 mar  7  2006 ipw2200-3.0-LICENSE
-rw-r--r-- 1 root root 191142 mar  7  2006 ipw2200-bss.fw
-rw-r--r-- 1 root root 185660 mar  7  2006 ipw2200-ibss.fw
-rw-r--r-- 1 root root 187836 mar  7  2006 ipw2200-sniffer.fw
-rw-r--r-- 1 root root   6472 aoû 11  2005 ipw-2.4-boot.fw
-rw-r--r-- 1 root root 168344 aoû 11  2005 ipw-2.4-bss.fw
-rw-r--r-- 1 root root  16334 aoû 11  2005 ipw-2.4-bss_ucode.fw
-rw-r--r-- 1 root root 162884 aoû 11  2005 ipw-2.4-ibss.fw
-rw-r--r-- 1 root root  16312 aoû 11  2005 ipw-2.4-ibss_ucode.fw
-rw-r--r-- 1 root root 168344 aoû 11  2005 ipw-2.4-sniffer.fw
-rw-r--r-- 1 root root  16344 aoû 11  2005 ipw-2.4-sniffer_ucode.fw

Solaris 11, Scientific Linux 6.1. FC15 en virtualisation.

Hors ligne

#7 11/03/2007 14:32:51

OuiOuiZnotDead
Membre
Inscription : 11/03/2007
Messages : 6

Re : Problème Configuration ipw2200

Voila pour la vérification de l'installation des firmware:

[root@localhost ~]# ls -l /lib/firmware
total 2184
-rw-r--r-- 1 root root   11880 sep 29  2004 ipw2200-2.2-LICENSE
-rw-r--r-- 1 root root   12007 aoû 11  2005 ipw2200-2.4-LICENSE
-rw-r--r-- 1 1000 users 191142 mar  7  2006 ipw2200-bss.fw
-rwxr-xr-x 1 root root  270419 mar 10 22:35 ipw2200-fw-2.4.tgz
drwxr-xr-x 2 1000 users   4096 mar 10 23:30 ipw2200-fw-3.0
-rwxr-xr-x 1 root root  269999 mar 10 22:35 ipw2200-fw-3.0.tgz
-rw-r--r-- 1 1000 users 185660 mar  7  2006 ipw2200-ibss.fw
-rw-r--r-- 1 1000 users 187836 mar  7  2006 ipw2200-sniffer.fw
-rw-r--r-- 1 root root    6472 déc 20  2004 ipw-2.2-boot.fw
-rw-r--r-- 1 root root  166960 déc 20  2004 ipw-2.2-bss.fw
-rw-r--r-- 1 root root   16334 déc 20  2004 ipw-2.2-bss_ucode.fw
-rw-r--r-- 1 root root  161568 déc 20  2004 ipw-2.2-ibss.fw
-rw-r--r-- 1 root root   16312 déc 20  2004 ipw-2.2-ibss_ucode.fw
-rw-r--r-- 1 1000 users   6472 aoû 11  2005 ipw-2.4-boot.fw
-rw-r--r-- 1 1000 users 168344 aoû 11  2005 ipw-2.4-bss.fw
-rw-r--r-- 1 1000 users  16334 aoû 11  2005 ipw-2.4-bss_ucode.fw
-rw-r--r-- 1 1000 users 162884 aoû 11  2005 ipw-2.4-ibss.fw
-rw-r--r-- 1 1000 users  16312 aoû 11  2005 ipw-2.4-ibss_ucode.fw
-rw-r--r-- 1 1000 users 168344 aoû 11  2005 ipw-2.4-sniffer.fw
-rw-r--r-- 1 1000 users  16344 aoû 11  2005 ipw-2.4-sniffer_ucode.fw
-rwxrwxr-x 1 1000  1000  12007 aoû 11  2005 LICENSE
-rw-r--r-- 1 1000 users  12007 mar  7  2006 LICENSE.ipw2200-fw

Et pour les commandes iwconfig et ifconfig:

[root@localhost ~]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      unassociated  ESSID:off/any  
          Mode:Managed  Channel=0  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sit0      no wireless extensions.

[root@localhost ~]# ifconfig
lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3325 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3325 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          RX bytes:5617404 (5.3 MiB)  TX bytes:5617404 (5.3 MiB)

Je ne sais pas se qu'est une interface du genre tmp_245463573.
Désolé si les choses que je demande paraisse basique.

Dernière modification par OuiOuiZnotDead (11/03/2007 14:36:10)

Hors ligne

#8 11/03/2007 14:41:02

herrib
Retraité
Lieu : Rennes
Inscription : 04/12/2004
Messages : 3 736

Re : Problème Configuration ipw2200

Bon, utilise system-config-network pour déclarer la connexion Wireless car manifestement, les paramètres ne sont pas actifs:

administration -> réseau -> nouveau -> wireless.


Solaris 11, Scientific Linux 6.1. FC15 en virtualisation.

Hors ligne

#9 11/03/2007 17:43:42

OuiOuiZnotDead
Membre
Inscription : 11/03/2007
Messages : 6

Re : Problème Configuration ipw2200

Cet fois-ci je vous ai fait quelques photo d'écran:

Avec system-config-network:
Onglet périfériques et matériel
070311042418383024.png070311043031383041.png

J'ai aussi essayé de suivre un tuto de ce site:

$ su -
# iwconfig wlan0 mode managed 
# iwconfig wlan0 essid Votre_reseau_essid 
# iwconfig wlan0 channel Votre_canal
# iwconfig wlan0 key Votre_clef_wep/wpa 
# ifconfig wlan0 up 
# iwlist wlan0 scan 
# iwconfig wlan0 ap Adresse_MAC_de_l'AP

su -
service NetworkManager start
service NetworkManagerDispatcher start

J'obtient alors un icone en haut à droite, mais il n'arrete pas de me demander ma clef alors que je lui donne.
070311043429383054.png

identification de l'AP (club internet box)
clé wep 128 bit:B474D510C6A83D5DD4A7355F04
SSID:TECOM-AH4021-94F50F
Address Mac: 00:03:C9:8A:A6:6F

[root@localhost ~]# iwconfig
lo        no wireless extensions.
__tmp1804289383  IEEE 802.11g  ESSID:"TECOM-AH4021-94F50F"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:03:C9:8A:A6:6F   
          Bit Rate:54 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:79D0-0144-276D-A92C-9677-7D72-12   Security mode:open
          Power Management:off
          Link Quality=84/100  Signal level=-45 dBm  Noise level=-88 dBm
          Rx invalid nwid:0  Rx invalid crypt:2  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

sit0      no wireless extensions.

[root@localhost ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:03:0D:30:C5:93  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interruption:217 Adresse de base:0xac00 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2564 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2564 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          RX bytes:5509400 (5.2 MiB)  TX bytes:5509400 (5.2 MiB)

Dans le résultat de la commande iwconfig on remarque que se n'est pas la clé que j'ai rentré.

Hors ligne

#10 11/03/2007 17:48:56

remi
Crazy PHP packages monkey... !
Rédacteur Wiki
Lieu : Champagne...
Inscription : 16/10/2004
Messages : 5 578
Site Web

Re : Problème Configuration ipw2200

Une clé WEP 128 ne devrait pas être saisie avec le 0x au début ? (enfin c'est comme cela dans system-config-network, networkmanager je connais pas)

Mes 0,02 cts (parce que le Wifi, c'est vraiment pas ma spécialité).

A+

Hors ligne

#11 11/03/2007 19:22:01

herrib
Retraité
Lieu : Rennes
Inscription : 04/12/2004
Messages : 3 736

Re : Problème Configuration ipw2200

remi a écrit :

Une clé WEP 128 ne devrait pas être saisie avec le 0x au début ? (enfin c'est comme cela dans system-config-network, networkmanager je connais pas)A+

Dans NetworkManager, la saisie se réalise sans 0x. On choisit WEP 64/128bits (hex) et on saisit les valeurs hexa.

OuiOuiZnotDead, manifestement, ta connexion Wifi est bien créée mais pour autant, l'association n'est pas réalisée. Dans NetworkManager, tu vas désigner une authentification en clé partagée et lancer la connexion. La clé aurait été déclarée en WEP 64/128bits (hex)

Tu as transmis en clair le nom du réseau et la clé secrète partagée ... Etait-ce nécessaire? tes voisons vont pouvoir se connecter smile


Solaris 11, Scientific Linux 6.1. FC15 en virtualisation.

Hors ligne

#12 11/03/2007 22:06:57

liho
Membre
Inscription : 10/12/2005
Messages : 2 022

Re : Problème Configuration ipw2200

Bonjour,
Je remarque, dans les copies d'écran que tu as postées, que dans l'onglet périphérique, le périphérique est appelé eth1:0 .
J'ai la même carte et, au même endroit, mon périphérique est nommé eth1 (tout court). Je crois me souvenir que j'avais des périphériques nommés eth1:X quand j'utilisais plusieurs profils wifi avec system-config-network. Je ne sais pas si tu utilises plusieurs profils, mais si tu n'arrives pas à activer ta connexion, il y-a peut être quelque chose à regarder de ce côté là.


ASUS N751JX-T7015H   -   Fedora 29 x86_64   -   Gnome

Hors ligne

#13 11/03/2007 22:14:15

slobberbone
Ancien Ambassadeur Fedora
Rédacteur Wiki
Lieu : Caen
Inscription : 20/02/2006
Messages : 1 265
Site Web

Re : Problème Configuration ipw2200

Pour le périphérique, c bon t'occupes pas du tmp_635532 ... c un probleme que moi j'ai rencontré ... c pour ca!

D'apres tes captures, dans NetworkManager ... tu rentres apparement un clé Hexadecimale ... hors tu indiques que c'est un phrase secrete que tu rentres !! précises que c bien une clé hexadecimale !!

Hors ligne

#14 12/03/2007 11:13:46

nannouD
Membre
Inscription : 12/03/2007
Messages : 15

Re : Problème Configuration ipw2200

j'ai un probleme avec mon interface ETH0, je ne sais pas comment configurer cette interface j'attends des réponses:roll:

Hors ligne

#15 12/03/2007 11:45:06

n1ck0
Débutant en programmation
Lieu : Belgique - Gosselies
Inscription : 05/09/2006
Messages : 1 391

Re : Problème Configuration ipw2200

nannouD a écrit :

j'ai un probleme avec mon interface ETH0, je ne sais pas comment configurer cette interface j'attends des réponses:roll:

système =>administration=>reseau


À vendre radeon 9800 se en AGP, fonctionne avec pilote libre.

Hors ligne

#16 12/03/2007 13:34:39

nannouD
Membre
Inscription : 12/03/2007
Messages : 15

Re : Problème Configuration ipw2200

concernant l'adaptateur comment choisir?
il ne figure pas quand je tape lspci en root

Hors ligne

#17 14/03/2007 11:31:05

OuiOuiZnotDead
Membre
Inscription : 11/03/2007
Messages : 6

Re : Problème Configuration ipw2200

Merci de toutes vos réponses, la semaine je n'ai pas accès à internet facilement alors je vous tiendrai au courant le week-end prochain.

PS:Je suis surpris de la grande réactivité du forum. C cool

Hors ligne

#18 17/03/2007 00:02:58

OuiOuiZnotDead
Membre
Inscription : 11/03/2007
Messages : 6

Re : Problème Configuration ipw2200

Encore merci à tous pour les nombreuses réponses. Je viens de réussir à conecter mon réseau wifi.
Les drivers étaient corectement instalés.
J'ai utilisé: system-config-network 1.3.95 (installé par défault).
Le problème venait bien de la clé wep que j'avais renter sans '0x' (pour l'hexadécimal). Et du périphérique eth1:0.

Hors ligne

Pied de page des forums