Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora Linux 36 est disponible !

#1 Re : Le comptoir du libre » Conky - Partage de scripts » 21/01/2017 02:09:52

Hello les "ConkyFan"

Vous trouverez mes scripts bash et conky pour la meteo OpenWeatherMap ici :
https://github.com/D4void/OWM

1484687581.png

#2 Re : Le comptoir du libre » Conky - Partage de scripts » 18/01/2017 23:38:44

hello

Pas de soucis, je vais partager tout çà sur Github.
Le script conky à lui seul ne suffit pas, il y a 2 scripts bash et un dossier thème icones.

Je suis en train de finaliser.
Vous serez mes beta-testeurs. Cela marche bien chez moi mais à voir ailleurs !

@chepioq: en effet, j'ai trouvé ce forum avec google en Décembre. Cela m'a inspiré.
Pour le barographe, j'ai vu çà sur DeviantArt et j'ai trouvé l'idée géniale. Alors j'ai testé :)
Par contre, je voulais me baser sur une API et pas devoir me galérer à découper des pages web.
Et comme il n'y a pas d'API free avec accuweather , j'ai pris OpenWeatherMap.
Après je ne sais pas trop ce que valent leurs prévisions mais bon.

#3 Re : Le comptoir du libre » Conky - Partage de scripts » 17/01/2017 23:16:46

Salut tout le monde,

Voici une capture de mon conky meteo tout fraichement développé avec un script que j'ai créé pour récupérer les infos avec l'API OpenWeatherMap.
Il y a quelques années , j'utilisais le fameux script ConkyForecast mais qui ne fonctionne plus depuis longtemps.
J'ai eu envie de remettre un conky météo sur mon bureau alors je me suis retroussé les manches ;)
Pour le fun, j'ai ajouté une possibilité d'enregistrer régulièrement la pression courante et la température pour créer un barographe :)
(pc tournant H24)

1484687581.png

#4 Re : Le comptoir du libre » Votre bureau » 04/01/2017 22:46:37

merci pour ton retour.
oui conky met aussi les images en transparent , ce qui est pas logique. C'est un bug. Il y a un post sur github.
Et ca m'ennuie fortement pour mes icones météo car cela fait tout pourri avec le fond d'écran.

Cela fonctionne bien sur XFCE en utilisant uniquement l'option transparent yes (qui est du fake transparency)
Mais pas de bol, cette option seule marche pas sur gnome 3 visiblement...

#5 Re : Le comptoir du libre » Votre bureau » 02/01/2017 00:19:21

salut
nice !
Peux-tu me dire qu'est ce que tu as mis comme paramètre conky pour la transparence ?
Je vois que l'image de la pochette spotify n'est pas transparente.
En mode argb_visual, j'ai un problème avec les images, elles sont transparentes également!
Et le mode transparent ne fonctionne pas sur mon gnome.

Je suis en train de finaliser un script et un conky météo perso.

#6 Re : [Anciennes versions] Matériel » Driver Nvidia et Fedora » 09/09/2016 14:17:11

Salut,

En général, quand tu as le "oops", c'est que le système n'a pas réussi à lancer le driver nvidia demandé.

La doc du wiki ici est très bien : http://doc.fedora-fr.org/wiki/Carte_gra … es_pilotes
Il faut prendre le bon driver.

Perso, j'ai créé dans mon dossier root un petit script logx11.sh avec
cat /var/log/Xorg.0.log | grep EE && cat /var/log/Xorg.0.log | grep WW

#!/bin/bash

cat /var/log/Xorg.0.log | grep EE && cat /var/log/Xorg.0.log | grep WW

Comme çà , tu vois tout de suite l'erreur (et tu verras sans doute load driver "nvidia" fail)

J'utilise playonlinux pour hearthstone, diablo 3 notamment et cela fonctionne bien.
J'utilisais le pilote nouveau jusqu'à il y a encore peu mais pour diablo c'est même pas la peine.

J'ai une GTX560 Ti et j'ai utilisé le pilote 340. Il supporte la GTX670: cf pour infos http://www.nvidia.fr/object/unix-fr.html
Il semble d'ailleurs que les derniers supportent aussi nos cartes.
Il faudrait que je test du coup avec le akmod-nividia tout court.

#7 [Anciennes versions] Support général » Bug crontab avec SELinux » 26/01/2016 11:10:56

DaWeed
Réponses : 0

Bonjour

Pour infos , j'ai constaté que mes crontab ne fonctionnait plus.
Après recherche il y a visiblement un bug avec SELinux qui bloque les crontab.

Dans les logs on voit un truc du genre:
crond[1406]: (root) Unauthorized SELinux context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 file_context=unconfined_u:object_r:user_cron_spool_t:s0 (/var/spool/cron/root)

Moyen de contournement:

Créer fichier: mycron.cil
(allow unconfined_t user_cron_spool_t( file ( entrypoint)))

lancer:
semodule -i mycron.cil

Relancer crond:
systemctl restart crond.service

Quand ce sera corrigé, suppression du workaround:

semodule -r mycron
systemctl restart crond.service


https://bugzilla.redhat.com/show_bug.cgi?id=1263328

#8 Re : [Anciennes versions] Installation de Fedora » f19 à f21 ? » 14/12/2014 22:40:27

c'est bon, tout à parfaitement fonctionné. Juste quelques paquets fc19 à désinstaller.
Nickel !

Fidèle à fedora depuis FC1 et encore pour longtemps :)

#9 [Anciennes versions] Installation de Fedora » f19 à f21 ? » 12/12/2014 00:06:47

DaWeed
Réponses : 3

c'est possible directement ?

(Et oui mon fixe est resté sur fc19)

#10 [Anciennes versions] Réseaux » network.service : plus d'interface graphique ? » 12/03/2013 13:22:24

DaWeed
Réponses : 0

Bonjour,

Je préfère utiliser network.service plutôt que NetworkManager.service sur mon serveur. Mes connexions ne changent jamais, donc pas besoin de l'autre.
Je viens d'up sur FC18 mais par contre, je ne retrouve pas l'interface graphique que l'on avait avant?
system-config-network me lance un menu mais en mode console.
J'ai cherché  system-config-network-gui  mais j'ai pas trouvé.
Si qqun a une idée. merci

#11 Re : [Anciennes versions] Support général » Help pour Affichage et Gestion couleur ! » 06/03/2012 21:40:29

Je n'ai toujours pas trouvé la réponse à ce soucis. Je pense aussi que ce n'est pas normal et j'avais aussi un écran avant. Par contre, moi je n'ai rien du tout...

Pour charger mon profil, j'ai une commande dans gnome-session-properties qui lance dispcalGUI-apply-profiles au démarrage.

J'étais parti dans des recherches sur xrandr et le fichier monitors.xml mais je n'ai pas abouti...

#12 Re : [Anciennes versions] Matériel » changement de carte mère vers Sandybridge: bug PCI / IRQ disabling » 05/03/2012 22:13:27

je me remplis mon petit post smile mais ca peut servir à d'autre.
Je confirme que c'est bien cette puce que j'ai:

lspci -v
(...)
06:00.0 PCI bridge: ASMedia Technology Inc. Device 1080 (rev 01) 

Irqpoll semble bien aider. Suis sur FC depuis 1h, pas de bug pour le moment!

#13 Re : [Anciennes versions] Matériel » [Résolu] parcage des tetes HDD intempestifs besoin d'aide SVP. » 05/03/2012 13:34:45

bonjour
j'ai un disque qui fait souvent un clic aussi. C'est un hitachi également. (en fait j'en ai 3 mais je crois que c'est le plus vieux des 3 qui fait çà)
Est-ce que le parcage fait un bruit particulier ?
Je pense que ca doit etre çà.
Y a-t-il une commande pour vérifier le disque en cause ? Je ne connais pas hdparm. Il peut me l'indiquer ?

#14 Re : [Anciennes versions] Matériel » changement de carte mère vers Sandybridge: bug PCI / IRQ disabling » 05/03/2012 13:12:35

+ ce post : http://www.gossamer-threads.com/lists/l … el/1466185
Dernier message jeroen.vandenkeybus at gmail, Dec 11, 2011, 7:28 AM

Visiblement, si je vire ma carte PCI (que j'utilise pour le wifi), le soucis devrait etre très limité.
Quel misère, mon host wifi :s
Le point 2 explique effectivement la suite de mes symptomes !
J'espère qu'il y aura une solution dans les porchains kernel.
J'y comprends rien dans ces traces/debug. Je ne sais pas où on peut suivre si c'est pris en compte.

1. The IRQ bug manifests itself when using any device behind the
ASM1083 bridge. That includes the 2 PCI slots on the motherboard, as
well as the Firewire interface. Avoid their use. Preferably use the
PCIe x1 slot.

2. An important problem is that, when IRQ 16..19 goes down, an
integrated device, which otherwise works flawlessly, goes along with
it. This includes the SATA, USB and both audio (HDMI / Analog)
subsystems. If possible, enable the use of MSI for these devices.
Clemens's patch for AHCI MSI is a real help here.

3. Step 1 above will practically eliminate the occurrence of the IRQ
bug. If the PCI bus really is needed, the patch below must be used
(with the kernel irqpoll command line option turned on, of course).

#15 [Anciennes versions] Matériel » changement de carte mère vers Sandybridge: bug PCI / IRQ disabling » 05/03/2012 12:16:54

DaWeed
Réponses : 2

bonjour,

Suite à un crash PC (diag carte mère/CPU en cours mais je pense que c'est la CM), j'ai refait une config avec une ASUS P8P67 Evo + Core i5 2500K.
Evidemment j'ai du réinstaller ma partition windows (youpi! et avec 150 reboot à la clé avec les updates etc) et j'étais tout fier de voir ma Fedora 16 redémarrer tranquille en ayant quasi rien à faire (sauf la reconfiguration des cartes réseaux)

Mais pas de bol, je crois que je suis tombé sur un os qui semble lié aux cartes mères Asus sad
Je me suis rendu compte de ce problème hier.

J'ai des messages comme celui là qui tombent :
irq 16: nobody cared (try booting with the "irqpoll" option)
et qui finissent en :
Disabling IRQ #16

Après çà, le PC rame (affichage saccadé, souris saccadé etc)
Je viens de faire des recherches et à priori, cela semble lié à une puce buguée :(
(ASM108x PCI bridge)
Je vais vérifier çà ce soir.
J'ai déjà mis un irqpoll hier soir, j'ai vérifié vite fait ce matin et le bug ne semble pas s'être produit. Mais apparemment cela ne fait que ralentir l'apparition.

Vu ici :
https://bugzilla.redhat.com/show_bug.cgi?id=755956

Liste des bugs ouvert sur "irq 16: nobody cared"
https://bugzilla.redhat.com/buglist.cgi … body+cared

Message sur Phoronix.com : Sandy Bridge PCI Card Drivers Fail with "Disabling IRQ"
http://phoronix.com/forums/showthread.p … g-IRQ-quot

Y a-t-il d'autres Fedoriens dans la même situation que moi ? Si oui, faites vous connaitre, je me sentirai moins seul smile

#16 Re : [Anciennes versions] Support général » Help pour Affichage et Gestion couleur ! » 12/12/2011 16:20:09

justement, c'est là que je vais , mais il identifie pas mon écran pour appliquer le profil...

#17 [Anciennes versions] Support général » Help pour Affichage et Gestion couleur ! » 10/12/2011 17:27:49

DaWeed
Réponses : 8

Bonjour,

J'ai un soucis, je n'ai aucun écran détecté dans le menu Couleur des paramètres système.
Cela m'indique "aucun périphérique acceptant la gestion de couleur n'a été détecté"

Pourtant, ds les précédentes versions de gnome, c'était ok. (J'ai une sonde et utilise dispcalgui pr cela)
Quand je vais dans paramètres système, rubrique matériel, icone Affichage, mon écran est identifié comme inconnu.
Si je fais, détecter les écrans , rien ne se passe.

Si quelqu'un a une idée  ? Je trouve pas de piste pour éditer çà :( Je sèche.

J'ai tenté de recréer monitors.xml dans /etc/gnome-settings-daemon/xrandr/ mais cela n'a rien changé.

Merci

#18 Re : [Anciennes versions] Installation de Fedora » [Résolu] moi aussi j'ai le "oh mince......." » 10/12/2011 17:22:16

oui il est bien installé mais je n'ai jms eu de fenetre apparaissant lors du pb...
A priori, c'est ok maintenant. J'ai reinstallé akmod-nividia, selinux et redémarrer après un autre touch "/.autorelabel"

#19 Re : [Anciennes versions] Installation de Fedora » [Résolu] moi aussi j'ai le "oh mince......." » 10/12/2011 11:10:59

bonjour,
Je déterre ce topic car j'ai tjs le "oh mince .." sur mon user principal
Pourtant j'ai eu les mises à jour de kernel et selinux depuis le temps.
Je viens de tenter un "touch ./autorelabel" , j'ai tenté le "yum reinstall gnome-shell", en vain.
Quand je désactive les gnome-shell-extensions c'est pareil.
Ce qui est sûr c'est qu'en faisant "setenforce 0" avant de me logguer, j'ai pas de "oh mince..." Donc c'est bien SELinux.
Je sais plus trop quoi faire. Je vais tenter de réinstaller SELinux pour voir....

#20 Re : [Anciennes versions] Réseaux » un malin s'amuse à essayer de se connecter en SSH sur mon serveur » 07/12/2011 23:25:43

lmaurin a écrit :

iptables peut aussi servir à limiter les accès : netfilter recent patch

J'ai mis cela en place de mon côté. J'ai fait des règles Iptables anti brute-force. Si intéresse, je peux filer çà.
Dès qu'il y a trop de paquets SYN qui arrivent sur mon port 22, l'adresse IP source est black-listé pdt quelques minutes et iptables drop les rafales de connexion.
En général les tentatives de brute force s'arrêtent assez vite. (j'ai un script qui surveille mes logs et extrait les IP sources de ceux qui ont tenté du brute force ^_^)

Après  j'utilise également une autentification par clé et sur un seul user. Pas de mot de passe.
En général, le brute force échoue donc dès cette étape !

Je n'ai pas encore testé fail2ban. Faudrait que je regarde çà à l'occaz ;)
Changer le numéro de port standard c'est aussi une option de tranquilité mais faut être sûr que les endroits depuis lesquels on se connecte ne soient pas filtré (le port 22 peut être autorisé, mais pas pour d'autres...)

#21 Re : [Anciennes versions] Support général » Orde de démarrage services avec Systemd / iptables boot avant network! » 27/11/2011 23:04:45

bonjour,

Mes soucis se sont réglés avec FC16. Maintenant les services sont lancés dans l'ordre adéquat.
@Philippe, Je n'ai pas constaté de soucis pour le chargement des règles, non.
J'utilise un script maison pour configurer mon firewall et à la fin j'ai toujours fait : #iptables-save > /etc/sysconfig/iptables
Je vais tout de même vérifier et si soucis, je viendrais en faire part...

#22 Re : [Anciennes versions] Support général » Extension 30 vers 3.2 » 18/11/2011 23:59:45

bonsoir,
merci pour l'aide, le retour arrière a bien fonctionné (entre-temps des maj sont sorties officiellement ds la semaine sans doute car j'ai eu moins de paquets rétrogradés)

Et effectivement, j'aurais du utiliser --enablerepo, mais comme j'utilise jamais le testing, j'ai pas eu le réflexe ;)
On ne m'y reprendra pas à 2 fois.

#23 Re : [Anciennes versions] Support général » Editer le menu de Grub2 » 14/11/2011 22:00:23

merci pr l'exemple.
Par contre "grub2-editenv", ca n'existe pas apparemment...

#24 Re : [Anciennes versions] Support général » mon bureau s'affiche en mode restreint sous nxserver ? » 14/11/2011 21:50:44

salut,
je crois que c'est parce qu'il n'y a pas d'accélération 3D supporté sur freenx, donc Gnome3 démarre en mode restreint...

#25 Re : [Anciennes versions] Support général » Extension 30 vers 3.2 » 14/11/2011 00:00:17

help!
cette am j'ai pu installer le dock.
Par contre, comme un boulet j'ai laissé le repo testing enabled et ce soir , j'ai fait une maj machinalement :(
Du coup, j'ai installé toutes les maj du testing...
J'ai essayé de faire un yum history undo xxx mais j'ai une erreur sur gnome-settings:
"Échec lors du lors du retour à la version précédente : gnome-settings-daemon-3.2.1-4.fc16.x86_64"

Apparemment, il ne sait pas où retrouver la précédente version:

" Mis à jour    gnome-settings-daemon-3.2.1-4.fc16.x86_64             ?
    Mise à jour                         3.2.2-1.fc16.x86_64             @updates-testing"

Y a-t-il un moyen de corriger çà manuellement ?
J'ai quand même eu plus de 200 mises à jour et c'est le seul pb apparemment.
J'ai pas envie de mettre du testing. Déjà le service iptables ne se lance plus au démarrage maintenant :(

merci pour votre aide.

Pied de page des forums

Propulsé par FluxBB