Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Représenter Fedora au Capitole du Libre 2019

#1 Re : [F29] Support général » [Résolu] Maté Menu applications etc.. » 25/04/2019 12:10:46

salut
quand on découvre une nouvelle distribution, le bon choix semble être le bureau choisi par défaut de la distribution; c'est la meilleure garantie d'être dans le main stream;
sur fedora, c'est le bureau gnome, qui est très plaisant;
et sur ubuntu, c'est pareil, le bureau gnome; et sur debian, aussi;
en fait, le bureau gnome, s'il est choisi comme bureau par défaut par beaucoup de distribution parmi les plus populaires, c'est bien qu'il doit y avoir une raison;
moi, sur une mageia, je me suis amusé à installer plusieurs bureaux;
spontanément, je démarre sur gnome qui est mon préféré;
en second, il y a cinnamon, qui est une bonne évolution de gnome;
(quand j'ai essayé cinnamon pour la première fois, c'était après avoir bricolé les bureaux gnome de fedora et mageia avec les extensions et le tweaktool; j'ai eu la curieuse impression que avec cinnamon, je n'avais rien à faire, les extensions que j'avais ajouter sur gnome était déjà là; en fait spontanément sans le savoir, j'avais modifier gnome pour qu'il ressemble à un cinnamon; donc, le cinnamon, je pourrais le définir ainsi : c'est un gnome dans lequel les extensions les plus populaires sont déjà intégrées; cool!)
sans oublier plasma, qui reste un très bon bureau, à condition de savoir s'en servir, ce qui est plus compliqué que les deux précédents;
mate et xfce sont tristounets, en tout cas sur mageia, j'ai pas essayé ailleurs;
bonne journée

#2 Re : [F29] Installation de Fedora 29 » [Résolu] Fixer le nombre de noyaux » 25/04/2019 11:30:34

bonjour
je suis curieux de l'issue de cette discussion ;
pour info, la limite à 3 noyaux me convient très bien sur fedora, donc je n'ai jamais cherché à la modifié;
par contre, sur mageia, les noyaux s'accumulent et il faut de temps à autre faire du ménage manuellement;
comme dnf est utilisable, j'avais essayé de configurer le "installonly" comme sur fedora avec 3 et de faire les mises à jour avec dnf (au lieu de urpmi);
et bien ça ne marche pas! (sur mageia6)
les noyaux continuent de s'accumuler au fil des mises à jour;
j'en conclue que dnf (en tout cas sur mageia) ne tient pas compte de ce paramètre;
si ça peut vous donner une idée du problème, voilà ce que j'ai constaté sur ce point;
bonne journée

#3 Re : [F29] Installation de Fedora 29 » Je ne retrouve pas mes anciens fichiers linux de partition et... » 04/04/2019 02:19:33

salut
je ne suis pas souvent sur ce forum, et rarement je poste car je n'en ait pas les compétences;
dans un système linux il y a souvent plusieurs façon d'atteindre un objectif;
la direction prise me déroute complètement, c'est pour cela que je t'ai conseillé de faire marche arrière à partir du moment où ça avait posé problème;
c'est une démarche générale, du "petit poucet";
le dernier commentaire d'hechmi50 me paraît plein de bon sens;
de toute façon, si la manip finit par marcher, tu vas te retrouver avec une fedora 29 mais avec les fichiers "cachés" dans "bombastic" (les fichiers qui commencent par .) de la fedora26;
c'est encore une source très probable de problèmes, alors que tu avais un /home/niger tout neuf qui marchait bien avec la 29!
il te suffisait de récupérer les dossiers qui t'intéresse dans /home/bombastic;
cette histoire me fait penser à Molière :
"mais qu'allait-il faire dans cette galère !"

nb
si tu réussi à créer un user test comme te le conseille hechmi50, certes il sera tout bon avec la fedora29 mais, il aura un UID de 1001, ce qui veut dire, qu'il n'aura pas le droit d'accéder au dossier ni de "niger" (celui là on s'en fout, il est vide je suppose) ni à celui de "bombastic", dans lequel tu as tes fichiers.

rien n'est désespéré, il y a une solution à tout, mais là, je crois que c'est une voie semée d'embûche qui a été suivie, remarque, c'est formateur!

dans certain forum, c'est du 100% "clic'o'drome; ici, la ligne de commande est acceptée, c'est bien, mais de façon très "divine", comme si c'était une incantation sans comprendre ce qu'on fait;
moi, j'aime bien rajouter un peu de blabla, si ça peut aider à comprendre;
"il vaut mieux apprendre à pécher à quelqu'un que de lui donner un poisson".

#4 Re : [F29] Installation de Fedora 29 » Je ne retrouve pas mes anciens fichiers linux de partition et... » 02/04/2019 21:49:54

Je pense que la modification du fichier /etc/password était une mauvaise idée et surtout inutile;
il me semble bien avoir lu dans la doc que ce genre de fichier ne doit pas être édité directement mais que l'on doit utiliser les commandes "adhoc" pour cela; (useradd ou adduser, userdel ou deluser, etc,...)
d'autant que dans ton cas, à la vue de ton /home, il s'avère que la partition "bombastic" appartient à "niger" (car bombastic et niger ont tout deux le même UID de 1000) donc il te suffisait en console et en user "niger" de faire un "cd /home/bombastic" suivi d'un "ls-al" pour retrouver tes dossiers;
ensuite, les transférer avec un "mv", toujours en simple user puisque tu es dans ton /home;

si tu ne peut plus démarrer, c'est qu'il faut faire marche arrière, soit annuler cette modif faite sur le fichier /etc/password; normalement, l'ayant faite avec "vi", il doit t'avoir conservé la précédente version avec une extension ~; faudra la remettre à la place de celle modifiée qui ne marche pas, toujours avec "mv";
si tu peut booter en mode "recovery" (soit "init3"), tu te logues en "root et tu fait la manip de restaurer l'ancien /etc/password en terminal;
sinon, il te restes à booter avec une live et faire un "chroot" sur la partition où se trouve ton système et faire la modif du /etc/password précédente
pour le "chroot" ma référence est celle là :
https://www.linuxtricks.fr/wiki/chroote … teme-linux
bonne chance

#5 Re : [F29] Installation de Fedora 29 » [Résolu] Réutilisation d'anciennes partitions » 28/03/2019 20:54:25

salut
j'ai eu récemment le même genre de souci avec l'installateur d'une live fedora29KDE scientific;
j'ai un multiboot avec deux disques, un HDD et un SSD;
sur le ssd, l'actuelle fedora 29 a été installée il y a un an avec une 27, et j'avais put l'installer sans souci, juste sur une partition sdb2, sans swap au début (j'en ai qu'une sur l'autre disque, et ça il ne savait pas le voir, donc j'ai installé sans puis je l'ai rajouté à la main dans le /etc/fstab) et en partageant le /home avec d'autres OS (mageia et opensuse), donc sans avoir à formatter le /home;
avec la fedora29 cela m'a été impossible;
j'ai eu l'impression qu'il voulait absolument me créer une table de partition en "gpt" pour tout le disque ce que je ne voulait surtout pas; mon bon vieux MBR fait parfaitement l'affaire;
donc, j'ai renoncé à l'installer, ce qui n'est pas bien grave puisque j'ai la version gnome de base qui marche, mais j'ai l'impression que l'installateur depuis un an, entre celui de la 27 et celui de la 29 est devenu moins sympas avec les multiboots!
où alors, c'est la solution table de partitions msdos/MBR qui ne lui convient plus ?
je suis donc aussi preneur de solutions pour réussir à faire faire son job a cet installateur un peu retords.

#6 Re : [F29] Support général » [Résolu] souci de lecture de vidéos sur YT avec firefox » 22/02/2019 17:21:30

merci pour la réponse.
après plusieurs essais, c'est finalement "NoScript" qu'il faut désactiver sur l'onglet pour que ça s'affiche!
ce qui est curieux, c'est que ça dépend du chemin d'accès.
par un accès direct depuis le menu Youtube, ça marche même avec "NoScript" activé;

#7 [F29] Support général » [Résolu] souci de lecture de vidéos sur YT avec firefox » 21/02/2019 00:22:51

pplemoco
Réponses : 2

bonjour
je poste ici car je suis passé sous fedora 29 depuis quelques jours, mais le problème existait sur la 28 depuis quelques temps, et la mise à jour n'y a rien fait.

description du problème : avec firefox à jour 65.0.1
si j'ouvre un onglet de firefox sur le menu de youtube et que je clique sur une vidéo, ça marche normalement;
mais, si je veux y accéder via, soit les marques pages, ou l'historique, ou via un lien reçu dans un mail par exemple, alors là, ça m'affiche un écran noir avec un message du genre "mon navigateur ne reconnaît aucun format disponible"; il n'y a plus qu'à fermer l'onglet désormais bloqué!

PS
dans le même cas de figure, sur mageai6 et firefox 60.x ESR, ça affiche un warning "firefox a bloqué la redirection " et un bouton pour autoriser;
en cliquant sur le bouton ça s'ouvre normalement;
je précise que les comptes sont synchronisés, je retrouve mon historique et mes marques pages!
ça a très bien marché pendant plusieurs mois, je n'ai pas compris ce qui a put dérégler ce fonctionnement.
merci de vos lumières!

#8 Re : [F29] Installation de Fedora 29 » Installation Fedora 29 : retour d'expérience » 20/02/2019 22:04:06

bonjour
migration tardive sur vieille tour ACER de 2008.
cause principale : hésitation;
en effet, lors de la sortie de la béta 29, j'avais installé une version KDE Scientific en vm qui m'a bien plu.
mais, alors cela supposait de réinstaller fédora, et de perdre, la configuration de bogofilter dans évolution, le tri de mes photos dans shotwell, ...
finalement, j'ai opté pour la simplicité, je reste avec gnome pour l'instant et donc j'ai fait la migration via dnf comme lors du passage de 27 -> 28;
aucun souci majeur.
petit souci mineur avec une extension que j'aime bien, le "hidetopbar", qui ne marchait plus.
il m'a fallu installer aussi "chrome-gnome-shell", bien qu'utilisant firefox pour accéder au site de gnome.
et après quelques recherches, j'ai trouvé la solution sur le github;
elle refonctionne sur fedora 29!
tout est pour le mieux!
bravo fedora et ses équipes
pour ce qui concerne la scientific KDE, pour le moment, elle est toujours en vm;
elle marche bien, mais sur mon vieux bousin, c'est pas très fonctionnel;

#9 Re : [Anciennes versions] Support général » problème de connexion avec wayland » 05/10/2018 22:21:52

bonjour
je relance ce post parce que le problème demeure;
agacé par les soucis relatés plus haut, j'étais resté sur X.org et tout fonctionne;
hier avec l'arrivée du noyau 4.18.10; au reboot, je me suis dis : "si je testais avec wayland pour voir";
ça fige au niveau de gdm, après l'entrée du password;
je n'ai pas tenté la manip avec "pompier", j'ai juste repassé sur X.org, puisque ça marche ainsi.

de toute façon, côté firefox, il n'y en plus qu'un (la période où il y avait le choix fut de courte durée), et il marche bien avec X.org.

bonne soirée

#10 Re : Actualités » Fedora 29 Beta prêt à être testé » 28/09/2018 01:57:32

Bonjour

petit retour sur essai en VM

- premier essai infructueux avec une image téléchargée en suivant le lien de winmandrake;
(Téléchargée depuis cette source : https://dl.fedoraproject.org/pub/fedora … 23.n.0.iso)
l'installation n'a pas été complète (pas passée par l'étape de création de root et user)
et elle n'a jamais démarré

- deuxième essai réussi avec une image récupérée en torrent via le lien donné par Renault
(Si l'aventure vous intéresse, les images sont disponibles par Torrent ou via le site officiel.)

comme il y a un grand choix, j'ai installé Fedora-Scientific-29- KDE
j'ai fait les mises à jours (459 paquets) et ai passé un moment à configurer le bureau selon mon goût;

elle marche du tonnerre !

le bureau KDE me semble un brin plus léger que gnome;

bravo à tous les dev's

#11 Re : [Anciennes versions] Installation des programmes » [Résolu] Firefox 62 - preferences de moteur de recherche » 14/09/2018 13:25:55

bonjour
même problème chez moi avec ce firefox62 :

- google qui se remet à chaque démarrage (la modif faite via "préférences ... " pour choisir un autre moteur n'est pas permanente)

- le correcteur orthographique n'a suivi;

#12 Re : [Anciennes versions] Installation de Fedora » [Résolu] Problème d'installation à cause du swap » 04/09/2018 18:28:06

salut
dans un système où il existe déjà un swap, la meilleure façon d'installer fedora (ou autre), c'est de passer par l'installation "manuelle" ET installer SANS swap;
ensuite, lors de la première utilisation, faut aller dans le fichier /etc/fstab,avec un éditeur, et rajouter le montage de la swap déjà existante, c'est une ligne.
sans cette précaution, l'installateur veut formater et donner un nouvel UUID à la swap, ce qui est la source de nombreux problème en cas de multiboot.

#13 Re : Le comptoir du libre » debian » 04/09/2018 17:59:58

bonjour à tous
mon petit grain de sel à cette discussion
comparer fedora et debian !
posée de cette façon, difficile à répondre;
si on introduit une notion de famille, alors les choses ont une autre allure :
fedora est le membre à l'avant garde dans la famille redhat /CentOS;
les paquets sont des rpm, gérés par yum ou dnf
debian est à l'origine d'une famille qui comprends entre autre ubuntu et linuxmint;
les paquets sont des .deb gérés par apt-get (entre autre)
d'autre part, chez debian proprement dite, il y a la version 9.x dite stable, actuellement "stretch", que l'on peut comparer à une CentOS7;
et une version en testing, baptisée "buster", qui peut être comparée avec fedora28;
tout au moins pour ce qui concerne la fraicheur des logiciels.

et, est annoncé la sortie de LMDE3, une linuxmint debian-edition, basée sur debian stretch, ce qui va complexifier encore plus les choix autour de cette famille.

#14 Re : Le comptoir du libre » Fedora LTS » 09/08/2018 19:04:24

bonjour
intéressante conversation !

un lien vers une vidéo
www.youtube.com/watch?v=vuuo2m8LBWE
il est question de "rafraichir" une CentOS, de manière assez simple et sécure

#15 Re : [Anciennes versions] Installation de Fedora » Conseils pour l'installation » 20/06/2018 19:41:14

bonjour
mea culpa pour la remarque déplacée autant qu'inutile, puisque notre ami obélix1502 n'est pas un débutant sur linux, et il doit avoir son opinion sur cette chose et n'a pas besoin de connaître la mienne.

pour en revenir au sujet, si tu fais ce que tu dis dans la dernière phrase, cela revient à ce que les deux systèmes s'ignorent, ça devrait marcher (j'en sais rien j'ai pas essayé), mais c'est assez rigide, car à chaque démarrage, il te faudra "sauter" sur la touche ("F12" chez moi) assez vite, sinon ça démarrera sur celle que le BIOS a comme défaut.

bonne journée

#16 Re : [Anciennes versions] Installation de Fedora » Conseils pour l'installation » 20/06/2018 04:17:39

Bonsoir
je ne connais pas manjaro, il paraît qu'elle est fragile au niveau du grub en multiboot;
toutefois, j'ai organisé un multiboot sur deux disques (hdd 1to et ssd 240 gio);
je suis en BIOS et MBR; donc j'ai rendu les deux disques bootables (c'est toujours mieux en cas de panne) en ayant un MBR sur chaque disque; c'est aussi une sécurité, quand on installe une nouvelle distribution, on sait jamais ce qu'elle peut faire au niveau du grub; donc, si suite à une mise à jour, ça ne boote plus avec sda, et bien ça boote toujours avec sdb;
bon, c'est une contrainte de maintenir chaque fois qu'il y a un nouveau noyau les deux MBR, mais c'est une sécurité que les autres systèmes marcheront toujours;
ensuite, parmi les systèmes présents, j'ai mageia6, qui grâce au CCM et à "grub-customizer" me permet de gérer ça très bien;
faut aussi faire attention à la swap : lors de l'installation, son UUID risque d'être modifiée, ce qui pose problème aux autres distributions présentes; la solution, c'est d'installer sans swap, puis lors du premier démarrage, rajouter à la main dans le "/etc/fstab" la ligne pour monter la swap, avec la bonne UUID;
ça ressemble à ça :
# Entry for swap in sda5
UUID=66c58924-9db0-417a-a741-d4ef5859e8df swap swap defaults 0 0
(voir "man fstab" pour la signification des 6 champs d'une ligne de fstab)
avec la bonne UUID chez toi obtenue avec "blkid"

ensuite, pour partager le /home, il faut que le nom de "login" soit différent sur différentes distributions, mais pour partager les données, il faut que l'UID des users soit la même (en général c'est le cas, le premier user ayant l'UID à 1000)

je ne sais pas comment c'est sur manjaro, mais sur fédora28, c'est les mauvaises pratiques ubuntuesque qui sont arrivés, avec un seul user et utilisation de "sudo";
mais on peut toujours créer un compte "root", heureusement!
moi, je préfère la vieille école : 3 users, soit le "root" avec son password, le user normal et un user de secours normal, qui ne sert qu'en cas de souci avec l'autre;
bonne chance
et bienvenue sur fédora

#17 Re : [Anciennes versions] Support général » problème de connexion avec wayland » 06/06/2018 15:01:57

continuations ...
depuis peu, je me suis rendu compte del'apparition d'une version "wayland" de firefox;
comme j'utilise gnome en wayland, je me suis dit je vais l'adopter;
et il me semble d'ailleurs que c'est plus réactif, l'ensemble gnome + firefox, tout deux en wayland;

seulement voilà, tant que j'ai utilisé le firefox classique, le passage par "pompier", le user de secours n'était nécessaire qu'une seule fois; ça réparait le truc de façon pérenne, jusqu'à la nouvelle arrivée d'un kernel;
mais, ce coup ci, ça n'a pas réparré, il m'a fallu repasser chaque fois par "pompier" pour pouvoir me logger en wayland avec mon user;
je me suis dit, tient ce nouveau firefox a modifié le comportement;
donc, j'ai lancé une navigation avec l'ancien firefox;
puis j'ai rebooté, et la connexion directe avec mon user a été possible;
pas besoin ce coup là de passer par "pompier";
conclusions :
après l'arrivée d'un nouveau noyau, la connexion en wayland à mon compte est impossible : ça fige!
si je me connecte avec un user de secours normal, ça marche, il me suffit ensuite de faire une fermeture de session et de me relogger avec mon user;
ET
si j'utilise firefox ancien, la réparation est pérenne, tant que l'on ne change pas de kernel; ça veut dire qu'ensuite je peut me logger directement avec mon user normal;
mais si j'utilise firefox - wayland alors, il me faut systématiquement passer par le user de secours, la connexion avec mon user étant toujours impossible.

voilà ce que j'ai remarqué, si ça peut aider!

#18 Re : [Anciennes versions] Support général » problème de connexion avec wayland » 06/06/2018 14:19:36

par user de secours, j'entends simplement un user normal, sans droits particuliers, que j'ai appelé "pompier", il a son /home/pompier, vide puisque je ne m'en sert que pour ça!
j'ai aussi un vrai compte "root", puisque je suis de l'ancienne mode (on n'est pas sur ubuntu mdr !), avec son propre password;
et je ne m'en sert qu'en "terminal"; je n'utilise jamais le "sudo";

par contre, je n'ai jamais lancé plusieurs session différentes en même temps ? je ne comprends pas ?
je me loge avec "pompier", puis je ferme la session (avec gnome), je me retrouve sur gdm le loggin, et je me loge avec mon user habituel;

#19 Re : [Anciennes versions] Support général » problème de connexion avec wayland » 06/06/2018 13:22:33

Bonjour
ça a remis les choses en ordre, provisoirement;
avec l'arrivée du nouveau noyau, 4.16.13, rebelote!
la connexion avec mon user est impossible, mais en passant par le user de secours, ça marche, puis en faisant une fermeture de session, alors la connexion avec mon user est possible;
c'est pas bien grave puisque j'ai une solution de contournement facile, mais ça reste un problème!
bonne journée

#20 Re : [Anciennes versions] Support général » Firefox & Firefox Wayland » 02/06/2018 17:38:25

Bonjour
moi, non plus je ne l'avais pas remarqué, puisque je lance firefox toujours depuis les favoris;
dans le menu, effectivement, il y a deux firefox;
j'ai lancé celui avec wayland, qui à l'air de fonctionner;
j'ai lancé une vidéo sur YT, suis passé en plein écran sans problème;
il faut dire que je lance de préférence le gnome wayland, puisque c'est l'avenir;
pourquoi vouloir le supprimer, avoir le choix, c'est toujours mieux.

#21 Re : [Anciennes versions] Support général » [Résolu] Nautilus » 02/06/2018 17:18:35

à propos de la commande "mv"

si la source et la destination sont sur le même "device", eg, la même partition, ça va se comporter comme un renommage;
mais si la destination est sur un dd externe par exemple, ça va bien le copier dans "destination" et le SUPPRIMER" de la source! c'est bien un déplacement!

#22 Re : [Anciennes versions] Support général » problème de connexion avec wayland » 28/05/2018 14:56:02

Bonjour
comme ça marchait avec x.org, je me suis pas trop énervé, et puis j'avais d'autre truc à faire;
hier nouvelle maj, avec le kernel 4.16.11 (j'ai du rater le 10 ou alors on est passé de 9 à 11 directement?)

toujours le même problème, connection avec mon UID impossible en wayland mais possible avec x.org et aussi possible en wayland avec une UID toute neuve;

j'ai désactivé 2 extensions dont je ne me sert pas en fait via le tweaktool rebaptisé Ajustement;
puis dans .local/share/gnome-shell/extensions, j'ai fait du ménage, soit supprimé 5 dossiers avec la commande "rm -rf le_nom_de_l_extension";
(les 2 désactivées et 3 autres déjà désactivées avant)
toujours le même problème!
MAIS
logé avec le user de secours avec wayland, au lieu de rebooter j'ai juste changé de session avec mon UID, et là ça marche avec wayland;
et aujourd'hui, j'ai démarré directement avec mon UID en wayland et ça marche!

j'ai pas bien compris pourquoi ni comment!
en passant par l'UID de secours et un changement de session ça a remis les choses en ordre!

#23 Re : [Anciennes versions] Support général » problème de connexion avec wayland » 23/05/2018 23:17:57

Bien vu Vindicators

avec un nouveau user, ça marche;
donc, c'est surement une extensions gnome qui doit poser problème, le tout est de découvrir laquelle;

merci pour la réponse

#24 Re : [Anciennes versions] Support général » problème de connexion avec wayland » 23/05/2018 16:25:58

Ok merci pour le lien!
mais maintenant, j'ai pas le temps de me plonger là dedans, d'autant que c'est pas bloquant!
en fait, wayland ou x.org, je ne vois pas la différence;
une prochaine maj règlera peut être le problème!
sinon, je regarderais la chose plus en détails plus tard!

#25 Re : [Anciennes versions] Support général » problème de connexion avec wayland » 23/05/2018 15:59:33

madko a écrit :

Bonjour,

tu l'as signalé sur le bugzilla redhat c'est ça ?

En tout cas pas de soucis ici. Quelle carte graphique ?

Non, je le signale juste ici, le bugzilla de redhat, je ne le connais pas!
J'imagine qu'il doit falloir être inscrit et décrire le problème en anglais!
la carte vidéo est NVIDIA G94 GeForce 9600GS

Pied de page des forums

Propulsé par FluxBB