Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 30 est mort ce soir

#1 Re : [Anciennes versions] Installation de Fedora » [Résolu] Écran noir après la mise à Niveau » 31/10/2018 21:04:00

Je te dis ce qui m'avait embrouillé, mais je crois que c'est vraiment moi, ça me semble clair maintenant.

vous pouvez utiliser la commande grub2-install /dev/sda en remplaçant bien sûr sda par le nom du disque sur lequel se trouve votre partition racine

J'avais mal lu et remplacé /dev/sda par la partition racine elle-même, /dev/sda5 chez moi. Alors qu'en fait j'avais rien à remplacer du tout.
En tant que non-informaticien, dans le stress d'un ordi qui plante, on a vite fait de lire de travers...

#2 Re : [Anciennes versions] Installation de Fedora » [Résolu] Problème avec perl-libs » 31/10/2018 19:33:42

Au temps pour moi, dvdrip-master n'est effectivement pas dans les dépots. J'avais dû l'installer en le téléchargeant quelque part.

#3 Re : [Anciennes versions] Installation de Fedora » [Résolu] Écran noir après la mise à Niveau » 31/10/2018 18:16:52

C'est bon c'était bien grub le problème !
je l'ai réinstallé proprement et j'ai même plus la page d'erreurs avant qu'il n'apparaisse. Je crois que la dernière fois que je l'avais fait j'avais mal compris un truc dans la doc.

Merci en tout cas !

#4 Re : [Anciennes versions] Installation de Fedora » [Résolu] Écran noir après la mise à Niveau » 31/10/2018 17:34:54

Merci mais ça ne change rien...

Depuis le live USB j'ai accès à tous mes fichiers en tout cas, et ma partition root n'a pas l'air abîmée.

Comme j'ai récemment eu pas mal de soucis avec grub, je pense que le problème doit venir de lui. Je peux peut-être tenter de le reconfigure depuis le live.

En fait, avant que grub ne s'affiche, j'ai un écran un peu bizarre avec des erreurs listées qui passe très vite. Mais je l'avais déjà avec f28.

En plus, l'entrée Fedora 29 est bien apparue dans mon grub après la maj... Donc je suis un peu perdu...

#5 [Anciennes versions] Installation de Fedora » [Résolu] Écran noir après la mise à Niveau » 31/10/2018 17:03:09

ccazerty
Réponses : 7

Bonjour,

Ma mise à niveau est terminée, mais après le Grub, j'ai un écran noir avec un tiret blanc qui clignote indéfiniment en haut à gauche.
J'ai essayé de booter en mode texte en remplaçant "rhgb quite" par 3 dans l'entrée grub mais ça ne fait rien (peut-être n'est-ce pas la bonne méthode ?)

Je vais booter avec un live usb pour voir ce qu'il en est ede ma partition, mais si vous avez des idées, je me permets de solliciter votre aide.

Merci !

#6 [Anciennes versions] Installation de Fedora » [Résolu] Problème avec perl-libs » 31/10/2018 12:16:38

ccazerty
Réponses : 2

Bonjour,

Quand j'ai tenté la mise à niveau vers Fedora 29, trois paquets n'existaient pas dans les nouveaux dépots. J'ai pu en désinstaller deux, qui n'étaient pas de trop importantes dépendances, mais le dernier, perl-libs, sert visiblement à 963 paquets chez moi. Impossible donc de le désinstaller.

Voilà c'était juste pour le signaler smile Je vais attendre quelques jours et réessayer big_smile

Edit : Finalement j'ai réussi en supprimant le paquet dvdrip-master qui apparemment était le seul a avoir besoin que perl-libs soit dans les nouveaux dépots.

Je laisse quand même ce message pour signaler les paquets que j'ai dû supprimer pour faire la mise à Jour :

- VLC
- libplacebo
- dvdrip-master (à cause de perl-libs)

#7 Re : [Anciennes versions] Support général » grub2-mkconfig ne détecte pas fedora » 09/09/2018 14:45:34

Merci à tous, je n'ose pas trop tester tout de suite les manips car j'ai un boulot important à finir sur mon PC, je ne peux pas me permettre de risquer la panne, mais dès que j'ai fini je m'y met !

#8 Re : [Anciennes versions] Support général » grub2-mkconfig ne détecte pas fedora » 23/08/2018 20:10:59

Merci ! J'ai lancé la commande, mais il semble que j'ai un logiciel FlexNet dans le secteur 32, qui doit me servir pour Windows, est-ce que ça peut déranger Grub2 ou ça ira ?

grub2-install /dev/sda --recheck
Installation pour la plate-forme i386-pc.
grub2-install : attention : Le secteur 32 est déjà utilisé par le programme « FlexNet » ; à éviter. Ce logiciel risque de poser des problèmes d'amorçage ou autre à l'avenir. Veuillez demander à ses auteurs de ne pas sauver de données dans la piste d'amorçage.
Installation terminée, sans erreur.

#9 Re : [Anciennes versions] Support général » grub2-mkconfig ne détecte pas fedora » 23/08/2018 18:28:20

Il se peut que les kernels installés et ceux présents dans /boot ne soient plus en accord par contre.
Donc voir pour réinstaller le dernier noyau

Comment je ferai dans ce cas là pour réinstaller le noyau ? Fedora bootera quand même ou pas ?

#10 Re : [Anciennes versions] Support général » grub2-mkconfig ne détecte pas fedora » 23/08/2018 18:16:14

Après un umount /boot, je retrouve un dossier /boot normal effectivement !

Par commenter tu veux dire inactiver la ligne en la passant en commentaire avec #, c'est bien ça ?

#11 Re : [Anciennes versions] Support général » grub2-mkconfig ne détecte pas fedora » 23/08/2018 17:52:37

perso je me demande comment la même partition peut être montée à deux endroits différents ?

Moi aussi...

Je peux peut-être effacer la ligne de code "/dev/sda7 /boot ext4 rw,seclabel,relatime 0 0" de /proc/mounts ? Ou je vais encore faire une connerie ?

Sinon, vu que j'ai une partition /home séparée, y'a pas tout simplement un moyen de réinstaller Fedora sans perdre mes données ? Je réinstallerai mes logiciels, tant pis... Et puis je me ferai une partition /boot.

Vu que j'ai fait toutes mes conneries de débutant sous linux sur ce système ça lui fera pas de mal...

#12 Re : [Anciennes versions] Support général » grub2-mkconfig ne détecte pas fedora » 23/08/2018 11:14:52

Merci de vos répnses !
Ce que j'ai fait, c'est que j'ai installé une autre distribution linux, puis je l'ai supprimée comme un con via gparted, sans prendre aucune précaution. Ensuite j'ai essayé de réparer mon grub par divers moyens (sachant que je n'avais pas de partition /boot). D'où l'estpace libre que j'ai laissé comme ça par peur de m'enfoncer encore plus, vu que maintenant je parviens quand-même à booter sans problème (même si le démarrage est très long.)

le contenu de fstab :

#
# /etc/fstab
# Created by anaconda on Thu Oct 20 20:35:20 2016
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=bfd4934a-ac40-45d1-bd9b-ad1b76512294 /                       ext4    defaults        1 1
UUID=258f079c-64b9-44c3-9929-d276c22a07df /home                   ext4    defaults        1 2
UUID=51d49c09-789b-4866-94fa-64243fbd89bb swap                    swap    defaults        0 0
/dev/disk/by-id/wwn-0x50014ee25afd5c92-part4 /mnt/wwn-0x50014ee25afd5c92-part4 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-id/wwn-0x50014ee25afd5c92-part5 /mnt/wwn-0x50014ee25afd5c92-part5 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-id/wwn-0x50014ee25afd5c92-part1 /mnt/wwn-0x50014ee25afd5c92-part1 auto nosuid,nodev,nofail,x-gvfs-show 0 0
UUID=258f079c-64b9-44c3-9929-d276c22a07df       /boot   ext4    defaults        0       2

et le résultat de mount :

sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime,seclabel)                                                                                                     
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)                                                                                                               
devtmpfs on /dev type devtmpfs (rw,nosuid,seclabel,size=6075984k,nr_inodes=1518996,mode=755)                                                                            
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)                                                                                    
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,seclabel)                                                                                                                 
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,seclabel,gid=5,mode=620,ptmxmode=000)                                                                         
tmpfs on /run type tmpfs (rw,nosuid,nodev,seclabel,mode=755)                                                                                                            
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,seclabel,mode=755)                                                                                           
cgroup2 on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime,seclabel,nsdelegate)                                                                    
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,seclabel,xattr,name=systemd)                                                              
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime,seclabel)                                                                                         
bpf on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime,mode=700)                                                                                                  
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,seclabel,freezer)                                                                         
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,seclabel,cpu,cpuacct)                                                                 
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,seclabel,devices)                                                                         
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,seclabel,cpuset)                                                                           
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,seclabel,net_cls,net_prio)                                                       
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,seclabel,hugetlb)                                                                         
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,seclabel,pids)                                                                               
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,seclabel,blkio)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,seclabel,memory)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,seclabel,perf_event)
configfs on /sys/kernel/config type configfs (rw,relatime)
/dev/sda5 on / type ext4 (rw,relatime,seclabel)
selinuxfs on /sys/fs/selinux type selinuxfs (rw,relatime)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=30,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=2025)
mqueue on /dev/mqueue type mqueue (rw,relatime,seclabel)
debugfs on /sys/kernel/debug type debugfs (rw,relatime,seclabel)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,seclabel,pagesize=2M)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,seclabel)
/dev/sda7 on /home type ext4 (rw,relatime,seclabel)
/dev/sda7 on /boot type ext4 (rw,relatime,seclabel)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,seclabel,size=1217896k,mode=700,uid=1000,gid=1000)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
/dev/fuse on /run/user/1000/doc type fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)

Merci encore !

#13 Re : [Anciennes versions] Support général » grub2-mkconfig ne détecte pas fedora » 28/06/2018 15:25:50

$ lsblk -f
NAME                    FSTYPE LABEL              UUID                                 MOUNTPOINT                                                                       
sda                                                                                                                                                                     
├─sda1                  ntfs   Réservé au système 94660C62660C4806                                                                                                      
│ └─osprober-linux-sda1 ntfs   Réservé au système 94660C62660C4806                                                                                                      
├─sda2                  ntfs                      248A0FE28A0FAF7C                                                                                                      
│ └─osprober-linux-sda2 ntfs                      248A0FE28A0FAF7C                                                                                                      
├─sda3                                                                                                                                                                  
├─sda5                  ext4                      bfd4934a-ac40-45d1-bd9b-ad1b76512294 /                                                                                
├─sda6                  swap                      51d49c09-789b-4866-94fa-64243fbd89bb [SWAP]                                                                           
└─sda7                  ext4                      258f079c-64b9-44c3-9929-d276c22a07df /boot                                                                            
sdb                                                                                                                                                                     
├─sdb1                                                                                                                                                                  
└─sdb2                  ntfs   IntelRST           FC141747141703F4                                                                                                      
  └─osprober-linux-sdb2 ntfs   IntelRST           FC141747141703F4                                                                                                      
sr0

Je pense à un truc : j'ai un grand espace vide sur mon disque entre windows et fedora, ça pourrait jouer dans le fait que fedora n'est pas détecté ? En plus l'espace vide est dans la partition logique. En gros, dans sda3, avant sda5 j'ai du vide.

Edit : Je viens de me rentre compte que, dans ma racine, mon dossier boot et mon dossier home étaient en quelque sorte "confondus". J'ai bien les deux, mais que je clique sur l'un ou sur l'autre ça m'amène dans ma partition home, dans laquelle j'ai mon dossier perso et le grub2. Ça me semble bizarre, mais peut-être est-ce normal ?

#14 Re : [Anciennes versions] Support général » grub2-mkconfig ne détecte pas fedora » 28/06/2018 11:21:11

fdsik -l :

Disque /dev/sda : 698,7 GiB, 750156374016 octets, 1465149168 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0xb1cca958

Périphérique Amorçage      Début        Fin  Secteurs Taille Id Type
/dev/sda1                   2048     718847    716800   350M  7 HPFS/NTFS/exFAT
/dev/sda2    *            718848  515422207 514703360 245,4G  7 HPFS/NTFS/exFAT
/dev/sda3              515424254 1464223743 948799490 452,4G  5 Étendue
/dev/sda5              949071872 1046726655  97654784  46,6G 83 Linux
/dev/sda6             1046728704 1058447359  11718656   5,6G 82 partition d'échange Linux / Solaris
/dev/sda7             1058449408 1464223743 405774336 193,5G 83 Linux

La partition 3 ne commence pas sur une frontière de cylindre physique.


Disque /dev/sdb : 22,4 GiB, 24015495168 octets, 46905264 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : gpt
Identifiant de disque : C1EF77F1-53BE-4A5A-AC7E-DA784E15E7AD

Périphérique   Début      Fin Secteurs Taille Type
/dev/sdb1    8392704 46903295 38510592  18,4G inconnu
/dev/sdb2       2048  8390655  8388608     4G Flash rapide Intel

Les entrées de la table de partitions ne sont pas dans l'ordre du disque.




Disque /dev/mapper/osprober-linux-sda1 : 350 MiB, 367001600 octets, 716800 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0x73736572

Périphérique                          Amorçage      Début        Fin   Secteurs Taille Id Type
/dev/mapper/osprober-linux-sda1-part1          1920221984 3736432267 1816210284   866G 72 inconnu
/dev/mapper/osprober-linux-sda1-part2          1936028192 3889681299 1953653108 931,6G 6c inconnu
/dev/mapper/osprober-linux-sda1-part3                   0          0          0     0B  0 Vide
/dev/mapper/osprober-linux-sda1-part4            27722122   27722568        447 223,5K  0 Vide

La partition 4 ne commence pas sur une frontière de cylindre physique.
Les entrées de la table de partitions ne sont pas dans l'ordre du disque.


Disque /dev/mapper/osprober-linux-sda2 : 245,4 GiB, 263528120320 octets, 514703360 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0x6c727443

Périphérique                          Amorçage      Début        Fin   Secteurs Taille Id Type
/dev/mapper/osprober-linux-sda2-part1          1970237472 3672215697 1701978226 811,6G 75 PC/IX
/dev/mapper/osprober-linux-sda2-part2          1929382413 3883035520 1953653108 931,6G 72 inconnu
/dev/mapper/osprober-linux-sda2-part3                   0          0          0     0B  0 Vide
/dev/mapper/osprober-linux-sda2-part4            27394442   27394879        438   219K  0 Vide
La partition 2 ne commence pas sur une frontière de cylindre physique.
La partition 4 ne commence pas sur une frontière de cylindre physique.
Les entrées de la table de partitions ne sont pas dans l'ordre du disque.


Disque /dev/mapper/osprober-linux-sdb2 : 4 GiB, 4294967296 octets, 8388608 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0x73736572

Périphérique                          Amorçage      Début        Fin   Secteurs Taille Id Type
/dev/mapper/osprober-linux-sdb2-part1          1920221984 3736432267 1816210284   866G 72 inconnu
/dev/mapper/osprober-linux-sdb2-part2          1936028192 3889681299 1953653108 931,6G 6c inconnu
/dev/mapper/osprober-linux-sdb2-part3                   0          0          0     0B  0 Vide
/dev/mapper/osprober-linux-sdb2-part4            27722122   27722568        447 223,5K  0 Vide

Y'a l'air d'y avoir un beau bordel dans sda5...

sdb est un ssd cache qui ne sert que pour Windows normalement.

pour la commande de config, c'était :

grub2-mkconfig -o /boot/grub2/grub.cfg

je viens de le refaire et là il ne m'a carrément rien listé :

Generating grub configuration file ...                                                                                                                                  
done

d'habitude il liste deux entrées Windows. Ou bien les entrées Fedora quand je suis depuis le live USB.

#15 [Anciennes versions] Support général » grub2-mkconfig ne détecte pas fedora » 27/06/2018 23:08:03

ccazerty
Réponses : 19

bonjour,

J'ai fait récemment une débilité qui m'a valu de perdre mon grub...

Après beaucoup de recherches et de bidouillages, j'ai presque réussi à tout récupérer. J'ai juste un bug embêtant dans la config du grub :

En gros, quand je suis sur mon fedora principal et que je lance la config du grub, il ne détecte que les entrées windows (d'ailleurs il en détecte deux alors qu'avant je n'en avait qu'une, aurait-ce un lien ?), et au prochain redémarrage je suis obligé de passer par une USBlive, qui me permet de relancer la config du grub après chroot, et là ça ne détecte que les entrées Fedora... en plus avant chroot, toujours sur l'USBlive, si je lance grub-customizer je vois les entrées Windows seulement aussi !

Je n'y comprends vraiment rien, alors si vous avez des idées...

au moins je peux me débrouiller pour accéder à mes deux OS, donc je panique moins, mais bonjour la manip de 30 minutes à chaque démarrage...

J'utilise un Bios legacy, et j'ai 3 partitions principales, 2 pour windows ("réservé système" et l'os en lui-même) et une étendue pour Fedora. Grub est installé dans ma partition root de Fedora.

Merci !

Edit : En fait j'ai comme l'impression que j'ai deux grub, ou deux grub.cfg. Par exemple là, quand j'ai booté, j'ai d'abord eu un grub avec seulement les entrées windows, puis j'ai ouvert la console grub et j'ai fait :

set boot=(hd0,5)/boot
set prefix=(hd0,5)/boot/grub2

et là j'avais mes entrées Fedora.

Re-Edit : J'ai une nouvelle info : quand je suis dans mon fedora principal, dans grub customizer, quand je fais "changer l'environnement" j'ai deux fois la partition /dev/sda5 (celle ou est installée mon root). un marqué "(actuel)" et l'autre juste marqué avec "ext4" comme s'il n'était pas monté ! quand je suis sur le "actuel", il trouve les partitions Windows, et quand je sélectionne le "ext4", j'ai les kernels Fedora. Du coup je peux me débrouiller en copiant les entrées de l'un dans l'autre, mais ça ne m'a pas l'air très propre...

#16 Re : [Anciennes versions] Matériel » [Résolu] Aide Prime+Nouveau » 27/06/2018 15:36:11

Edouard_le_homard a écrit :

> est-ce normal sous fedora 28 KDE ?
oui, Wayland n'est pas assez stable sous KDE

Lance pour voir :

glxinfo | grep "OpenGL vendor string"
DRI_PRIME=0 glxinfo | grep "OpenGL vendor string"
DRI_PRIME=1 glxinfo | grep "OpenGL vendor string"

Merci !

J'obtiens ça :

ATTENTION: default value of option vblank_mode overridden by environment.
OpenGL vendor string: Intel Open Source Technology Center
$ DRI_PRIME=0 glxinfo | grep "OpenGL vendor string"
ATTENTION: default value of option vblank_mode overridden by environment.
OpenGL vendor string: Intel Open Source Technology Center
$ DRI_PRIME=1 glxinfo | grep "OpenGL vendor string"
ATTENTION: default value of option vblank_mode overridden by environment.
OpenGL vendor string: nouveau

C'est plutôt bon signe, non ? Ça veut dire que Prime marche déjà en fait, non ?

Refuznik a écrit :

N'utilise pas nouveau tout simplement.

Je veux bien, mais depuis que j'utilise Fedora, j'ai déjà essayé deux fois d'installer les pilotes propriétaires Nvidia, ce qui m'a valu un Fedora qui boot en mode texte... Ça m'a un peu découragé...

#17 [Anciennes versions] Matériel » [Résolu] Aide Prime+Nouveau » 26/06/2018 16:22:04

ccazerty
Réponses : 4

Bonjour,

Je suis en train d'essayer de faire fonctionner mon PC Optimus avec Prime+Nouveau et jai un souci :

Apparemment j'utilise X.org et non Wayland (est-ce normal sous fedora 28 KDE ?), mais quand je lance

xrandr --listproviders

, j'obtiens ça :

Providers: number : 2
Provider 0: id: 0x76 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 4 associated providers: 1 name:modesetting
Provider 1: id: 0x3f cap: 0x5, Source Output, Source Offload crtcs: 0 outputs: 0 associated providers: 1 name:modesetting

Que veut dire ce "modesetting" que j'ai à la place du nom des Pilotes ? Merci !

#18 Re : [Anciennes versions] Installation de Fedora » Installation Fedora 28 retour experience » 09/06/2018 18:58:22

- Méthode d'installation :

dnf

- Problèmes majeurs :

Grand retours des problèmes de Tearing sur tout ce qui est vidéo, jeu vidéo, et même défilement des pages Web. (Carte graphique Nvidia)
Je vais chercher comment régler ce problème que je n'avais pas eu depuis F24

Problèmes avec les applications nécessitant des droits root, comme Grub Customizer qui ne s'ouvre plus, et Unetbootin que je suis obligé de lancer dans un terminal.

- Soucis mineurs :

aucun

- Points positifs :

Rapidité, de démarrage et de fonctionnement. Sur mon ordi la différence est grande par rapport à F27.

Plus aucun problème d'affichage. Dans la version précédente quand j'ouvrais firefox, je devais redimentionner ma fenêtre, sinon seul le cadre apparaissait. c'est réglé.

- Points négatifs :
a première vue aucun (à part mentionné plus haut)

#19 Re : [Anciennes versions] Matériel » Drivers Clé Wifi » 18/11/2017 20:06:15

Je suis passé à fedora 26 hier pour voir si ça arrangeait les choses, mais non.

Ma version kernel est : 4.13.12-200.fc26.x86_64

sinon j'ai fait quelques manips en suivant d'autres sujets et le message a changé quand je fais une installation manuelle (avec make etc...)

le voilà : (je ne mets pas en code pour voir les couleurs)

make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.13.12-200.fc26.x86_64/build M=/home/cclement/temp/rtl8821au  modules
make[1] : on entre dans le répertoire « /usr/src/kernels/4.13.12-200.fc26.x86_64 »
  CC [M]  /home/cclement/temp/rtl8821au/os_dep/osdep_service.o
In file included from /home/cclement/temp/rtl8821au/include/drv_types.h:32:0,
                 from /home/cclement/temp/rtl8821au/os_dep/osdep_service.c:25:
/home/cclement/temp/rtl8821au/include/osdep_service.h: Dans la fonction « thread_enter »:
/home/cclement/temp/rtl8821au/include/osdep_service.h:100:2: error: déclaration implicite de la fonction « allow_signal »; vouliez-vous utiliser « do_signal » ? [-Werror=implicit-function-declaration]
allow_signal(SIGTERM);
  ^~~~~~~~~~~~
  do_signal
/home/cclement/temp/rtl8821au/include/osdep_service.h: Dans la fonction « flush_signals_thread »:
/home/cclement/temp/rtl8821au/include/osdep_service.h:105:6: error: déclaration implicite de la fonction « signal_pending »; vouliez-vous utiliser « timer_pending » ? [-Werror=implicit-function-declaration]
  if (signal_pending (current)) {
      ^~~~~~~~~~~~~~
      timer_pending
/home/cclement/temp/rtl8821au/include/osdep_service.h:106:3: error: déclaration implicite de la fonction « flush_signals »; vouliez-vous utiliser « do_signal » ? [-Werror=implicit-function-declaration]
  flush_signals(current);
   ^~~~~~~~~~~~~
   do_signal
cc1 : certains avertissements sont traités comme des erreurs
make[2]: *** [scripts/Makefile.build:303: /home/cclement/temp/rtl8821au/os_dep/osdep_service.o] Error 1
make[1]: *** [Makefile:1516: _module_/home/cclement/temp/rtl8821au] Error 2
make[1] : on quitte le répertoire « /usr/src/kernels/4.13.12-200.fc26.x86_64 »
make: *** [Makefile:116: modules] Error 2

#20 Re : [Anciennes versions] Matériel » Drivers Clé Wifi » 17/11/2017 11:55:53

Merci, j'ai suivi le sujet de la semaine dernière en remplaçant rtl8812AU par rtl8821AU, qui est le firmware de ma clé.

Mais ça n'a rien changé, le message d'erreur est toujours le même.

#21 [Anciennes versions] Matériel » Drivers Clé Wifi » 16/11/2017 11:18:43

ccazerty
Réponses : 4

Bonjour,

J'ai acheté la clé Wifi AC600 Wireless USB Adapter Car celle de mon ordinateur portable était de trop mauvaise qualité.

Quand j'essaie d'installer les drivers linux avec le install.sh fourni, il me renvoie ça :

make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.13.12-100.fc25.x86_64/build M=/home/cclement/Téléchargements/drivers Wifi/MWA255_Drivers_Linux_4.x/rtl8812au-master  modules
make[1]: *** /lib/modules/4.13.12-100.fc25.x86_64/build : No such file or directory. Arrêt.
Makefile:1052 : la recette pour la cible « modules » a échouée
make: *** [modules] Erreur 2

Quelqu'un aurait une idée de ce que ça veut dire svp ?

Merci !

Egalement : comment fait-on pour savoir si on utilise la carte wifi intégrée ou le dongle ?

#22 Re : [Anciennes versions] Matériel » [Résolu] Casque BT Plantronics backbeat pro » 23/09/2017 13:29:07

Bonjour,

J'ai le même casque, et j'ai réussi, grâce à ce sujet, à le connecter.

Par contre j'ai un gros problème de qualité de son, avec une très grosse friture sur le moindre son, et une énorme latence. C'est vraiment inaudible...

PS : J'utilise KDE, et mon Dongle est un ASUS USB-BT211.

Merci !

#23 [Anciennes versions] Matériel » Problème magic mouse » 07/06/2017 09:20:08

ccazerty
Réponses : 0

Bonjour,

Je possède un iMac mi-2007 sous fedora, avec une magic mouse 1.

Or le scrolling ne fonctionne pas, dans aucun sens.

Quand je cherche sur Google, je vois que les gens ont le souci avec la MM2, mais partout il est dit que la MM1 fonctionne nativement sous linux.

Pouvez-vous m'aider à comprendre pourquoi chez moi ça ne fonctionne pas ? Je suis très mauvais en diagnostic...

Merci !

#25 [Anciennes versions] Matériel » [Résolu] Problème de boot sur iMac » 22/01/2017 11:35:13

ccazerty
Réponses : 1

Bonjour à tous,

Je viens d'hériter d'un iMac mi-2007 sous El Capitan.

J'ai voulu faire un dual boot avenc fedora en suivant ce tuto : Dual boot Mac OS X El Capitan / Ubuntu Linux et en remplaçant Ubuntu par Fedora.

Au moment de l'installation de Fedora, j'ai étéobligé de créer une partition /boot/efi pour que ça marche. C'est là je pense mon erreur. J'aurais dû sélectionner la partition dans laquelle était déjà installé rEFInd (je pense).

Actuellement, quand je boot, j'ai Grub, qui me propose fedora, Mac OS X 64 et 32 bits (je ne comprends pas très bien pourquoi le 64 bits d'ailleurs), mais quand je clique, j'ai trois lignes d'erreur :

Can't find 'xmv-uuid'
Can't find 'xmv-kernel'
Can't find 'xmv-kextdir'

et "appuyez sur une touche pour continuer" qui me ramène au Grub.

Comment faire pour plutôt booter sur rEFInd ? J'avais pensé modifier le point de montage /boot/efi dans gparted, mais celui-ci me dit que ça va effacer les données de mon disque, je n'ai pas osé confirmer.

Via alt au démarrage, j'ai toujours accès à mac et à son recovery. Le seul vraiment inaccessible est rEFInd.

Merci !

Pied de page des forums

Propulsé par FluxBB