Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 37 Beta est disponible

#1 Re : [Anciennes versions] Support général » Problème de configuration de vim » 06/01/2012 10:16:16

Petit up car j'aimerai vraiment pouvoir configurer mon vim comme je le souhaite.

#2 Re : [Anciennes versions] Support général » Problème de configuration de vim » 19/12/2011 15:30:08

Tout d'abord merci pour ta réponse MarbolanGos.
J'ai déjà été confronté à ce problème de double raccourci sous Ubuntu10.04 et lorsqu'il n'y avait qu'un seul onglet de Gnome-terminal d'ouvert il changeait bien l'onglet de vim.
Le souci n'intervenait qu'avec plusieurs onglets de gnome-terminal ouverts.
Mais ici la commande n'a aucun effet sur vim même s'il n'y a qu'un seul onglet de gnome-terminal ouvert.

#3 [Anciennes versions] Support général » Problème de configuration de vim » 19/12/2011 14:56:46

Tuny
Réponses : 4

Bonjour à tous,

J'essaye depuis quelques temps de reprogrammer des raccouris clavier sous vim mais impossible qu'il me les prennent en compte. Je m'explique :
Sous vim, lorsqu'on utilise l'édition par onglet donné par la commande :tabedit, il faut utiliser la combinaison gt et gT pour naviguer entre les onglets.
J'aimerai pouvoir reprogrammer les raccourcis pour qu'ils deviennent CTRL+PageUp pour gt et CTRL+PageDown pour gT.
Je me suis donc attaqué à l'édition de .vimrc en y ajoutant :

map <C-PageUp> gt
map <C-PageDown> gT

Mais vim ne prends pas ces nouveaux raccourcis.

Quelqu'un aurait il une idée d'où se trouve mon erreur?

Merci d'avance à tous.

#4 Re : [Anciennes versions] Réseaux » Problème avec le Wifi. » 09/12/2011 16:23:55

Ici la seule interface qui est démarrée est ton interface cablée appelée em1.

Essaye la commande suivante dans un terminal et poste moi ce qu'elle retourne s'il y a un problème :

ifconfig wlan0 up

#5 Re : [Anciennes versions] Installation de Fedora » [Résolu] Blocage près preupgrade » 05/12/2011 15:42:04

Bon je viens de trouver la solution qui était en somme toute bête. Je tournai sur la version 4.1.2 de virtualbox et elle n'est pas compatible avec Fedora 16. J'ai simplement upgradé vbox vers la version 4.1.6 et refait la manip que j'ai décrit précedemment et ça remarche.

#6 Re : [Anciennes versions] Installation de Fedora » [Résolu] Blocage près preupgrade » 05/12/2011 15:24:35

Dernier rebondissement.

J'ai monté l'iso des additions invité avec la commande :

mount -t iso9660 /dev/cdrom /media/

Je me rends ensuite dans le dossier media et y recompile les drivers Vbox à l'aide de la commande :

sh VBoxLinuxAdditions.run

Là tout ce passe bien jusqu'aux drivers graphiques. A ce moment là j'ai le message d'erreur suivant :

Warning : unknown version of the X Window System installed. Not installing X Window System drivers.

Que puis je faire pour palier à cette erreur?

#7 Re : [Anciennes versions] Installation de Fedora » [Résolu] Blocage près preupgrade » 05/12/2011 14:58:37

Bonjour et merci pour ta réponse.

Malheuresement mon souci est différent car je suis sur une virtualbox et n'ai donc pas de drivers nvidia installés.

Bon finalement j'ai bien redemarré en mode texte et visiblement ce sont les additions invités de virtualbox qui ne passe pas. Comment puis-je faire pour les recompiler en ligne de commande?

#9 Re : [Anciennes versions] Installation de Fedora » [Résolu] Blocage près preupgrade » 23/11/2011 16:38:20

Je n'arrive pas à démarrer F16 en mode texte je suis un peu perdu avec grub 2. Sinon je l'ai démarré en mode recovery. Il démarre alors sans souci en mode texte mais je n'arrive pas à activer la prise en charge réseau.
Quelqu'un pourrait-il me sortir de là

#10 [Anciennes versions] Installation de Fedora » [Résolu] Blocage près preupgrade » 15/11/2011 14:06:29

Tuny
Réponses : 10

Bonjour à tous,

Suite à la sortie de Fedora 16 j'ai voulu mettre à jour mes différentes stations sous Fedora 15.
Ayant dû refaire mes deux systèmes après le passage de Fedora 14 vers Fedora 15 et doutant donc de la fiabilité de preupgrade j'ai commencé par tester preupgrade sur une machine virtuelle sous Fedora 15 (et grand bien m'en a pris!!)
Résultat : Le système ne démarre plus.
Il reste simplement bloqué sur le message :

Started SYSV : Late init script for live image..

Je l'ai laissé tourner pour voir s'il n'était pas un peu lent mais au bout d'une demi heure j'en ai conclu qu'il s'était carément endormi!!

Quelqu'un aurait-il une idée de l'origine de ce souci?

#11 Re : [Anciennes versions] Installation de Fedora » fedora 16 ne passe pas » 14/11/2011 10:52:20

Par quel moyen as tu téléchargé ton image cd?
As tu vérifié son checksum?

#12 Re : [Anciennes versions] Matériel » Surchaufe processeur i5 » 09/11/2011 20:10:04

Il parlait bien des pilotes proprio la réponse est donc trouvée. Pour les pilotes libres c'est ceux que je lui ai indiqué et qu'il a déjà.

#13 Re : [Anciennes versions] Installation de Fedora » Remplacer Mandriva par Fedora » 09/11/2011 20:06:20

Ca c'est certain mais c'est conseillé même quand on ne fait pas de manips incertaines.

#14 Re : [Anciennes versions] Installation de Fedora » [Résolu] Problème après preupgrade: Oh mince! ... » 09/11/2011 20:02:43

Non tu n'as toujours pas de réseau. Si tu observe bien en bas tu verra qu'il te signale que ton périphérique n'as pas pu démarré et te remonte une interruption :

Interruption:20 Mémoire:d3500000-d3520000

Il faudrait trouver ce que signifie cette interruption mais je craint qu'elle soit le signe que ton système est instable et que la préupgrade c'est mal passée.
Au pire si tu ne trouve pas ce que veut dire cette interruption tu peux essayer de sauver ton install avec le mode rescue d'un CD.

#15 Re : [Anciennes versions] Installation de Fedora » Fedora 16 live fr » 09/11/2011 19:58:18

Dans ce cas il y a une ligne à taper dans ta console et ça devrait aller mieux il me semble que c'est :

setkeymap fr

ou un truc de ce style.

#16 Re : [Anciennes versions] Installation de Fedora » fedora 16 ne passe pas » 09/11/2011 19:54:49

Oulà soit plus précis là ça relève de madame Irma de te dépanner.
Est ce une install fraiche ou une préupgrade?
As tu déjà réussi à booter?
Si oui qu'as tu fais depuis?
Si non as tu essayé de booter en mode texte et est ce que ça boot?
Pour ta version 15 c'est un dual boot?

#17 Re : [Anciennes versions] Matériel » Surchaufe processeur i5 » 09/11/2011 19:51:51

Attends un peu peut être qu'il ne sont pas encore dispo (je ne dispose malheuresement pas de ma Fedora sous la main pour tester)

#18 Re : [Anciennes versions] Réseaux » probleme wifi » 09/11/2011 19:46:01

Perso avec une carte broadcom mon wifi ne fonctionne plus depuis des mois et j'ai fini par laissé tomber après avoir tenté avec a peu près tous les paquets dispo.

#19 Re : [Anciennes versions] Installation de Fedora » [Résolu] Problème après preupgrade: Oh mince! ... » 09/11/2011 19:41:28

Oui effectivement ce que tu vois là est ta boucle locale (localhost) donc pour le moment tu n'as pas de réseau. As tu essayé de démarrer manuellement tes périphériques?

ifconfig eth0 up

ou pour du wifi (mais là je pense qu'il ne faut pas pousser!! hammer )

ifconfig wlan0 up

#20 Re : [Anciennes versions] Installation de Fedora » Remplacer Mandriva par Fedora » 09/11/2011 19:35:28

Il suffit de faire un peu de ménage avant dans les fichiers de config présents sur /home. De plus KDE et Gnome peuvent très bien avoir leurs fichiers de conf côte à côte ça ne pose aucun souci. Perso j'ai 5 environnement de bureau installés et ça ne fiche pas le bazar.

#21 Re : [Anciennes versions] Installation de Fedora » Remplacer Mandriva par Fedora » 09/11/2011 19:27:48

S'il est formaté dans un format compatible (ce qui doit être le cas) je doute que cela pose problème. Il te suffira à l'installation de Fedora de redéfinir le point de montage de cette partition comme étant /home.

#22 Re : [Anciennes versions] Matériel » Surchaufe processeur i5 » 09/11/2011 19:22:48

Il y a effectivement des drivers pour ATI. Pour cela il te suffit de regarder la doc ici puis tu as la démarche complète d'installation de drivers pour ta carte graphique ici voilà qui je pense devrait résoudre tes soucis.

#23 Re : [Anciennes versions] Installation de Fedora » [Résolu] Problème après preupgrade: Oh mince! ... » 09/11/2011 19:17:44

Si tout à fait et cela signifie que quelque chose c'est mal passé dans ta mise à jour.
Pour voir si tu as du réseau ou non fais un ifconfig et regarde si l'un de tes périphériques est connecté. (Tu le verra car dans ce cas il aura une adresse IP)

#24 Re : Le comptoir du libre » Votre bureau » 09/11/2011 18:43:10

Pas de souci Pingou. Emilien si tu as besoin d'un coup de main avec ta VM ouvre un nouveau fil et je viendrai t'aider dessus. ce sera effectivement plus profitable à tout le monde.

#25 Re : Le comptoir du libre » Votre bureau » 08/11/2011 11:01:32

Il y a normalement une option pour éviter ton souci avec nautilus. Il me semble que c'est l'option --no-desktop qu'il faut passer à nautilus au moment du lancement mais vérifie je ne voudrai pas te dire de bétises.

Pied de page des forums

Propulsé par FluxBB