Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Clap de fin pour Fedora Linux 35 !

#1 Re : [Anciennes versions] Support général » permission de fichiers » 06/05/2010 13:01:47

rp

Au hasard comme cela...
Tu n'aurais pas ajouter ton utilisateur "user" au groupe "apache" en cours de session?
En fait, d'après le "man groups", on a :

Identique  à  id  -Gn.  S'il n'y a pas de NOM_DUTILISATEUR, utiliser le
       processus courant.

"groups" te retourne donc la liste des groupes auquel tu appartiens à ce moment (en l'occurence uniquement le groupe "user").

Et par contre la commande "groups user" va lire le fichier "/etc/group" et te retourne  une autre liste des groupes auquel tu appartiens car elle a été modifiée.
Pour qu'elle soit prise en compte, il faut te déconnecter et te reconnecter.

Je pense donc que ton utilisateur a été rajouté au groupe "apache" pendant ta session...

C'est du moins mon avis au premier regard ;)

#2 Re : Aide à la création de RPM » fedora-qa : verifier le respect des règles Fedora » 01/05/2010 16:54:41

rp

Ok, merci pour la réponse.
J'avais voulu le tester car ce fil de discussion était "Épinglé" et je pensais que c'était donc toujours d'actualité ;)

#3 Re : Aide à la création de RPM » fedora-qa : verifier le respect des règles Fedora » 30/04/2010 13:53:08

rp

Hello,

Histoire de refaire quelques paquets fedora pour le plaisir, j'ai décidé de revoir les différents tutoriels existants. En effet, j'ai (hum) tout oublié.
Du coup, je me la joue petit et j'ai suivi ce tuto: https://fedoraproject.org/wiki/A_Short_RPM_Tutorial
Pas de soucis de ce côté là.

Ayant appris l'existence de ton script, j'ai voulu le tester pour voir comment il fonctionnait et là, pas de chance pour moi:


[builder@homebox tmp]$ fedora-qa hello-2.5-1.fc12.src.rpm 
/home/builder/bin/fedora-qa:42: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
Checking for updated guidelines on the wiki...
Warning: I can't check if the wiki page Guidelines has changed
Warning: I can't check if the wiki page ReviewGuidelines has changed
Starting QA for local srpm hello-2.5-1.fc12.src.rpm
Checking hello, version 2.5, release 1.fc12...
Are the name, version and release correct according to Fedora's package naming guidelines (http://fedoraproject.org/wiki/Packaging/NamingGuidelines)
(looks good to my automatic check) ([y]/n)
y
Checking source 0
Traceback (most recent call last):
  File "/home/builder/bin/fedora-qa", line 1833, in <module>
    srpm.runChecks()
  File "/home/builder/bin/fedora-qa", line 352, in runChecks
    check_item.check()
  File "/home/builder/bin/fedora-qa", line 534, in check
    urlgrabber.urlgrab(sourceUrl, reget='check_timestamp', progress_obj=urlgrabber.progress.TextMeter(fo=sys.stdout))
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 618, in urlgrab
    return default_grabber.urlgrab(url, filename, **kwargs)
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 982, in urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 886, in _retry
    r = apply(func, (opts,) + args, {})
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 968, in retryfunc
    fo = PyCurlFileObject(url, filename, opts)
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 1051, in __init__
    raise NotImplementedError, "check_timestamp regets are not implemented in this ver of urlgrabber. Please report this."
NotImplementedError: check_timestamp regets are not implemented in this ver of urlgrabber. Please report this.

So what? :)

#4 Re : [Anciennes versions] Support général » Cloner une clé usb » 26/04/2010 08:02:19

rp

Hello,

Je n'ai jamais utilisé partimage, mais plutot dd (comme l'a suggéré didierg plus haut).
Essaye un truc du genre:
dd if=/dev/sda of=sauvegardeclef.img conv=notrunc,noerror
(en supposant que /dev/sda correspond bien à ta clef USB).

Voici un lien intéressant pour la commande dd:
http://wiki.mandriva.com/fr/Copie_par_blocs_d'octets_avec_dd

#5 Re : [Anciennes versions] Réseaux » Question sur Active Directory 2K3 et client F12 » 23/04/2010 10:59:46

rp

Je confirme pour les GPO, il faut attendre samba 4.
en 2008, j'ai travaillé au sein d'une société ou l'on avait mis en place une solution basée sur du samba, du kerberos pour s'authentifier sur un active directory. On avait cherché des équivalents aux GPO mais sans succés.

Pour automatiser au maximum les choses, on avait crée des paquets personnalisés pour nos distribs. Lorsque les utilisateurs mettaient à jour leur machine, nos paquets mettaient à jour ou lançaient des scripts écrits par nos soins, des groupes de programmes, etc. Ca remplace pas les GPO, mais ça nous aidait quand même pas mal.

Pied de page des forums

Propulsé par FluxBB