Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 31 prêt à être utilisé !

#1 Re : [F31] Installation des programmes » [Résolu] Recherche " libdvdcss2 " pour handbrake » 09/11/2019 19:23:54

Le problème c'est que je n'arrive pas avec dnf et depot remi enable d'installer libdvdcss2

dnf upgrade --refresh
Fedora Modular 31 - x86_64                       29 kB/s |  19 kB     00:00    
Fedora Modular 31 - x86_64 - Updates             42 kB/s |  23 kB     00:00    
Fedora 31 - x86_64 - Updates                     46 kB/s |  23 kB     00:00    
Fedora 31 - x86_64                               40 kB/s |  20 kB     00:00    
google-earth                                     12 kB/s | 1.3 kB     00:00    
JEO repo for Fedora 31 - x86_64 - packages       29 kB/s | 3.0 kB     00:00    
Remi's Modular repository - Fedora 31 - x86_64   13 kB/s | 3.5 kB     00:00    
Remi's RPM repository - Fedora 31 - x86_64       12 kB/s | 3.0 kB     00:00    
RPM Fusion for Fedora 31 - Free - Updates        37 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 31 - Free - Updates        45 kB/s |  41 kB     00:00    
RPM Fusion for Fedora 31 - Free                  38 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 31 - Nonfree - Updates     33 kB/s | 8.6 kB     00:00    
RPM Fusion for Fedora 31 - Nonfree - Updates     17 kB/s |  13 kB     00:00    
RPM Fusion for Fedora 31 - Nonfree               38 kB/s |  11 kB     00:00    
skype (stable)                                   12 kB/s | 2.9 kB     00:00    
Dépendances résolues.
================================================================================
 Paquet                Architecture
                                   Version                      Dépôt     Taille
================================================================================
Mise à jour:
 ImageMagick           x86_64      1:6.9.10.71-1.fc31.remi      remi       69 k
 ImageMagick-libs      x86_64      1:6.9.10.71-1.fc31.remi      remi      2.4 M

Résumé de la transaction
================================================================================
Mettre à niveau  2 Paquets

Taille totale des téléchargements : 2.4 M
Voulez-vous continuer ? [o/N] : o
Téléchargement des paquets :
(1/2): ImageMagick-6.9.10.71-1.fc31.remi.x86_64 318 kB/s |  69 kB     00:00    
(2/2): ImageMagick-libs-6.9.10.71-1.fc31.remi.x 2.5 MB/s | 2.4 MB     00:00    
--------------------------------------------------------------------------------
Total                                           2.3 MB/s | 2.4 MB     00:01     
attention : /var/cache/dnf/remi-59855e15d4994a54/packages/ImageMagick-6.9.10.71-1.fc31.remi.x86_64.rpm: Entête V4 RSA/SHA256 Signature, clé ID bbae6f1b: NOKEY
Remi's RPM repository - Fedora 31 - x86_64      3.0 MB/s | 3.1 kB     00:00    
Import de la clef GPG 0xBBAE6F1B :
Utilisateur : « Remi's RPM repository (https://rpms.remirepo.net/) <remi@remirepo.net> »
Empreinte : 5F13 6145 BF10 369B 7685 D8DE 5036 66CC BBAE 6F1B
Provenance : /etc/pki/rpm-gpg/RPM-GPG-KEY-remi-31
Voulez-vous continuer ? [o/N] : o
La clé a bien été importée
Test de la transaction
La vérification de la transaction a réussi.
Lancement de la transaction de test
Transaction de test réussie.
Exécution de la transaction
  Préparation           :                                                   1/1 
  Exécution du scriptlet: ImageMagick-libs-1:6.9.10.71-1.fc31.remi.x86_64   1/4 
  Mise à jour de        : ImageMagick-libs-1:6.9.10.71-1.fc31.remi.x86_64   1/4 
  Mise à jour de        : ImageMagick-1:6.9.10.71-1.fc31.remi.x86_64        2/4 
  Nettoyage de          : ImageMagick-1:6.9.10.67-1.fc31.x86_64             3/4 
  Nettoyage de          : ImageMagick-libs-1:6.9.10.67-1.fc31.x86_64        4/4 
  Exécution du scriptlet: ImageMagick-libs-1:6.9.10.67-1.fc31.x86_64        4/4 
  Vérification de       : ImageMagick-1:6.9.10.71-1.fc31.remi.x86_64        1/4 
  Vérification de       : ImageMagick-1:6.9.10.67-1.fc31.x86_64             2/4 
  Vérification de       : ImageMagick-libs-1:6.9.10.71-1.fc31.remi.x86_64   3/4 
  Vérification de       : ImageMagick-libs-1:6.9.10.67-1.fc31.x86_64        4/4 

Mis à niveau:
  ImageMagick-1:6.9.10.71-1.fc31.remi.x86_64                                    
  ImageMagick-libs-1:6.9.10.71-1.fc31.remi.x86_64                               

Terminé !

[root@localhost ~]# dnf install libdvdcss2
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:00:40 le sam. 09 nov. 2019 18:18:47 CET.
Aucune correspondance pour l’argument : libdvdcss2
Erreur : Impossible de trouver une correspondance: libdvdcss2
[root@localhost ~]# 

et qu'il faut faire :
# dnf install libdvdcss

#2 Re : [F31] Support général » [Résolu] Thunderbird repasse en anglais » 03/11/2019 20:32:49

Bonsoir ,
j'ai fais plus simple, mais ce n'était pas évident, car pas logique selon l'historique de Thunderbird
/Edition/Préférences/Rédaction/Télécharger d'autres dictionnaires.

#4 Re : [F30] Matériel » Support Raspberry Pi 4 B » 09/10/2019 11:50:14

sur F30 un :
$ cat /usr/share/doc/arm-image-installer/SUPPORTED-BOARDS | grep rpi

arndale chiliboard cl-som-am57x rpi2 rpi3 olpc_xo175

donc par rpi4 pour l'instant

#5 Re : [F30] Matériel » fedora server 30 sur raspberry Pi3 B+ » 07/09/2019 19:52:37

Rajoutez 2 lignes au fstab

$ sudo nano /etc/fstab

tmpfs /tmp tmpfs defaults,noatime,nosuid,size=100m 0 0
tmpfs /var/tmp tmpfs defaults,noatime,nosuid,size=30m 0 0

sauvegarde et contrôle

$ sudo reboot
$ df -h

/tmp  et /var/tmp   apparaissent les valeurs 100m et 30m peuvent être modifées en fonction des besoins et de la ram

#6 Re : [F30] Matériel » fedora server 30 sur raspberry Pi3 B+ » 07/09/2019 08:05:45

j’attends la pi4 pour voir les performances avec la séparation des ports usb

#10 Re : [F30] Support général » [Résolu] oom-kill n'est-il pas un peu trop agressif? » 17/06/2019 18:11:01

Est-ce des fuites de mémoires ? , des tmp/tmps non vidés ?
Dans mon cas pour le swap, l'origine de de la surcharge est Firefox qui après fermeture ne vide pas le cache swap. ( Pour le cas où je reviens sur le site. Mais R.A.F, la fibre est là et les compteurs de cookies ou autres trackers se rechargent -> stat des connexions bidons.)
A l'heure ou nos machines ont des SSD ("rapide") et autres TMPS qui tournent vite, de la mémoire à gogo et pas chère, les développeurs ne prennent pas garde à vider l'historique s'il y a demande pressante de l'utilisateur. D'où la méthode bourrin. Le swapoff met les données dans la ram => vérifier avant, l'état de la ram.
Par contre si tu travailles avec une machine poussive avec peu de RAM, cela devient vite rédhibitoire. J'ai un Q6600 avec 2 Go de Ram et F30 64 bits dessus. Machine de 2006 . Pour la bureautique cela suffit. Les 95W du processeur me chagrine malgré tout.
C'est une histoire de rigueur de codage.
Concernant les VM, ces remarques s'appliquent également.

Pour info, j'ai appris a coder sur cartes perforées puis en assembleur sur 8086 puis ses enfants, et quand les interfaces graphiques sont arrivées, j'ai laissé tombé car gaspillages de ressources. Je n'ai plus retrouvé l'élégance du codage. Je m'amuse encore avec Python.

Malgré tout, Madko et Vindicators vos propos sont justes. wink

Je parle pour les Desktops avec interface bureautique.
Concernant les serveurs purs c'est mieux concernant les problèmes de fuites. Quoique ,,, pour les applicatifs cloud je m'interroge.

#11 Re : [F30] Support général » [Résolu] oom-kill n'est-il pas un peu trop agressif? » 17/06/2019 06:00:34

Bonjour, j'ai également constaté que le swap ne se vidait pas totalement après avoir clôt tous les applicatifs.
La seule solution que j'ai trouvé pour vidé le swap est :

# swapoff -a && swapon -a &

Méthode bourrin je le reconnais

Pour la ram

$ watch -n 1 cat /proc/meminfo

## pour nettoyer

# sync && echo 3 | tee /proc/sys/vm/drop_caches

#12 Re : [F30] Support général » [Résolu] Figer un kernel » 09/06/2019 09:16:06

Autre solution dans le fichier /etc/dnf/dnf.conf,
rajouter à la fin la ligne : exclude=kernel*

#13 Re : [F30] Matériel » Pilote "nouveau" à mettre à jour ? » 07/06/2019 18:41:38

Ânerie du post # 29 corrigée . Inattention de rédaction.

#14 Re : [F30] Matériel » Pilote "nouveau" à mettre à jour ? » 06/06/2019 20:56:31

la commande ,  su - , consiste à demander à travailler en root ( avec demande du mot de passe root. Tu as tous les droits sur ton O.S. Sous Ubuntu la commande sudo -s est équivalente.
la commande sudo, consiste à faire comme si ....
Tout travail de compilation demande à être en root user. Cela veut dire, une maîtrise totale des tenants et aboutissants de l'environnement "root" et "user". Tes professeurs ont dû t'apprendre la responsabilité du codage.
Bonne chance.

Padawan -> Jedi ? Le grand saut vers des territoires inconnus cool

#15 Re : [F30] Matériel » Pilote "nouveau" à mettre à jour ? » 06/06/2019 19:45:03

Si tu es pressé de mettre "nouveau" à jour, tu prends la solution du post #11
tu installes les outils rpm
https://doc.fedora-fr.org/wiki/RPM_:_en … nstruction
tu modifies le fichier spec en installant au préalable les *.devel  puis sur le fichier *.spec "modifiable" selon ta conf, par ex :

%define xorg_ver %(pkg-config xorg-server --modversion|cut -d. -f 1-2)
Name:          xorg-drv-video-nouveau
Version:       1.0.16
Release:       Fedora
Summary:       X.Org accelerated Open Source video driver for nVidia cards
Group:         System/X11
Vendor:        Fedora
Distribution:  Fedora
Packager:      Antbel <antbel@fedora.fr>
URL:           http://x.org
Source:        ftp://x.org/pub/individual/driver/xf86-video-nouveau-%{version}.tar.bz2
License:       MIT
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libcap-devel
BuildRequires: libdrm-devel
BuildRequires: libpcre-devel
BuildRequires: libselinux-devel
BuildRequires: libsepol-devel
BuildRequires: libudev-devel
## AUTOBUILDREQ-END
BuildRequires: xorg-server-devel >= 1.20.4
BuildRequires: xproto-devel
Requires:      xorg-server >= %{xorg_ver}
Requires:      xorg-server <= %{xorg_ver}.255
BuildRoot:     %{_tmppath}/%{name}-%{version}-root

%description
X.Org accelerated Open Source video driver for nVidia cards.

%prep
%setup -q -n xf86-video-nouveau-%{version}

%build
%configure
%make

%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall

%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"

%files
%defattr(-,root,root)
%{_libdir}/xorg/modules/drivers/nouveau_drv.la
%{_libdir}/xorg/modules/drivers/nouveau_drv.so
%{_mandir}/man4/nouveau.4.gz

%changelog
* repris pour test par antbel pour carabao

* Sun Mar 03 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.16-2mamba
- rebuilt with xorg-server 1.20.4

* Fri Feb 01 2019 Automatic Build System <autodist@mambasoft.it> 1.0.16-1mamba
- automatic version update by autodist

* Thu Dec 07 2017 Automatic Build System <autodist@mambasoft.it> 1.0.15-2mamba
- rebuild with xorg-server 1.19.5

* Sun Aug 13 2017 Automatic Build System <autodist@mambasoft.it> 1.0.15-1mamba
- automatic version update by autodist

* Sat Mar 18 2017 Automatic Build System <autodist@mambasoft.it> 1.0.14-1mamba
- automatic version update by autodist

* Mon Sep 26 2016 Automatic Build System <autodist@mambasoft.it> 1.0.13-1mamba
- automatic version update by autodist

* Fri Jan 15 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.12-1mamba
- update to 1.0.12

* Fri Aug 21 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.11-2mamba
- rebuilt with xorg-server 1.17.2

* Wed Mar 04 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.11-1mamba
- update to 1.0.11

* Sat Jun 14 2014 Automatic Build System <autodist@mambasoft.it> 1.0.10-2mamba
- X.org 1.15 rebuild

* Thu Dec 12 2013 Automatic Build System <autodist@mambasoft.it> 1.0.10-1mamba
- automatic update by autodist

* Mon Aug 12 2013 Automatic Build System <autodist@mambasoft.it> 1.0.9-1mamba
- automatic update by autodist

* Fri Jun 14 2013 Automatic Build System <autodist@mambasoft.it> 1.0.8-1mamba
- automatic version update by autodist

* Sun Mar 31 2013 Automatic Build System <autodist@mambasoft.it> 1.0.7-1mamba
- automatic version update by autodist

* Thu Jan 10 2013 Automatic Build System <autodist@mambasoft.it> 1.0.6-1mamba
- automatic version update by autodist

* Fri Nov 16 2012 Automatic Build System <autodist@mambasoft.it> 1.0.4-1mamba
- automatic version update by autodist

* Wed Oct 10 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.2-2mamba
- rebuilt with xorg-server 1.12

* Tue Oct 09 2012 Automatic Build System <autodist@mambasoft.it> 1.0.2-1mamba
- automatic version update by autodist

* Thu Jun 07 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0.16.git20120113-3mamba
- automatic update by autodist

* Fri Feb 17 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0.16.git20120113-2mamba
- automatic update by autodist

* Fri Jan 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0.16.git20120113-1mamba
- update to 0.0.16.git20120113

* Fri Jan 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0.16-3mamba
- updated to git 20120113

* Tue Aug 09 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0.16-2mamba
- rebuilt with xorg-server 1.10

* Fri Oct 01 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0.16-1mamba
- package created

et tu testes en souhaitant que pour ta carte cela marche.

J'espère que ta participation fera avancer le schimmliii blickk selon G.Lux

#16 Re : [F30] Support général » [Résolu] firefox message SSL_ERROR_DECODE_ERROR_ALERT » 06/06/2019 19:27:24

Problème résolu ?
donc active "Résolu" dans ton ticket ?
C'est plus propre pint

#17 Re : [F30] Matériel » Pilote "nouveau" à mettre à jour ? » 05/06/2019 18:23:33

Solution un peu rude , car réactiver la carte demande des droits root, puis lancer ton applicatif en user .Je pense que la meilleure solution est d'essayer avec akmod.

#18 Re : [F30] Matériel » Pilote "nouveau" à mettre à jour ? » 05/06/2019 18:02:00

Sinon tu as la solution d'installer le akmod nvidia

#19 Re : [F30] Matériel » Pilote "nouveau" à mettre à jour ? » 05/06/2019 17:52:08

Si tu n'as pas beaucoup besoin de 3D , tu peux désactiver ta carte nvidia, et c'est au moment de lancer ton /tes programmes 3D que tu réactives la 3D. Par exemple, sur la ligne Exec du fichier bureau  xxx.desktop

Exec= sudo echo ON > /sys/kernel/debug/vgaswitcheroo/switch &&  firefox %u

#20 Re : [F30] Matériel » Pilote "nouveau" à mettre à jour ? » 05/06/2019 17:35:17

Comme tu as un processeur graphique intel. Que ce passe-t-il quand ta carte nvidia est désactivée ?
https://doc.fedora-fr.org/wiki/Prime#Fo … des_cartes

#22 Re : [F30] Matériel » Pilote "nouveau" à mettre à jour ? » 05/06/2019 17:21:49

Bonjour, les pilotes sont mis à jour quand du matériel et/ou technologie récente arrive sur le marché.
Sur "d'anciens" matériel il peut y avoir des bugs comme tu le montres dans ton post#3, si cela n'est pas bloquant, les erreurs restent et Madko n'a pas obtenu sa réponse.

NB: Ne jamais oublié que nouveau c'est du rétro-ingéniering.
https://fr.wikipedia.org/wiki/R%C3%A9tr … formatique

#25 Re : [F30] Matériel » Pilote "nouveau" à mettre à jour ? » 02/06/2019 15:32:38

Le projet continu toujours le 30 avril 2019 la version 1.0.16 a été délivrée pour fedora. C'est donc récent

https://repology.org/project/xdrv:nouveau/history

Pied de page des forums

Propulsé par FluxBB