Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 31 c'est fini

#1 [Anciennes versions] Support général » Chromium & google-chrome super lent » 28/06/2017 17:42:05

elbelo69
Réponses : 0

Bonjour,

Je suis en 4.11.6-201.fc25.x86_64 depuis hier et depuis cette mise à jour chromium et google-chrome sont inutilisable tellement c'est lent !
J'ai effacé mon profile chrome (~/.config/google-chrome et chromium) mais rien n'y fait.
Pas d'erreur, les seuls erreurs trouvés sont

[804.900827] QDBusConnection[4732]: segfault at 7fe4ccac0270 ip 00007fe4f12b3f8d sp 00007fe4e98af9c0 error 4 in libQt5Core.so.5.7.1[7fe4f1043000+478000]
[ 804.902316] QDBusConnection[4723]: segfault at 7f3a885b6270 ip 00007f3aacd17f8d sp 00007f3aa53139c0 error 4 in libQt5Core.so.5.7.1[7f3aacaa7000+478000]

mais je ne sais pas si ces erreurs sont apparues après update.

Je ne sais pas ou regarder et quoi chercher .... toutes idées est la bienvenue !
D'avance merci

#2 Re : [Anciennes versions] Réseaux » installatioin de OpenVPN » 10/05/2017 10:04:09

Salut,

Non ce n'est pas idiot mais c'est étrange comme besoin.
Un VPN est un tunnel crypté permettant d'interconnecté des réseaux.
D'après ta description, j'ai l'impression que tu cherche plutôt à te servir de A comme passerelle ?
Dans ce cas, pas besoin de VPN !
Tu dispose de switch réseau, combien de carte réseau dispose tu sur A ?

#3 Re : [Anciennes versions] Installation des programmes » Activer le https sous fedora » 09/05/2017 23:50:00

Auto signé .... pour avoir le petit verrou ouvert, Firefox qui râle etc ...
Je conseil largement l'initiative Open Source révolutionnaire ! https://letsencrypt.org/   (c'est plus qu'une mode pour moi : c'est une révolution ! En plus, pour une fois, la NSA n'a pas la master clé !  cool )
Un vrai certificat, signé par API, avec une chaîne de certificat trusté !
C'est du caviar ! J'utilise ça en production depuis Février 2016.
En plus, même un Windowsien s'en sort tellement c'est simple depuis certboot ! https://certbot.eff.org/

#4 Re : [Anciennes versions] Réseaux » installatioin de OpenVPN » 09/05/2017 23:44:01

Salut,
Le server coté Freebox. Ca tombe bien la freebox implement un serveur VPN wink

Dans l'interface de ta freebox, tu coche activer le VPN. force le port 443 (tu passera de partout 443 = SSL ouvert sur la grande majorité des proxy).
Ensuite tu peux télécharge le fichier de configuration du client VPN, tu le colle sur ta machine client et

sudo openvpn --config <LE_FICHIER_DONNE_PAR_LA_FREE_BOX>

Sudo car openvpn va modifié ta table de routage et seul root peut faire ça.
Et te voila connecté chez toi, enfin sur ton LAN

Il y a plusieurs mode de VPN : ROUTé, BRIDGé. Le choix de le configuration dépends de ce que tu veux faire.
Tu peux m'en dire plus ?

#5 Re : [Anciennes versions] Réseaux » [Résolu] réseau routed avec libvirt » 08/03/2017 17:34:27

Bonjour,

>Je cherche à faire un bridge pour mes machines virtuelles afin qu'elles soient sur le même réseau que mes autres machines réelles.

Donc tu as une machine qui est connectée à un réseau ou il y a d'autre machines. Tu veux que tout le monde communique avec tout le monde c'est bien ça ?

Si oui c'est relativement simple :

virsh iface-bridge eth0 vbr0

Pour créer l'interface bridge.
Ensuite il faut activé le routage sur les interfaces (par defaut depuis F23 il me semble)

echo 1 > /proc/sys/net/ipv4/ip_forward # Prend effet de suite 
echo "net.ipv4.ip_forward=1" >>/etc/sysctl.conf   # Pour activé le routage lors d'un reboot 

Ensuite tu crée ta vm en forçant l'interface.



virt-install --vcpus=2 --ram=1024 --name=Fedora25server --file=/home/vm/Fedora25server.qcow2 \
  --cdrom=/home/vm/iso/F25NetWorkInstall.iso --hvm --network bridge:vbr0

Attention, par défaut il faut un DHCP sur ton réseau, sinon l'interface bridge n'aura pas d'adresse.

Petite précision :
>J'utilise comme hyperviseur libvirt.
libvirt n'est pas un hyperviseur, mais une API qui te permet de manipuler des hyperviseurs (KVM, QEMU, VirtualBox et même HyperV il me semble)

#6 [Anciennes versions] Fedora Cloud & Fedora Server » 389 Directory Server » 16/09/2016 19:28:36

elbelo69
Réponses : 0

Bonjour,

J'ai installé et configuré un annuaire 389.
J'ai associé mon gitlab sur ce server ldap, je peux me loguer etc... tout va bien.

Je cherche a dire à Gitlab, qu'il ne doit autoriser que les utilisateurs d'un groupe.
Je prend mon client ldap préféré pour tester ma requête et je me rends compte que mes users ne dispose pas de l'attribut memberof.
Comment puis-je m'en sortir ?
Pourquoi cet attribut n'est pas là par défaut. J'ai activé le plugin mais ca ne change rien ...

Une idée ?
D'avance merci

#7 Re : [Anciennes versions] Support général » imprimante réseau avec freebox » 20/07/2016 15:46:03

Bonjour,
Sur la freebox V6 (revolution), tu as une interface web qui te permet de "piloter" certaine fonctions de la freebox (dhcp, DECT, forward de port, NAT ...)
Dans la partie "Partage Windows" il te faut cocher la case "partagez cette imprimante"
C'est fait sur ta freebox ?

La freebox ne peut que reconnaître ton imprimante, du moins pour les fonction de base. ipp (Internet Printing Protocol ) est un standard supporté par tous les constructeurs. En revanche tu n'auras peu être pas accès au niveau d'encre et autre options, en générale spécifiques, et codées uniquement dans le drivers Windows ...

#9 Re : [Anciennes versions] Support général » imprimante réseau avec freebox » 18/07/2016 15:40:54

Bonjour,

Passe par CUPS, http://localhost:631
Tu te log en root, tu ajout l'imprimante et roule ma poule.

#10 Re : [Anciennes versions] Support général » Disque dur USB "retiré sans risque" qui remonte tout seul » 13/07/2016 11:06:37

Salut,
Je vois un vboxdrv ...tu as un VM de lancé ?
Le port usb ou ton disque est connecté ne serais pas présenté à ta VM ?

#11 Re : [Anciennes versions] Support général » [Résolu] ZenBook ux501j » 13/07/2016 10:48:58

J'ai pas eu le temps de répondre.
C'était un défaut matériel !!! Le sonde au niveau du CPU était morte.
ASUS me l'as remplacé a neuf !

#12 Re : [Anciennes versions] Support général » Docker Fedora 24 » 13/07/2016 10:45:53

Bonjour,
Bon, ba je sais pas pourquoi, après redémarrage du docker daemon ca n'a rien changé mais parès un redémarrage complet de la machine, c'est ok.
J'ai l'impression que le pont entre docker0 et mon réseau étais sur la carte wifi, connecté à un réseau sans internet....
Comment est déclaré l'interface docker0 ?

#13 Re : [Anciennes versions] Support général » imprimante réseau avec freebox » 12/07/2016 18:19:16

Bonjour

HeyHoLet'sGo a écrit :

l'imprimante est connectée au port usb arrière de la box comme préconnisé. elle n'a pas de port ethernet
et elle fonctionne tres bien sur mon pc.

Tu veux dire sous Windows ?

#14 [Anciennes versions] Support général » Docker Fedora 24 » 12/07/2016 18:16:54

elbelo69
Réponses : 3

Bonjour,

Pour un besoin spécifique, je télécharge l'image de base officiel de Fedora 24 sur https://getfedora.org/en/cloud/download/docker.html
Je charge l'image, je lance un container et dans ce container impossible de faire un dnf update, install ou autre.
J'ai invariablement la même erreur :

[root@65c907604381 /]# dnf update
Error: Failed to synchronize cache for repo 'fedora'
[root@65c907604381 /]# 

Une idée ?

#15 Re : [Anciennes versions] Support général » [Résolu] [Docker ] Error building images: cannot connect to Docker endpoint » 12/07/2016 17:46:46

Bonjour, depuis les update (je ne sais pas exactement lesquels) de juillet, plus de problème .....

#16 [Anciennes versions] Support général » [Résolu] [Docker ] Error building images: cannot connect to Docker endpoint » 29/06/2016 19:57:49

elbelo69
Réponses : 1

Bonjour,

Je démarre un docker de la façon suivante :

sudo docker run --name=vp0 --restart=unless-stopped -it -p 5000:5000 -p 30303:30303 -e CORE_PEER_ID=vp0 -e CORE_VM_ENDPOINT=http://172.17.0.1:4243 -e CORE_PEER_ADDRESSAUTODETECT=true VfxDocker/latest <MACOMMANDE>

Jusque là, pas de problème.

Dans un autre shell, je me connecte a ce même docker

sudo docker exec -it vp0 bash

Même chose, pas de problème. Avec ps, je vois <MACOMMANDE> etc ...
Je lance maintenant une autre commande qui va forcer mon docker à écrire.

Et là, c'est le drame, dans les log du container:

16:57:50.553 [dockercontroller] deployImage -> ERRO 019 Error building images: cannot connect to Docker endpoint
16:57:50.556 [dockercontroller] Start -> ERRO 01a start-could not recreate container cannot connect to Docker endpoint

Je précise que :
Dans /etc/sysconfig/docker, j'ai ajouté l'option (pour le docker daemon) : -H tcp://0.0.0.0:2375 -H unix:///var/run/docker.sock comme suite :

..
# Modify these options if you want to change the way the docker daemon runs
OPTIONS='-H tcp://0.0.0.0:2375 -H unix:///var/run/docker.sock --selinux-enabled --log-driver=journald'
DOCKER_CERT_PATH=/etc/docker

J'ai désactivé mon firewall au cas ou.
J'ai tout lancé en sudo, au cas ou
J'ai désactivé selinux,  au cas ou
Le pont réseau du docker daemon et bien sur 172.17.0.1

[vincent@vfx ~]$ ifconfig
docker0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 172.17.0.1  netmask 255.255.0.0  broadcast 0.0.0.0
        inet6 fe80::42:99ff:fe51:ddd  prefixlen 64  scopeid 0x20<link>
        ether 02:42:99:51:0d:dd  txqueuelen 0  (Ethernet)
        RX packets 38650  bytes 2076859 (1.9 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 73329  bytes 111761834 (106.5 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
....

Le fichier socket et bien là :

[vincent@vfx ~]$ ll /var/run/docker.sock
srw-rw---- 1 root docker 0 29 juin  19:54 /var/run/docker.sock


Le problème est directement lié à Fedora, sur Debian (testing), pas de problème.
Je ne sais plus quoi faire, quelqu'un aurais une idée ?

#17 Re : [Anciennes versions] Réseaux » serveur d'applications » 28/06/2016 09:35:40

Bonjour,
Il faudrait être un peu plus précis sur tes besoins .....
Qu'est ce que c'est pour toi un serveur d'application ?

#18 Re : [Anciennes versions] Support général » creation d"un live fedora avec mon ks perso » 28/06/2016 09:34:36

Bonjour,

Je n'ai pas dis que ce n'étais pas possible, au contraire, j'ai juste dis que je ne savais pas comment faire.
Mais maintenant je sais ! Merci beaucoup.

#19 Re : [Anciennes versions] Support général » creation d"un live fedora avec mon ks perso » 23/06/2016 14:33:49

Bonjour,

La phylosophie du kickstart n'est pas exactement là. Le kickstart permet de répéter une installation (beaucoup utiliser avant l'arrivé des clonezilla etc qui on grandement simplifié la vie du sys admin que j'étais).
Néanmoins, tu peux faire ce que tu souhaite mais en trichant :

Tu extrait l'image
Tu pousse ton kickstart dans l'arbo
Tu force ton grub a utiliser le kickstart quand tu boot sur ton image avec un linux ks=cdrom:/ks-dev.cfg  par exemple.

Je ne connais pas de méthode qui te permette de ne prendre dans l'image que ce que tu installe, mais ça doit être possible.

Si tu souhaite faire un iso de TON installation pour pourvoir la restauré plus vite, clonezilla offre cette possibilité.
Tu installe ta fedo, tu boot sur clonezilla et tu demande à clonezilla de généré une iso de restauration de ton système.

#20 Re : [Anciennes versions] Réseaux » [Résolu] Impossible d'utilise mes vpn » 30/05/2016 17:40:05

Salut,

le VPN ne fonctionne pas, cad ? Tu es connecté ou ça plante avant ?
Ca ne serais pas simplement un problème de DNS ? Moi j'ai eu le problème avec dnsMasq depuis son arrivé sur F22 je crois... Il faut déclarer l'interface réseau et la route.
http://www.foell.org/justin/rerouting-v … h-dnsmasq/

#21 Re : [Anciennes versions] Matériel » [Résolu] UX501 Assus et GTX 960M » 30/05/2016 17:35:32

Bonjour,

Merci pour vos conseils, mais j'avais DÉJÀ suivie ce tuto.
J'ai trouvé mon bonheur sur un forum de Arch Linux https://wiki.archlinux.org/index.php/Bumblebee

J'ai écris mon xorg.conf à la main pour que le driver utilise bien le bon bus ID et plus de problème.
Merci encore.

#22 [Anciennes versions] Matériel » [Résolu] UX501 Assus et GTX 960M » 26/05/2016 17:40:31

elbelo69
Réponses : 6

Bonjour,

Je cherche a faire fonctionner mon Asus UX501 avec Bumblebee mais voilà ...
La machine dispose d'une carte GTX 960M
Mais :

[root@ux501 ~]# lspci  | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Crystal Well Integrated Graphics Controller (rev 08)

Mais

[root@ux501 ~]#  lspci | grep NVIDIA
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 960M] (rev a2)

Donc la carte est bien là !
Quand j'installe kmod-nvidia, le serveur X ne démarre plus, pareil avec akmod, et toujours pareil avec akmod + bumblebee

Je ne sais pas trop quoi faire et je ne trouve pas grand chose sur le web...

#23 Re : [Anciennes versions] Réseaux » SSH Agent forwarding » 26/05/2016 17:24:30

Salut,

Il me semble que tu dois te connecter sur Machine 1 avec un ssh -A
Ensuite, si depuis Machine 1 tu te connecte à Machine 2, la clé fourni sera celle te ton host car tu forward ssh-agent.
Moi je m'en sert comme ça. C'est bien ça que tu souhaite ?
Peut être est ce possible de le faire en une seul commande mais effectivement par grand chose sur le web.

#24 Re : [Anciennes versions] Matériel » MFC 7365 N & Fedora 23 » 26/05/2016 17:16:21

Bonjour,

Tu as essayé de désactivé le firewall (temporairement) pour voir ?

systemctl stop firewalld

J'ai eu le soucis avec un multifonction lier au protocole Bonjour.
Juste une idée ...

#25 Re : [Anciennes versions] Support général » [Résolu] DHCP Orange Livebox Play » 25/01/2016 18:10:49

Bonjour,

Moi je fais ça avec un routeur qui n'est pas une live box et je n'ai pas de problème ....
A priori bcp de problème avec la live box play  .. : http://communaute.orange.fr/t5/ma-conne … d-p/538194

Pied de page des forums

Propulsé par FluxBB