Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora-Fr aux 15èmes Rencontres Mondiales du Logiciel Libre

#1 04/12/2004 00:53:22

silk
Membre
Inscription : 28/11/2004
Messages : 18

Probleme d'installation de Java j2se5.0 pour firefox 1.0

J ai essaié d'installer java automatiquement avec firefox il veut pas!! Dc j'installes Java comme suit:

Installation of Self-Extracting Binary
Use these instructions if you want to use the self-extracting binary file to install the JDK. If you want to install RPM packages instead, see Installation of RPM File.

1. Download and check the download file size to ensure that you have downloaded the full, uncorrupted software bundle.

    You can download to any directory you choose; it does not have to be the directory where you want to install the JDK.

    Before you download the file, notice its byte size provided on the download page on the web site. Once the download has completed, compare that file size to the size of the downloaded file to make sure they are equal.

2. Make sure that execute permissions are set on the self-extracting binary.

    Run this command:
    chmod +x jdk-1_5_0_<version>-linux-i586.bin

3. Change directory to the location where you would like the files to be installed.

    The next step installs the JDK into the current directory.

4. Run the self-extracting binary.

    Execute the downloaded file, prepended by the path to it. For example, if the file is in the current directory, prepend it with "./" (necessary if "." is not in the PATH environment variable):

    ./jdk-1_5_0_<version>-linux-i586.bin

    The binary code license is displayed, and you are prompted to agree to its terms.

    The JDK files are installed in a directory called jdk1.5.0_<version> in the current directory. Follow this link to see its directory structure. The JDK documentation is a separate download.


Quand je retourne sur ma page web rien!! J ai essaié de bidouiller rien y fait!!

De plus je n arrive pas a mettre firefox en francais!!
Car j avais reussi mais j ai fait un yum update et redevenu en UK. Et maintenant les xpi que j ai ne mache plus!!

J'espere que qq un aura la bonté de m'aider ds ca monde infernal q est fedora au debut!! lol

Merci d'avance pour votre

Ps: Firefox derniere version et Fedora Core 3 sous Gnome

Hors ligne

#2 04/12/2004 01:04:50

Marcet
@HappyDino
Modérateur
Lieu : Ile de France
Inscription : 11/11/2004
Messages : 5 916
Site Web

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

Pour installer le Java Plug-in de Firefox, il faut utiliser la commande

yum install mozilla-j2re

Fedora : "A consommer sans modération !"

Hors ligne

#3 04/12/2004 02:37:55

silk
Membre
Inscription : 28/11/2004
Messages : 18

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

tu me dire de faire j essaie meme si je l avais fait sans yum !!!

Ca marche pas!!

Lorsque je vais sur une page web contenant du java le navigateur se ferme (sans que j ai rien demandé)!!!

Merci pour votre aide mais une aide plus développé???? Parce q il n y apas que moi ki est ce pb....

Hors ligne

#4 04/12/2004 02:41:39

silk
Membre
Inscription : 28/11/2004
Messages : 18

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

tu me dire de faire j essaie meme si je l avais fait sans yum !!!

Ca marche pas!!

Lorsque je vais sur une page web contenant du java le navigateur se ferme (sans que j ai rien demandé)!!!

Merci pour votre aide mais une aide plus développé???? Parce q il n y apas que moi ki est ce pb....

Hors ligne

#5 04/12/2004 12:23:10

Marcet
@HappyDino
Modérateur
Lieu : Ile de France
Inscription : 11/11/2004
Messages : 5 916
Site Web

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

Si tu veux qu'on t'aide, il va d'abord falloir abandonner le style SMS qui est vraiment chiant à lire.

Bon, maintenant que c'est dit... Regarde dans les logs pour voir si tu as un message d'erreur au moment de la fermeture du navigateur. Et donnes nous un peut plus de détail sur ta config.


Fedora : "A consommer sans modération !"

Hors ligne

#6 04/12/2004 12:40:16

fredgalu
Membre
Lieu : le pays du bon vin
Inscription : 15/11/2004
Messages : 77

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

Salut,
Idem pour moi, installation de mozilla-j2re avec yum.
Lors de la visite d'une page contenant du java,(ex:l'horloge parlante: http://www.horlogeparlante.com/)
Fermeture de Firefox.

J'ai essayé les 3 liens vers les plugins de java:
1 /usr/lib/jre/plugin/i386/ns4/libjavaplugin.so
2 /usr/lib/jre/plugin/i386/ns610/libjavaplugin_oji.so
3 /usr/lib/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so

sad

Puis, je ne sais pas si cela a un rapport, mais j'ai installé gcc.
Création d'un lien symbolique de 3 (voir plus haut) vers /usr/lib/mozilla/plugins

Et, big_smile


......
Santé & prospérité.
pint .........

Hors ligne

#7 04/12/2004 14:30:27

Marcet
@HappyDino
Modérateur
Lieu : Ile de France
Inscription : 11/11/2004
Messages : 5 916
Site Web

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

Je viens d'essayer le site dont tu parles (horloge parlante). Pas de plantage pour moi. Ma machine utilise le dernier kernel (681) et est à jour.


Fedora : "A consommer sans modération !"

Hors ligne

#8 04/12/2004 17:31:06

fredgalu
Membre
Lieu : le pays du bon vin
Inscription : 15/11/2004
Messages : 77

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

Salut,
Je ne sais pas si tu m'as compris mais je voulais dire qu'après ces manip., le plugin fonctionne.


......
Santé & prospérité.
pint .........

Hors ligne

#9 04/12/2004 17:34:28

Marcet
@HappyDino
Modérateur
Lieu : Ile de France
Inscription : 11/11/2004
Messages : 5 916
Site Web

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

Effectivement, je n'avais pas compris que çà marchait.

Super...


Fedora : "A consommer sans modération !"

Hors ligne

#10 04/12/2004 18:50:11

Invité

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

J'ai un peu le même problème
J'ai lancé l'installation de jdk-1_5_0-linux-i586.rpm
rien ne se passait.

J'ai donc fait les liens sous /usr/lib/firefox-1.0/plugins et dans usr/lib/mozilla/plugins comme décrit plus haut.

mais toujours rien alors que le plugin de flashplayer a fonctionné du premier coup. Quelqu'un a t'il une idée ?

sad

#11 04/12/2004 20:46:59

herrib
Retraité
Lieu : Rennes
Inscription : 04/12/2004
Messages : 3 736

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

Que donne, sous Firefox, la commande (dans la fenêtre de navigation): about:plugins ?

Si le plugin apparaît bien dans la liste, il faut encore vérifier les droits associés au fichier cible du lien.


Solaris 11, Scientific Linux 6.1. FC15 en virtualisation.

Hors ligne

#12 04/12/2004 21:08:38

Invité

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

J'ai fait cette commande mais le plugin n'apparait pas ??

#13 04/12/2004 21:14:59

herrib
Retraité
Lieu : Rennes
Inscription : 04/12/2004
Messages : 3 736

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

Le lien ne semble donc pas créé. Que donne un  ls -l /usr/lib/firefox-1.0/plugins ?


Solaris 11, Scientific Linux 6.1. FC15 en virtualisation.

Hors ligne

#14 04/12/2004 21:18:21

Bibelosse
Membre
Lieu : POMPIGNAC
Inscription : 29/08/2004
Messages : 100

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

voici le résultat..

-rwxr-xr-x  1 1006 wheel 2096844 mai 20  2004 libflashplayer.so
-rwxr-xr-x  3 root root    77040 sep 15 15:18 libjavaplugin_jni.so
-rwxr-xr-x  3 root root   267264 sep 15 15:18 libjavaplugin_nscp.so
-rwxr-xr-x  2 root root   134116 sep 15 15:18 libjavaplugin_oji.so
-rwxr-xr-x  1 root root    16304 nov 11 07:18 libnullplugin.so


.........

Hors ligne

#15 04/12/2004 21:50:49

fredgalu
Membre
Lieu : le pays du bon vin
Inscription : 15/11/2004
Messages : 77

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

Salut,
N'y-a-t-il pas trop de "plugins" java ?
Dur de faire un choix.
Voici mes plugins:
ls /usr/lib/mozilla/plugins:
flashplayer.xpt    libjavaplugin_oji.so  nphelix.so
libflashplayer.so  mplayerplug-in.so     nphelix.xpt

Tout roule........


......
Santé & prospérité.
pint .........

Hors ligne

#16 04/12/2004 23:38:05

Invité

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

Personnellement j'ai suivi le guide d'installation sur le site de sun et tout marche nikel

http://www.java.com/fr/download/help/li … nstall-pkg

#17 05/12/2004 17:38:42

silk
Membre
Inscription : 28/11/2004
Messages : 18

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

Donc j ai solutionné le probleme et je vous communique cela ca aidera peut etre d'autres personnes:

j' ai installé jre1.5.rpm

Apres cette 1ere opération rien ne marchait sur firefox.

Ensuite j' ai fait un lien ln -s /usr/java/jre1.5.0/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/firefox-1.0/plugins

et la ca marche sans pb

A noter q auparavant j avais fait un lien:
ln -s /usr/java/jre1.5.0/plugin/i386/ns7-gcc29/libjavaplugin_oji.so /usr/lib/firefox-1.0/plugins
et la mon nvigateur plantait lorsque je tapais about:plugins

J espère que mon msg aura pu aider qq uns et merci pour votre aide car sans vous je n'aurait pas reussi.

@+

Hors ligne

#18 05/12/2004 20:24:40

Bibelosse
Membre
Lieu : POMPIGNAC
Inscription : 29/08/2004
Messages : 100

Re : Probleme d'installation de Java j2se5.0 pour firefox 1.0

Ok, j'ai supprimé tous les lien et j'ai refait le tien en suivant les instructions du site java que tu m'as donné. Cela marche bien. SUPER

Merci pour ton aide...

Cordialement.

Emmanuel


.........

Hors ligne

Pied de page des forums