Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Sortie de la bêta de Fedora 21

#1 21/05/2012 19:10:39

marc0504
Membre
Inscription : 06/04/2012
Messages : 10

impossible d'installer ou supprimer un programme

Bonjour à tous,

J'ai un problème avec l'outil d'ajout/suppression de programme
Dès l'ouverture de l'outil j'ai un message m'indiquant :
"l'initialisation des paquets à échouée, ceci peut survenir si d'autres outils de paquets sont utilisés simultanément"
et dans les détails il est indiqué : there are unfinished transactions remaining.Please run yum complete transaction as root"
Mon problème c'est que je ne vois pas quel autre logiciel utilise les paquets en même temps que yum
Ça fait maintenant 2 jours que j'ai ce message comme si un programme utilisait constamment les paquets
Merci pour votre aide

Hors ligne

#2 21/05/2012 19:37:31

marc0504
Membre
Inscription : 06/04/2012
Messages : 10

Re : impossible d'installer ou supprimer un programme

j'ai essayé justement de lancer "yum-complete-transaction" mais comme je suis novice sous linux je ne dois pas rentrer correctement la commande,
en fait comment l'entrer en root?

Hors ligne

#3 21/05/2012 19:46:24

marc0504
Membre
Inscription : 06/04/2012
Messages : 10

Re : impossible d'installer ou supprimer un programme

Merci j'ai pu lancer l'appli mais j'ai toujours le prblème avec comme message ds le terminal :

Erreur : Tentative de retrait de « yum », qui est protégé
Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
** 1 problèmes RPMDB préexistants trouvés, la sortie de « yum check » est la suivante :
selinux-policy-3.10.0-86.fc16.noarch est un doublon de selinux-policy-3.10.0-84.fc16.noarch

Hors ligne

#4 21/05/2012 21:58:34

marc0504
Membre
Inscription : 06/04/2012
Messages : 10

Re : impossible d'installer ou supprimer un programme

le problème persiste
l

Hors ligne

#5 28/05/2012 15:59:26

roms42
Membre
Inscription : 22/09/2006
Messages : 101

Re : impossible d'installer ou supprimer un programme

Bonjour,

Je me permets de réagir. J'ai le même problème que marc0504, j'ai essayé toutes les méthodes données ci-dessus sans succès, à la fin quand je retente de lancer un yum update j'ai ça (extrait) :

xorg-x11-drv-intel-2.17.0-8.fc16.x86_64 has missing requires of libXfixes.so.3()(64bit)
xorg-x11-drv-intel-2.17.0-8.fc16.x86_64 has missing requires of libXvMC.so.1()(64bit)
xorg-x11-drv-intel-2.17.0-8.fc16.x86_64 has missing requires of libpciaccess.so.0()(64bit)
xorg-x11-drv-intel-2.17.0-8.fc16.x86_64 has missing requires of libudev.so.0()(64bit)
xorg-x11-drv-intel-2.17.0-8.fc16.x86_64 has missing requires of libxcb >= ('0', '1.5', None)
xorg-x11-drv-intel-2.17.0-8.fc16.x86_64 has missing requires of libxcb-dri2.so.0()(64bit)
xorg-x11-drv-intel-2.17.0-8.fc16.x86_64 has missing requires of libxcb.so.1()(64bit)
1:xorg-x11-drv-nouveau-0.0.16-27.20110720gitb806e3f.fc16.x86_64 has missing requires of libudev
1:xorg-x11-drv-nouveau-0.0.16-27.20110720gitb806e3f.fc16.x86_64 has missing requires of libudev.so.0()(64bit)
xorg-x11-drv-openchrome-0.2.904-16.fc16.x86_64 has missing requires of libXvMC.so.1()(64bit)
xorg-x11-drv-wacom-0.12.0-1.fc16.x86_64 has missing requires of libXinerama.so.1()(64bit)
xorg-x11-drv-wacom-0.12.0-1.fc16.x86_64 has missing requires of libgcc_s.so.1()(64bit)
xorg-x11-drv-wacom-0.12.0-1.fc16.x86_64 has missing requires of libgcc_s.so.1(GCC_3.0)(64bit)
xorg-x11-drv-wacom-0.12.0-1.fc16.x86_64 has missing requires of libgcc_s.so.1(GCC_3.3.1)(64bit)
xorg-x11-drv-wacom-0.12.0-1.fc16.x86_64 has missing requires of libudev
xorg-x11-server-Xephyr-1.11.4-2.fc16.x86_64 has missing requires of libGL.so.1()(64bit)
xorg-x11-server-Xephyr-1.11.4-2.fc16.x86_64 has missing requires of libaudit.so.1()(64bit)
xorg-x11-server-Xephyr-1.11.4-2.fc16.x86_64 has missing requires of libpixman-1.so.0()(64bit)
xorg-x11-server-Xephyr-1.11.4-2.fc16.x86_64 has missing requires of libselinux.so.1()(64bit)
xorg-x11-server-Xorg-1.11.4-2.fc16.x86_64 has missing requires of libaudit.so.1()(64bit)
xorg-x11-server-Xorg-1.11.4-2.fc16.x86_64 has missing requires of libpciaccess.so.0()(64bit)
xorg-x11-server-Xorg-1.11.4-2.fc16.x86_64 has missing requires of libpixman-1.so.0()(64bit)
xorg-x11-server-Xorg-1.11.4-2.fc16.x86_64 has missing requires of libselinux.so.1()(64bit)
xorg-x11-server-Xorg-1.11.4-2.fc16.x86_64 has missing requires of libudev.so.0()(64bit)
xorg-x11-server-Xorg-1.11.4-2.fc16.x86_64 has missing requires of system-setup-keyboard
xorg-x11-server-common-1.11.4-2.fc16.x86_64 has missing requires of pixman >= ('0', '0.21.8', None)
xorg-x11-server-utils-7.5-7.fc16.x86_64 has missing requires of libICE.so.6()(64bit)
xorg-x11-server-utils-7.5-7.fc16.x86_64 has missing requires of libXt.so.6()(64bit)
xorg-x11-utils-7.5-3.fc16.x86_64 has missing requires of libXinerama.so.1()(64bit)
xorg-x11-utils-7.5-3.fc16.x86_64 has missing requires of libxcb-shape.so.0()(64bit)
xorg-x11-utils-7.5-3.fc16.x86_64 has missing requires of libxcb.so.1()(64bit)
xorg-x11-xkb-utils-7.5-5.fc16.x86_64 has missing requires of libgcc_s.so.1()(64bit)
xorg-x11-xkb-utils-7.5-5.fc16.x86_64 has missing requires of libgcc_s.so.1(GCC_3.0)(64bit)
xorg-x11-xkb-utils-7.5-5.fc16.x86_64 has missing requires of libgcc_s.so.1(GCC_3.3.1)(64bit)
1:yelp-3.2.1-2.fc16.x86_64 has missing requires of gnome-user-docs
1:yelp-3.2.1-2.fc16.x86_64 has missing requires of libgdk-3.so.0()(64bit)
1:yelp-3.2.1-2.fc16.x86_64 has missing requires of libgio-2.0.so.0()(64bit)
1:yelp-3.2.1-2.fc16.x86_64 has missing requires of libglib-2.0.so.0()(64bit)
1:yelp-3.2.1-2.fc16.x86_64 has missing requires of libgobject-2.0.so.0()(64bit)
1:yelp-3.2.1-2.fc16.x86_64 has missing requires of libgthread-2.0.so.0()(64bit)
1:yelp-3.2.1-2.fc16.x86_64 has missing requires of libgtk-3.so.0()(64bit)
1:yelp-libs-3.2.1-2.fc16.x86_64 has missing requires of libgdk-3.so.0()(64bit)
1:yelp-libs-3.2.1-2.fc16.x86_64 has missing requires of libgio-2.0.so.0()(64bit)
1:yelp-libs-3.2.1-2.fc16.x86_64 has missing requires of libglib-2.0.so.0()(64bit)
1:yelp-libs-3.2.1-2.fc16.x86_64 has missing requires of libgobject-2.0.so.0()(64bit)
1:yelp-libs-3.2.1-2.fc16.x86_64 has missing requires of libgtk-3.so.0()(64bit)
yum-3.4.3-23.fc16.noarch has missing requires of pygpgme
yum-3.4.3-23.fc16.noarch has missing requires of python-urlgrabber >= ('0', '3.9.0', '8')
yum-3.4.3-23.fc16.noarch has missing requires of rpm >= ('0', '4.4.2', None)
yum-metadata-parser-1.1.4-5.fc16.x86_64 has missing requires of glib2 >= ('0', '2.15', None)
yum-metadata-parser-1.1.4-5.fc16.x86_64 has missing requires of libglib-2.0.so.0()(64bit)
yum-presto-0.7.1-1.fc16.noarch has missing requires of deltarpm >= ('0', '3.4', '2')
zenity-3.2.0-1.fc16.x86_64 has missing requires of libcairo.so.2()(64bit)
zenity-3.2.0-1.fc16.x86_64 has missing requires of libfontconfig.so.1()(64bit)
zenity-3.2.0-1.fc16.x86_64 has missing requires of libgdk-3.so.0()(64bit)
zenity-3.2.0-1.fc16.x86_64 has missing requires of libgio-2.0.so.0()(64bit)
zenity-3.2.0-1.fc16.x86_64 has missing requires of libglib-2.0.so.0()(64bit)
zenity-3.2.0-1.fc16.x86_64 has missing requires of libgmodule-2.0.so.0()(64bit)
zenity-3.2.0-1.fc16.x86_64 has missing requires of libgobject-2.0.so.0()(64bit)
zenity-3.2.0-1.fc16.x86_64 has missing requires of libgthread-2.0.so.0()(64bit)
zenity-3.2.0-1.fc16.x86_64 has missing requires of libgtk-3.so.0()(64bit)
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-05-28.16-48.NAUfFA.yumtx

Que faut-il faire? Je ne peux plus installer quoi que ce soit (par yum ou le gestionnaire de paquet), je ne peux plus lancer Firefox (sans doute parce qu’il faisait parti des mises à jours)

Merci pour votre aide.

Hors ligne

#6 28/05/2012 17:45:38

jtro
Membre
Lieu : pornichet
Inscription : 06/03/2010
Messages : 106

Re : impossible d'installer ou supprimer un programme

as tu lancé la commande proposée ?

Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-05-28.16-48.NAUfFA.yumtx

Hors ligne

#7 30/05/2012 20:38:07

roms42
Membre
Inscription : 22/09/2006
Messages : 101

Re : impossible d'installer ou supprimer un programme

Oui, idem

Hors ligne

#8 01/06/2012 16:59:01

roms42
Membre
Inscription : 22/09/2006
Messages : 101

Re : impossible d'installer ou supprimer un programme

autre question, est-ce que ce problème peut empêcher un upgrade à fedora 17?

Hors ligne

#9 13/06/2012 20:34:15

roms42
Membre
Inscription : 22/09/2006
Messages : 101

Re : impossible d'installer ou supprimer un programme

je confirme que je suis bloqué pour l'upgrade...

Hors ligne

#10 19/12/2012 21:38:52

shnoulle
FreePoste Addict
Lieu : Roubaix
Inscription : 06/07/2006
Messages : 1 010
Site Web

Re : impossible d'installer ou supprimer un programme

Salut Tertous,

Confronté à un problème de yum update avec un yum-complete-transaction  non terminé.

J'ai eu un problème similaire.
Le yum-complete-transaction  me donne un :
Tentative de retrait de « yum », qui est protégé

Au final, ce qui a fonctionné:

yum reinstall zlib
rm -f /var/lib/rpm/__db.*
rpm --rebuilddb
yum clean all
package-cleanup --cleandupes

yum update

Le reinstall zlib est ici: http://forums.fedora-fr.org/viewtopic.php?id=54424

Denis


En train de lire FAQ - DOC

Hors ligne

Pied de page des forums