Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Rencontres Fedora 20

#76 18/05/2012 07:14:04

ptitdernier
Membre
Inscription : 19/09/2006
Messages : 638

Re : Bumblebee pour Optimus

Bravo Roultabie pour ton boulot.

J'ai utilisé ta méthode avec nouveau et ça fonctionne bien. (mon portable Asus a à peu près les mêmes caractéristiques que le tien).

Par contre je rencontre un problème avec le driver nVidia qui ne veut pas s'installer. hammer hammer hammer

[michel@michel ~]$ su -lc 'yum install http://downloads.aelys-info.net/fedora/16/testing/x86_64/xorg-x11-drv-nvidia-bumblebee-295.40-1.fc16.x86_64.rpm \
http://downloads.aelys-info.net/fedora/16/testing/x86_64/xorg-x11-drv-nvidia-bumblebee-libs-295.40-1.fc16.x86_64.rpm \
http://downloads.aelys-info.net/fedora/16/testing/x86_64/xorg-x11-drv-nvidia-bumblebee-devel-295.40-1.fc16.x86_64.rpm'
Mot de passe : 
Modules complémentaires chargés : langpacks, presto, refresh-packagekit
xorg-x11-drv-nvidia-bumblebee-295.40-1.fc16.x86_64.rpm                                                                   | 2.2 MB     00:05     
Examen de /var/tmp/yum-root-fl7VBr/xorg-x11-drv-nvidia-bumblebee-295.40-1.fc16.x86_64.rpm : 1:xorg-x11-drv-nvidia-bumblebee-295.40-1.fc16.x86_64
Sélection de /var/tmp/yum-root-fl7VBr/xorg-x11-drv-nvidia-bumblebee-295.40-1.fc16.x86_64.rpm pour installation 
xorg-x11-drv-nvidia-bumblebee-libs-295.40-1.fc16.x86_64.rpm                                                              |  18 MB     00:48     
Examen de /var/tmp/yum-root-fl7VBr/xorg-x11-drv-nvidia-bumblebee-libs-295.40-1.fc16.x86_64.rpm : 1:xorg-x11-drv-nvidia-bumblebee-libs-295.40-1.fc16.x86_64
Sélection de /var/tmp/yum-root-fl7VBr/xorg-x11-drv-nvidia-bumblebee-libs-295.40-1.fc16.x86_64.rpm pour installation 
xorg-x11-drv-nvidia-bumblebee-devel-295.40-1.fc16.x86_64.rpm                                                             | 3.1 kB     00:00     
Examen de /var/tmp/yum-root-fl7VBr/xorg-x11-drv-nvidia-bumblebee-devel-295.40-1.fc16.x86_64.rpm : 1:xorg-x11-drv-nvidia-bumblebee-devel-295.40-1.fc16.x86_64
Sélection de /var/tmp/yum-root-fl7VBr/xorg-x11-drv-nvidia-bumblebee-devel-295.40-1.fc16.x86_64.rpm pour installation 
Résolution des dépendances
--> Lancement de la transaction de test
---> Le paquet xorg-x11-drv-nvidia-bumblebee.x86_64 1:295.40-1.fc16 sera installé
--> Traitement de la dépendance : nvidia-kmod >= 295.40 pour le paquet : 1:xorg-x11-drv-nvidia-bumblebee-295.40-1.fc16.x86_64
---> Le paquet xorg-x11-drv-nvidia-bumblebee-devel.x86_64 1:295.40-1.fc16 sera installé
---> Le paquet xorg-x11-drv-nvidia-bumblebee-libs.x86_64 1:295.40-1.fc16 sera installé
--> Lancement de la transaction de test
---> Le paquet kmod-nvidia.x86_64 1:295.49-1.fc16.2 sera installé
--> Traitement de la dépendance : kmod-nvidia-3.3.5-2.fc16.x86_64 >= 1:295.49-1.fc16.2 pour le paquet : 1:kmod-nvidia-295.49-1.fc16.2.x86_64
--> Lancement de la transaction de test
---> Le paquet kmod-nvidia-3.3.5-2.fc16.x86_64.x86_64 1:295.49-1.fc16.2 sera installé
--> Traitement de la dépendance : nvidia-kmod-common >= 1:295.49 pour le paquet : 1:kmod-nvidia-3.3.5-2.fc16.x86_64-295.49-1.fc16.2.x86_64
--> Lancement de la transaction de test
---> Le paquet xorg-x11-drv-nvidia.x86_64 1:295.49-1.fc16 sera installé
--> Traitement de la dépendance : xorg-x11-drv-nvidia-libs(x86-64) = 1:295.49-1.fc16 pour le paquet : 1:xorg-x11-drv-nvidia-295.49-1.fc16.x86_64
--> Traitement de la dépendance : nvidia-settings pour le paquet : 1:xorg-x11-drv-nvidia-295.49-1.fc16.x86_64
--> Traitement de la dépendance : nvidia-xconfig pour le paquet : 1:xorg-x11-drv-nvidia-295.49-1.fc16.x86_64
--> Lancement de la transaction de test
---> Le paquet nvidia-settings.x86_64 0:1.0-17.fc16 sera installé
---> Le paquet nvidia-xconfig.x86_64 0:1.0-15.fc16 sera installé
---> Le paquet xorg-x11-drv-nvidia-libs.x86_64 1:295.49-1.fc16 sera installé
--> Traitement du conflit : 1:xorg-x11-drv-nvidia-bumblebee-295.40-1.fc16.x86_64 entre en conflit avec xorg-x11-drv-nvidia
Aucun paquet correspondant à mettre à jour : xorg-x11-drv-nvidia-bumblebee
--> Traitement du conflit : 1:xorg-x11-drv-nvidia-bumblebee-295.40-1.fc16.x86_64 entre en conflit avec nvidia-xconfig
Aucun paquet correspondant à mettre à jour : xorg-x11-drv-nvidia-bumblebee
--> Traitement du conflit : 1:xorg-x11-drv-nvidia-bumblebee-295.40-1.fc16.x86_64 entre en conflit avec nvidia-settings
Aucun paquet correspondant à mettre à jour : xorg-x11-drv-nvidia-bumblebee
--> Résolution des dépendances terminée
Erreur : xorg-x11-drv-nvidia-bumblebee conflicts with nvidia-settings-1.0-17.fc16.x86_64
Erreur : xorg-x11-drv-nvidia-bumblebee conflicts with 1:xorg-x11-drv-nvidia-295.49-1.fc16.x86_64
Erreur : xorg-x11-drv-nvidia-bumblebee conflicts with nvidia-xconfig-1.0-15.fc16.x86_64
 Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
 Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest
[michel@michel ~]$ 

si j'ai bien lu et compris le fil des discussions pour y arriver il faudrait faire dans l'ordre :

- désinstaller bumblebee
- désinstaller openGL
- installer nVidia et nettoyer xorg le cas échéant
- installer openGL
- installer bumblebee
- installer pilote nvidia labellisé "bumblebee"

Est-ce bien la marche à suivre ? (je ne voudrais pas casser mon installation)

Pour info j'ai fait un passage de quelques mois chez debian car je n'arrivais pas à installer bumblebee, et leur méthode fonctionne très bien installation bumblebee debian wheezy


ASUS K53S - 4Go- Intel core i5 2410M 2,3 Ghz - nVidia GeForce GT 520MX optimus
Acer 7730ZG- 4Go -Intel Dual Core T3400 2,16 Ghz - nVidia GeForce 9300M GS

Hors ligne

#77 18/05/2012 20:42:08

donkishoot
Membre
Inscription : 11/01/2007
Messages : 10

Re : Bumblebee pour Optimus

Roultabie a écrit :

Pour être tenu au courant des MAJ des paquets (en particulier pour Fedora 17), rejoingnez google+ (Voir sujet dédié sur le forum).

Et sinon t'as pas une idée pour que je retrouve l’accélération avec mon I915 pour ne pas avoir un gnome3 en carton et conserver mon optirun ? merci d'avance


[    11.127] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    11.127] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    11.127] (II) Loader magic: 0x7caac0
[    11.127] (II) Module ABI versions:
[    11.127]    X.Org ANSI C Emulation: 0.4
[    11.128]    X.Org Video Driver: 11.0
[    11.128]    X.Org XInput driver : 13.0
[    11.128]    X.Org Server Extension : 6.0
[    11.130] (--) PCI:*(0:0:2:0) 8086:0126:17aa:21d3 rev 9, Mem @ 0xf1400000/4194304, 0xe0000000/268435456, I/O @ 0x00005000/64, BIOS @ 0x????????/131072
[    11.130] (--) PCI: (0:1:0:0) 10de:1056:17aa:21d3 rev 161, Mem @ 0xf0000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/524288
...

[    11.237] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[    11.237] (II) Module fbdev: vendor="X.Org Foundation"
[    11.237]    compiled for 1.10.99.902, module version = 0.4.2
[    11.237]    ABI class: X.Org Video Driver, version 11.0
[    11.237] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
        i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
        E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
        965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
        4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
        Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
        Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
        Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
        Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
        Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server
[    11.238] (II) VESA: driver for VESA chipsets: vesa
[    11.238] (II) FBDEV: driver for framebuffer: fbdev
[    11.238] (++) using VT number 1

[    11.247] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[    11.247] (WW) Falling back to old probe method for vesa
[    11.247] (WW) Falling back to old probe method for fbdev
[    11.247] (II) Loading sub module "fbdevhw"
[    11.247] (II) LoadModule: "fbdevhw"
[    11.248] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[    11.249] (II) Module fbdevhw: vendor="X.Org Foundation"
[    11.249]    compiled for 1.11.4, module version = 0.0.2
[    11.249]    ABI class: X.Org Video Driver, version 11.0
[    11.249] (EE) open /dev/fb0: No such device
[    11.249] drmOpenDevice: node name is /dev/dri/card0
[    11.249] drmOpenDevice: open result is -1, (No such device)
[    11.254] drmOpenByBusid: Searching for BusID pci:0000:00:02.0
[    11.254] drmOpenDevice: node name is /dev/dri/card0
[    11.254] drmOpenDevice: open result is -1, (No such device)
[    11.254] drmOpenByBusid: drmOpenMinor returns -22
[    11.254] drmOpenDevice: node name is /dev/dri/card1
[    11.254] drmOpenDevice: open result is 8, (OK)
[    11.254] drmOpenByBusid: drmOpenMinor returns 8
[    11.254] drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
...
[    11.260] (II) intel(0): [DRI2] Setup complete
[    11.260] (II) intel(0): [DRI2]   DRI driver: i965
[    11.260] (II) intel(0): Allocated new frame buffer 1600x900 stride 6656, tiled
[    11.263] (II) UXA(0): Driver registered support for the following operations:
[    11.263] (II)         solid
[    11.263] (II)         copy
[    11.263] (II)         composite (RENDER acceleration)
[    11.263] (II)         put_image
[    11.263] (II)         get_image
[    11.263] (==) intel(0): Backing store disabled
[    11.263] (==) intel(0): Silken mouse enabled
[    11.263] (II) intel(0): Initializing HW Cursor
[    11.329] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    11.332] (==) intel(0): DPMS enabled
[    11.332] (==) intel(0): Intel XvMC decoder enabled
[    11.333] (II) intel(0): Set up textured video
[    11.333] (II) intel(0): [XvMC] xvmc_vld driver initialized.
[    11.333] (II) intel(0): direct rendering: DRI2 Enabled
[    11.333] (==) intel(0): hotplug detection: "enabled"
[    11.335] (--) RandR disabled
[    11.335] (II) Initializing built-in extension Generic Event Extension
[    11.335] (II) Initializing built-in extension SHAPE
[    11.335] (II) Initializing built-in extension MIT-SHM
[    11.335] (II) Initializing built-in extension XInputExtension
[    11.335] (II) Initializing built-in extension XTEST
[    11.335] (II) Initializing built-in extension BIG-REQUESTS
[    11.335] (II) Initializing built-in extension SYNC
[    11.335] (II) Initializing built-in extension XKEYBOARD
[    11.335] (II) Initializing built-in extension XC-MISC
[    11.335] (II) Initializing built-in extension XINERAMA
[    11.335] (II) Initializing built-in extension XFIXES
[    11.335] (II) Initializing built-in extension RENDER
[    11.335] (II) Initializing built-in extension RANDR
[    11.335] (II) Initializing built-in extension COMPOSITE
[    11.335] (II) Initializing built-in extension DAMAGE
[    11.338] (II) SELinux: Disabled by boolean
[    11.342] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
[    11.345] (II) intel(0): Setting screen physical size to 423 x 238

Hors ligne

#78 18/05/2012 21:26:07

donkishoot
Membre
Inscription : 11/01/2007
Messages : 10

Re : Bumblebee pour Optimus

Je me répond :

Il faut créé ce fichier pour forcer le chargement de la bonne librarie wink

[root@L ~]# cat /etc/X11/xorg.conf
Section "Module"
    Load "/usr/lib64/xorg/modules/extensions/libglx.so"
EndSection

Hors ligne

#79 18/05/2012 23:04:31

Roultabie
Le jour ou FC11 a changé ma vie
Inscription : 11/06/2009
Messages : 265

Re : Bumblebee pour Optimus

;)
@ ptitdernier, il faut que tu supprime tous les paquets (drv, akmod, kmod) puis tu installe ceux de bumblebee.

Pour tous, mon profil google+ https://plus.google.com/106698767629097588505/posts


Config: Asus U53SD, Intel Core i5-2410M, DDR3 4G, NVIDIA GeForce GT520M, Fedora 16 x86_64 Archlinux, Optimus avec Bumblebee.

Hors ligne

#80 19/05/2012 06:29:04

ptitdernier
Membre
Inscription : 19/09/2006
Messages : 638

Re : Bumblebee pour Optimus

@Roultabie

le problème c'est qu'il n'y a aucun paquet  nvidia d'installé !

[michel@michel ~]$ yum list *nvidia*
Modules complémentaires chargés : langpacks, presto, refresh-packagekit
Paquets disponibles
akmod-nvidia.x86_64                                                    1:295.49-1.fc16                                     rpmfusion-nonfree-updates
kmod-nvidia.x86_64                                                     1:295.49-1.fc16.2                                   rpmfusion-nonfree-updates
kmod-nvidia-3.1.0-7.fc16.x86_64.x86_64                                 1:285.05.09-1.fc16.4                                rpmfusion-nonfree        
kmod-nvidia-3.1.1-1.fc16.x86_64.x86_64                                 1:290.06-1.fc16.2                                   rpmfusion-nonfree-updates
kmod-nvidia-3.1.1-2.fc16.x86_64.x86_64                                 1:290.06-1.fc16.3                                   rpmfusion-nonfree-updates
kmod-nvidia-3.1.2-1.fc16.x86_64.x86_64                                 1:290.10-1.fc16.1                                   rpmfusion-nonfree-updates
kmod-nvidia-3.1.4-1.fc16.x86_64.x86_64                                 1:290.10-1.fc16.2                                   rpmfusion-nonfree-updates
kmod-nvidia-3.1.5-1.fc16.x86_64.x86_64                                 1:290.10-1.fc16.3                                   rpmfusion-nonfree-updates
kmod-nvidia-3.1.5-2.fc16.x86_64.x86_64                                 1:290.10-1.fc16.4                                   rpmfusion-nonfree-updates
kmod-nvidia-3.1.5-6.fc16.x86_64.x86_64                                 1:290.10-1.fc16.5                                   rpmfusion-nonfree-updates
kmod-nvidia-3.1.6-1.fc16.x86_64.x86_64                                 1:290.10-1.fc16.6                                   rpmfusion-nonfree-updates
kmod-nvidia-3.1.7-1.fc16.x86_64.x86_64                                 1:290.10-1.fc16.7                                   rpmfusion-nonfree-updates
kmod-nvidia-3.1.8-2.fc16.x86_64.x86_64                                 1:290.10-1.fc16.8                                   rpmfusion-nonfree-updates
kmod-nvidia-3.1.9-1.fc16.x86_64.x86_64                                 1:290.10-1.fc16.9                                   rpmfusion-nonfree-updates
kmod-nvidia-3.2.1-3.fc16.x86_64.x86_64                                 1:290.10-1.fc16.10                                  rpmfusion-nonfree-updates
kmod-nvidia-3.2.10-3.fc16.x86_64.x86_64                                1:290.10-1.fc16.20                                  rpmfusion-nonfree-updates
kmod-nvidia-3.2.2-1.fc16.x86_64.x86_64                                 1:290.10-1.fc16.11                                  rpmfusion-nonfree-updates
kmod-nvidia-3.2.3-2.fc16.x86_64.x86_64                                 1:290.10-1.fc16.12                                  rpmfusion-nonfree-updates
kmod-nvidia-3.2.5-3.fc16.x86_64.x86_64                                 1:290.10-1.fc16.13                                  rpmfusion-nonfree-updates
kmod-nvidia-3.2.6-3.fc16.x86_64.x86_64                                 1:290.10-1.fc16.14                                  rpmfusion-nonfree-updates
kmod-nvidia-3.2.7-1.fc16.x86_64.x86_64                                 1:290.10-1.fc16.15                                  rpmfusion-nonfree-updates
kmod-nvidia-3.2.8-3.fc16.x86_64.x86_64                                 1:290.10-1.fc16.16                                  rpmfusion-nonfree-updates
kmod-nvidia-3.2.9-1.fc16.x86_64.x86_64                                 1:290.10-1.fc16.17                                  rpmfusion-nonfree-updates
kmod-nvidia-3.2.9-2.fc16.x86_64.x86_64                                 1:290.10-1.fc16.18                                  rpmfusion-nonfree-updates
kmod-nvidia-3.3.0-4.fc16.x86_64.x86_64                                 1:295.33-2.fc16                                     rpmfusion-nonfree-updates
kmod-nvidia-3.3.0-8.fc16.x86_64.x86_64                                 1:295.33-2.fc16.1                                   rpmfusion-nonfree-updates
kmod-nvidia-3.3.1-2.fc16.x86_64.x86_64                                 1:295.33-2.fc16.2                                   rpmfusion-nonfree-updates
kmod-nvidia-3.3.1-3.fc16.x86_64.x86_64                                 1:295.33-2.fc16.3                                   rpmfusion-nonfree-updates
kmod-nvidia-3.3.1-5.fc16.x86_64.x86_64                                 1:295.40-2.fc16                                     rpmfusion-nonfree-updates
kmod-nvidia-3.3.2-1.fc16.x86_64.x86_64                                 1:295.40-2.fc16.1                                   rpmfusion-nonfree-updates
kmod-nvidia-3.3.2-6.fc16.x86_64.x86_64                                 1:295.40-2.fc16.2                                   rpmfusion-nonfree-updates
kmod-nvidia-3.3.4-1.fc16.x86_64.x86_64                                 1:295.49-1.fc16                                     rpmfusion-nonfree-updates
kmod-nvidia-3.3.4-3.fc16.x86_64.x86_64                                 1:295.49-1.fc16.1                                   rpmfusion-nonfree-updates
kmod-nvidia-3.3.5-2.fc16.x86_64.x86_64                                 1:295.49-1.fc16.2                                   rpmfusion-nonfree-updates
nvidia-settings.x86_64                                                 1.0-17.fc16                                         rpmfusion-nonfree-updates
nvidia-xconfig.x86_64                                                  1.0-15.fc16                                         rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                                             1:295.49-1.fc16                                     rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-devel.i686                                         1:295.49-1.fc16                                     rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-devel.x86_64                                       1:295.49-1.fc16                                     rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.i686                                          1:295.49-1.fc16                                     rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                                        1:295.49-1.fc16                                     rpmfusion-nonfree-updates
[michel@michel ~]$ 

ASUS K53S - 4Go- Intel core i5 2410M 2,3 Ghz - nVidia GeForce GT 520MX optimus
Acer 7730ZG- 4Go -Intel Dual Core T3400 2,16 Ghz - nVidia GeForce 9300M GS

Hors ligne

#81 20/05/2012 17:19:31

Roultabie
Le jour ou FC11 a changé ma vie
Inscription : 11/06/2009
Messages : 265

Re : Bumblebee pour Optimus

Mise à jour de la procédure d'installation, passage exclusif au support de Fedora 17 + prise en compte de vos remarques. Pour l'instant bumblebee ne fonctionne qu'avec nouveau. Je travaille actuellement sur nvidia.

Pour voir la procédure d'installation, regardez le tout premier message.

Vous devez absolument supprimer tous les paquets anciennement utilisés ! bumblebee, VirtualGL et xorg-x11-nvidia-bumblebee*

Dernière modification par Roultabie (21/05/2012 23:59:27)


Config: Asus U53SD, Intel Core i5-2410M, DDR3 4G, NVIDIA GeForce GT520M, Fedora 16 x86_64 Archlinux, Optimus avec Bumblebee.

Hors ligne

#82 22/05/2012 00:02:38

Roultabie
Le jour ou FC11 a changé ma vie
Inscription : 11/06/2009
Messages : 265

Re : Bumblebee pour Optimus

J'ai finalement créé deux dépots pour Fedora 16 et 17. Tous les paquets nécessaires à l'utilisation de bumblebee tant avec nouveau qu'avec nvidia sont maintenant disponibles dessus et donc bien plus facile à mettre à jour.

Ils ne demandent qu'à être testés !

Voir :

http://downloads.aelys-info.net/fedora/

et

https://plus.google.com/b/102564918628992494676/

Bonne semaine à vous.

Dernière modification par Roultabie (22/05/2012 00:03:16)


Config: Asus U53SD, Intel Core i5-2410M, DDR3 4G, NVIDIA GeForce GT520M, Fedora 16 x86_64 Archlinux, Optimus avec Bumblebee.

Hors ligne

#83 24/05/2012 11:45:45

Yokav
Membre
Lieu : Be
Inscription : 01/02/2009
Messages : 208
Site Web

Re : Bumblebee pour Optimus

Bonjour,

J'ai une ou deux questions à propos de tes paquets Roultabie. wink

Pour ma part, j'ai un portable Asus, il y a quelques mois j'ai pas mal galérer pour installer Fedora du fait des deux cartes graphiques. De mémoire, l'utilisation des drivers nvidia de rpmfusion faisait tout planter tandis que si on forçait le driver nouveau ça passait. J'ai aussi du ajouter cette ligne dans grub "rdblacklist=nouveau" afin de forcer le chargement de la puce intel.

Pour le moment, tout fonctionne bien mais ce qui m'ennuie c'est le bruit monstre que fait la soufflerie du portable, car en réalité la carte graphique intel et nvidia fonctionnent toutes les deux en permanence. Ca a pour effet de rapidement vider ma batterie aussi.

D'où ma question, est-ce que l'utilisation de tes rpms permettait de désactiver complètement l'une ou l'autre carte ?

Hors ligne

#84 24/05/2012 14:55:30

Roultabie
Le jour ou FC11 a changé ma vie
Inscription : 11/06/2009
Messages : 265

Re : Bumblebee pour Optimus

@Yokav Dans tous les cas, pour désactiver la CG secondaire via ton environnement, il te faut installer BBSwitch du projet bumblebee.

Je travaille actuellement sur le paquet, donc pour l'instant il faut que tu le compile.

Ensuite c'est une simple commande pour l'arrêter.

Pour plus d'infos, vas voir sur mon dépot (cf les liens mis précédemment)


Config: Asus U53SD, Intel Core i5-2410M, DDR3 4G, NVIDIA GeForce GT520M, Fedora 16 x86_64 Archlinux, Optimus avec Bumblebee.

Hors ligne

#85 29/05/2012 23:21:24

loloboua
Biologiste ardennais
Lieu : Taissy
Inscription : 01/05/2011
Messages : 113

Re : Bumblebee pour Optimus

Salut.

Maintenant que j'ai du temps, j'essaie de suivre les explications ici mais je tombe sur ca...

sudo yum install bumblebee
[sudo] password for laurent: 
Modules complémentaires chargés : langpacks, presto, refresh-packagekit
aelys-info                                               | 2.9 kB     00:00     
aelys-info/primary_db                                    | 8.7 kB     00:00     
Résolution des dépendances
--> Lancement de la transaction de test
---> Le paquet bumblebee.i686 0:3.0-4.fc17 sera installé
--> Traitement de la dépendance : VirtualGL pour le paquet : bumblebee-3.0-4.fc17.i686
--> Lancement de la transaction de test
---> Le paquet VirtualGL.i686 0:2.3-4.fc17 sera installé
--> Traitement de la dépendance : libturbojpeg.so(TURBOJPEG_1.0) pour le paquet : VirtualGL-2.3-4.fc17.i686
--> Traitement de la dépendance : libturbojpeg.so pour le paquet : VirtualGL-2.3-4.fc17.i686
--> Lancement de la transaction de test
---> Le paquet turbojpeg.i686 0:1.2.0-1.fc17 sera installé
--> Résolution des dépendances terminée

Dépendances résolues

================================================================================
 Package           Architecture Version                Dépôt              Taille
================================================================================
Installation de :
 bumblebee         i686         3.0-4.fc17             aelys-info          39 k
Installation pour dépendances :
 VirtualGL         i686         2.3-4.fc17             aelys-info         787 k
 turbojpeg         i686         1.2.0-1.fc17           fedora             112 k

Résumé de la transaction
================================================================================
Installation   1 Paquet (+2 Paquets en dépendance)

Taille totale des téléchargements : 938 k
Taille d'installation : 2.1 M
Est-ce correct [o/N] : o
Téléchargement des paquets :
(1/3): VirtualGL-2.3-4.fc17.i686.rpm                     | 787 kB     00:00     
attention: rpmts_HdrFromFdno: Entête V4 RSA/SHA1 Signature, key ID 1b4b20d5: NOKEY
La clé publique pour VirtualGL-2.3-4.fc17.i686.rpm n'est pas installée
(2/3): bumblebee-3.0-4.fc17.i686.rpm                     |  39 kB     00:00     
(3/3): turbojpeg-1.2.0-1.fc17.i686.rpm                   | 112 kB     00:00     
--------------------------------------------------------------------------------
Total                                           823 kB/s | 938 kB     00:01     
Récupération de la clé à partir de http://download.aelys-info.net/fedora/RPM-GPG-KEY-Aelys


Échec de la récupération de la clé GPG : [Errno 14] curl#6 - "Couldn't resolve host"

Une petite idée?


"Le gras c'est la vie!!!"
Celui qui n'a jamais mangé un jarret de porc grillé sedanais n'a jamais rien mangé.
Asus Eeepc 1215n

Hors ligne

#86 30/05/2012 08:31:25

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 17 165

Re : Bumblebee pour Optimus

Une petite idée?

Oui relire le post n°82 plus haut et se rendre compte qu'il y a une erreur dans le nom d'hôte du dépot qui est

http://downloads.aelys-info.net/fedora/  avec un S à downloads qui a donc été mal orthographié.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#87 30/05/2012 10:29:12

loloboua
Biologiste ardennais
Lieu : Taissy
Inscription : 01/05/2011
Messages : 113

Re : Bumblebee pour Optimus

D'accord merci pour le tuyau.


"Le gras c'est la vie!!!"
Celui qui n'a jamais mangé un jarret de porc grillé sedanais n'a jamais rien mangé.
Asus Eeepc 1215n

Hors ligne

#88 30/05/2012 10:38:29

loloboua
Biologiste ardennais
Lieu : Taissy
Inscription : 01/05/2011
Messages : 113

Re : Bumblebee pour Optimus

Mais du coup je ne vois pas ce que je dois faire parce que j'ai suivi cette procédure pour installer le dépot :

yum install http://downloads.aelys-info.net/fedora/17/current/i386/aelys-info.repo-1-3.fc17.noarch.rpm

Le S de downloads y est bien mais quand je veux installer bumblebee, il essaie de demander la clé à l'adresse sans le S...


"Le gras c'est la vie!!!"
Celui qui n'a jamais mangé un jarret de porc grillé sedanais n'a jamais rien mangé.
Asus Eeepc 1215n

Hors ligne

#89 30/05/2012 10:43:49

loloboua
Biologiste ardennais
Lieu : Taissy
Inscription : 01/05/2011
Messages : 113

Re : Bumblebee pour Optimus

en fait il m'a suffit de modifier le fichier /etc/yum.repos.d/aelys-info.repo en rajoutant un "S" là ou ca parle de la key.

[aelys-info]
name=Aélys informatique repo for specific fedora packages
baseurl=http://downloads.aelys-info.net/fedora/$releasever/current/$basearch/
enabled=1
gpgkey=http://downloads.aelys-info.net/fedora/RPM-GPG-KEY-Aelys
gpgcheck=1

Merci pour le coup de main. Je continue.

En revanche je n'arrive pas à installer xorg-x11-drv-nvidia et xorg-x11-drv-nvidia-libs à partir de ton dépot. J'ai bien rajouter " priority=2" dans rpmfusion-nonfree.repo, rpmfusion-nonfree-updates.repo mais ca veut installer ceux de rpmfusion-nonfree-rawhide.repo. Alors je lui met un taquet derrière la tête à coup de "priority=2" comme les précédents, un coup de

sudo yum clean all
sudo yum makecache

Mais il veut toujours m'installer le tout a partir de rpmfusion-nonfree-rawhide.repo.

Pour info voici mon rpmfusion-nonfree.repo :

[rpmfusion-nonfree]
name=RPM Fusion for Fedora $releasever - Nonfree
#baseurl=http://download1.rpmfusion.org/nonfree/fedora/releases/$releasever/Everything/$basearch/os/
mirrorlist=http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-$releasever&arch=$basearch
enabled=0
#metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-$releasever-$basearch
priority=2
[rpmfusion-nonfree-debuginfo]
name=RPM Fusion for Fedora $releasever - Nonfree - Debug
#baseurl=http://download1.rpmfusion.org/nonfree/fedora/releases/$releasever/Everything/$basearch/debug/
mirrorlist=http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-debug-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-$releasever-$basearch

[rpmfusion-nonfree-source]
name=RPM Fusion for Fedora $releasever - Nonfree - Source
#baseurl=http://download1.rpmfusion.org/nonfree/fedora/releases/$releasever/Everything/source/SRPMS/
mirrorlist=http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-source-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-$releasever-$basearch

Les deux autres sont changés de la même façon. Et je suis sous F17 sur un Asus 1215n et donc 32bits.

Dernière modification par loloboua (30/05/2012 13:03:10)


"Le gras c'est la vie!!!"
Celui qui n'a jamais mangé un jarret de porc grillé sedanais n'a jamais rien mangé.
Asus Eeepc 1215n

Hors ligne

#90 30/05/2012 14:54:23

Roultabie
Le jour ou FC11 a changé ma vie
Inscription : 11/06/2009
Messages : 265

Re : Bumblebee pour Optimus

J'ai vu cette erreur dans mon dépot, mais comme je travaillais cette nuit, je n'ai pas pu répondre. Je vais mettre à jour le paquet !
Merci pour l'info !


Config: Asus U53SD, Intel Core i5-2410M, DDR3 4G, NVIDIA GeForce GT520M, Fedora 16 x86_64 Archlinux, Optimus avec Bumblebee.

Hors ligne

#91 30/05/2012 15:00:03

Roultabie
Le jour ou FC11 a changé ma vie
Inscription : 11/06/2009
Messages : 265

Re : Bumblebee pour Optimus

@loloboua : Vérifie que le aelys-info.repo est bien indiqué à priority=1
Sinon, désactive les repos de RPMfusion le temps de l'installation.
Comme je suis sous x86_64 et que ça fonctionne correctement chez moi...
Je viens de mettre à jour le repo fc17 i386 au cas ou, régénère ton cache.
Tiens moi au courant !


Config: Asus U53SD, Intel Core i5-2410M, DDR3 4G, NVIDIA GeForce GT520M, Fedora 16 x86_64 Archlinux, Optimus avec Bumblebee.

Hors ligne

#92 31/05/2012 09:06:30

loloboua
Biologiste ardennais
Lieu : Taissy
Inscription : 01/05/2011
Messages : 113

Re : Bumblebee pour Optimus

J'ai déja vérifier et c'est bien en priority=1. Pour désactiver le dépot j'ai tout commenter à l'intérieur de rpmfusion-nonfree-rawhide (je pense que j'aurais pu supprimer le fichier vu que je ne me sert pas de Rawhide) et maintenant jo'btient ca :

[laurent@1215n ~]$ sudo yum install xorg-x11-drv-nvidia
Modules complémentaires chargés : langpacks, presto, refresh-packagekit
Résolution des dépendances
--> Lancement de la transaction de test
---> Le paquet xorg-x11-drv-nvidia.i686 1:295.53-3.fc17 sera installé
--> Traitement de la dépendance : xorg-x11-drv-nvidia-libs(x86-32) = 1:295.53-3.fc17 pour le paquet : 1:xorg-x11-drv-nvidia-295.53-3.fc17.i686
--> Traitement de la dépendance : nvidia-kmod >= 295.53 pour le paquet : 1:xorg-x11-drv-nvidia-295.53-3.fc17.i686
--> Lancement de la transaction de test
---> Le paquet xorg-x11-drv-nvidia.i686 1:295.53-3.fc17 sera installé
--> Traitement de la dépendance : nvidia-kmod >= 295.53 pour le paquet : 1:xorg-x11-drv-nvidia-295.53-3.fc17.i686
---> Le paquet xorg-x11-drv-nvidia-libs.i686 1:295.53-3.fc17 sera installé
--> Résolution des dépendances terminée
Erreur : Paquet : 1:xorg-x11-drv-nvidia-295.53-3.fc17.i686 (aelys-info)
             Requiert : nvidia-kmod >= 295.53
 Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
** 3 problèmes RPMDB préexistants trouvés, la sortie de « yum check » est la suivante :
ffmpeg-libs-0.10.3-1.fc18.i686 a des dépendances manquantes de libopenjpeg.so.1
rpmfusion-free-release-18-0.1.noarch a des dépendances manquantes de system-release >= ('0', '18', None)
rpmfusion-nonfree-release-18-0.1.noarch a des dépendances manquantes de system-release >= ('0', '18', None)
[laurent@1215n ~]$ 

Voici ce que j'obtient avec les --skip-broken :

sudo yum install --skip-broken xorg-x11-drv-nvidia
[sudo] password for laurent: 
Modules complémentaires chargés : langpacks, presto, refresh-packagekit
Résolution des dépendances
--> Lancement de la transaction de test
---> Le paquet xorg-x11-drv-nvidia.i686 1:295.53-3.fc17 sera installé
--> Traitement de la dépendance : xorg-x11-drv-nvidia-libs(x86-32) = 1:295.53-3.fc17 pour le paquet : 1:xorg-x11-drv-nvidia-295.53-3.fc17.i686
--> Traitement de la dépendance : nvidia-kmod >= 295.53 pour le paquet : 1:xorg-x11-drv-nvidia-295.53-3.fc17.i686
--> Lancement de la transaction de test
---> Le paquet xorg-x11-drv-nvidia.i686 1:295.53-3.fc17 sera installé
--> Traitement de la dépendance : nvidia-kmod >= 295.53 pour le paquet : 1:xorg-x11-drv-nvidia-295.53-3.fc17.i686
---> Le paquet xorg-x11-drv-nvidia-libs.i686 1:295.53-3.fc17 sera installé

Paquets omis en raison de problèmes de dépendances :
    1:xorg-x11-drv-nvidia-295.53-3.fc17.i686 depuis aelys-info
    1:xorg-x11-drv-nvidia-libs-295.53-3.fc17.i686 depuis aelys-info

Et lorsque j'essaie un :

[laurent@1215n ~]$ sudo yum install nvidia-kmod
[sudo] password for laurent: 
Modules complémentaires chargés : langpacks, presto, refresh-packagekit
Aucun paquet nvidia-kmod disponible.
Erreur : Rien à faire

Dernière modification par loloboua (31/05/2012 09:37:13)


"Le gras c'est la vie!!!"
Celui qui n'a jamais mangé un jarret de porc grillé sedanais n'a jamais rien mangé.
Asus Eeepc 1215n

Hors ligne

#93 31/05/2012 09:45:16

loloboua
Biologiste ardennais
Lieu : Taissy
Inscription : 01/05/2011
Messages : 113

Re : Bumblebee pour Optimus

Et pour utiliser Nouveau, il n'yaurait pas une petite bidouille à faire quand même? Parce que là, bumblebee est installé et voici la réponse que j'obtient :

[laurent@1215n ~]$ optirun glxgears
[ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

[ERROR]Aborting because fallback start is disabled.

"Le gras c'est la vie!!!"
Celui qui n'a jamais mangé un jarret de porc grillé sedanais n'a jamais rien mangé.
Asus Eeepc 1215n

Hors ligne

#94 31/05/2012 12:52:55

Roultabie
Le jour ou FC11 a changé ma vie
Inscription : 11/06/2009
Messages : 265

Re : Bumblebee pour Optimus

@loloboua, on va créer un nouveau topic sur Fedora 17.

Pour le kmod, c'est normal, il prend celui de rpm-fusion. Il faut que tu l'active avec priority=2.
Je pense que je n'avais pas mis à jour les metadonées du dépot i386, chose faite.

Pour nouveau, normalement (je désinstalle nvidia et te confirme) ça fonctionne.


Config: Asus U53SD, Intel Core i5-2410M, DDR3 4G, NVIDIA GeForce GT520M, Fedora 16 x86_64 Archlinux, Optimus avec Bumblebee.

Hors ligne

#95 31/05/2012 12:58:30

Roultabie
Le jour ou FC11 a changé ma vie
Inscription : 11/06/2009
Messages : 265

Re : Bumblebee pour Optimus


Config: Asus U53SD, Intel Core i5-2410M, DDR3 4G, NVIDIA GeForce GT520M, Fedora 16 x86_64 Archlinux, Optimus avec Bumblebee.

Hors ligne

#96 01/09/2012 19:21:33

SUHOKAWA
Membre
Inscription : 01/09/2012
Messages : 1

Re : Bumblebee pour Optimus

Bonjour à Tous,
Je sais je ne me suis pas encore présenté, mais je viens de finir l'installation de Bumblebee sur CENTOS 6.3.
J'ai réussit grâce à toutes les infos sur se site et d'autres car sur CENTOS 6.3 ça n'a pas été si facile.

Matériel: ASUS K75VM i7 6go 750goDD GT630M 17.3" hammer

Maintenant je vais fêter ça... pint

Je posterai mes tests demain

Dernière modification par SUHOKAWA (01/09/2012 19:26:22)

Hors ligne

#97 01/09/2012 19:46:25

ptitdernier
Membre
Inscription : 19/09/2006
Messages : 638

Re : Bumblebee pour Optimus

je te rappelle qu'ici c'est le forum fedora et non Centos.
Mais si tu a réussi tant mieux !

Dernière modification par ptitdernier (02/09/2012 08:44:36)


ASUS K53S - 4Go- Intel core i5 2410M 2,3 Ghz - nVidia GeForce GT 520MX optimus
Acer 7730ZG- 4Go -Intel Dual Core T3400 2,16 Ghz - nVidia GeForce 9300M GS

Hors ligne

#98 01/09/2012 20:57:18

theboogymaster
Membre
Lieu : Suisse
Inscription : 07/04/2008
Messages : 594
Site Web

Re : Bumblebee pour Optimus

Si la même procédure à fontionner sur cent os il est fort probable que la même puisse marcher sur fedora avec probablement quelque modification. Donc à mon avis il serai quand même bien de la partager ici.


Success is to be measured not so much by the position that one has reached in life as by the obstacles which he has overcome.
http://www.tuxgeek.org
rhce-logo.png

Hors ligne

Pied de page des forums