Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Rencontres Fedora 20

#1 11/04/2012 10:38:47

shteph
Membre
Inscription : 11/04/2012
Messages : 10

[Résolu] Configurer profondeur des couleurs (?)

Hello à toutes et tous! :)

J'ai un affichage assez mauvais des couleurs sur les images qui apparaissent très sombres. J'ai déjà eu ce problème lors de ma précédente installation (reinstall parce que mort du DD), et je me souviens que pour rectifier ça (sauf erreur de ma part) j'avais modifié la valeur d'un fichier (depth=xxx), mais impossible de retrouver ce fichier (ni son nom)...

Auriez-vous une idée, ou une autre piste, svp?

Merci beaucoup!


Matos et system:

* 2.6.42.12-1.fc15.x86_64
* carte graphique -> G86 [GeForce 8400 GS]

Hors ligne

#2 11/04/2012 11:20:10

Refuznik
Membre
Inscription : 31/01/2007
Messages : 6 625

Re : [Résolu] Configurer profondeur des couleurs (?)

C'est ton fichier xorg.conf /etc/X11/xorg.conf

Hors ligne

#3 11/04/2012 11:43:45

shteph
Membre
Inscription : 11/04/2012
Messages : 10

Re : [Résolu] Configurer profondeur des couleurs (?)

Merci pour ta réponse Refuznik, mais j'ai pas de xorg.conf dans /etc/X11/ (ni ailleurs du reste).

J'imagine qu'il faut que j'en crée un...

Saurais-tu ce qu'il faut mettre dedans?

Hors ligne

#4 11/04/2012 11:52:04

shteph
Membre
Inscription : 11/04/2012
Messages : 10

Re : [Résolu] Configurer profondeur des couleurs (?)

Je vais essayé ce qui est indiqué ici:

https://fedoraproject.org/wiki/How_to_create_xorg.conf

You can create a basic xorg.conf using the X executable itself. As root run:

Xorg :1 -configure

Hors ligne

#5 11/04/2012 11:59:16

shteph
Membre
Inscription : 11/04/2012
Messages : 10

Re : [Résolu] Configurer profondeur des couleurs (?)

Est-ce que quelqu'un peut me dire quoi penser de l'opération dont j'ai parlé ci-dessus, le résultat est-il satisfaisant:

# Xorg :1 -configure

X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: x86-02 2.6.32-131.2.1.el6.x86_64 
Current Operating System: Linux sefer 2.6.42.12-1.fc15.x86_64 #1 SMP Tue Mar 20 16:30:08 UTC 2012 x86_64
Kernel command line: ro root=/dev/mapper/vg_sefer-lv_root rd_LVM_LV=vg_sefer/lv_root rd_LVM_LV=vg_sefer/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=fr-latin9 rhgb quiet vga=794
Build Date: 07 September 2011  04:14:13PM
Build ID: xorg-x11-server 1.10.4-1.fc15 
Current version of pixman: 0.20.2
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Wed Apr 11 11:52:46 2012
List of video drivers:
	nv
	glint
	siliconmotion
	sis
	apm
	mga
	savage
	ati
	voodoo
	intel
	cirrus
	openchrome
	sisusb
	ast
	i128
	trident
	tdfx
	nouveau
	i740
	mach64
	vmwlegacy
	r128
	v4l
	vmware
	radeon
	rendition
	dummy
	qxl
	s3virge
	fbdev
	vesa
(EE) Failed to load module "vmwgfx" (module does not exist, 0)
(EE) vmware: Please ignore the above warnings about not being able to to load module/driver vmwgfx
(EE) vmware: Unexpected failure while loading the "vmwlegacy" driver. Giving up.
(EE) Failed to load module "vmware" (a required submodule could not be loaded, 0)
(++) Using config file: "/root/xorg.conf.new"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) NV: The PCI device 0x10de0422 (GeForce 8400 GS) at 01@00:00:0 has a kernel module claiming it.
(EE) NV: This driver cannot operate until it has been unloaded.
(EE) NV: The PCI device 0x10de0422 (GeForce 8400 GS) at 01@00:00:0 has a kernel module claiming it.
(EE) NV: This driver cannot operate until it has been unloaded.
Number of created screens does not match number of detected devices.
  Configuration failed.

Et voici le contenu de mon xorg.conf:

Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	Screen      1  "Screen1" RightOf "Screen0"
	Screen      2  "Screen2" RightOf "Screen1"
	Screen      3  "Screen3" RightOf "Screen2"
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib64/xorg/modules"
	FontPath     "catalogue:/etc/X11/fontpath.d"
	FontPath     "built-ins"
EndSection

Section "Module"
	Load  "dri"
	Load  "record"
	Load  "extmod"
	Load  "dbe"
	Load  "dri2"
	Load  "glx"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Monitor"
	Identifier   "Monitor1"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Monitor"
	Identifier   "Monitor2"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Monitor"
	Identifier   "Monitor3"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "UseFBDev"           	# [<bool>]
        #Option     "Rotate"             	# [<str>]
        #Option     "VideoKey"           	# <i>
        #Option     "FlatPanel"          	# [<bool>]
        #Option     "FPDither"           	# [<bool>]
        #Option     "CrtcNumber"         	# <i>
        #Option     "FPScale"            	# [<bool>]
        #Option     "FPTweak"            	# <i>
        #Option     "DualHead"           	# [<bool>]
	Identifier  "Card0"
	Driver      "nv"
	BusID       "PCI:1:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "UseFBDev"           	# [<bool>]
        #Option     "Rotate"             	# [<str>]
        #Option     "VideoKey"           	# <i>
        #Option     "FlatPanel"          	# [<bool>]
        #Option     "FPDither"           	# [<bool>]
        #Option     "CrtcNumber"         	# <i>
        #Option     "FPScale"            	# [<bool>]
        #Option     "FPTweak"            	# <i>
        #Option     "DualHead"           	# [<bool>]
	Identifier  "Card1"
	Driver      "nv"
	BusID       "PCI:1:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "Rotate"             	# <str>
        #Option     "fbdev"              	# <str>
        #Option     "debug"              	# [<bool>]
	Identifier  "Card2"
	Driver      "fbdev"
	BusID       "PCI:1:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "DefaultRefresh"     	# [<bool>]
        #Option     "ModeSetClearScreen" 	# [<bool>]
	Identifier  "Card3"
	Driver      "vesa"
	BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen1"
	Device     "Card1"
	Monitor    "Monitor1"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen2"
	Device     "Card2"
	Monitor    "Monitor2"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen3"
	Device     "Card3"
	Monitor    "Monitor3"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Est-ce que je le garde tel quel, ou est-ce que je dois le modifier (je pense notamment aux mentions des screen 1 à 3)?

Dernière modification par shteph (11/04/2012 12:00:30)

Hors ligne

#6 12/04/2012 20:00:32

shteph
Membre
Inscription : 11/04/2012
Messages : 10

Re : [Résolu] Configurer profondeur des couleurs (?)

Hop!

Personne n'a une idée pour mon problème? :/

Hors ligne

#7 13/04/2012 11:13:23

shteph
Membre
Inscription : 11/04/2012
Messages : 10

Re : [Résolu] Configurer profondeur des couleurs (?)

Bon...

J'ai copié tel quel (voir contenu du fichier plus haut) le xorg.conf dans /etc/X11/ et le problème est résolu.

Merci à tous pour votre aide!

Hors ligne

#8 10/06/2012 16:43:42

korbé
Membre
Inscription : 04/11/2009
Messages : 348

Re : [Résolu] Configurer profondeur des couleurs (?)

J'ai essayé de faire pareil mais cela n'a pas fonctionné.

Au démarrage Xorg se block et je suis obligé de supprimer xorg.conf.

Mon problème est que j'ai un écran qui gère 10 bits par canaux et non 8, donc après la déclaration du 24 bits (3*8) j'ai rajouté:

	SubSection "Display"
		Viewport   0 0
		Depth     30
	EndSubSection

Mais rien n'y fait. :(

Edit: Simple question: Xorg sait-il gérer plus que 24 bits?

Dernière modification par korbé (10/06/2012 18:25:20)


Portable: Lynx Levio 3510 (Gigabyte I1320) avec Fedora 15 Gnome.
Media-Center: Assus EEEBox avec Fedora 15 XBMC.

Hors ligne

Pied de page des forums