Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Rencontres Fedora 20

#1 09/03/2012 15:55:06

melouzibadize
Membre
Inscription : 02/04/2011
Messages : 37

Apache ne marche plus

Salut la famille,depuis un bout de temps, mon serveur apache démarre plus.
Or qu'il marchait très bien.Chaque fois que je fait

service httpd start

sous root bien sur, j'ai l'erreur suivante

Starting httpd (via systemctl):  Job failed. See system logs and 'systemctl status' for details.
                                                           [ÉCHOUÉ]

J'ai le même message lorsque je fais

su -lc 'service httpd start'

Je n'ai modifié aucun fichier de configuration.
Merci

Hors ligne

#2 09/03/2012 16:58:55

PapsOu
Graphiste en herbe
Rédacteur Wiki
Lieu : Breizh
Inscription : 27/11/2009
Messages : 1 809

Re : Apache ne marche plus

Et ça ça donne quoi « See system logs and 'systemctl status' for details » ???


[PapsOu@Home] $ su -lc 'yum update breizh'

Hors ligne

#3 09/03/2012 17:20:46

melouzibadize
Membre
Inscription : 02/04/2011
Messages : 37

Re : Apache ne marche plus

systemctl status donne

Too few arguments.

J 'ai donc mis

systemctl -a|grep htt*

J'ai eu comme résultat

httpd.service             loaded failed   failed        LSB: start and stop Apache HTTP Server
http-daemon.target        loaded active   active        Web Server

Pour les fichiers logs lequel dois-je lire? /var/log/httpd/access_log? ou celui des erreurs?
Merci

Hors ligne

#4 09/03/2012 17:56:05

PapsOu
Graphiste en herbe
Rédacteur Wiki
Lieu : Breizh
Inscription : 27/11/2009
Messages : 1 809

Re : Apache ne marche plus

error_log pour httpd c'est mieux


[PapsOu@Home] $ su -lc 'yum update breizh'

Hors ligne

#5 09/03/2012 19:06:58

melouzibadize
Membre
Inscription : 02/04/2011
Messages : 37

Re : Apache ne marche plus

Voici ce que donne

cat /var/log/httpd/error_log

C'est assez long et j'y comprends pas grand chose

[Sun Mar 04 21:44:56 2012] [notice] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
[Sun Mar 04 21:44:56 2012] [notice] SSL FIPS mode disabled
[Sun Mar 04 21:44:56 2012] [notice] Digest: generating secret for digest authentication ...
[Sun Mar 04 21:44:56 2012] [notice] Digest: done
[Sun Mar 04 21:44:57 2012] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
[Sun Mar 04 21:44:57 2012] [notice] mod_python: using mutex_directory /tmp 
[Sun Mar 04 21:44:57 2012] [notice] SSL FIPS mode disabled
[Sun Mar 04 21:44:57 2012] [notice] Apache/2.2.17 (Unix) DAV/2 PHP/5.3.6 mod_python/3.3.1 Python/2.7.1 mod_ssl/2.2.17 OpenSSL/1.0.0d-fips mod_perl/2.0.4 Perl/v5.12.3 configured -- resuming normal operations
[Sun Mar 04 21:45:07 2012] [error] [client 127.0.0.1] PHP Warning:  include(menu.php): failed to open stream: No such file or directory in /var/www/html/php/accueil.php on line 3
[Sun Mar 04 21:45:07 2012] [error] [client 127.0.0.1] PHP Warning:  include(): Failed opening 'menu.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/html/php/accueil.php on line 3
[Sun Mar 04 22:03:26 2012] [notice] caught SIGTERM, shutting down
[Mon Mar 05 06:04:03 2012] [notice] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
[Mon Mar 05 06:04:03 2012] [notice] SSL FIPS mode disabled
[Mon Mar 05 06:04:03 2012] [notice] Digest: generating secret for digest authentication ...
[Mon Mar 05 06:04:03 2012] [notice] Digest: done
[Mon Mar 05 06:04:03 2012] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
[Mon Mar 05 06:04:03 2012] [notice] mod_python: using mutex_directory /tmp 
[Mon Mar 05 06:04:04 2012] [notice] SSL FIPS mode disabled
[Mon Mar 05 06:04:04 2012] [notice] Apache/2.2.17 (Unix) DAV/2 PHP/5.3.6 mod_python/3.3.1 Python/2.7.1 mod_ssl/2.2.17 OpenSSL/1.0.0d-fips mod_perl/2.0.4 Perl/v5.12.3 configured -- resuming normal operations
[Mon Mar 05 06:53:50 2012] [notice] caught SIGTERM, shutting down
[Mon Mar 05 06:53:50 2012] [notice] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
[Mon Mar 05 06:53:50 2012] [notice] SSL FIPS mode disabled
[Mon Mar 05 06:53:50 2012] [notice] Digest: generating secret for digest authentication ...
[Mon Mar 05 06:53:50 2012] [notice] Digest: done
[Mon Mar 05 06:53:50 2012] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
[Mon Mar 05 06:53:50 2012] [notice] mod_python: using mutex_directory /tmp 
[Mon Mar 05 06:53:50 2012] [notice] SSL FIPS mode disabled
[Mon Mar 05 06:53:50 2012] [notice] Apache/2.2.17 (Unix) DAV/2 PHP/5.3.6 mod_python/3.3.1 Python/2.7.1 mod_ssl/2.2.17 OpenSSL/1.0.0d-fips mod_perl/2.0.4 Perl/v5.12.3 configured -- resuming normal operations
[Mon Mar 05 07:02:50 2012] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/html/
[Mon Mar 05 07:06:16 2012] [error] [client 127.0.0.1] File does not exist: /var/www/html/php/phpinfo
[Mon Mar 05 07:06:21 2012] [error] [client 127.0.0.1] PHP Warning:  phpinfo(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'GMT/0.0/no DST' instead in /var/www/html/php/phpinfo.php on line 2
[Mon Mar 05 07:08:43 2012] [notice] caught SIGTERM, shutting down

Hors ligne

Pied de page des forums