Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora-Fr aux 15èmes Rencontres Mondiales du Logiciel Libre

#1 12/09/2011 21:37:59

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 91

wifi avec carte RT3090 ne fonctionne plus !

Bonsoir tout le monde,

depuis quelques versions (je ne sais plus laquelle) de noyau, mon wifi ne fonctionne plus.

le wifi de mon portable fonctionnait très bien depuis l'installation de  : kmod-staging, akmod-rt3070.
J'avais notamment suivi ce tuto : http://forums.fedora-fr.org/viewtopic.php?id=52957

ma carte :

$ lspci | grep -i network 
02:00.0 Network controller: RaLink RT3090 Wireless 802.11n 1T/1R PCIe

le voyant est bien allumé.

Quelqu'un a-t-il une idée ?

Hors ligne

#2 12/09/2011 23:37:06

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 91

Re : wifi avec carte RT3090 ne fonctionne plus !

un peu plus d'infos :

Au démarrage j'ai un message qui me dit de lancer systemctl.
Le résultat de la commande me donne entre autres :

akmods.service            loaded failed failed        LSB: Builds and install new kmods from akmod packages

Ca à l'air d'être un problème de compilation du pilote akmod-rt3070 ?

une idée ?

Hors ligne

#3 14/09/2011 20:46:06

Nicosss
Membre
Lieu : Sablons
Inscription : 05/03/2007
Messages : 1 867
Site Web

Re : wifi avec carte RT3090 ne fonctionne plus !

Tu peux installer le kmod-rt3070 correspondant à ton kernel au lieu d'utiliser akmod. Déjà pour voir si ça fonctionne.
Après tu as un problème avec le service akmods.service qui échoue au démarrage.
Tu peux utiliser la commande systemctl pour peut-être en savoir plus.

# systemctl status akmods.service
# systemctl start akmods.service

Tu as bien les kernel-devel et kernel-headers de ton kernel ?


F20_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F20_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F20_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F20_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#4 14/09/2011 21:11:06

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 91

Re : wifi avec carte RT3090 ne fonctionne plus !

Bonsoir,

Merci Nicosss pour ta réponse.
J'avais aussi essayé le kmod. Mais ce n'était pas mieux.

pour le kernel-devel et les headers je pense que c'est bon :

$ rpm -qa kernel\* | sort
kernel-2.6.40.3-0.fc15.x86_64
kernel-2.6.40.4-5.fc15.x86_64
kernel-2.6.40-4.fc15.x86_64
kernel-devel-2.6.40.3-0.fc15.x86_64
kernel-devel-2.6.40.4-5.fc15.x86_64
kernel-devel-2.6.40-4.fc15.x86_64
kernel-headers-2.6.40.4-5.fc15.x86_64

mon noyau :

$ uname -r
2.6.40.4-5.fc15.x86_64

pour les akmod ça pas l'air de fonctionner terrible :

$ systemctl status akmods.service
akmods.service - LSB: Builds and install new kmods from akmod packages
	  Loaded: loaded (/etc/rc.d/init.d/akmods)
	  Active: failed since Wed, 14 Sep 2011 20:53:01 +0200; 10min ago
	 Process: 816 ExecStart=/etc/rc.d/init.d/akmods start (code=exited, status=128)
	  CGroup: name=systemd:/system/akmods.service

# systemctl start akmods.service
Job failed. See system logs and 'systemctl status' for details.

 

je ne vois pas quels logs il faut regarder ! /var/log ?

Je viens de voir qu'il y avait de nouvelles mises à jours dont kmod-rt3070.
Je vais essayer ça.

Hors ligne

#5 14/09/2011 21:19:12

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 91

Re : wifi avec carte RT3090 ne fonctionne plus !

Je viens de voir qu'il y avait de nouvelles mises à jours dont kmod-rt3070.
Je vais essayer ça.

pas mieux !

Hors ligne

#6 14/09/2011 22:02:24

Nicosss
Membre
Lieu : Sablons
Inscription : 05/03/2007
Messages : 1 867
Site Web

Re : wifi avec carte RT3090 ne fonctionne plus !

As-tu le paquet kmod-rt3070-2.6.40.4-5.fc15.x86_64 installé ? Si non alors essaye de l'installer.


F20_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F20_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F20_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F20_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#7 14/09/2011 22:19:53

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 91

Re : wifi avec carte RT3090 ne fonctionne plus !

oui il est installé.
Il y a aussi : rt3070-2.3.0.4-3.fc15 (noarch) ainsi que akmod-rt3070-2.3.0.4-2.fc15(x86_64)

Hors ligne

#8 14/09/2011 22:58:52

Nicosss
Membre
Lieu : Sablons
Inscription : 05/03/2007
Messages : 1 867
Site Web

Re : wifi avec carte RT3090 ne fonctionne plus !

Tu as bien blacklisté les modules rt2x... ?

Que retourne

$ lsmod

F20_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F20_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F20_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F20_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#9 14/09/2011 23:08:30

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 91

Re : wifi avec carte RT3090 ne fonctionne plus !

pour la blacklist :
j'ai rajouté dans /etc/modprobe.d/blacklist.conf :
blacklist rt2800usb
blacklist rt2x00usb
blacklist rt2x00lib
blacklist rt2800pci

lsmod

# lsmod
Module                  Size  Used by
fuse                   62381  3 
ppdev                   7508  0 
parport_pc             21184  0 
lp                      9677  0 
parport                32342  3 ppdev,parport_pc,lp
sunrpc                200079  1 
cpufreq_ondemand        5934  8 
acpi_cpufreq            9536  1 
mperf                   1449  1 acpi_cpufreq
rfcomm                 59295  4 
bnep                   14635  2 
ip6t_REJECT             3992  2 
nf_conntrack_ipv6       7730  6 
nf_defrag_ipv6          9083  1 nf_conntrack_ipv6
nf_conntrack_ipv4       8358  6 
nf_defrag_ipv4          1513  1 nf_conntrack_ipv4
xt_state                1306  12 
nf_conntrack           67613  3 nf_conntrack_ipv6,nf_conntrack_ipv4,xt_state
ip6table_filter         1655  1 
ip6_tables             16908  1 ip6table_filter
iTCO_wdt               13000  0 
snd_hda_codec_hdmi     22499  1 
snd_hda_codec_idt      56485  1 
snd_hda_intel          23896  2 
snd_hda_codec          82508  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
snd_hwdep               6328  1 snd_hda_codec
snd_seq                52322  0 
snd_seq_device          5941  1 snd_seq
snd_pcm                78424  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_timer              19372  2 snd_seq,snd_pcm
snd                    63380  13 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
soundcore               6267  1 snd
hp_accel               14480  0 
hp_wmi                  8103  0 
lis3lv02d              11456  1 hp_accel
i7core_edac            16001  0 
edac_core              40186  3 i7core_edac
btusb                  14828  2 
bluetooth             191587  23 rfcomm,bnep,btusb
r8169                  38146  0 
uvcvideo               57089  0 
videodev               72104  1 uvcvideo
media                  11611  2 uvcvideo,videodev
v4l2_compat_ioctl32     7377  1 videodev
snd_page_alloc          7343  2 snd_hda_intel,snd_pcm
iTCO_vendor_support     2578  1 iTCO_wdt
sparse_keymap           3358  1 hp_wmi
rfkill                 16436  4 hp_wmi,bluetooth
mii                     4335  1 r8169
microcode              18587  0 
i2c_i801                9237  0 
joydev                  9615  0 
input_polldev           3382  1 lis3lv02d
mei                    64331  0 
ipv6                  284570  49 ip6t_REJECT,nf_conntrack_ipv6,nf_defrag_ipv6
wmi                     9033  1 hp_wmi
video                  12340  0 
radeon                690599  3 
ttm                    55273  1 radeon
drm_kms_helper         26474  1 radeon
drm                   193923  5 radeon,ttm,drm_kms_helper
i2c_algo_bit            4974  1 radeon
i2c_core               25712  6 videodev,i2c_i801,radeon,drm_kms_helper,drm,i2c_algo_bit

Hors ligne

#10 14/09/2011 23:28:10

Nicosss
Membre
Lieu : Sablons
Inscription : 05/03/2007
Messages : 1 867
Site Web

Re : wifi avec carte RT3090 ne fonctionne plus !

Effectivement le module rt3070sta n'est pas chargé.
Essaye

# modprobe rt3070sta
# lsmod |grep rt3070sta

Si ce n'est toujours pas bon il faudra reprendre le tuto et vérifier que tout soit bon déjà en utilisant la méthode kmod et non akmod.


F20_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F20_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F20_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F20_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#11 14/09/2011 23:34:11

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 91

Re : wifi avec carte RT3090 ne fonctionne plus !

merci de ta patience,

# lsmod |grep rt3070sta
rt3070sta             573443  0 

je redémarre NetworkManager :

# service NetworkManager restart
Redirecting to /bin/systemctl  restart NetworkManager.service

Je n'ai toujours que la connexion filaire !

Petite question : J'ai kmod-staging d'installé. Est-ce qu'il faut ou au contraire cela peut-il gêner ?

Dernière modification par bouq's (14/09/2011 23:46:48)

Hors ligne

#12 16/09/2011 10:41:33

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 91

Re : wifi avec carte RT3090 ne fonctionne plus !

Bonjour a tous,

Je ne m'en sort toujours pas !
Est-ce que quelqu'un a le même genre de problème avec le driver RT3070 depuis le passage en kernel 2.6.40.x ?
Y a-t-il possibilité de trouver les driver RT3090 et de les compiler/installer? en espérant que cela fonctionne mieux !
Apparemment j'ai un problème de lancement du service akmods, mais apparemment je ne suis pas le seul pour ça (cf : http://forums.fedora-fr.org/viewtopic.php?id=53242)!
Si je ne mets pas le pilote akmod mais plutôt le kmod les problèmes ne devraient pas être liés.

Hors ligne

#13 16/09/2011 15:25:32

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 91

Re : wifi avec carte RT3090 ne fonctionne plus !

En réinstallant kmod-rt3070 après moult essais, je viens de m'apercevoir que j'avais ça comme message :

  Installation  : kmod-rt3070-2.6.40.4-5.fc15.x86_64-2.3.0.4-2.fc15.7.x86_64                                                                     1/3 
WARNING: /lib/modules/2.6.40.4-5.fc15.x86_64/extra/staging/sbe-2t3e3.ko needs unknown symbol alloc_hdlcdev
WARNING: /lib/modules/2.6.40.4-5.fc15.x86_64/extra/staging/sbe-2t3e3.ko needs unknown symbol hdlc_close
WARNING: /lib/modules/2.6.40.4-5.fc15.x86_64/extra/staging/sbe-2t3e3.ko needs unknown symbol hdlc_start_xmit
WARNING: /lib/modules/2.6.40.4-5.fc15.x86_64/extra/staging/sbe-2t3e3.ko needs unknown symbol hdlc_open
WARNING: /lib/modules/2.6.40.4-5.fc15.x86_64/extra/staging/sbe-2t3e3.ko needs unknown symbol hdlc_ioctl
WARNING: /lib/modules/2.6.40.4-5.fc15.x86_64/extra/staging/sbe-2t3e3.ko needs unknown symbol hdlc_change_mtu
WARNING: /lib/modules/2.6.40.4-5.fc15.x86_64/extra/staging/sbe-2t3e3.ko needs unknown symbol unregister_hdlc_device
  Installation  : kmod-rt3070-2.3.0.4-2.fc15.7.x86_64                                                                                            2/3 
  Installation  : rt3070-2.3.0.4-3.fc15.noarch                                                                                                   3/3 

Installé:
  kmod-rt3070.x86_64 0:2.3.0.4-2.fc15.7                                                                                                              

Dépendance(s) installée(s) :
  kmod-rt3070-2.6.40.4-5.fc15.x86_64.x86_64 0:2.3.0.4-2.fc15.7                             rt3070.noarch 0:2.3.0.4-3.fc15                            

une idée ?

Hors ligne

#14 16/09/2011 16:55:11

Nicosss
Membre
Lieu : Sablons
Inscription : 05/03/2007
Messages : 1 867
Site Web

Re : wifi avec carte RT3090 ne fonctionne plus !

Vu tes dernières erreurs, essaye de virer le kmod-staging car c'est peut-être à cause de lui. Réinstalle même le kmod-rt3070 et kmod-rt3070-2.6.40.4-5.fc15.x86_64-2.3.0.4-2.fc15.7.x86_64 au besoin.
Pour ma part j'ai une machine F15 64bits Gnome-Shell qui utilise le kmod-rt3070 et qui fonctionne très bien.

Edit : Correction du kmod-rt3090 en kmod-rt3070

Dernière modification par Nicosss (17/09/2011 10:37:09)


F20_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F20_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F20_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F20_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#15 17/09/2011 10:30:48

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 91

Re : wifi avec carte RT3090 ne fonctionne plus !

kmod-rt3090 ? Je ne l'ai pas trouvé celui-là !
Ca viens peut-être de là ?
Moi j'ai essayé kmod-rt3070 et kmod-rt2860 (car selon ralink il fonctionne pour rt3090 !).

Ca ne fonctionne pas mieux en enlevant kmod-staging.
Je réinstallerai tout en dernier recours, mais j'aimerais bien comprendre dans un premier temps !

Hors ligne

#16 17/09/2011 10:35:21

Nicosss
Membre
Lieu : Sablons
Inscription : 05/03/2007
Messages : 1 867
Site Web

Re : wifi avec carte RT3090 ne fonctionne plus !

Désolé c'est bien une erreur de ma part c'est bien kmod-rt3070.

As-tu redémarré entre temps ?
As-tu des logs dans /var/log/messages qui pourraient donner des pistes ?


F20_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F20_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F20_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F20_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#17 17/09/2011 10:51:01

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 91

Re : wifi avec carte RT3090 ne fonctionne plus !

Oui, j'ai redémarré après la désinstallation de kmod-staging et kmod-rt3070 puis après la réinstallation kmod-rt3070.

pour aujourd'hui dans /var/log/messages j'ai ça (en faisant un |grep fail) :

Sep 17 10:09:05 tigrou bluetoothd[769]: Parsing /etc/bluetooth/serial.conf failed: No such file or directory
Sep 17 10:09:05 tigrou bluetoothd[769]: bluetoothd[769]: Parsing /etc/bluetooth/serial.conf failed: No such file or directory
Sep 17 10:09:05 tigrou kernel: [    2.773438]  pci0000:00: ACPI _OSC request failed (AE_ERROR), returned control mask: 0x1d
Sep 17 10:09:05 tigrou kernel: [    2.789564]  pci0000:7f: ACPI _OSC request failed (AE_NOT_FOUND), returned control mask: 0x1d
Sep 17 10:09:05 tigrou systemd[1]: Unit akmods.service entered failed state.
Sep 17 10:09:14 tigrou gdm-simple-greeter[1312]: Gtk-CRITICAL: gtk_widget_get_mapped: assertion `GTK_IS_WIDGET (widget)' failed
Sep 17 10:09:14 tigrou gdm-simple-greeter[1312]: GLib-GObject-CRITICAL: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Sep 17 10:09:14 tigrou gdm-simple-greeter[1312]: Gtk-CRITICAL: gtk_widget_get_mapped: assertion `GTK_IS_WIDGET (widget)' failed
Sep 17 10:09:14 tigrou gdm-simple-greeter[1312]: GLib-GObject-CRITICAL: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Sep 17 10:09:40 tigrou kernel: [   62.877653] btusb_bulk_complete: hci0 urb ffff88012260e9c0 failed to resubmit (19)
Sep 17 10:09:40 tigrou kernel: [   62.877734] btusb_intr_complete: hci0 urb ffff88012260ecc0 failed to resubmit (19)
Sep 17 10:09:40 tigrou kernel: [   62.877792] btusb_bulk_complete: hci0 urb ffff88012260ea80 failed to resubmit (19)
Sep 17 10:09:40 tigrou kernel: [   62.877840] btusb_send_frame: hci0 urb ffff880118902300 submission failed
Sep 17 10:09:43 tigrou bluetoothd[769]: Parsing /etc/bluetooth/serial.conf failed: No such file or directory
Sep 17 10:09:43 tigrou bluetoothd[769]: bluetoothd[769]: Parsing /etc/bluetooth/serial.conf failed: No such file or directory
Sep 17 10:14:53 tigrou kernel: [    2.689699]  pci0000:00: ACPI _OSC request failed (AE_ERROR), returned control mask: 0x1d
Sep 17 10:14:53 tigrou kernel: [    2.705841]  pci0000:7f: ACPI _OSC request failed (AE_NOT_FOUND), returned control mask: 0x1d
Sep 17 10:15:02 tigrou gdm-simple-greeter[1282]: Gtk-CRITICAL: gtk_widget_get_mapped: assertion `GTK_IS_WIDGET (widget)' failed
Sep 17 10:15:02 tigrou gdm-simple-greeter[1282]: GLib-GObject-CRITICAL: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Sep 17 10:15:02 tigrou gdm-simple-greeter[1282]: Gtk-CRITICAL: gtk_widget_get_mapped: assertion `GTK_IS_WIDGET (widget)' failed
Sep 17 10:15:02 tigrou gdm-simple-greeter[1282]: GLib-GObject-CRITICAL: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Sep 17 10:17:27 tigrou kernel: [    2.764630]  pci0000:00: ACPI _OSC request failed (AE_ERROR), returned control mask: 0x1d
Sep 17 10:17:27 tigrou kernel: [    2.780751]  pci0000:7f: ACPI _OSC request failed (AE_NOT_FOUND), returned control mask: 0x1d
Sep 17 10:17:36 tigrou gdm-simple-greeter[1279]: Gtk-CRITICAL: gtk_widget_get_mapped: assertion `GTK_IS_WIDGET (widget)' failed
Sep 17 10:17:36 tigrou gdm-simple-greeter[1279]: GLib-GObject-CRITICAL: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Sep 17 10:17:36 tigrou gdm-simple-greeter[1279]: Gtk-CRITICAL: gtk_widget_get_mapped: assertion `GTK_IS_WIDGET (widget)' failed
Sep 17 10:17:36 tigrou gdm-simple-greeter[1279]: GLib-GObject-CRITICAL: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

Hors ligne

#18 17/09/2011 11:13:37

Nicosss
Membre
Lieu : Sablons
Inscription : 05/03/2007
Messages : 1 867
Site Web

Re : wifi avec carte RT3090 ne fonctionne plus !

Peux-tu parcourir le fichier pour voir ce que ça donne lorsque le périphérique wifi est "reconnu" ? Voir si tu vois autre chose car ton grep fail n'est peut-être pas le plus judicieux.


F20_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F20_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F20_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F20_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#19 17/09/2011 11:26:41

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 91

Re : wifi avec carte RT3090 ne fonctionne plus !

en faisant lsusb je trouve ça :

Bus 001 Device 004: ID 148f:1000 Ralink Technology, Corp.

Apparemment, si je comprends bien, ça à l'air reconnu !

Sep 17 10:17:27 tigrou kernel: [    5.152431] usb 1-1.3: new full speed USB device number 4 using ehci_hcd
Sep 17 10:17:27 tigrou kernel: [    5.417410] usb 1-1.3: New USB device found, idVendor=148f, idProduct=1000
Sep 17 10:17:27 tigrou kernel: [    5.417418] usb 1-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Sep 17 10:17:27 tigrou kernel: [    5.492861] usb 2-1.3: new full speed USB device number 3 using ehci_hcd
Sep 17 10:17:27 tigrou kernel: [    5.579409] usb 2-1.3: New USB device found, idVendor=138a, idProduct=0005
Sep 17 10:17:27 tigrou kernel: [    5.579416] usb 2-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=1
Sep 17 10:17:27 tigrou kernel: [    5.579422] usb 2-1.3: SerialNumber: 00307e463d87

[edit]

si j'actionne le bouton d’activation de wifi/Bluetooth en OFF puis ON j'ai en faisant dmesg :

[ 4783.943449] usb 1-1.3: USB disconnect, device number 4
[ 4783.943543] btusb_bulk_complete: hci0 urb ffff880136f76480 failed to resubmit (19)
[ 4783.943607] btusb_intr_complete: hci0 urb ffff880136f76d80 failed to resubmit (19)
[ 4783.943669] btusb_bulk_complete: hci0 urb ffff880136f76540 failed to resubmit (19)
[ 4783.943722] btusb_send_frame: hci0 urb ffff880037833a80 submission failed
[ 4785.911114] usb 1-1.3: new full speed USB device number 5 using ehci_hcd
[ 4786.972194] usb 1-1.3: New USB device found, idVendor=148f, idProduct=1000
[ 4786.972198] usb 1-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=0

[/edit]

Dernière modification par bouq's (17/09/2011 11:41:35)

Hors ligne

#20 17/09/2011 13:01:27

Nicosss
Membre
Lieu : Sablons
Inscription : 05/03/2007
Messages : 1 867
Site Web

Re : wifi avec carte RT3090 ne fonctionne plus !

Oui elle est détectée ça il n'y a pas trop de souci par contre as-tu le module rt3070sta chargé aussi ?
Que retourne

$ nmcli dev

Dans tes logs tu ne retrouves rien concernant un périphérique nommé ra0 ?

Dernière modification par Nicosss (17/09/2011 13:02:12)


F20_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F20_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F20_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F20_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#21 17/09/2011 14:00:45

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 91

Re : wifi avec carte RT3090 ne fonctionne plus !

si je fais : grep ra0 -i -R /var/log/ cela ne donne rien.

J'ai chargé rt3070sta à la main (avec modprobe) car il n'y avait rien.

lsmod |grep rt
rt3070sta             573443  0
# nmcli dev
PÉRIPHÉRIQUE TYPE              ÉTAT         
em2        802-3-ethernet    connecté    

Apparemment il n'y a que le filaire.

Hors ligne

#22 17/09/2011 14:20:18

Nicosss
Membre
Lieu : Sablons
Inscription : 05/03/2007
Messages : 1 867
Site Web

Re : wifi avec carte RT3090 ne fonctionne plus !

Que vois-tu dans les logs, après avoir vérifié que le module rt3070sta soit bien chargé, lorsque que tu désactives ta carte puis que tu la réactives ?


F20_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F20_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F20_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F20_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#23 17/09/2011 14:27:16

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 91

Re : wifi avec carte RT3090 ne fonctionne plus !

Désactivation

Sep 17 14:23:18 tigrou NetworkManager[3390]: <info> WiFi now disabled by radio killswitch
Sep 17 14:23:18 tigrou kernel: [14767.855052] usb 1-1.3: USB disconnect, device number 7
Sep 17 14:23:18 tigrou kernel: [14767.855164] btusb_intr_complete: hci0 urb ffff880037833e40 failed to resubmit (19)
Sep 17 14:23:18 tigrou kernel: [14767.855172] btusb_bulk_complete: hci0 urb ffff880037833000 failed to resubmit (19)
Sep 17 14:23:18 tigrou kernel: [14767.855282] btusb_bulk_complete: hci0 urb ffff880037833b40 failed to resubmit (19)
Sep 17 14:23:18 tigrou kernel: [14767.855322] btusb_send_frame: hci0 urb ffff880118e28a80 submission failed
Sep 17 14:23:18 tigrou bluetoothd[756]: HCI dev 0 down
Sep 17 14:23:18 tigrou bluetoothd[756]: Adapter /org/bluez/756/hci0 has been disabled
Sep 17 14:23:18 tigrou bluetoothd[756]: bluetoothd[756]: HCI dev 0 down
Sep 17 14:23:18 tigrou bluetoothd[756]: bluetoothd[756]: Adapter /org/bluez/756/hci0 has been disabled
Sep 17 14:23:19 tigrou bluetoothd[756]: HCI dev 0 unregistered
Sep 17 14:23:19 tigrou bluetoothd[756]: Stopping hci0 event socket
Sep 17 14:23:19 tigrou bluetoothd[756]: Unregister path: /org/bluez/756/hci0
Sep 17 14:23:19 tigrou bluetoothd[756]: bluetoothd[756]: HCI dev 0 unregistered
Sep 17 14:23:19 tigrou bluetoothd[756]: bluetoothd[756]: Stopping hci0 event socket
Sep 17 14:23:19 tigrou bluetoothd[756]: bluetoothd[756]: Unregister path: /org/bluez/756/hci0
Sep 17 14:23:19 tigrou dbus: [system] Rejected send message, 3 matched rules; type="error", sender=":1.66" (uid=500 pid=1634 comm="/usr/bin/gnome-shell ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply=0 destination=":1.0" (uid=0 pid=756 comm="/usr/sbin/bluetoothd -n "))
Sep 17 14:23:19 tigrou systemd[1]: Service bluetooth.target is not needed anymore. Stopping.

Activation

Sep 17 14:24:12 tigrou NetworkManager[3390]: <info> WiFi now enabled by radio killswitch
Sep 17 14:24:13 tigrou kernel: [14822.515029] usb 1-1.3: new full speed USB device number 8 using ehci_hcd
Sep 17 14:24:14 tigrou kernel: [14823.603451] usb 1-1.3: New USB device found, idVendor=148f, idProduct=1000
Sep 17 14:24:14 tigrou kernel: [14823.603459] usb 1-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Sep 17 14:24:14 tigrou bluetoothd[756]: HCI dev 0 registered
Sep 17 14:24:14 tigrou bluetoothd[756]: Listening for HCI events on hci0
Sep 17 14:24:14 tigrou bluetoothd[756]: bluetoothd[756]: HCI dev 0 registered
Sep 17 14:24:14 tigrou bluetoothd[756]: bluetoothd[756]: Listening for HCI events on hci0
Sep 17 14:24:14 tigrou bluetoothd[756]: HCI dev 0 up
Sep 17 14:24:14 tigrou bluetoothd[756]: bluetoothd[756]: HCI dev 0 up
Sep 17 14:24:14 tigrou bluetoothd[756]: Parsing /etc/bluetooth/serial.conf failed: No such file or directory
Sep 17 14:24:14 tigrou bluetoothd[756]: bluetoothd[756]: Parsing /etc/bluetooth/serial.conf failed: No such file or directory
Sep 17 14:24:14 tigrou bluetoothd[756]: Adapter /org/bluez/756/hci0 has been enabled
Sep 17 14:24:14 tigrou bluetoothd[756]: bluetoothd[756]: Adapter /org/bluez/756/hci0 has been enabled

Dernière modification par bouq's (17/09/2011 14:29:25)

Hors ligne

#24 17/09/2011 16:09:38

Nicosss
Membre
Lieu : Sablons
Inscription : 05/03/2007
Messages : 1 867
Site Web

Re : wifi avec carte RT3090 ne fonctionne plus !

C'est étrange ça fait appel au bluethooth.
Désactive le service et refais la même manip pour voir.

# systemctl status bluetoothd.service
# systemctl stop bluetoothd.service
# systemctl disable bluetoothd.service

Par contre si tu utilises le bluetooth avec il faudra repasser une commande avec enable.


F20_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F20_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F20_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F20_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#25 17/09/2011 16:56:20

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 91

Re : wifi avec carte RT3090 ne fonctionne plus !

Merci pour ta persévérance !

systemctl status bluetoothd.service
bluetoothd.service
	  Loaded: error
	  Active: inactive (dead)

Pour le Bluetooth (dont je ne me sers pas) c'est normal je pense car il me semble que le RT3090 gère les 2.

Dernière modification par bouq's (17/09/2011 16:57:47)

Hors ligne

Pied de page des forums