Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora-Fr aux 15èmes Rencontres Mondiales du Logiciel Libre

#1 17/02/2013 00:25:16

balustre
Membre
Lieu : Maisons-Alfort
Inscription : 25/07/2005
Messages : 482

[Résolu] UEFI : invalide drivemap

Bonjour,

Je viens d'installer Fedora 18 sur un portable Samsung serie 3 sous windows 8. L'installation (mode secured boot) s'est bien déroulée et j'ai même été surprise de voir windows 8 apparaitre directement dans les choix de grub2 au démarrage. Par contre, si j'essaie de le lancer, je tombe sur ce message d'erreur :

Can't find command drivemap
Invalid uefi path

Pourtant :

# gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.5

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 1465149168 sectors, 698.6 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): B91639CE-EEF8-420D-9CC8-CB4AFD1E8EAB
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 1465149134
Partitions will be aligned on 8-sector boundaries
Total free space is 5804 sectors (2.8 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048         1023999   499.0 MiB   2700  Basic data partition
   2         1024000         1638399   300.0 MiB   EF00  EFI system partition
   3         1638400         1900543   128.0 MiB   0C01  Microsoft reserved part
   4         1900544       713357312   339.2 GiB   0700  Basic data partition
   5      1413201921      1463050240   23.8 GiB    2700  Basic data partition
   6      1463050241      1465147392   1024.0 MiB  2700  Basic data partition
   7       713359360       713768959   200.0 MiB   EF00  EFI System Partition
   8       713768960       714792959   500.0 MiB   0700  
   9       714792960      1413201919   333.0 GiB   8E00  
[root@localhost ~]# 

La partition EFI de windows semble être /dev/sda2 avec UUID :

# blkid /dev/sda2
/dev/sda2: LABEL="SYSTEM" UUID="ECB7-2436" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="f718c38a-c1d8-4c72-9b59-e098594840a2"

Et le contenu relatif à windows 8 dans /boot/efi/EFI/fedora/grub.cfg

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows 8 (loader) (on /dev/sda2)' --class windows --class os $menuentry_id_option 'osprober-chain-ECB7-2436' {
	insmod part_gpt
	insmod fat
	set root='hd0,gpt2'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  ECB7-2436
	else
	  search --no-floppy --fs-uuid --set=root ECB7-2436
	fi
	drivemap -s (hd0) ${root}
	chainloader +1
}

Je ne comprends pas bien toutes les commandes donc je ne préfère pas me lancer dans des modifications... En plus, l'UUID semble être le bon...

Quelqu'un a-t-il une idée du soucis dans la configuration ?

D'avancer merci.


F19: ASUSTeK M2N, AMD 64 X2 Dual Core Processor 5400+, nVidia GeForce 8400 GS, m-audio Audiophile 24/96

Hors ligne

#2 18/02/2013 23:38:39

Changux
Membre
Lieu : Dijon
Inscription : 28/06/2012
Messages : 45

Re : [Résolu] UEFI : invalide drivemap

Bonjour,
Je n'ai pas la solution mais le même problème sur mon ASUS R500A tout neuf avec un "secured boot" et un Win8 sur lequel j'ai installé une F18.
Par contre si je trouve bien dans le menu de Grub une entrée :
"Windows 8 (loader) (on /dev/sda4)" et malheureusement la même erreur,
en regardant mes fichiers :

[root@Device8-3 jean-pierre]# gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.5

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 1465149168 sectors, 698.6 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 7F6EA309-1BAB-4D4A-9090-5F8ED70708C7
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 1465149134
Partitions will be aligned on 2048-sector boundaries
Total free space is 5805 sectors (2.8 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name                                                                                                           
   1            2048          616447   300.0 MiB   EF00  EFI system partition                                                                                           
   2          616448         2459647   900.0 MiB   2700  Basic data partition                                                                                           
   3         2459648         2721791   128.0 MiB   0C01  Microsoft reserved part                                                                                        
   4         2721792       281579519   133.0 GiB   0700  Basic data partition
   5       281579520       363497471   39.1 GiB    0700  Basic data partition
   6       363499520       363909119   200.0 MiB   EF00  EFI System Partition
   7       363909120       364318719   200.0 MiB   EF00  EFI System Partition
   8      1423183872      1465147391   20.0 GiB    2700  Basic data partition
   9       364318720       365342719   500.0 MiB   0700  
  10       365342720      1423183871   504.4 GiB   8E00

puis :

[root@Device8-3 jean-pierre]# blkid /dev/sda4
/dev/sda4: LABEL="Windows" UUID="D0D2CDF1D2CDDBBA" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="af029779-e09a-4a94-88c3-333d9f956017"

Le label Windows est bien noté sur la partition sda4.
Néanmoins j'ai vu que je pouvais lancer Windows 8 en modifiant les options de boot dans le bios. En effet j'ai le choix "Windows 8" ou "fedora". Cela n'est pas très pratique.
Voici pour info.
Salut.
Jean-Pierre

Hors ligne

#3 16/03/2013 13:44:57

balustre
Membre
Lieu : Maisons-Alfort
Inscription : 25/07/2005
Messages : 482

Re : [Résolu] UEFI : invalide drivemap

bonjour,

je n'ai pas eu accès à l'ordinateur en question pendant un bon moment, désolée pour cette réponse tardive.
En tout cas, j'ai pu résoudre le problème grâce à vos conseils. Le démarrage sous windows fonctionne très bien avec la partie os-prober dans /boot/efi/EFI/fedora/grub.cfg suivante (donc en commentant le set root, le drivemap et en désignant le cgemin du chainloader)

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows 8 (loader) (on /dev/sda2)' --class windows --class os $menuentry_id_option 'osprober-chain-BLKID_du_UEFI_Windows' {
	insmod part_gpt
	insmod fat
	#set root='hd0,gpt2'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 BLKID_du_UEFI_Windows
	else
	  search --no-floppy --fs-uuid --set=root BLKID_du_UEFI_Windows
	fi
	#drivemap -s (hd0) ${root}
	chainloader /EFI/microsoft/BOOT/bootmgfw.efi
}

Dernière modification par balustre (19/03/2013 21:36:15)


F19: ASUSTeK M2N, AMD 64 X2 Dual Core Processor 5400+, nVidia GeForce 8400 GS, m-audio Audiophile 24/96

Hors ligne

#4 16/03/2013 13:47:43

balustre
Membre
Lieu : Maisons-Alfort
Inscription : 25/07/2005
Messages : 482

Re : [Résolu] UEFI : invalide drivemap

Changux a écrit :

Bonjour,
Je n'ai pas la solution mais le même problème sur mon ASUS R500A tout neuf avec un "secured boot" et un Win8 sur lequel j'ai installé une F18.
Par contre si je trouve bien dans le menu de Grub une entrée :
"Windows 8 (loader) (on /dev/sda4)" et malheureusement la même erreur,
en regardant mes fichiers :

[root@Device8-3 jean-pierre]# gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.5

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 1465149168 sectors, 698.6 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 7F6EA309-1BAB-4D4A-9090-5F8ED70708C7
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 1465149134
Partitions will be aligned on 2048-sector boundaries
Total free space is 5805 sectors (2.8 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name                                                                                                           
   1            2048          616447   300.0 MiB   EF00  EFI system partition                                                                                           
   2          616448         2459647   900.0 MiB   2700  Basic data partition                                                                                           
   3         2459648         2721791   128.0 MiB   0C01  Microsoft reserved part                                                                                        
   4         2721792       281579519   133.0 GiB   0700  Basic data partition
   5       281579520       363497471   39.1 GiB    0700  Basic data partition
   6       363499520       363909119   200.0 MiB   EF00  EFI System Partition
   7       363909120       364318719   200.0 MiB   EF00  EFI System Partition
   8      1423183872      1465147391   20.0 GiB    2700  Basic data partition
   9       364318720       365342719   500.0 MiB   0700  
  10       365342720      1423183871   504.4 GiB   8E00

puis :

[root@Device8-3 jean-pierre]# blkid /dev/sda4
/dev/sda4: LABEL="Windows" UUID="D0D2CDF1D2CDDBBA" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="af029779-e09a-4a94-88c3-333d9f956017"

Le label Windows est bien noté sur la partition sda4.
Néanmoins j'ai vu que je pouvais lancer Windows 8 en modifiant les options de boot dans le bios. En effet j'ai le choix "Windows 8" ou "fedora". Cela n'est pas très pratique.
Voici pour info.
Salut.
Jean-Pierre

Dans votre cas, le EFI de windows est /dev/sda1 et non dev/sda4. Il faut donc faire un
#blkid /dev/sda1 et c'est celui-là qu'il faudra mettre dans /boot/efi/EFI/fedora/grub.cfg (voir post précédent).


F19: ASUSTeK M2N, AMD 64 X2 Dual Core Processor 5400+, nVidia GeForce 8400 GS, m-audio Audiophile 24/96

Hors ligne

#5 19/03/2013 18:04:26

Changux
Membre
Lieu : Dijon
Inscription : 28/06/2012
Messages : 45

Re : [Résolu] UEFI : invalide drivemap

Bonjour,
Ce sujet est résolu mais j'aimerais avoir une précision supplémentaire concernant "grub.cfg".
Après plusieurs problèmes voici le résultat de ma commande "gdisk" :

[root@PC-ASUS jean-pierre]# gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.5

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 1465149168 sectors, 698.6 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): A45B7038-DAD1-4897-962A-95550116B3BC
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 1465149134
Partitions will be aligned on 2048-sector boundaries
Total free space is 3757 sectors (1.8 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          616447   300.0 MiB   EF00  EFI system partition
   2          616448         1845247   600.0 MiB   2700  Basic data partition
   3         1845248         2107391   128.0 MiB   0C01  Microsoft reserved part
   4         2107392       362883071   172.0 GiB   0700  Basic data partition
   5       362883072       363292671   200.0 MiB   EF00  EFI System Partition
   6       363292672       364316671   500.0 MiB   0700  
   7      1423183872      1465147391   20.0 GiB    2700  Basic data partition
   8       364316672      1423183871   504.9 GiB   8E00 

et la commande "blkid" :

[root@PC-ASUS jean-pierre]# blkid /dev/sda1
/dev/sda1: LABEL="SYSTEM" UUID="1026-36EA" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="7142155b-a36d-41ee-941d-bed8bf0e0d74"

Si j'ai bien compris les explications de "balustre" je dois modifier mon fichier "/boot/efi/EFI/fedora/grub.cfg" à la main. Mais :

[root@PC-ASUS fedora]# cat grub.cfg
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub2-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub

Alors comment faire pour modifier cette partie de "grub.cfg" ???

menuentry 'Windows 8 (loader) (on /dev/sda4)' --class windows --class os $menuentry_id_option 'osprober-chain-EA2E9D362E9CFCAF' {
        insmod part_gpt
        insmod ntfs
        set root='hd0,gpt4'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  EA2E9D362E9CFCAF
        else
          search --no-floppy --fs-uuid --set=root EA2E9D362E9CFCAF
        fi
        drivemap -s (hd0) ${root}
        chainloader +1

Il faut mettre sda1 à la place de sda4 et le bon UUID soit = "1026-36EA" puis ajouter "/EFI/microsoft/BOOT/bootmgfw.efi" au chainloader.
Peut-on utiliser : grug2-mkconfig ???
Merci pour votre aide.
Jean-Pierre

Hors ligne

#6 19/03/2013 21:34:48

balustre
Membre
Lieu : Maisons-Alfort
Inscription : 25/07/2005
Messages : 482

Re : [Résolu] UEFI : invalide drivemap

Changux a écrit :

Bonjour,
et la commande "blkid" :

[root@PC-ASUS jean-pierre]# blkid /dev/sda1
/dev/sda1: LABEL="SYSTEM" UUID="1026-36EA" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="7142155b-a36d-41ee-941d-bed8bf0e0d74"

Si j'ai bien compris les explications de "balustre" je dois modifier mon fichier "/boot/efi/EFI/fedora/grub.cfg" à la main. Mais :

[root@PC-ASUS fedora]# cat grub.cfg
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub2-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub

Alors comment faire pour modifier cette partie de "grub.cfg" ???

menuentry 'Windows 8 (loader) (on /dev/sda4)' --class windows --class os $menuentry_id_option 'osprober-chain-EA2E9D362E9CFCAF' {
        insmod part_gpt
        insmod ntfs
        set root='hd0,gpt4'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  EA2E9D362E9CFCAF
        else
          search --no-floppy --fs-uuid --set=root EA2E9D362E9CFCAF
        fi
        drivemap -s (hd0) ${root}
        chainloader +1

Il faut mettre sda1 à la place de sda4 et le bon UUID soit = "1026-36EA" puis ajouter "/EFI/microsoft/BOOT/bootmgfw.efi" au chainloader.
Peut-on utiliser : grug2-mkconfig ???
Merci pour votre aide.
Jean-Pierre

En fait, c'est très facile...Ce n'est peut-être pas la "meilleure" méthode mais cela ne pose aucun problème d'éditer à la main le fichier /boot/efi/EFI/fedora/grub.cfg.

Pour cela, j'utilise le logiciel "gedit" : donc en root :
gedit /boot/efi/EFI/fedora/grub.cfg

Ensuite i lsuffit de modifier la partie de grub problématique en la remplaçant par :

menuentry 'Windows 8 (loader) (on /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-1026-36EA' {
        insmod part_gpt
        insmod ntfs
        #set root='hd0,gpt4'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  1026-36EA
        else
          search --no-floppy --fs-uuid --set=root 1026-36EA
        fi
        #drivemap -s (hd0) ${root}
        chainloader /EFI/microsoft/BOOT/bootmgfw.efi

suivi d'un redémarrage pour tester...

Il faudrait aussi faire de même pour les autres partitions (recovery...).


F19: ASUSTeK M2N, AMD 64 X2 Dual Core Processor 5400+, nVidia GeForce 8400 GS, m-audio Audiophile 24/96

Hors ligne

#7 21/03/2013 22:25:32

Changux
Membre
Lieu : Dijon
Inscription : 28/06/2012
Messages : 45

Re : [Résolu] UEFI : invalide drivemap

Bonjour et merci,
J'étais absent.
Je vais faire un essai, mais en regardant bien le fichier "grub.cfg" ne faut-il pas en plus changer les "gpt4" en "gpt1" ???? Pour être en relation avec "sda1" ???
Je ne sais pas. C'est la raison pour laquelle je suis un peu rétissant.
Je n'utilise Windows que très rarement dans des cas spécifiques, et concernant "recovery" ne n'est pas important pour moi.
Salut.
Jean-Pierre

Hors ligne

#8 22/03/2013 10:49:39

balustre
Membre
Lieu : Maisons-Alfort
Inscription : 25/07/2005
Messages : 482

Re : [Résolu] UEFI : invalide drivemap

Changux a écrit :

Bonjour et merci,
J'étais absent.
Je vais faire un essai, mais en regardant bien le fichier "grub.cfg" ne faut-il pas en plus changer les "gpt4" en "gpt1" ???? Pour être en relation avec "sda1" ???
Je ne sais pas. C'est la raison pour laquelle je suis un peu rétissant.

Non non !! Il y a auncun soucis avec cette configuration, ca marche très bien sur les deux ordinateurs où je l'ai testé !
Mais effectivement, changer gpt4 en gpt1 est logique (et ne posera pas de problème), mais ce n'est pas nécessaire pour pouvoir démarrer sous windows.

Dernière modification par balustre (22/03/2013 10:54:51)


F19: ASUSTeK M2N, AMD 64 X2 Dual Core Processor 5400+, nVidia GeForce 8400 GS, m-audio Audiophile 24/96

Hors ligne

#9 27/03/2013 22:47:38

Changux
Membre
Lieu : Dijon
Inscription : 28/06/2012
Messages : 45

Re : [Résolu] UEFI : invalide drivemap

Bonjour,
J'ai fini par modifier mon fichier "grub.cfg" comme ci-desous :

menuentry 'Windows 8 (loader) (on /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-1026-36EA' {
        insmod part_gpt
        insmod ntfs
        #set root='hd0,gpt1'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1 1026-36EA
        else
          search --no-floppy --fs-uuid --set=root 1026-36EA
        fi
        #drivemap -s (hd0) ${root}
        chainloader /EFI/microsoft/BOOT/bootmgfw.efi

Mais malheureusement cela ne marche pas. Lorsque je sélectionne ce choix pour lancer Window 8 au niveau du menu de grub, l'écran de grub devient noir et tout ce bloque.
Je dois arrêter la machine avec l'interrupteur.
Bon merci malgré tout. Si je trouve une solution je le signalerai.
Salut.
Jean-Pierre

Hors ligne

#10 28/03/2013 08:35:37

chepioq
FEDORA FOR EVER
Lieu : a l'est de marseille
Inscription : 07/06/2006
Messages : 5 630

Re : [Résolu] UEFI : invalide drivemap

Il te manque une accolade fermante } à la fin de ton fichier

menuentry 'Windows 8 (loader) (on /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-1026-36EA' {
        insmod part_gpt
        insmod ntfs
        #set root='hd0,gpt1'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1 1026-36EA
        else
          search --no-floppy --fs-uuid --set=root 1026-36EA
        fi
        #drivemap -s (hd0) ${root}
        chainloader /EFI/microsoft/BOOT/bootmgfw.efi
        }

Tout est dans tout... et réciproquement...
C'est quoi un chalumeau??? C'est un dromaludaire à deux bosses...
Quand le sage montre la lune l'imbécile regarde le doigt...
1277887812.gif

Hors ligne

#11 29/03/2013 17:53:58

Changux
Membre
Lieu : Dijon
Inscription : 28/06/2012
Messages : 45

Re : [Résolu] UEFI : invalide drivemap

Bonjour,
Merci , mais malheureusement il ne manque rien. Il y a bien une accolade fermante } en fin. Voir ci-joint :

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows Recovery Environment (loader) (on /dev/sda2)' --class windows --class os $menuentry_id_option 'osprober-chain-E88C99268C98F074' {
        insmod part_gpt
        insmod ntfs
        set root='hd0,gpt2'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  E88C99268C98F074
        else
          search --no-floppy --fs-uuid --set=root E88C99268C98F074
        fi
        drivemap -s (hd0) ${root}
        chainloader +1
}
menuentry 'Windows 8 (loader) (on /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-1026-36EA' {
        insmod part_gpt
        insmod ntfs
        #set root='hd0,gpt1'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1 1026-36EA
        else
          search --no-floppy --fs-uuid --set=root 1026-36EA
        fi
        #drivemap -s (hd0) ${root}
        chainloader /EFI/microsoft/BOOT/bootmgfw.efi
}
### END /etc/grub.d/30_os-prober ###

Salut.
Jean-Pierre

Hors ligne

#12 31/03/2013 17:04:04

Changux
Membre
Lieu : Dijon
Inscription : 28/06/2012
Messages : 45

Re : [Résolu] UEFI : invalide drivemap

Bonjour,
C'est OK et merci.
J'ai supprimé le "#". Tout marche bien.
J'avais simplement suivi le modèle de "Balustre en #4", mais ...
Salut.
Jean-Pierre

Hors ligne

#13 02/06/2013 16:28:53

balustre
Membre
Lieu : Maisons-Alfort
Inscription : 25/07/2005
Messages : 482

Re : [Résolu] UEFI : invalide drivemap

Merci d'avoir posté ta solution aussi ! C'est étrange, j'ai bien vérifié et ça fonctionne très bien avec le # pour moi...


F19: ASUSTeK M2N, AMD 64 X2 Dual Core Processor 5400+, nVidia GeForce 8400 GS, m-audio Audiophile 24/96

Hors ligne

Pied de page des forums