Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora-Fr aux 15èmes Rencontres Mondiales du Logiciel Libre

#1 14/07/2012 17:00:12

mehdi.dell
Membre
Inscription : 04/12/2008
Messages : 20

installation fc17 sur un amd apu A8 3510-MX

Bonjour
je viens d'installer fc17 il ne démarre qu'en mode terminal avec un message Cannot open font file true. voici mon Xorg.0.log:

[   369.104] 
X.Org X Server 1.12.0
Release Date: 2012-03-04
[   369.104] X Protocol Version 11, Revision 0
[   369.104] Build Operating System: x86-01 2.6.32-220.4.1.el6.x86_64 
[   369.104] Current Operating System: Linux dallhost.dalldomain 3.3.4-5.fc17.x86_64 #1 SMP Mon May 7 17:29:34 UTC 2012 x86_64
[   369.105] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.3.4-5.fc17.x86_64 root=UUID=6be0106b-fc30-4c4b-80fa-42bc2feae123 ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True rd.luks=0 KEYTABLE=fr LANG=en_US.UTF-8 rhgb quiet
[   369.105] Build Date: 14 March 2012  03:02:21PM
[   369.105] Build ID: xorg-x11-server 1.12.0-2.fc17 
[   369.105] Current version of pixman: 0.24.4
[   369.105] 	Before reporting problems, check [url]http://wiki.x.org[/url]
	to make sure that you have the latest version.
[   369.105] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   369.105] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul 14 17:22:30 2012
[   369.106] (==) Using config file: "/etc/X11/xorg.conf"
[   369.106] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   369.106] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   369.106] (==) No Layout section.  Using the first Screen section.
[   369.106] (==) No screen section available. Using defaults.
[   369.106] (**) |-->Screen "Default Screen Section" (0)
[   369.106] (**) |   |-->Monitor "<default monitor>"
[   369.106] (==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
[   369.106] (**) |   |-->Device "Videocard0"
[   369.106] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[   369.106] (==) Automatically adding devices
[   369.106] (==) Automatically enabling devices
[   369.106] (==) FontPath set to:
	catalogue:/etc/X11/fontpath.d,
	built-ins
[   369.106] (==) ModulePath set to "/usr/lib64/xorg/modules"
[   369.106] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   369.106] (II) Loader magic: 0x7c5ac0
[   369.106] (II) Module ABI versions:
[   369.106] 	X.Org ANSI C Emulation: 0.4
[   369.106] 	X.Org Video Driver: 12.0
[   369.106] 	X.Org XInput driver : 16.0
[   369.106] 	X.Org Server Extension : 6.0
[   369.108] (--) PCI:*(0:0:1:0) 1002:9641:144d:c609 rev 0, Mem @ 0xa0000000/268435456, 0xfeb00000/262144, I/O @ 0x0000f000/256, BIOS @ 0x????????/131072
[   369.108] (--) PCI: (0:2:0:0) 1002:6741:144d:c609 rev 0, Mem @ 0xb0000000/268435456, 0xfea20000/131072, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
[   369.108] (II) LoadModule: "extmod"
[   369.108] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[   369.108] (II) Module extmod: vendor="X.Org Foundation"
[   369.108] 	compiled for 1.12.0, module version = 1.0.0
[   369.108] 	Module class: X.Org Server Extension
[   369.108] 	ABI class: X.Org Server Extension, version 6.0
[   369.108] (II) Loading extension SELinux
[   369.108] (II) Loading extension MIT-SCREEN-SAVER
[   369.108] (II) Loading extension XFree86-VidModeExtension
[   369.108] (II) Loading extension XFree86-DGA
[   369.108] (II) Loading extension DPMS
[   369.108] (II) Loading extension XVideo
[   369.108] (II) Loading extension XVideo-MotionCompensation
[   369.108] (II) Loading extension X-Resource
[   369.108] (II) LoadModule: "dbe"
[   369.108] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[   369.108] (II) Module dbe: vendor="X.Org Foundation"
[   369.108] 	compiled for 1.12.0, module version = 1.0.0
[   369.108] 	Module class: X.Org Server Extension
[   369.108] 	ABI class: X.Org Server Extension, version 6.0
[   369.108] (II) Loading extension DOUBLE-BUFFER
[   369.108] (II) LoadModule: "glx"
[   369.109] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   369.109] (II) Module glx: vendor="X.Org Foundation"
[   369.109] 	compiled for 1.12.0, module version = 1.0.0
[   369.109] 	ABI class: X.Org Server Extension, version 6.0
[   369.109] (==) AIGLX enabled
[   369.109] (II) Loading extension GLX
[   369.109] (II) LoadModule: "record"
[   369.109] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[   369.109] (II) Module record: vendor="X.Org Foundation"
[   369.109] 	compiled for 1.12.0, module version = 1.13.0
[   369.109] 	Module class: X.Org Server Extension
[   369.109] 	ABI class: X.Org Server Extension, version 6.0
[   369.109] (II) Loading extension RECORD
[   369.109] (II) LoadModule: "dri"
[   369.109] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[   369.109] (II) Module dri: vendor="X.Org Foundation"
[   369.109] 	compiled for 1.12.0, module version = 1.0.0
[   369.109] 	ABI class: X.Org Server Extension, version 6.0
[   369.109] (II) Loading extension XFree86-DRI
[   369.109] (II) LoadModule: "dri2"
[   369.109] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[   369.109] (II) Module dri2: vendor="X.Org Foundation"
[   369.109] 	compiled for 1.12.0, module version = 1.2.0
[   369.109] 	ABI class: X.Org Server Extension, version 6.0
[   369.109] (II) Loading extension DRI2
[   369.109] (II) LoadModule: "vesa"
[   369.110] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[   369.110] (II) Module vesa: vendor="X.Org Foundation"
[   369.110] 	compiled for 1.11.99.901, module version = 2.3.0
[   369.110] 	Module class: X.Org Video Driver
[   369.110] 	ABI class: X.Org Video Driver, version 12.0
[   369.110] (II) VESA: driver for VESA chipsets: vesa
[   369.110] (--) using VT number 1

[   369.115] vesa: Ignoring device with a bound kernel driver
[   369.115] (WW) Falling back to old probe method for vesa
[   369.116] (II) UnloadModule: "vesa"
[   369.116] (EE) Screen(s) found, but none have a usable configuration.
[   369.116] 
Fatal server error:
[   369.116] no screens found
[   369.116] 
Please consult the Fedora Project support 
	 at [url]http://wiki.x.org[/url]
 for help. 
[   369.116] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   369.116] 
[   369.152] Server terminated with error (1). Closing log file.

L'erreur vient du screen " no screens found ".
Merci de m'aider a résoudre se problème.

Dernière modification par mehdi.dell (14/07/2012 21:50:17)


Processor :  AMD A8-3510MX Cadencé à 1.80 GHz QuadCoeurs; Carte mère:  SAMSUNG ELECTRONICS CO., LTD. 305V4A/305V4A 04PW;
Carte Graphique: AMD Radeon(TM) HD 6620G Ecran: Generic PnP Monitor SAMSUNG
Réseau:  Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express)

Hors ligne

#2 14/07/2012 18:06:10

Nicosss
Membre
Lieu : Sablons
Inscription : 05/03/2007
Messages : 1 852
Site Web

Re : installation fc17 sur un amd apu A8 3510-MX

Il semble que ce soit plus lié à Grub et l'option SYSFONT où tu as true au lieu de latarcyrheb-sun16.

Tu peux éditer le fichier /etc/default/grub en root et faire la modification, puis regénérer ton fichier /boot/grub2/grub.cfg par la commande suivante

# grub2-mkconfig -o /boot/grub2/grub.cfg

Voilà dis-nous si ça suffit pour régler ton problème.

P.S. : Pense à te servir des balises code pour mettre tes logs, ce sera plus lisible.


F20_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F20_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F20_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F20_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#3 14/07/2012 21:52:21

mehdi.dell
Membre
Inscription : 04/12/2008
Messages : 20

Re : installation fc17 sur un amd apu A8 3510-MX

Salut Nicoss

Merci pour ta reponce, mais je savais que cette modification du grub.cfg corrigé la premier bug. Cependant, mon server x ne start tjs pas.


Processor :  AMD A8-3510MX Cadencé à 1.80 GHz QuadCoeurs; Carte mère:  SAMSUNG ELECTRONICS CO., LTD. 305V4A/305V4A 04PW;
Carte Graphique: AMD Radeon(TM) HD 6620G Ecran: Generic PnP Monitor SAMSUNG
Réseau:  Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express)

Hors ligne

#4 15/07/2012 00:05:53

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 17 627

Re : installation fc17 sur un amd apu A8 3510-MX

Tu ne penses pas qu'indiquer la configuration matérielle et surtout la/les carte(s) graphique(s) ainsi que le moniteur pourrait aider ?


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#5 15/07/2012 04:13:02

mehdi.dell
Membre
Inscription : 04/12/2008
Messages : 20

Re : installation fc17 sur un amd apu A8 3510-MX

C'est fait dans mas signature :)


Processor :  AMD A8-3510MX Cadencé à 1.80 GHz QuadCoeurs; Carte mère:  SAMSUNG ELECTRONICS CO., LTD. 305V4A/305V4A 04PW;
Carte Graphique: AMD Radeon(TM) HD 6620G Ecran: Generic PnP Monitor SAMSUNG
Réseau:  Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express)

Hors ligne

#6 15/07/2012 08:09:13

Nicosss
Membre
Lieu : Sablons
Inscription : 05/03/2007
Messages : 1 852
Site Web

Re : installation fc17 sur un amd apu A8 3510-MX

Déjà un début de réponse http://www.x.org/wiki/FAQErrorMessages# … iguration. pour t'orienter dans tes recherches.

Peux-tu poster le contenu de ton fichier /etc/X11/xorg.conf.

Ensuite essaye de démarrer en init 3 pour faire les mises à jours de Fedora voir s'il ça corrige quelque chose. Tu pourras aussi essayer de faire un startx à partir de ton user en init 3 pour voir ce que ça donne en messages et regarder aussi les messages dans /var/log/messages.

Sinon plus basiquement, as-tu essayé de changer de port vidéo quoique ce doit être un portable ? Tu as fait ton installation à partir de quel média ? A partir d'un Live ça fonctionne ?

Dernière modification par Nicosss (15/07/2012 20:04:54)


F20_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F20_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F20_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F20_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#7 15/07/2012 09:23:19

VINDICATORs
RédactWikix and the graphicatorix!
Rédacteur Wiki
Lieu : Arrosès(64) France
Inscription : 23/11/2004
Messages : 13 542
Site Web

Re : installation fc17 sur un amd apu A8 3510-MX

Donc il semble qu'il y ai un problème avec la détection du port de la sortie de l'écran par la partie graphique.

Je suis d'accord pour voir si la détection sur l'écran externe n'est pas fonctionnel. Si c'est le cas, ou non, il faudrait le rapporter sur le bugzilla.

Si c'est fonctionnel, il faudrait regarder dans les options du pilote "man radeon" pour voir comment forcer la détection de la bonne sortie.

Je pense que cela doit ce situer à ce niveau :

Option "IgnoreEDID" "boolean"
              Do  not use EDID data for mode validation.  DDC is still used for monitor detection.
              This is different from NoDDC option.
              The default value is off.

       Option "CustomEDID" "string"
              Forces the X driver to use the EDID data specified in a file rather  than  the  dis‐
              play's EDID. Also overrides DDC monitor detection.
              You may specify a semicolon-separated list of output name and filename pairs with an
              optional flag, "digital" or "analog", to override the digital bit in the EDID  which
              is  used  by  the  driver  to determine whether to use the analog or digital encoder
              associated with a DVI-I port.  The output name  is  the  RandR  output  name,  e.g.,
              "VGA-0" or "DVI-0"; consult the Xorg log for the supported output names of any given
              system.
              The file must contain a raw 128-byte EDID block, as captured by get-edid.
              For example: Option "CustomEDID"  "VGA-0:/tmp/edid1.bin;  DVI-0:/tmp/edid2.bin:digi‐
              tal"  will  assign the EDID from the file /tmp/edid1.bin to the output device VGA-0,
              and the EDID from the file /tmp/edid2.bin to the output device DVI-0 and  force  the
              DVI port to use the digital encoder.
              Note  that  an output name must always be specified, even if only one EDID is speci‐
              fied.
              Caution: Specifying an EDID that doesn't exactly match your display may damage  your
              hardware, as it allows the driver to specify timings beyond the capabilities of your
              display. Use with care.

Mais bon je pense que c'est plus un problème du pilote qu'il faudrait mettre à jour. Il me semble avoir vu passer dans la branche de développement la correction de ce problème.

A tu fais les mises à jour de fedora?

Dernière modification par VINDICATORs (15/07/2012 09:27:00)


Intel i7 4771 + MSI Z87-GD65 Gaming, 16Go de RAM DDR3 1866Mhz Corsair Vengeance C9, ATI HD4850(640Mhz)512Mo GDDR3(1986Mhz)
Real 520w, SSD Crucial M4 129Go + 500Go WD black + 2To Seagate
Samsung Galaxy S3 32Go Bleu nuit

Hors ligne

#8 15/07/2012 18:59:22

mehdi.dell
Membre
Inscription : 04/12/2008
Messages : 20

Re : installation fc17 sur un amd apu A8 3510-MX

Hy

Mais je n'ai aucun user ni group. je me demande s'il n'ont pas ete créer lors de l'install.?!


Processor :  AMD A8-3510MX Cadencé à 1.80 GHz QuadCoeurs; Carte mère:  SAMSUNG ELECTRONICS CO., LTD. 305V4A/305V4A 04PW;
Carte Graphique: AMD Radeon(TM) HD 6620G Ecran: Generic PnP Monitor SAMSUNG
Réseau:  Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express)

Hors ligne

Pied de page des forums