Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Sortie de la bêta de Fedora 21

#1 03/06/2012 18:18:06

Moustache
Membre
Inscription : 03/06/2012
Messages : 26

[Résolu] Mise à jour impossible

Bonjour, je suis nouveau sur Fedora et je me heurte à un problème avec yum, impossible de faire des mise à jour depuis que la dernière a été stoppée accidentellement alors qu'elle était en cours.
Je reçois un message d'erreur disant :

Impossible d'obtenir les mises à jour.
Échec de traitement de la requête.

There are unfinished transactions remaining. Please run yum-complete-transaction as root

Je l'ai fait plusieurs fois, ça ne change rien au problème, j'ai aussi essayé yum clean all qui n'a pas aidé davantage.
Quelqu'un a une idée?

Dernière modification par Moustache (03/06/2012 18:18:29)


Fedora 17 (64 bits)

Hors ligne

#2 04/06/2012 01:06:28

Edouard_le_homard
Membre
Inscription : 24/03/2012
Messages : 1 141

Re : [Résolu] Mise à jour impossible

Bonjour,

quelle version de fedora utilises tu ?

si j'ai bien compris tu as fait le "yum-complete-transaction" plusieurs fois ?


F20 x86_64 KDE - Asus X73SV

Hors ligne

#3 04/06/2012 12:30:44

mtirabo
Membre
Inscription : 24/05/2006
Messages : 408
Site Web

Re : [Résolu] Mise à jour impossible

Bonjour: essaies

# updatedb

Microsoft leader mondial du monopole...
chatonquijoues52.gif
F20 64 KDE

Hors ligne

#4 04/06/2012 16:00:34

Moustache
Membre
Inscription : 03/06/2012
Messages : 26

Re : [Résolu] Mise à jour impossible

J'utilise Fedora 17 (64 bits).
J'ai essayé plusieurs fois yum-complete-transaction puisque la commande est censée s'occuper d'une "transaction" à la fois si j'ai bien compris? Mais c'est vraiment comme si rien ne changeait du tout, j'ai bien essayé une dizaine de fois.

J'ai essayé updatedb en root, le problème persiste toujours, même erreur.

Dernière modification par Moustache (04/06/2012 16:00:51)


Fedora 17 (64 bits)

Hors ligne

#5 04/06/2012 16:07:06

Edouard_le_homard
Membre
Inscription : 24/03/2012
Messages : 1 141

Re : [Résolu] Mise à jour impossible

mmm peux tu copier le retour de la commande yum-complete-transaction s'il te plait ?

d'autre part, ta F17 est elle une fresh install ou une upgrade ? le cas échéant, que te renvoie la commande uname -a ?


F20 x86_64 KDE - Asus X73SV

Hors ligne

#6 04/06/2012 16:21:14

Moustache
Membre
Inscription : 03/06/2012
Messages : 26

Re : [Résolu] Mise à jour impossible

Attention, c'est très long :

J'ai rajouté des points de suspension entre "The remaining transaction had 108 elements left to run" et le reste parce que ça défile et je n'ai pas su copier ce qu'il y avait entre (impossible de remonter jusque là dans le terminal à la fin de la procédure).

Loaded plugins: langpacks, presto, refresh-packagekit
Repository google-chrome is listed more than once in the configuration
There are 1 outstanding transactions to complete. Finishing the most recent one
The remaining transaction had 108 elements left to run

...

---> Package wine-twain.x86_64 0:1.5.3-1.fc17 will be erased
---> Package wine-wow.x86_64 0:1.5.3-1.fc17 will be erased
--> Running transaction check
---> Package PackageKit-device-rebind.x86_64 0:0.7.4-4.fc17 will be erased
---> Package mingw32-wine-gecko.noarch 0:1.5-2.fc17 will be erased
---> Package mingw64-wine-gecko.noarch 0:1.5-2.fc17 will be erased
---> Package plymouth-system-theme.x86_64 0:0.8.4-0.20120319.2.fc17 will be erased
--> Finished Dependency Resolution
Error: Trying to remove "yum", which is protected
 You could try using --skip-broken to work around the problem
** Found 33 pre-existing rpmdb problem(s), 'yum check' output follows:
PackageKit-0.7.4-4.fc17.x86_64 is a duplicate with PackageKit-0.7.4-3.fc17.x86_64
PackageKit-device-rebind-0.7.4-4.fc17.x86_64 is a duplicate with PackageKit-device-rebind-0.7.4-3.fc17.x86_64
PackageKit-glib-0.7.4-4.fc17.x86_64 is a duplicate with PackageKit-glib-0.7.4-3.fc17.x86_64
PackageKit-yum-0.7.4-4.fc17.x86_64 is a duplicate with PackageKit-yum-0.7.4-3.fc17.x86_64

...

--> Processing Dependency: libopencv_features2d.so.2.3()(64bit) for package: gstreamer-plugins-bad-free-extras-0.10.23-2.fc17.x86_64
--> Processing Dependency: libopencv_flann.so.2.3()(64bit) for package: gstreamer-plugins-bad-free-extras-0.10.23-2.fc17.x86_64
--> Processing Dependency: libopencv_highgui.so.2.3()(64bit) for package: gstreamer-plugins-bad-free-extras-0.10.23-2.fc17.x86_64
--> Processing Dependency: libopencv_imgproc.so.2.3()(64bit) for package: gstreamer-plugins-bad-free-extras-0.10.23-2.fc17.x86_64
--> Processing Dependency: libopencv_legacy.so.2.3()(64bit) for package: gstreamer-plugins-bad-free-extras-0.10.23-2.fc17.x86_64
--> Processing Dependency: libopencv_ml.so.2.3()(64bit) for package: gstreamer-plugins-bad-free-extras-0.10.23-2.fc17.x86_64
--> Processing Dependency: libopencv_objdetect.so.2.3()(64bit) for package: gstreamer-plugins-bad-free-extras-0.10.23-2.fc17.x86_64
--> Processing Dependency: libopencv_video.so.2.3()(64bit) for package: gstreamer-plugins-bad-free-extras-0.10.23-2.fc17.x86_64
---> Package pango.i686 0:1.30.0-1.fc17 will be erased
---> Package pango.x86_64 0:1.30.0-1.fc17 will be erased
---> Package paps.x86_64 0:0.6.8-18.fc17 will be erased
---> Package pinentry-gtk.x86_64 0:0.8.1-6.fc17 will be erased
---> Package poppler.x86_64 0:0.18.4-3.fc17 will be erased
---> Package poppler-glib.x86_64 0:0.18.4-3.fc17 will be erased
---> Package poppler-utils.x86_64 0:0.18.4-3.fc17 will be erased
--> Processing Dependency: poppler-utils for package: 1:cups-1.5.2-12.fc17.x86_64
---> Package pulseaudio-gdm-hooks.x86_64 0:1.1-9.fc17 will be erased
---> Package pygtk2.x86_64 0:2.24.0-4.fc17 will be erased
--> Processing Dependency: pygtk2 for package: python-slip-gtk-0.2.20-2.fc17.noarch
--> Processing Dependency: pygtk2 >= 2.8.0 for package: gstreamer-python-0.10.19-3.fc17.x86_64
--> Processing Dependency: pygtk2 >= 2.16 for package: system-config-users-1.2.115-1.fc17.noarch
--> Processing Dependency: pygtk2(x86-64) >= 2.10.3 for package: gnome-python2-2.28.1-8.fc17.x86_64
---> Package pygtk2-libglade.x86_64 0:2.24.0-4.fc17 will be erased
--> Processing Dependency: pygtk2-libglade >= 2.14.0 for package: authconfig-gtk-6.2.1-1.fc17.x86_64
---> Package qt-x11.x86_64 1:4.8.1-10.fc17 will be erased
---> Package rest.x86_64 0:0.7.12-2.fc17 will be erased
---> Package setroubleshoot.x86_64 0:3.1.11-1.fc17 will be erased
---> Package smc-meera-fonts.noarch 0:5.0.1-2.fc17 will be erased
---> Package telepathy-gabble.x86_64 0:0.16.0-1.fc17 will be erased
---> Package telepathy-salut.x86_64 0:0.8.0-1.fc17 will be erased
---> Package thai-scalable-waree-fonts.noarch 0:0.5.0-1.fc17 will be erased
---> Package totem-pl-parser.x86_64 0:3.4.2-1.fc17 will be erased
---> Package upower.x86_64 0:0.9.16-1.fc17 will be erased
--> Processing Dependency: libupower-glib.so.1()(64bit) for package: 1:telepathy-mission-control-5.12.0-1.fc17.x86_64
---> Package urw-fonts.noarch 0:2.4-11.fc17 will be erased
---> Package usermode-gtk.x86_64 0:1.109-1.fc17 will be erased
---> Package vlc-core.x86_64 0:2.0.1-1.fc17 will be erased
---> Package vlgothic-fonts.noarch 0:20120325-1.fc17 will be erased
---> Package webkitgtk3.x86_64 0:1.8.1-2.fc17 will be erased
---> Package wine-fonts.noarch 0:1.5.3-1.fc17 will be erased
--> Processing Dependency: wine-fonts = 1.5.3-1.fc17 for package: wine-1.5.3-1.fc17.x86_64
---> Package xorg-x11-fonts-Type1.noarch 0:7.5-5.fc17 will be erased
---> Package xorg-x11-fonts-ethiopic.noarch 0:7.5-5.fc17 will be erased
---> Package xorg-x11-fonts-misc.noarch 0:7.5-5.fc17 will be erased
---> Package xulrunner.x86_64 0:12.0-1.fc17 will be erased
--> Processing Dependency: gecko-libs >= %{gecko_version} for package: libproxy-mozjs-0.4.7-4.fc17.x86_64
---> Package yum.noarch 0:3.4.3-23.fc17 will be erased
--> Processing Dependency: yum for package: 1:anaconda-yum-plugins-1.0-7.fc17.noarch
--> Processing Dependency: yum >= 3.0 for package: yum-langpacks-0.2.4-3.fc17.noarch
--> Processing Dependency: yum >= 3.0 for package: yum-presto-0.7.3-1.fc17.noarch
--> Processing Dependency: yum >= 2.9.2 for package: anaconda-17.29-1.fc17.x86_64
--> Processing Dependency: yum >= 3.4.3-4 for package: createrepo-0.9.9-11.fc17.noarch
--> Processing Dependency: yum >= 3.2.29 for package: yum-utils-1.1.31-4.fc17.noarch
--> Processing Dependency: yum >= 3.2.19 for package: PackageKit-yum-0.7.4-4.fc17.x86_64
--> Running transaction check
---> Package NetworkManager-gnome.x86_64 1:0.9.4.0-9.git20120521.fc17 will be erased
---> Package NetworkManager-gtk.x86_64 1:0.9.4.0-9.git20120521.fc17 will be erased
---> Package NetworkManager-openconnect.x86_64 0:0.9.4.0-3.fc17 will be erased
---> Package NetworkManager-openvpn.x86_64 1:0.9.3.997-1.fc17 will be erased
---> Package NetworkManager-pptp.x86_64 1:0.9.3.997-1.fc17 will be erased
---> Package NetworkManager-vpnc.x86_64 1:0.9.3.997-1.fc17 will be erased
---> Package PackageKit-yum.x86_64 0:0.7.4-4.fc17 will be erased
--> Processing Dependency: PackageKit-backend for package: PackageKit-0.7.4-4.fc17.x86_64
---> Package abrt-addon-vmcore.x86_64 0:2.0.10-4.fc17 will be erased
---> Package adwaita-gtk3-theme.x86_64 0:3.4.2-1.fc17 will be erased
---> Package aisleriot.x86_64 1:3.2.3.2-2.fc17 will be erased
---> Package anaconda.x86_64 0:17.29-1.fc17 will be erased
---> Package anaconda-yum-plugins.noarch 1:1.0-7.fc17 will be erased
---> Package artwiz-aleczapka-fonts.noarch 0:1.3-12.fc17 will be erased
---> Package authconfig-gtk.x86_64 0:6.2.1-1.fc17 will be erased
---> Package avahi-ui-gtk3.x86_64 0:0.6.30-7.fc17 will be erased
---> Package baobab.x86_64 0:3.4.1-2.fc17 will be erased
---> Package brasero.x86_64 0:3.4.1-1.fc17 will be erased
---> Package brasero-libs.x86_64 0:3.4.1-1.fc17 will be erased
---> Package brasero-nautilus.x86_64 0:3.4.1-1.fc17 will be erased
---> Package cairomm.x86_64 0:1.10.0-4.fc17 will be erased
---> Package clutter-gst.x86_64 0:1.5.4-2.fc17 will be erased
---> Package clutter-gtk.x86_64 0:1.2.0-1.fc17 will be erased
---> Package cogl.x86_64 0:1.10.2-1.fc17 will be erased
---> Package createrepo.noarch 0:0.9.9-11.fc17 will be erased
---> Package cups.x86_64 1:1.5.2-12.fc17 will be erased
--> Processing Dependency: cups for package: ptouch-driver-1.3-8.fc17.x86_64
--> Processing Dependency: cups for package: bluez-cups-4.99-1.fc17.x86_64
---> Package deja-dup.x86_64 0:20.2-2.fc17 will be erased
---> Package eekboard-libs.x86_64 0:1.0.7-2.fc17 will be erased
---> Package evince.x86_64 0:3.4.0-2.fc17 will be erased
---> Package evince-libs.x86_64 0:3.4.0-2.fc17 will be erased
---> Package ffmpeg-libs.x86_64 0:0.10.3-1.fc17 will be erased
--> Processing Dependency: libavcodec.so.53()(64bit) for package: gstreamer-ffmpeg-0.10.13-2.fc17.x86_64
--> Processing Dependency: libavcodec.so.53()(64bit) for package: xine-lib-extras-freeworld-1.1.20.1-2.fc17.x86_64
--> Processing Dependency: libavcodec.so.53(LIBAVCODEC_53)(64bit) for package: gstreamer-ffmpeg-0.10.13-2.fc17.x86_64
--> Processing Dependency: libavcodec.so.53(LIBAVCODEC_53)(64bit) for package: xine-lib-extras-freeworld-1.1.20.1-2.fc17.x86_64
--> Processing Dependency: libavformat.so.53()(64bit) for package: gstreamer-ffmpeg-0.10.13-2.fc17.x86_64
--> Processing Dependency: libavformat.so.53(LIBAVFORMAT_53)(64bit) for package: gstreamer-ffmpeg-0.10.13-2.fc17.x86_64
--> Processing Dependency: libavutil.so.51()(64bit) for package: gstreamer-ffmpeg-0.10.13-2.fc17.x86_64
--> Processing Dependency: libavutil.so.51()(64bit) for package: xine-lib-extras-freeworld-1.1.20.1-2.fc17.x86_64
--> Processing Dependency: libavutil.so.51(LIBAVUTIL_51)(64bit) for package: gstreamer-ffmpeg-0.10.13-2.fc17.x86_64
--> Processing Dependency: libavutil.so.51(LIBAVUTIL_51)(64bit) for package: xine-lib-extras-freeworld-1.1.20.1-2.fc17.x86_64
--> Processing Dependency: libpostproc.so.52()(64bit) for package: gstreamer-ffmpeg-0.10.13-2.fc17.x86_64
--> Processing Dependency: libpostproc.so.52()(64bit) for package: xine-lib-extras-freeworld-1.1.20.1-2.fc17.x86_64
--> Processing Dependency: libpostproc.so.52(LIBPOSTPROC_52)(64bit) for package: gstreamer-ffmpeg-0.10.13-2.fc17.x86_64
--> Processing Dependency: libpostproc.so.52(LIBPOSTPROC_52)(64bit) for package: xine-lib-extras-freeworld-1.1.20.1-2.fc17.x86_64
--> Processing Dependency: libswscale.so.2()(64bit) for package: gstreamer-ffmpeg-0.10.13-2.fc17.x86_64
--> Processing Dependency: libswscale.so.2(LIBSWSCALE_2)(64bit) for package: gstreamer-ffmpeg-0.10.13-2.fc17.x86_64
---> Package file-roller.x86_64 0:3.4.2-1.fc17 will be erased
---> Package firstboot.x86_64 0:17.3-1.fc17 will be erased
---> Package gcr.x86_64 0:3.4.1-2.fc17 will be erased
---> Package ghostscript-cups.x86_64 0:9.05-1.fc17 will be erased
---> Package gjs.x86_64 0:1.32.0-1.fc17 will be erased
---> Package gnome-bluetooth-libs.x86_64 1:3.4.0-2.fc17 will be erased
---> Package gnome-dictionary.x86_64 0:3.4.0-2.fc17 will be erased
---> Package gnome-disk-utility.x86_64 0:3.4.1-1.fc17 will be erased
---> Package gnome-keyring.x86_64 0:3.4.1-2.fc17 will be erased
--> Processing Dependency: gnome-keyring >= 0.5.0 for package: gnome-python2-gnomekeyring-2.32.0-9.fc17.x86_64
--> Processing Dependency: gnome-keyring = 3.4.1-2.fc17 for package: gnome-keyring-pam-3.4.1-2.fc17.x86_64
---> Package gnome-power-manager.x86_64 0:3.4.0-1.fc17 will be erased
---> Package gnome-python2.x86_64 0:2.28.1-8.fc17 will be erased
--> Processing Dependency: gnome-python2(x86-64) = 2.28.1-8.fc17 for package: gnome-python2-gconf-2.28.1-8.fc17.x86_64
---> Package gnome-python2-desktop.x86_64 0:2.32.0-9.fc17 will be erased
---> Package gnome-screenshot.x86_64 0:3.4.1-2.fc17 will be erased
---> Package gnome-search-tool.x86_64 0:3.4.0-1.fc17 will be erased
---> Package gnome-session.x86_64 0:3.4.2-1.fc17 will be erased
--> Processing Dependency: gnome-session = 3.4.2-1.fc17 for package: gnome-session-xsession-3.4.2-1.fc17.x86_64
---> Package gnome-system-log.x86_64 1:3.4.1-2.fc17 will be erased
---> Package gnome-system-monitor.x86_64 0:3.4.1-2.fc17 will be erased
---> Package gnome-terminal.x86_64 0:3.4.1.1-1.fc17 will be erased
---> Package gstreamer-plugins-bad-free.x86_64 0:0.10.23-2.fc17 will be erased
--> Processing Dependency: gstreamer-plugins-bad-free for package: gnome-dvb-daemon-0.2.8-1.fc17.x86_64
--> Processing Dependency: gstreamer-plugins-bad-free >= 0.10.22 for package: gstreamer-plugins-bad-0.10.22-4.fc17.x86_64
---> Package gstreamer-plugins-bad-free-extras.x86_64 0:0.10.23-2.fc17 will be erased
---> Package gstreamer-plugins-base.i686 0:0.10.36-1.fc17 will be erased
--> Processing Dependency: libgstapp-0.10.so.0 for package: wine-core-1.5.3-1.fc17.i686
---> Package gstreamer-plugins-base.x86_64 0:0.10.36-1.fc17 will be erased
--> Processing Dependency: libgstapp-0.10.so.0()(64bit) for package: gstreamer-rtsp-0.10.8-2.fc17.x86_64
--> Processing Dependency: libgstapp-0.10.so.0()(64bit) for package: wine-core-1.5.3-1.fc17.x86_64
--> Processing Dependency: libgstaudio-0.10.so.0()(64bit) for package: gstreamer-plugins-ugly-0.10.19-1.fc17.x86_64
--> Processing Dependency: libgstaudio-0.10.so.0()(64bit) for package: gstreamer-plugins-bad-nonfree-0.10.22-3.fc17.x86_64
--> Processing Dependency: libgstcdda-0.10.so.0()(64bit) for package: gstreamer-plugins-ugly-0.10.19-1.fc17.x86_64
--> Processing Dependency: libgstpbutils-0.10.so.0()(64bit) for package: gstreamer-plugins-ugly-0.10.19-1.fc17.x86_64
--> Processing Dependency: libgstriff-0.10.so.0()(64bit) for package: gstreamer-plugins-ugly-0.10.19-1.fc17.x86_64
--> Processing Dependency: libgstrtp-0.10.so.0()(64bit) for package: gstreamer-plugins-ugly-0.10.19-1.fc17.x86_64
--> Processing Dependency: libgstrtp-0.10.so.0()(64bit) for package: gstreamer-rtsp-0.10.8-2.fc17.x86_64
--> Processing Dependency: libgstrtsp-0.10.so.0()(64bit) for package: gstreamer-plugins-ugly-0.10.19-1.fc17.x86_64
--> Processing Dependency: libgstrtsp-0.10.so.0()(64bit) for package: gstreamer-rtsp-0.10.8-2.fc17.x86_64
--> Processing Dependency: libgstsdp-0.10.so.0()(64bit) for package: gstreamer-plugins-ugly-0.10.19-1.fc17.x86_64
--> Processing Dependency: libgstsdp-0.10.so.0()(64bit) for package: gstreamer-rtsp-0.10.8-2.fc17.x86_64
--> Processing Dependency: libgsttag-0.10.so.0()(64bit) for package: gstreamer-plugins-ugly-0.10.19-1.fc17.x86_64
--> Processing Dependency: libgstvideo-0.10.so.0()(64bit) for package: gstreamer-plugins-ugly-0.10.19-1.fc17.x86_64
---> Package gstreamer-python.x86_64 0:0.10.19-3.fc17 will be erased
---> Package gtk-vnc2.x86_64 0:0.5.0-2.fc17 will be erased
---> Package gtk2-immodule-xim.x86_64 0:2.24.10-1.fc17 will be erased
---> Package gtk3-immodule-xim.x86_64 0:3.4.3-2.fc17 will be erased
---> Package gtkhtml3.x86_64 0:4.4.1-2.fc17 will be erased
---> Package gtkmm30.x86_64 0:3.4.0-1.fc17 will be erased
---> Package gucharmap.x86_64 0:3.4.1.1-2.fc17 will be erased
---> Package gupnp-igd.x86_64 0:0.2.1-1.fc17 will be erased
---> Package gutenprint-cups.x86_64 0:5.2.7-11.fc17 will be erased
---> Package gvfs-archive.x86_64 0:1.12.3-1.fc17 will be erased
---> Package gvfs-fuse.x86_64 0:1.12.3-1.fc17 will be erased
---> Package gvfs-gphoto2.x86_64 0:1.12.3-1.fc17 will be erased
---> Package gvfs-obexftp.x86_64 0:1.12.3-1.fc17 will be erased
---> Package gvfs-smb.x86_64 0:1.12.3-1.fc17 will be erased
---> Package ibus-anthy.x86_64 0:1.4.99.20120327-1.fc17 will be erased
---> Package ibus-gtk3.x86_64 0:1.4.99.20120428-2.fc17 will be erased
---> Package ibus-hangul.x86_64 0:1.4.1-2.fc17 will be erased
---> Package ibus-hunspell-table.noarch 0:0.0.6-1.fc17 will be erased
---> Package ibus-pinyin.x86_64 0:1.4.0-16.fc17 will be erased
---> Package ibus-rawcode.x86_64 0:1.3.1.20100707-7.fc17 will be erased
---> Package im-chooser.x86_64 0:1.5.2.2-1.fc17 will be erased
--> Processing Dependency: im-chooser for package: imsettings-gnome-1.2.9-1.fc17.x86_64
---> Package im-chooser-common.x86_64 0:1.5.2.2-1.fc17 will be erased
---> Package iok.x86_64 0:2.1.2-1.fc17 will be erased
---> Package libcanberra-gtk3.x86_64 0:0.28-6.fc17 will be erased
---> Package libchamplain-gtk.x86_64 0:0.12.2-1.fc17 will be erased
---> Package libgnomekbd.x86_64 0:3.4.0.2-2.fc17 will be erased
---> Package libgphoto2.i686 0:2.4.14-1.fc17 will be erased
---> Package libgphoto2.x86_64 0:2.4.14-1.fc17 will be erased
--> Processing Dependency: libgphoto2.so.2()(64bit) for package: sane-backends-libs-1.0.22-10.fc17.x86_64
--> Processing Dependency: libgphoto2.so.2()(64bit) for package: sane-backends-1.0.22-10.fc17.x86_64
--> Processing Dependency: libgphoto2_port.so.0()(64bit) for package: sane-backends-libs-1.0.22-10.fc17.x86_64
--> Processing Dependency: libgphoto2_port.so.0()(64bit) for package: sane-backends-1.0.22-10.fc17.x86_64
---> Package libgxps.x86_64 0:0.2.2-1.fc17 will be erased
---> Package libmash.x86_64 0:0.2.0-7.fc17 will be erased
---> Package libpeas.x86_64 0:1.4.0-2.fc17 will be erased
---> Package libprojectM.x86_64 0:2.0.1-14.fc17 will be erased
---> Package libproxy-mozjs.x86_64 0:0.4.7-4.fc17 will be erased
---> Package libpurple.x86_64 0:2.10.2-1.fc17 will be erased
--> Processing Dependency: libpurple.so.0()(64bit) for package: telepathy-haze-0.6.0-1.fc17.x86_64
---> Package librsvg2.x86_64 0:2.36.1-1.fc17 will be erased
---> Package libsocialweb-keys.noarch 0:0.25.20-3.fc17 will be erased
---> Package libspectre.x86_64 0:0.2.6-5.fc17 will be erased
---> Package libtiger.x86_64 0:0.3.4-3.fc17 will be erased
---> Package libwnck3.x86_64 0:3.4.2-1.fc17 will be erased
---> Package mutter.x86_64 0:3.4.1-3.fc17 will be erased
---> Package notification-daemon.x86_64 0:0.7.4-1.fc17 will be erased
--> Processing Dependency: desktop-notification-daemon for package: libnotify-0.7.5-1.fc17.x86_64
---> Package pangomm.x86_64 0:2.28.4-1.fc17 will be erased
---> Package plymouth-plugin-label.x86_64 0:0.8.4-0.20120319.2.fc17 will be erased
--> Processing Dependency: plymouth-plugin-label for package: plymouth-plugin-two-step-0.8.4-0.20120319.2.fc17.x86_64
---> Package policycoreutils-sandbox.x86_64 0:2.1.11-6.fc17 will be erased
---> Package polkit-gnome.x86_64 0:0.105-2.fc17 will be erased
---> Package preupgrade.noarch 0:1.1.10-2.fc17 will be erased
---> Package printer-filters.noarch 0:1.1-6.fc17 will be erased
---> Package pulseaudio-module-bluetooth.x86_64 0:1.1-9.fc17 will be erased
---> Package pycairo.x86_64 0:1.8.10-4.fc17 will be erased
---> Package pygobject3.x86_64 0:3.2.2-1.fc17 will be erased
---> Package python-meh.noarch 0:0.12-1.fc17 will be erased
---> Package python-slip-gtk.noarch 0:0.2.20-2.fc17 will be erased
---> Package seed.x86_64 0:3.2.0-2.fc17.2 will be erased
---> Package simple-scan.x86_64 0:3.4.1-1.fc17 will be erased
---> Package sound-juicer.x86_64 0:3.4.0-1.fc17 will be erased
---> Package spice-gtk3.x86_64 0:0.12-4.fc17 will be erased
---> Package system-config-date.noarch 0:1.9.67-2.fc17 will be erased
---> Package system-config-firewall.noarch 0:1.2.29-7.fc17 will be erased
---> Package system-config-printer.x86_64 0:1.3.9-1.fc17 will be erased
---> Package system-config-users.noarch 0:1.2.115-1.fc17 will be erased
---> Package system-switch-java.noarch 0:1.1.5-4.fc17 will be erased
---> Package telepathy-farstream.x86_64 0:0.4.0-2.fc17 will be erased
---> Package telepathy-mission-control.x86_64 1:5.12.0-1.fc17 will be erased
---> Package tracker.x86_64 0:0.14.1-1.fc17 will be erased
---> Package transmission-gtk.x86_64 0:2.50-2.fc17 will be erased
---> Package unique3.x86_64 0:3.0.2-3.fc17 will be erased
---> Package vlc.x86_64 0:2.0.1-1.fc17 will be erased
---> Package vte3.x86_64 0:0.32.1-1.fc17 will be erased
---> Package wine.x86_64 0:1.5.3-1.fc17 will be erased
---> Package xdg-user-dirs-gtk.x86_64 0:0.9-1.fc17 will be erased
---> Package xine-lib-extras.x86_64 0:1.1.20.1-3.fc17 will be erased
---> Package yelp.x86_64 1:3.4.2-1.fc17 will be erased
---> Package yelp-libs.x86_64 1:3.4.2-1.fc17 will be erased
---> Package yum-langpacks.noarch 0:0.2.4-3.fc17 will be erased
---> Package yum-presto.noarch 0:0.7.3-1.fc17 will be erased
---> Package yum-utils.noarch 0:1.1.31-4.fc17 will be erased
---> Package zbar.x86_64 0:0.10-11.fc17 will be erased
---> Package zenity.x86_64 0:3.4.0-1.fc17 will be erased
--> Processing Dependency: zenity for package: easylife-3.2-2.noarch
--> Running transaction check
---> Package PackageKit.x86_64 0:0.7.4-4.fc17 will be erased
--> Processing Dependency: PackageKit = 0.7.4-4.fc17 for package: PackageKit-glib-0.7.4-4.fc17.x86_64
---> Package bluez-cups.x86_64 0:4.99-1.fc17 will be erased
---> Package easylife.noarch 0:3.2-2 will be erased
---> Package gnome-dvb-daemon.x86_64 0:0.2.8-1.fc17 will be erased
---> Package gnome-keyring-pam.x86_64 0:3.4.1-2.fc17 will be erased
---> Package gnome-python2-gconf.x86_64 0:2.28.1-8.fc17 will be erased
---> Package gnome-python2-gnomekeyring.x86_64 0:2.32.0-9.fc17 will be erased
---> Package gnome-session-xsession.x86_64 0:3.4.2-1.fc17 will be erased
---> Package gstreamer-ffmpeg.x86_64 0:0.10.13-2.fc17 will be erased
---> Package gstreamer-plugins-bad.x86_64 0:0.10.22-4.fc17 will be erased
---> Package gstreamer-plugins-bad-nonfree.x86_64 0:0.10.22-3.fc17 will be erased
---> Package gstreamer-plugins-ugly.x86_64 0:0.10.19-1.fc17 will be erased
---> Package gstreamer-rtsp.x86_64 0:0.10.8-2.fc17 will be erased
---> Package imsettings-gnome.x86_64 0:1.2.9-1.fc17 will be erased
--> Processing Dependency: imsettings-desktop-module = 1.2.9-1.fc17 for package: imsettings-1.2.9-1.fc17.x86_64
---> Package libnotify.x86_64 0:0.7.5-1.fc17 will be erased
---> Package plymouth-plugin-two-step.x86_64 0:0.8.4-0.20120319.2.fc17 will be erased
--> Processing Dependency: plymouth-plugin-two-step = 0.8.4-0.20120319.2.fc17 for package: plymouth-theme-charge-0.8.4-0.20120319.2.fc17.x86_64
---> Package ptouch-driver.x86_64 0:1.3-8.fc17 will be erased
---> Package sane-backends.x86_64 0:1.0.22-10.fc17 will be erased
--> Processing Dependency: sane-backends = 1.0.22-10.fc17 for package: sane-backends-drivers-scanners-1.0.22-10.fc17.x86_64
--> Processing Dependency: sane-backends for package: libsane-hpaio-3.12.4-2.fc17.x86_64
---> Package sane-backends-libs.x86_64 0:1.0.22-10.fc17 will be erased
--> Processing Dependency: libsane.so.1()(64bit) for package: hplip-libs-3.12.4-2.fc17.x86_64
--> Processing Dependency: libsane.so.1()(64bit) for package: colord-0.1.18-2.fc17.x86_64
---> Package telepathy-haze.x86_64 0:0.6.0-1.fc17 will be erased
---> Package wine-core.i686 0:1.5.3-1.fc17 will be erased
--> Processing Dependency: libwine.so.1 for package: wine-twain-1.5.3-1.fc17.i686
--> Processing Dependency: libwine.so.1 for package: wine-alsa-1.5.3-1.fc17.i686
--> Processing Dependency: libwine.so.1 for package: wine-ldap-1.5.3-1.fc17.i686
--> Processing Dependency: libwine.so.1 for package: wine-cms-1.5.3-1.fc17.i686
--> Processing Dependency: libwine.so.1 for package: wine-openal-1.5.3-1.fc17.i686
--> Processing Dependency: libwine.so.1 for package: wine-capi-1.5.3-1.fc17.i686
--> Processing Dependency: libwine.so.1(WINE_1.0) for package: wine-twain-1.5.3-1.fc17.i686
--> Processing Dependency: libwine.so.1(WINE_1.0) for package: wine-alsa-1.5.3-1.fc17.i686
--> Processing Dependency: libwine.so.1(WINE_1.0) for package: wine-ldap-1.5.3-1.fc17.i686
--> Processing Dependency: libwine.so.1(WINE_1.0) for package: wine-cms-1.5.3-1.fc17.i686
--> Processing Dependency: libwine.so.1(WINE_1.0) for package: wine-openal-1.5.3-1.fc17.i686
--> Processing Dependency: libwine.so.1(WINE_1.0) for package: wine-capi-1.5.3-1.fc17.i686
--> Processing Dependency: wine-core = 1.5.3-1.fc17 for package: wine-common-1.5.3-1.fc17.noarch
--> Processing Dependency: wine-core = 1.5.3-1.fc17 for package: wine-capi-1.5.3-1.fc17.x86_64
--> Processing Dependency: wine-core = 1.5.3-1.fc17 for package: wine-cms-1.5.3-1.fc17.x86_64
--> Processing Dependency: wine-core = 1.5.3-1.fc17 for package: wine-alsa-1.5.3-1.fc17.x86_64
--> Processing Dependency: wine-core = 1.5.3-1.fc17 for package: wine-openal-1.5.3-1.fc17.i686
--> Processing Dependency: wine-core = 1.5.3-1.fc17 for package: wine-ldap-1.5.3-1.fc17.i686
--> Processing Dependency: wine-core = 1.5.3-1.fc17 for package: wine-alsa-1.5.3-1.fc17.i686
--> Processing Dependency: wine-core = 1.5.3-1.fc17 for package: wine-openal-1.5.3-1.fc17.x86_64
--> Processing Dependency: wine-core = 1.5.3-1.fc17 for package: wine-twain-1.5.3-1.fc17.x86_64
--> Processing Dependency: wine-core = 1.5.3-1.fc17 for package: wine-cms-1.5.3-1.fc17.i686
--> Processing Dependency: wine-core = 1.5.3-1.fc17 for package: wine-ldap-1.5.3-1.fc17.x86_64
--> Processing Dependency: wine-core = 1.5.3-1.fc17 for package: wine-pulseaudio-1.5.3-1.fc17.x86_64
--> Processing Dependency: wine-core = 1.5.3-1.fc17 for package: wine-capi-1.5.3-1.fc17.i686
--> Processing Dependency: wine-core = 1.5.3-1.fc17 for package: wine-pulseaudio-1.5.3-1.fc17.i686
--> Processing Dependency: wine-core = 1.5.3-1.fc17 for package: wine-twain-1.5.3-1.fc17.i686
--> Processing Dependency: wine-core(x86-32) = 1.5.3-1.fc17 for package: wine-desktop-1.5.3-1.fc17.noarch
---> Package wine-core.x86_64 0:1.5.3-1.fc17 will be erased
--> Processing Dependency: libwine.so.1()(64bit) for package: wine-wow-1.5.3-1.fc17.x86_64
--> Processing Dependency: libwine.so.1(WINE_1.0)(64bit) for package: wine-wow-1.5.3-1.fc17.x86_64
--> Processing Dependency: wine-core(x86-64) = 1.5.3-1.fc17 for package: wine-wow-1.5.3-1.fc17.x86_64
---> Package xine-lib-extras-freeworld.x86_64 0:1.1.20.1-2.fc17 will be erased
--> Running transaction check
---> Package PackageKit-glib.x86_64 0:0.7.4-4.fc17 will be erased
--> Processing Dependency: PackageKit-glib = 0.7.4-4.fc17 for package: PackageKit-device-rebind-0.7.4-4.fc17.x86_64
---> Package colord.x86_64 0:0.1.18-2.fc17 will be erased
---> Package hplip-libs.x86_64 0:3.12.4-2.fc17 will be erased
---> Package imsettings.x86_64 0:1.2.9-1.fc17 will be erased
---> Package libsane-hpaio.x86_64 0:3.12.4-2.fc17 will be erased
---> Package plymouth-theme-charge.x86_64 0:0.8.4-0.20120319.2.fc17 will be erased
--> Processing Dependency: plymouth(system-theme) = 0.8.4-0.20120319.2.fc17 for package: plymouth-system-theme-0.8.4-0.20120319.2.fc17.x86_64
---> Package sane-backends-drivers-scanners.x86_64 0:1.0.22-10.fc17 will be erased
---> Package wine-alsa.i686 0:1.5.3-1.fc17 will be erased
---> Package wine-alsa.x86_64 0:1.5.3-1.fc17 will be erased
---> Package wine-capi.i686 0:1.5.3-1.fc17 will be erased
---> Package wine-capi.x86_64 0:1.5.3-1.fc17 will be erased
---> Package wine-cms.i686 0:1.5.3-1.fc17 will be erased
---> Package wine-cms.x86_64 0:1.5.3-1.fc17 will be erased
---> Package wine-common.noarch 0:1.5.3-1.fc17 will be erased
--> Processing Dependency: wine-common for package: mingw32-wine-gecko-1.5-2.fc17.noarch
--> Processing Dependency: wine-common for package: mingw64-wine-gecko-1.5-2.fc17.noarch
---> Package wine-desktop.noarch 0:1.5.3-1.fc17 will be erased
---> Package wine-ldap.i686 0:1.5.3-1.fc17 will be erased
---> Package wine-ldap.x86_64 0:1.5.3-1.fc17 will be erased
---> Package wine-openal.i686 0:1.5.3-1.fc17 will be erased
---> Package wine-openal.x86_64 0:1.5.3-1.fc17 will be erased
---> Package wine-pulseaudio.i686 0:1.5.3-1.fc17 will be erased
---> Package wine-pulseaudio.x86_64 0:1.5.3-1.fc17 will be erased
---> Package wine-twain.i686 0:1.5.3-1.fc17 will be erased
---> Package wine-twain.x86_64 0:1.5.3-1.fc17 will be erased
---> Package wine-wow.x86_64 0:1.5.3-1.fc17 will be erased
--> Running transaction check
---> Package PackageKit-device-rebind.x86_64 0:0.7.4-4.fc17 will be erased
---> Package mingw32-wine-gecko.noarch 0:1.5-2.fc17 will be erased
---> Package mingw64-wine-gecko.noarch 0:1.5-2.fc17 will be erased
---> Package plymouth-system-theme.x86_64 0:0.8.4-0.20120319.2.fc17 will be erased
--> Finished Dependency Resolution
Error: Trying to remove "yum", which is protected
 You could try using --skip-broken to work around the problem
** Found 33 pre-existing rpmdb problem(s), 'yum check' output follows:
PackageKit-0.7.4-4.fc17.x86_64 is a duplicate with PackageKit-0.7.4-3.fc17.x86_64
PackageKit-device-rebind-0.7.4-4.fc17.x86_64 is a duplicate with PackageKit-device-rebind-0.7.4-3.fc17.x86_64
PackageKit-glib-0.7.4-4.fc17.x86_64 is a duplicate with PackageKit-glib-0.7.4-3.fc17.x86_64
PackageKit-yum-0.7.4-4.fc17.x86_64 is a duplicate with PackageKit-yum-0.7.4-3.fc17.x86_64
abrt-2.0.10-4.fc17.x86_64 is a duplicate with abrt-2.0.10-3.fc17.x86_64
abrt-addon-ccpp-2.0.10-4.fc17.x86_64 is a duplicate with abrt-addon-ccpp-2.0.10-3.fc17.x86_64
abrt-addon-kerneloops-2.0.10-4.fc17.x86_64 is a duplicate with abrt-addon-kerneloops-2.0.10-3.fc17.x86_64
abrt-addon-python-2.0.10-4.fc17.x86_64 is a duplicate with abrt-addon-python-2.0.10-3.fc17.x86_64
abrt-addon-vmcore-2.0.10-4.fc17.x86_64 is a duplicate with abrt-addon-vmcore-2.0.10-3.fc17.x86_64
abrt-dbus-2.0.10-4.fc17.x86_64 is a duplicate with abrt-dbus-2.0.10-3.fc17.x86_64
abrt-gui-2.0.10-4.fc17.x86_64 is a duplicate with abrt-gui-2.0.10-3.fc17.x86_64
abrt-libs-2.0.10-4.fc17.x86_64 is a duplicate with abrt-libs-2.0.10-3.fc17.x86_64
adwaita-gtk2-theme-3.4.2-1.fc17.x86_64 is a duplicate with adwaita-gtk2-theme-3.4.1-1.fc17.x86_64
adwaita-gtk3-theme-3.4.2-1.fc17.x86_64 is a duplicate with adwaita-gtk3-theme-3.4.1-1.fc17.x86_64
1:control-center-filesystem-3.4.2-1.fc17.x86_64 is a duplicate with 1:control-center-filesystem-3.4.1-1.fc17.x86_64
dconf-0.12.1-1.fc17.x86_64 is a duplicate with dconf-0.12.0-1.fc17.x86_64
file-roller-3.4.2-1.fc17.x86_64 is a duplicate with file-roller-3.4.1-2.fc17.x86_64
gmime-2.6.9-1.fc17.x86_64 is a duplicate with gmime-2.6.4-1.fc17.x86_64
gnome-menus-3.4.2-1.fc17.x86_64 is a duplicate with gnome-menus-3.4.0-1.fc17.x86_64
gnome-online-accounts-3.4.2-1.fc17.x86_64 is a duplicate with gnome-online-accounts-3.4.1-1.fc17.x86_64
gnome-session-3.4.2-1.fc17.x86_64 is a duplicate with gnome-session-3.4.1-2.fc17.x86_64
gnome-session-xsession-3.4.2-1.fc17.x86_64 is a duplicate with gnome-session-xsession-3.4.1-2.fc17.x86_64
gsettings-desktop-schemas-3.4.2-1.fc17.x86_64 is a duplicate with gsettings-desktop-schemas-3.4.1-1.fc17.x86_64
libpinyin-0.6.0-1.fc17.x86_64 is a duplicate with libpinyin-0.5.92-1.fc17.x86_64
libpinyin-data-0.6.0-1.fc17.x86_64 is a duplicate with libpinyin-data-0.5.92-1.fc17.x86_64
libwnck3-3.4.2-1.fc17.x86_64 is a duplicate with libwnck3-3.4.0-1.fc17.x86_64
pygobject3-3.2.2-1.fc17.x86_64 is a duplicate with pygobject3-3.2.1-1.fc17.x86_64
1:totem-3.4.2-1.fc17.x86_64 is a duplicate with 1:totem-3.4.1-3.fc17.x86_64
totem-pl-parser-3.4.2-1.fc17.x86_64 is a duplicate with totem-pl-parser-3.4.1-2.fc17.x86_64
xmlrpc-c-1.29.3-1703.svn2290.fc17.x86_64 is a duplicate with xmlrpc-c-1.29.0-1701.svn2233.fc17.x86_64
1:yelp-3.4.2-1.fc17.x86_64 is a duplicate with 1:yelp-3.4.1-2.fc17.x86_64
1:yelp-libs-3.4.2-1.fc17.x86_64 is a duplicate with 1:yelp-libs-3.4.1-2.fc17.x86_64
yelp-xsl-3.4.2-1.fc17.noarch is a duplicate with yelp-xsl-3.4.1-1.fc17.noarch

C'est une fresh install mais voilà ce que donne la commande uname -a :

Linux Monocle 3.3.7-1.fc17.x86_64 #1 SMP Mon May 21 22:32:19 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Dernière modification par Moustache (04/06/2012 16:26:51)


Fedora 17 (64 bits)

Hors ligne

#7 04/06/2012 16:27:49

Edouard_le_homard
Membre
Inscription : 24/03/2012
Messages : 1 141

Re : [Résolu] Mise à jour impossible

alors je vois deux couilles potentielles :

1)

Error: Trying to remove "yum", which is protected
 You could try using --skip-broken to work around the problem

perso je tenterai un yum update yum --skip-broken ; puis si ça se passe bien un yum update; avec éventuellement le skip-broken.

note que je ne suis pas sûr de mon coup, sauvegarde bien tes données avant, des fois que...

2) tous les duplicates
là j'ai pas trop le temps mais si tu parles la langue de Shakespeare, va voir ces liens tu auras peut être des idées:

http://forums.fedoraforum.org/showthread.php?t=268328
http://www.ogre.com/node/369
http://www.silug.org/lists/silug-discus … 00001.html


c'est bizarre ces duplicates... je vois pas d'où ça peut venir, surtout pour une fresh instal. tu as correctement configuré tes repos ?

Dernière modification par Edouard_le_homard (04/06/2012 16:29:46)


F20 x86_64 KDE - Asus X73SV

Hors ligne

#8 04/06/2012 16:39:24

Moustache
Membre
Inscription : 03/06/2012
Messages : 26

Re : [Résolu] Mise à jour impossible

J'ai essayé toutes les commandes ci-dessus avec --skip broken, ça n'a pas l'air d'aidé, les mêmes erreurs sont toujours là en me disant d'essayer yum-complete-transaction. :/

Je vais jeter un coup d'oeil à tes liens, merci.

En ce qui concerne les dépôts, ils sont bien configurés normalement, j'ai juste un doute sur celui de google-chrome puisque je vois que "Repository google-chrome is listed more than once in the configuration", mais je ne sais pas quoi faire exactement pour arranger ça. Pour l'installer, j'ai suivi cette methode : http://www.if-not-true-then-false.com/2 … -hat-rhel/

Dernière modification par Moustache (04/06/2012 16:43:07)


Fedora 17 (64 bits)

Hors ligne

#9 04/06/2012 16:50:30

Edouard_le_homard
Membre
Inscription : 24/03/2012
Messages : 1 141

Re : [Résolu] Mise à jour impossible

mmm pour le dépôt chrome ça n'expliquerait pas tout, typiquement le duplicate de packagekit

peut être que ta rpmdb est corrompue (cf ** Found 33 pre-existing rpmdb problem(s), 'yum check' output follows:), tente ceci http://www.cyberciti.biz/tips/rebuildin … abase.html


F20 x86_64 KDE - Asus X73SV

Hors ligne

#10 04/06/2012 17:07:01

Moustache
Membre
Inscription : 03/06/2012
Messages : 26

Re : [Résolu] Mise à jour impossible

Alors j'ai essayé la méthode sur le dernier site que tu m'as passé, ça n'a pas eu l'air de fonctionner. Je suis passé sur les liens que tu m'avais donné juste avant, j'ai essayé quelques trucs du genre "yum cleanup" qui m'a retourné, bizarrement, que cette commande n'existait pas, mais j'ai quand même essayé un yum update et là, c'est occupé à télécharger les dernières mises à jour. Je ne sais pas si le problème est vraiment résolu (j'ai toujours le "Repository google-chrome is listed more than once in the configuration", je sais pas si c'est embêtant) mais au moins ça n'a plus l'air de bloquer dans les mises à jour pour le moment.
Merci! :D

Edit : Par contre, quand je passe par le logiciel de Mise à jour et non par "yum update", j'ai toujours les mêmes erreurs qui retournent le "run yum-complete-transactions".

Edit 2 : J'ai relancé un yum-complete-transaction dans le terminal et depuis je n'ai plus l'erreur.

Dernière modification par Moustache (05/06/2012 09:29:55)


Fedora 17 (64 bits)

Hors ligne

Pied de page des forums