Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Rencontres Fedora 20

#1 16/04/2012 00:55:05

mtxrider
Membre
Inscription : 06/04/2011
Messages : 58

apache : You don't have permission to access / on this server.

Bonjour,

j'essaye désespérément de monter un serveur web sur mon fedora.

J'ai donc installer appache + MySQL via yum install.

Après ça c'est afficher la page de base fedora quand je tapais un localhost dans le navigateur.

J'ai modifier le fichier httpd.conf de façon à diriger le document root dans mon dossier home /user / WWW :

<code>

DocumentRoot "/home/user/WWW"

<Directory "/home/user/WWW">

</code>

Par précaution et / ou après que rien n'est fonctionné, j'ai cocher toute les cases concernant apache dans selinux (au cas ou).

Actuellement je reçois une page type " Forbidden - You don't have permission to access / on this server. "

j'ai aussi donner les droits utilisateur au dossier grâce à chmod / chown.

Aussi, est-ce root qui doit avoir les droits sur le dossier WWW ou mon user ?

La en fait je suis entrain d'abandonner l'idée de monter un serveur web sous fedora, sa fait 1 semaine que tout les soirs je cherche à afficher mon putain d'index mais rien n'y fais.

Si je ne trouve pas la solution, je vais installer windows 2000 serv sur le nouveau serveur avec apache dessus, au moins en attendant.

J'espère grandement que quelqu'un saura m'aider car il serait temps que je passe à autre chose, je perds patience ^^, merci d'avance en tout cas.

Hors ligne

#2 16/04/2012 04:41:49

swisstico
Membre
Lieu : Costa Rica
Inscription : 23/02/2012
Messages : 109
Site Web

Re : apache : You don't have permission to access / on this server.

  1. Desactive SELinux complètement :  setenforce 0 puis fais un test(Si c'est ca, désactive le définitivement dans le /etc  A mon avis ce que tu as fait ne change rien, voir la doc ici

  2. Tu dis que tu as donné les droits utilisateurs... quel utilisateur ??? c'est l'utilisateur Apache qui doit avoir les droits, pas un autre (le groupe également). Regarde le /etc/passwd pour le connaitre ca doit probablement être un truc du style www-data

Si tout cela ne marche pas fais un

ls -ahlZ /home/user

et renvoie le résultat du dossier WWW

Dernière modification par swisstico (16/04/2012 04:42:44)


Fedora 20 - 64bits - Gnome 3.10
PC: i3-3220 3.30GHz - 8GB RAM - 2TB HD

Hors ligne

#3 16/04/2012 07:03:48

remi
Crazy PHP packages monkey... !
Rédacteur Wiki
Lieu : Champagne...
Inscription : 16/10/2004
Messages : 5 414
Site Web

Re : apache : You don't have permission to access / on this server.

> J'ai modifier le fichier httpd.conf

Donc, tu n'as pas suivi la doc présente ICI.
Tu aurais probablement du commencer par là.

Hors ligne

#4 16/04/2012 10:32:02

Mongos
openAddict & pinguAddict
Lieu : Palaiseau
Inscription : 25/06/2007
Messages : 740

Re : apache : You don't have permission to access / on this server.

swisstico a écrit :

....

  • Tu dis que tu as donné les droits utilisateurs... quel utilisateur ??? c'est l'utilisateur Apache qui doit avoir les droits, pas un autre (le groupe également). Regarde le /etc/passwd pour le connaitre ca doit probablement être un truc du style www-data

....

De base, apache est lancé sous le user apache et le groupe apache, mais il est tout à fait possible de changer l'utilisateur qui lance apache ( on peut très bien mettre tartanpion si on veut :) )


Il n'y a pas de problème, juste des solutions

Hors ligne

#5 17/04/2012 00:59:38

mtxrider
Membre
Inscription : 06/04/2011
Messages : 58

Re : apache : You don't have permission to access / on this server.

Rémi, j'ai survolé la documentation en question que tu as donné.

J'ai déjà eu des serveurs Wamp, ceci sans suivre aucune doc, la différence s'était la complication moindre.

Pour me rassurer j'ai chercher la doc que tu m'as donner, j'ai pu remarquer qu'à part selinux beaucoup de choses correspondaient, c'est probablement ce qui fait que j'ai survolé la dite-doc.

J'ai tester avec l'utilisateur apache (chown apache WWW)

j'ai vérifier les droits avec ls -l, il à tout les droits sur le dossier WWW.

j'ai fait setenforce 0 histoire de ne pas etre bloquer par selinux, j'ai toujours le même message d'erreur.


Par contre une question trote dans ma tete, le dossier WWW est dans /home/user/WWW

est ce que apache à les droit d'accès au dossier user ? s'il n'a pas les droits d'accès ils ne pourra donc pas accéder à WWW si je comprends bien c'est ça ?

Hors ligne

#6 17/04/2012 01:08:31

mtxrider
Membre
Inscription : 06/04/2011
Messages : 58

Re : apache : You don't have permission to access / on this server.

soucis résolu, j'ai créer un dossier /home/apache/ dans lequel j'ai créer un sous répertoire WWW.

J'ai donner les droits d'accès à l'user apache au dossier en question, maintenant ça passe.

Est-ce possible de donner les droits d'accès à ce nouveau dossier WWW en même temps à apache, et à mon user ?

En fait je ne sais utiliser que chown et chmod comme suis :

chmod -R 777 dossier

ou

chown dossier user

ce n'est pas sufisant pour donner des droits d'accès à une liste précise d'user, que me conseilleriez vous ?

Hors ligne

#7 17/04/2012 05:44:56

swisstico
Membre
Lieu : Costa Rica
Inscription : 23/02/2012
Messages : 109
Site Web

Re : apache : You don't have permission to access / on this server.

Tu peux ajouter l'utilisateur dans le groupe d'Apache (usermod -a -G groupeApache tonUser)
Ou jouer avec les ACL, beaucoup plus fin mais plus difficile à mettre en place.
http://www.siteduzero.com/tutoriel-3-31 … linux.html


Fedora 20 - 64bits - Gnome 3.10
PC: i3-3220 3.30GHz - 8GB RAM - 2TB HD

Hors ligne

#8 17/04/2012 07:33:20

remi
Crazy PHP packages monkey... !
Rédacteur Wiki
Lieu : Champagne...
Inscription : 16/10/2004
Messages : 5 414
Site Web

Re : apache : You don't have permission to access / on this server.

Arrêtez de donner trop de droits à apache.

Apache à juste besoin de "lire" les pages, rien d'autre (éventuellement d'écrire dans quelques dossiers spécifiques, genre "upload")

Si il refuse l'accès, c'est bien les droits de lecture qui manque.

Il faut juste vérifier "tous" les niveaux de l'arborescence, donc
/
/home
/home/user
/home/user/WWW

Et par défaut, les droits sont positionnés à 700 sur les dossiers utilisateur, il faut donc rajouter le droit de traverser ce dossier aux autres (chmod o+x ....)

Dernière modification par remi (17/04/2012 07:38:35)

Hors ligne

#9 18/04/2012 04:22:57

swisstico
Membre
Lieu : Costa Rica
Inscription : 23/02/2012
Messages : 109
Site Web

Re : apache : You don't have permission to access / on this server.

remi a écrit :

Arrêtez de donner trop de droits à apache.

chmod -R 777 /

big_smile hammer
OK, je sors...


(Surtout vous faites pas ca hein !)


Fedora 20 - 64bits - Gnome 3.10
PC: i3-3220 3.30GHz - 8GB RAM - 2TB HD

Hors ligne

#10 21/04/2012 13:38:04

mtxrider
Membre
Inscription : 06/04/2011
Messages : 58

Re : apache : You don't have permission to access / on this server.

Je suis d'accord de ne pas donner trop de droit à apache, dans un premier temps je vais la jouer full droit, et si ça marche je réduirais les droits.

Hors ligne

#11 21/04/2012 13:43:13

mtxrider
Membre
Inscription : 06/04/2011
Messages : 58

Re : apache : You don't have permission to access / on this server.

Il me reste un soucis en fait, j'ai pu config impeccable les droits d'accès sur WWW (j'ai mis 700 comme droit ça convient ?).

En dehors de ça par contre j'ai selinux qui continue à faire chier, je suis obliger de le shunter avec setenforce 0 pour avoir accès à mon serveur.

Est-ce normal ?

Hors ligne

#12 21/04/2012 23:41:34

C@sp€r
Bricoleur Fedora
Modérateur
Lieu : /dev/loop
Inscription : 09/04/2010
Messages : 694
Site Web

Re : apache : You don't have permission to access / on this server.

mtxrider a écrit :

Est-ce normal ?

Non.
Il faut dire à SELinux d'autoriser Apache à lire dans /home/ en activant un booléen. Tout ceci est bien sûr précisé dans la page wiki dont Remi a donné le lien...


2010 \ Copyleft GPL only, all rights permited.
1277413422.png

Hors ligne

#13 23/04/2012 08:21:54

remi
Crazy PHP packages monkey... !
Rédacteur Wiki
Lieu : Champagne...
Inscription : 16/10/2004
Messages : 5 414
Site Web

Re : apache : You don't have permission to access / on this server.

mtxrider a écrit :

Il me reste un soucis en fait, j'ai pu config impeccable les droits d'accès sur WWW (j'ai mis 700 comme droit ça convient ?).

700 cela signifie que seul le proprietaire a acces aux fichiers.
Si le site marche c'est donc que c'est apache le proprietaire ?

Donc c'est pas du tout malin.

Encore une fois, apache n'a ni besoin du droit d'écriture, ni d'être propriétaire des pages.

++

Hors ligne

#14 23/04/2012 12:46:42

mtxrider
Membre
Inscription : 06/04/2011
Messages : 58

Re : apache : You don't have permission to access / on this server.

j'ai cocher l'option concernant le répertoire home dans selinux préalablement, je l'ai fais tout au début.

En outre, le propriétaire de WWW est root mais apache à un accès en 700 sur le dossier.

C'est httpd_enable_homedirs, et le booléen est à 1.

Hors ligne

Pied de page des forums