Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora-Fr aux 15èmes Rencontres Mondiales du Logiciel Libre

#1 23/09/2011 23:12:30

Flamme_2
Membre
Inscription : 23/09/2011
Messages : 18

[Résolu] Problème connexion réseau cifs/samba

Bonjour,

Nouveau sur la distribution, et déjà un petit soucis hammer

J'ai une machine qui me sert de serveur sous une debian, partage samba & co.

Du coup, j'ai repris mon ancien fichier de configuration (fstab) qui provient de mon archlinux.

Les partages se montent, mais je n'ai pas les droits avec l'utilisateur lambda (root fonctionne)

J'ai monter de cette manière dans le fstab :

//192.168.1.253/data                            /media/partage/data             cifs		credentials=/root/.smbcredentials       0       0
//192.168.1.253/temps                       	/media/partage/temps        	cifs           	credentials=/root/.smbcredentials       0       0

avec le .smbcredentials qui va bien :

[root@ASUS ~]# ls -laF /root/.smbcredentials && cat /root/.smbcredentials
-rw-------. 1 root root 38 23 sept. 20:03 /root/.smbcredentials
username=flamme
password=[******]

Du coup en root j'ai :

[root@ASUS data]# ls /media/partage/data
Dossiers

et en simple utilisateur

[root@ASUS]# ls /media/partage/data
ls: impossible d'ouvrir le répertoire /media/partage/data: Permission non accordée

Et lorsque que je creer en simple utilisateur un dossier dans le partage ou j'ai un accès complet :
sur le serveur :

SCSERVER:/media# ls /temps
total 7,8G
drwxrwxr-x  2 flamme flamme  4,0K 24 sept. 00:58 test/

Une solution serait la bienvenue, car je patine pas mal....

Dernière modification par Flamme_2 (23/09/2011 23:13:33)

Hors ligne

#2 24/09/2011 00:22:05

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 17 507

Re : [Résolu] Problème connexion réseau cifs/samba

A toutes fins utiles, je te rappelle que la numérotation des utilisateurs normaux  commence (encore sur la version fedora 15) à 500, alors que sur Debian  elle commence à 1000. Et que le système n'utilise que les numéros d'utilisateurs, pas les noms.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#3 24/09/2011 09:17:28

Flamme_2
Membre
Inscription : 23/09/2011
Messages : 18

Re : [Résolu] Problème connexion réseau cifs/samba

nouvo09 a écrit :

A toutes fins utiles, je te rappelle que la numérotation des utilisateurs normaux  commence (encore sur la version fedora 15) à 500, alors que sur Debian  elle commence à 1000. Et que le système n'utilise que les numéros d'utilisateurs, pas les noms.

A toutes fins utiles, c'est toujours bon à savoir wink

Par contre je ne comprend pas cette ceci :

nouvo09 a écrit :

le système n'utilise que les numéros d'utilisateurs

Dans ce cas pourquoi renseigner un nom d'utilisateur suivit d'un mot de passe dans .smbcredentials ?
Et pourquoi en root cela fonctionne ?
Et pourquoi lors de la création d'un fichier, l'utilisateur est le bon ?

Du coup, qu'elle solution est a adopter ?

Merci de l’intérêt que tu porte a mon post.

Flamme_2

Dernière modification par Flamme_2 (24/09/2011 09:18:46)

Hors ligne

#4 24/09/2011 09:29:11

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 17 507

Re : [Résolu] Problème connexion réseau cifs/samba

Je ne connais pas bien smb, mais si tu pouvais poster le contenu du fichier .smbcredential, ça aiderait peut-être.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#5 24/09/2011 13:07:50

Flamme_2
Membre
Inscription : 23/09/2011
Messages : 18

Re : [Résolu] Problème connexion réseau cifs/samba

Oui, je l'ai posté, mais effectivement on ne le voit pas bien :

username=flamme
password=mdp

Hors ligne

#6 24/09/2011 13:38:59

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 17 507

Re : [Résolu] Problème connexion réseau cifs/samba

Tu as ton numero d'utilisateur sous archlinux ? pas celui de root hein, c'est toujours 0


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#7 24/09/2011 18:53:52

Flamme_2
Membre
Inscription : 23/09/2011
Messages : 18

Re : [Résolu] Problème connexion réseau cifs/samba

Dans /etc/passwd :

flamme:x:1000:1000:flamme:/home/flamme:/bin/bash

:/

Effectivement, on est à 500 sur fedora...
Je croyait vraiment que c'était le nom d’utilisateur qui était transmis...

Donc, la solution idéal serait de passer l’utilisateur en 1000 ? Cela paraît surprenant...

Hors ligne

#8 24/09/2011 19:08:31

proxy
Membre
Lieu : Localhost
Inscription : 15/08/2007
Messages : 8 794
Site Web

Re : [Résolu] Problème connexion réseau cifs/samba

Ne pas confondre le user samba du fichier credentials et le user avec lequel est fait le montage !!

En ligne de commande :

mount -t cifs -o credentials=CREENTIALS,uid=$(id -u ${USER}),gid=$(id -g ${USER}),file_mode=0760,dir_mode=0770 "//${host}/${share}" "POINTDEMONTAGE"

F20 / KDE 4.12
Il date de quand votre dernier backup ?

Hors ligne

#9 26/03/2012 14:29:56

Flamme_2
Membre
Inscription : 23/09/2011
Messages : 18

Re : [Résolu] Problème connexion réseau cifs/samba

Bonjour,

D'abord, je tient a m'excuser de ne jamais avoir répondu. Je vient tout juste de faire la manipulation (si si, après 6 mois :p ) Cependant aujourd'hui je me rattrape (cela me hantais la nuit :D ).

La solution fournit par proxy fonctionne.

Dans mon fstab :

//192.168.1.253/data                            /media/partage/data             cifs		credentials=/root/.smbcredentials,uid=500,gid=500       0       0

Je tenais donc a vous remercier, et m'excuse encore de ne pas l'avoir fait avant.

Dernière modification par Flamme_2 (26/03/2012 14:30:58)

Hors ligne

Pied de page des forums